[Testing Update] 2019-08-12 - XFCE 4.14, LibreOffice 6.3, Kernels, LibInput 1.14, Haskell

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

After applying update and reboot I can't login in xfce session.
After entering username and password login window shows up again.
Switching to mate session works...

Thanks, now Xfce 4.14.1 runs with Kernel 5.2.8-1 on my notebook.

Which package of xfce4-session do you have? The one from Arch or ours called xfce4-session-gtk3?

Interesting issue.
Every time there's a kernel update, when I reboot. It boots to black screen.
I have to restart and get the grub menu then manually select linux52 (which is my default boot kernel).
I've ensured haveged is running. My updates do not error so not partial updates.
I can't figure it out.
My other KDE (testing) machine (Tiamat) doesn't do it.

EDIT: Forgot to add, I've tried linux419 (My backup kernel) and it exhibits the same behaviour.

Frank
$ inxi -Fxxxza
System:    Host: Frank Kernel: 5.2.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=910dd8c2-76dd-4e17-963d-e10d25c1c445 
           rw quiet apparmor=1 security=apparmor 
           Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: 970A-G43 (MS-7693) v: 3.0 serial: <filter> 
           UEFI: American Megatrends v: 10.6 date: 01/08/2016 
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer family: 15 (21) 
           model-id: 2 stepping: N/A microcode: 6000852 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 42015 
           Speed: 3499 MHz min/max: N/A Core speeds (MHz): 1: 3499 2: 3500 3: 3500 4: 3499 5: 3499 6: 3500 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting,radeon 
           alternate: fbdev,vesa compositor: kwin_x11 resolution: 2560x1080~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.32.0 5.2.8-1-MANJARO LLVM 8.0.1) 
           v: 4.5 Mesa 19.1.4 direct render: Yes 
Audio:     Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k5.2.8-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
           driver: r8169 v: kernel port: d000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: down mac: <filter> 
           Device-2: Ralink RT5372 Wireless Adapter type: USB driver: rt2800usb bus ID: 2-1:2 
           chip ID: 148f:5372 
           IF: wlp0s19f2u1 state: up mac: <filter> 
Drives:    Local Storage: total: 1.43 TiB used: 199.46 GiB (13.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200BEKT-75PVMT1 size: 298.09 GiB block size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 
           scheme: GPT 
           ID-2: /dev/sdb vendor: Mushkin model: MKNSSDSR250GB size: 232.89 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 2A0 scheme: GPT 
           ID-3: /dev/sdc vendor: Samsung model: HD102UJ size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1113 scheme: GPT 
Partition: ID-1: / raw size: 232.59 GiB size: 227.94 GiB (98.00%) used: 92.30 GiB (40.5%) fs: ext4 
           dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 16.4 C mobo: N/A gpu: amdgpu temp: 30 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 3101 
Info:      Processes: 236 Uptime: 33m Memory: 23.49 GiB used: 3.27 GiB (13.9%) Init: systemd v: 242 
           Compilers: gcc: 9.1.0 clang: 8.0.1 Shell: zsh v: 5.7.1 running in: konsole inxi: 3.0.35 
systemctl status haveged.service
● haveged.service - Entropy Harvesting Daemon
   Loaded: loaded (/usr/lib/systemd/system/haveged.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2019-08-12 02:47:57 CDT; 27min ago
     Docs: man:haveged(8)
  Process: 626 ExecStartPre=/usr/bin/sysctl -w kernel.random.write_wakeup_threshold=1024 (code=exited, status=0/SUCCESS)
 Main PID: 629 (haveged)
    Tasks: 1 (limit: 4915)
   Memory: 4.1M
   CGroup: /system.slice/haveged.service
           └─629 /usr/bin/haveged --Foreground --verbose=1

Aug 12 02:47:57 Frank systemd[1]: Starting Entropy Harvesting Daemon...
Aug 12 02:47:57 Frank sysctl[626]: kernel.random.write_wakeup_threshold = 1024
Aug 12 02:47:57 Frank systemd[1]: Started Entropy Harvesting Daemon.
Aug 12 02:47:57 Frank haveged[629]: haveged: listening socket at 3
Aug 12 02:47:57 Frank haveged[629]: haveged: ver: 1.9.4; arch: x86; vend: ; build: (gcc 8.2.0 ITV); collect: 128K
Aug 12 02:47:57 Frank haveged[629]: haveged: cpu: (VC); data: 16K (D V); inst: 64K (V); idx: 39/40; sz: 52825/52825
Aug 12 02:47:57 Frank haveged[629]: haveged: tot tests(BA8): A:1/1 B:1/1 continuous tests(B):  last entropy estimate 7.99918
Aug 12 02:47:57 Frank haveged[629]: haveged: fills: 0, generated: 0

I've not yet done this update, but seeing the new Octopi updates surprises/amuses me, given yesterday's Octopi isn't properly exiting the update process. Ironically, last night based on that advice i uninstalled all the Octopi packages.

I have xfce4-session 4.12.1-8.1 installed.
Messages on console:
error while loading shared libraries: libxfconf-0.so.2
the xkeyboard keymap compiler reports: Warning: unsupported high keycode 372 for name
X11 cannot support keycodes above 255

Updated my LXQT with kernel 5.2.
All good :+1:
Thanks!

xfce4-session 4.14.0-2 should have been pushed, but I do not see it in synced mirrors.

I'm also on 4.12 and these are the only relevant updates I see:

libxfce4ui-4.14.1-2
libxfce4util-4.14.0-1
mousepad-0.4.2-2
thunar-1.8.9-2
thunar-volman-0.9.5-2
tumbler-0.2.7-1
xfce4-appfinder-4.14.0-1
xfce4-clipman-plugin-1.4.3-2
xfce4-genmon-plugin-4.0.2-1
xfce4-notes-plugin-1.8.1-4
xfce4-notifyd-0.4.4-2
xfce4-panel-4.14.0-1
xfce4-power-manager-1.6.5-2
xfce4-settings-4.14.0-1
xfce4-terminal-0.8.8-2
xfce4-xkb-plugin-0.8.1-2
xfconf-4.14.1-1
xfdesktop-4.14.1-2
xfwm4-4.14.0-1

Installed/Switched to xfce4-session-gtk3...
login working again.

1 Like

journalctl --no-pager --no-hostname -xb -1 -p3 ?

-1 means previous boot (when black screen occured). If you are 2 [re]boots ahead of that now, use -2, and so on.

2 Likes

The update of java-openjfx from 8 to 11 has totally borked a whole heap of java apps i use. They now all fail to start. We really need a java-openjfx 8 to be maintained along with the other openjava 8 that is offered. Now there is no version of java-openjfx8 at all which i'm certain @jonathon used to maintain?

Other than that, everything else seems fine.

Same here. I installed xfce4-notifyd-gtk3.
I was asked to replace

  • exo
  • xfce4-notifyd
  • libxfce4ui
  • xfconf

by their respective gtk3 counterparts, which I confirmed.
After that, the login worked again, and the desktop was loaded.

Dear developers, please let me kindly ask you to fix this error. There is already a discussion about this problem at Xfce4-gtk3 .

Kind regards.

Got the same problem and installing to xfce4-session-gtk3 solved it for me to!

No problems, xfce4-session-gtk3 4.14.0-2 , kernel 5.2.8-1, two machines, Core i5-3317U,
Core i5-8250U.

Hi @openminded,
I went back 5 just to be thorough.
Here you go.
:slight_smile:

Summary
$ journalctl --no-pager --no-hostname -xb -1 -p3                                                      130 ↵
-- Logs begin at Fri 2019-07-19 21:54:48 CDT, end at Mon 2019-08-12 03:58:43 CDT. --
-- No entries --
***
$ journalctl --no-pager --no-hostname -xb -2 -p3
-- Logs begin at Fri 2019-07-19 21:54:48 CDT, end at Mon 2019-08-12 03:59:01 CDT. --
Aug 12 02:45:51 systemd-udevd[398]: could not read from '/sys/module/pcc_cpufreq/initstate': No such device
Aug 12 02:46:26 kernel: watchdog: watchdog0: watchdog did not stop!
***
$ journalctl --no-pager --no-hostname -xb -3 -p3
-- Logs begin at Fri 2019-07-19 21:54:48 CDT, end at Mon 2019-08-12 03:59:13 CDT. --
Aug 12 02:45:31 kernel: watchdog: watchdog0: watchdog did not stop!
***
$ journalctl --no-pager --no-hostname -xb -4 -p3
-- Logs begin at Fri 2019-07-19 21:54:48 CDT, end at Mon 2019-08-12 04:00:22 CDT. --
Aug 12 02:44:03 kernel: watchdog: watchdog0: watchdog did not stop!
***
$ journalctl --no-pager --no-hostname -xb -5 -p3
-- Logs begin at Fri 2019-07-19 21:54:48 CDT, end at Mon 2019-08-12 04:00:13 CDT. --
Aug 12 00:27:11 kernel: watchdog: watchdog0: watchdog did not stop!

Same here.
Thanks!

OK, I found the issue. We had an overlay package for xfce4-session still there. Got removed now. Should therefore work.

1 Like

@philm

On minimal test ISO build today.

It seems good - only thing I noted is the duplicated Archive Manager / Engrampa Archive Manager - but I think I did the same thing with xarchiver and engrampa so not a big issue.

As part of the workaround previously described,
I replaced

  • exo by exo-gtk3
  • xfce4-notifyd by xfce4-notifyd-gtk3
  • libxfce4ui by libxfce4ui-gtk3
  • xfconf by xfconf-gtk3

Is it advisable to revert these changes now?

Thank you very much and kind regards.

Forum kindly sponsored by Bytemark