[Testing Update] 2019-08-12 - XFCE 4.14, LibreOffice 6.3, Kernels, LibInput 1.14, Haskell

I was curious so just checked since I use LO Writer a lot. I think it may be a GPU driver or DE related glitch. XFCE has had some major updates as well today after all.

It's behaving on my KDE installs with Intel and AMD hardware respectively if I type your example of 'Beckyhas' and then go back to add the space, the error indication goes immediately.

Graphic driver: nvidia v: 430.40, Desktop: Xfce 4.14.1 Both updated today.

1 Like

Which modules haven't been built yet out of curiosity? Is there a way to check? Getting a 5700 XT in a week so curious

Compare pacman -Ss linux52 and pacman -Ss linux53.

2 Likes

Ah ok! Thank you so much! Love your work!

Issue/question
Why is libplacebo needed now and why does it conflict with libplacebo-git from the AUR?

It's there just to keep people happy.

(More seriously, not sure. What issue are you seeing?)

pacman -Si libplacebo
Repository      : extra
Name            : libplacebo
Version         : 1.18.0-1
Description     : Reusable library for GPU-accelerated video/image rendering primitives
Architecture    : x86_64
URL             : https://github.com/haasn/libplacebo
Licenses        : LGPL2.1
Groups          : None
Provides        : libplacebo.so=18-64
Depends On      : vulkan-icd-loader  glslang  lcms2  shaderc  libshaderc_shared.so=1-64
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 171.69 KiB
Installed Size  : 567.00 KiB
Packager        : Levente Polyak <anthraxx@archlinux.org>
Build Date      : Thu 06 Jun 2019 01:19:33 BST
Validated By    : MD5 Sum  SHA-256 Sum  Signature
$ pactree -r libplacebo.so=18-64                   
libplacebo provides libplacebo.so=18-64
└─dav1d
  └─ffmpeg
    ├─chromaprint
    │ └─gst-plugins-bad
    │   ├─cheese
    │   │ └─gnome-control-center
    │   └─gnome-video-effects
    │     └─cheese
    ├─chromium
    ├─faudio
    │ ├─lib32-faudio
    │ │ └─wine
    │ │   ├─airwave-git
    │ │   ├─wine-mono
    │ │   ├─wine-nine
    │ │   ├─wine_gecko
    │ │   └─winetricks
    │ └─wine
    ├─firefox
    │ └─firefox-i18n-en-gb
    ├─freshplayerplugin
    ├─gst-libav
    │ └─pithos-git
    ├─pipewire
    │ └─mutter
    │   └─gnome-shell
    │     ├─chrome-gnome-shell
    │     └─gdm
    ├─qt5-webengine
    │ ├─bibletime
    │ └─nextcloud-client
    ├─telegram-desktop
    ├─vlc
    └─x264
      └─ffmpeg
1 Like

It tries to install itself over the -git version from the AUR, dependency hell ensues.

yay -Si libplacebo-git      
:: Querying AUR...
Repository      : aur
Name            : libplacebo-git
Keywords        : None
Version         : v1.18.0.20.g22a9919-1
Description     : Reusable library for GPU-accelerated video/image rendering primitives. (GIT version)
URL             : https://github.com/haasn/libplacebo
AUR URL         : https://aur.archlinux.org/packages/libplacebo-git
Groups          : None
Licenses        : LGPL2.1
Provides        : libplacebo  libplacebo.so
Depends On      : vulkan-icd-loader  lcms2  libshaderc_shared.so
Make Deps       : git  meson  ninja  vulkan-headers
Check Deps      : None
Optional Deps   : None
Conflicts With  : libplacebo  libplacebo.so
Maintainer      : sl1pkn07
Votes           : 3
Popularity      : 0.770307
First Submitted : Sun 29 Apr 2018 10:53:48 AM -05
Last Modified   : Sat 10 Aug 2019 06:09:32 AM -05
Out-of-date     : No

The -git package is an AUR package that's kind of up to you to fix. :wink:

Given the FFMPEG and x265 updates you'll probably have to rebuild the AUR package.

minor graphical issue in panel: xfce4-pulseaudio-plugin icon is solid black no matter which icon set i pick.

Using Adwaita in xfce 18.1.0 rc8 I get this:
Screenshot_2019-08-12_23-17-50

@oberon's edits from the last time they tried this, a year ago, works.

Applied via xfce4-pulseaudio-plugin-0.4.2-2.1

1 Like

Well, that's part of the problem.
It started happening after the aug. 3rd updated.

I've installed and re-installed almost every kernel available in mhwd, there no errors during installation, no error during grub update and no error when it boots to black screen.

3 of the 5 journals I posted at your request are the failed boots.

[Hour later EDIT]: So I've installed and tinkered with multiple kernels. Always get a black screen on reboot with each and have to use grub advanced menu to reselect the same kernel for it to boot. And zero errors. I'm obviously looking in the wrong place or something.
So I decided to grab another mouse (was using a razer) and remove openrazer dkms.
No luck.
But I kept thinking about no error message and decided to take out quiet from grub so I could perhaps see where it was hanging or something, anything.
I've rebooted with Linux52 12 times so far with quiet removed and it hasn't hung once.
Is Manjaro messing with me? :rofl:

@Sinister, I think you should create a new thread in the support section and post your issue there. Pls also post the contents of /etc/default/grub and /etc/mkinitcpio.conf.

@openminded, Ok. Apologies if this wasn't the place for it. :slight_smile:
Thanks for your time.

Oh, no excuses please!
I feel really weird when someone apologizes because of my failure to use emojis and proper English :joy:
No mentor tone was meant of course.

1 Like

The error (black screen) is caused by the default boot setting in grub.
Check this by changing to 0 (first boot menu option) instead of "last boot" (I'm on mobile, check proper settings names).

1 Like

See: [Stable Update] 2019-08-13 - Kernels, XFCE 4.14, KDE, LibreOffice 6.3, Discord, Mesa

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark