[Testing Update] 2019-08-10 - Kernels, Fpakman, Certbot, Python, 18.1.0-rc8, KDE-Dev

Hello community,

I am happy to announce another Testing Update. Mostly we have Kernel, Firefox and Certbot updates with this one.

Update news

This update holds the following changes:

  • Fpakman got some needed fixes
  • Certbot is now at 0.37.0
  • Kernels got updated to their latest revision
  • Latest python and upstream updates
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO or current KDE-Vanilla ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated. Office can be selected during installation between libreoffice-still or freeoffice: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.188 (no legacy nvidia-340 module!)
  • linux49 4.9.188
  • linux414 4.14.138
  • linux419 4.19.66
  • linux51 5.1.21 [EOL]
  • linux52 5.2.8 (no catalyst module!)
  • linux53 5.3-rc2 (not all modules build yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Package Updates (Sat Aug 10 04:50:43 CEST 2019)

  • testing community x86_64: 209 new and 209 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing extra x86_64: 71 new and 72 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
                          brisk-menu            0.5.0-3.2              0.6.0-1
                             fpakman            0.5.0-1.2              0.5.1-1
          konsole-colorscheme-matcha           20190613-1           20190810-1
           konversation-theme-matcha           20190613-1           20190810-1
                kvantum-theme-matcha           20190613-1           20190810-1
                          matcha-kde           20190613-1           20190810-1
               matcha-kde-wallpapers           20190613-1           20190810-1
                 yakuake-skin-matcha           20190613-1           20190810-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-236            1.1.0-237
                                agda           2.6.0.1-14           2.6.0.1-15
                            bfgminer              5.5.0-2              5.5.0-3
                         bitcoin-cli             0.18.0-1             0.18.0-2
                      bitcoin-daemon             0.18.0-1             0.18.0-2
                          bitcoin-qt             0.18.0-1             0.18.0-2
                          bitcoin-tx             0.18.0-1             0.18.0-2
                              catch2              2.9.1-1              2.9.2-1
                             certbot             0.36.0-1             0.37.0-1
                      certbot-apache             0.36.0-1             0.37.0-1
              certbot-dns-cloudflare             0.36.0-1             0.37.0-1
                certbot-dns-cloudxns             0.36.0-1             0.37.0-1
            certbot-dns-digitalocean             0.36.0-1             0.37.0-1
                certbot-dns-dnsimple             0.36.0-1             0.37.0-1
             certbot-dns-dnsmadeeasy             0.36.0-1             0.37.0-1
                  certbot-dns-gehirn             0.36.0-1             0.37.0-1
                  certbot-dns-google             0.36.0-1             0.37.0-1
                  certbot-dns-linode             0.36.0-1             0.37.0-1
                  certbot-dns-luadns             0.36.0-1             0.37.0-1
                   certbot-dns-nsone             0.36.0-1             0.37.0-1
                     certbot-dns-ovh             0.36.0-1             0.37.0-1
                 certbot-dns-rfc2136             0.36.0-1             0.37.0-1
                 certbot-dns-route53             0.36.0-1             0.37.0-1
             certbot-dns-sakuracloud             0.36.0-1             0.37.0-1
                       certbot-nginx             0.36.0-1             0.37.0-1
                              coturn            4.5.1.1-5            4.5.1.1-6
                             crystal             0.30.0-2             0.30.0-3
                              dbmail             3.2.3-10             3.2.3-11
                    dnscrypt-wrapper              0.4.2-1              0.4.2-2
                            electron              6.0.0-1              6.0.0-2
                           electron2             2.0.18-1             2.0.18-2
                           electron4              4.2.8-1              4.2.8-2
                           filezilla             3.43.0-2             3.44.1-1
           firefox-developer-edition            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-ach            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-af            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-an            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ar            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-ast            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-az            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-be            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-bg            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-bn            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-br            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-bs            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ca            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-cak            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-cs            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-cy            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-da            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-de            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-dsb            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-el            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-en-ca            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-en-gb            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-en-us            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-eo            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-es-ar            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-es-cl            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-es-es            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-es-mx            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-et            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-eu            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-fa            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ff            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-fi            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-fr            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-fy-nl            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-ga-ie            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-gd            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-gl            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-gn            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-gu-in            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-he            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-hi-in            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-hr            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-hsb            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-hu            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-hy-am            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ia            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-id            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-is            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-it            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ja            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ka            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-kab            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-kk            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-km            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-kn            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ko            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-lij            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-lt            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-lv            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-mk            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-mr            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ms            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-my            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-nb-no            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-ne-np            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-nl            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-nn-no            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-oc            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-pa-in            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-pl            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-pt-br            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-pt-pt            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-rm            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ro            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ru            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-si            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-sk            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-sl            69.0b11-1            69.0b12-1
  firefox-developer-edition-i18n-son            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-sq            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-sr            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-sv-se            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ta            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-te            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-th            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-tr            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-uk            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-ur            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-uz            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-vi            69.0b11-1            69.0b12-1
   firefox-developer-edition-i18n-xh            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-zh-cn            69.0b11-1            69.0b12-1
firefox-developer-edition-i18n-zh-tw            69.0b11-1            69.0b12-1
              firefox-tree-style-tab              3.1.6-1              3.1.7-1
                              foxdot             0.7.39-1             0.7.40-1
                           fragments                1.4-1                1.4-2
                               fstrm              0.5.0-1              0.5.0-2
                            gearmand             1.1.18-7             1.1.18-8
                              getdns              1.5.2-1              1.5.2-2
                           glusterfs              1:6.4-1              1:6.5-1
                      grafana-zabbix             3.10.3-1             3.10.4-1
                       haskell-cairo          0.13.6.0-26          0.13.6.0-27
                   haskell-esqueleto             3.0.0-30              3.1.0-1
                        haskell-glib          0.13.7.0-26          0.13.7.0-27
                         haskell-gtk            0.15.1-27            0.15.1-28
           haskell-gtk2hs-buildtools          0.13.5.0-26          0.13.5.0-27
                  haskell-hashtables            1.2.3.3-6            1.2.3.4-1
                       haskell-hasql                1.4-2                1.4-3
                  haskell-hasql-pool              0.5.1-6              0.5.1-7
           haskell-hasql-transaction              0.7.2-2              0.7.2-3
                 haskell-hledger-lib            1.14.1-40            1.14.1-41
                       haskell-pango          0.13.6.0-26          0.13.6.0-27
                             hledger            1.14.2-46            1.14.2-47
                         hledger-api             1.14-102             1.14-103
                          hledger-ui            1.14.2-56            1.14.2-57
                         hledger-web           1.14.1-113           1.14.1-114
                             hostapd                2.8-1                2.9-1
               intel-compute-runtime        19.29.13530-1        19.31.13700-1
             intel-graphics-compiler            1:1.0.9-1           1:1.0.10-1
                                  io         2017.06.08-4         2017.06.08-5
                             jenkins              2.186-1              2.187-1
                              kcptun           20190725-1           20190809-1
                        libfilezilla             0.17.1-2             0.18.0-1
                               lldpd              1.0.4-1              1.0.4-2
                              lolcat            99.9.21-1            99.9.99-1
                               lxcfs              3.1.1-1              3.1.2-1
                           neovim-qt             0.2.12-2             0.2.13-1
                  nextcloud-app-mail             0.15.1-1             0.15.2-1
                 nextcloud-app-tasks             0.11.0-1             0.11.1-1
                                 nsd              4.2.1-1              4.2.1-2
                           opensmtpd            6.0.3p1-2            6.0.3p1-3
                             padthv1              0.9.9-1              0.9.9-2
                                  pd             0.49.0-1             0.49.1-1
                           postgrest              6.0.0-3              6.0.0-4
                             pysolfc              2.4.0-1              2.6.4-1
                         python-acme             0.36.0-1             0.37.0-1
                     python-daiquiri              1.5.0-1              1.6.0-1
                         python-dkim              0.9.2-1              0.9.3-1
                      python-execnet              1.6.1-1              1.7.0-1
                  python-mysqlclient              1.4.2-1              1.4.3-1
                        python-redis              3.2.1-1              3.3.5-1
                  python-ruamel-yaml             0.16.0-1             0.16.1-1
                    python-schemdraw              0.4.0-2              0.5.0-1
                        python-vcrpy              2.0.1-2              2.1.0-1
                    python2-daiquiri              1.5.0-1              1.6.0-1
                     python2-execnet              1.6.1-1              1.7.0-1
                       python2-redis              3.2.1-1              3.3.5-1
                     python2-tornado              5.1.1-1              5.1.1-2
                              racket                7.3-1                7.4-1
                      racket-minimal                7.3-1                7.4-1
                      radare2-cutter              1.8.3-1            1:1.8.3-1
                              rspamd              1.9.4-1              1.9.4-2
                          rust-racer             2.1.22-1             2.1.25-1
                   shadowsocks-libev              3.3.0-1              3.3.1-1
                              shards              0.9.0-1              0.9.0-2
                            sslsplit              0.5.2-1              0.5.2-2
                         sstp-client             1.0.12-3             1.0.12-4
                     stylish-haskell           0.9.2.1-51            0.9.2.2-1
                    telegram-desktop             1.7.14-3              1.8.0-1
                               tmate              2.3.0-1              2.3.0-2
                                tmux              2.9_a-2              2.9_a-3
                                 tor            0.4.0.5-1            0.4.0.5-2
                             unbound              1.9.2-1              1.9.2-2
         v2ray-domain-list-community         20190801.1-1         20190808.1-1
                              vibe-d              0.8.5-2              0.8.5-3
                            xkcdpass             1.17.2-1             1.17.3-1
                               zcash              2.0.6-1              2.0.6-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
                            linux414           4.14.137-1           4.14.138-1
                    linux414-headers           4.14.137-1           4.14.138-1
                            linux419            4.19.65-1            4.19.66-1
                    linux419-headers            4.19.65-1            4.19.66-1
                             linux52              5.2.7-1              5.2.8-1
                     linux52-headers              5.2.7-1              5.2.8-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
                            libevent             2.1.10-1             2.1.11-1
                               links               2.19-1               2.19-2
                           nfs-utils              2.4.1-1              2.4.1-2
                            nfsidmap              2.4.1-1              2.4.1-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
               calamares-git 3.2.13.r6360.dce9b215a-1 3.2.13.r6387.b700eea6f-1
                            chromium      76.0.3809.100-0                    -
                  linux414-acpi_call            1.1.0-112            1.1.0-113
                   linux414-bbswitch              0.8-112              0.8-113
                linux414-broadcom-wl     6.30.223.271-112     6.30.223.271-113
                   linux414-catalyst    1:15.201.1151-112    1:15.201.1151-113
                linux414-ndiswrapper               1.62-7               1.62-8
                     linux414-nvidia           1:430.40-2           1:430.40-3
               linux414-nvidia-340xx           340.107-71           340.107-72
               linux414-nvidia-390xx            390.129-2            390.129-3
                   linux414-nvidiabl             0.88-112             0.88-113
                      linux414-r8168           8.047.02-4           8.047.02-5
                  linux414-rt3562sta       2.4.1.1_r4-111       2.4.1.1_r4-112
                   linux414-tp_smapi               0.43-4               0.43-5
                linux414-vhba-module          20190410-17          20190410-18
   linux414-virtualbox-guest-modules             6.0.10-4             6.0.10-5
    linux414-virtualbox-host-modules             6.0.10-4             6.0.10-5
                        linux414-zfs             0.8.1-10             0.8.1-11
                  linux419-acpi_call             1.1.0-58             1.1.0-59
                   linux419-bbswitch               0.8-57               0.8-58
                linux419-broadcom-wl      6.30.223.271-57      6.30.223.271-58
                   linux419-catalyst     1:15.201.1151-55     1:15.201.1151-56
                linux419-ndiswrapper               1.62-7               1.62-8
                     linux419-nvidia           1:430.40-3           1:430.40-4
               linux419-nvidia-340xx           340.107-57           340.107-58
               linux419-nvidia-390xx            390.129-4            390.129-5
                   linux419-nvidiabl              0.88-57              0.88-58
                      linux419-r8168           8.047.02-8           8.047.02-9
                  linux419-rtl8723bu   4.3.9.3.13200.0-42   4.3.9.3.13200.0-43
                   linux419-tp_smapi               0.43-7               0.43-8
                linux419-vhba-module          20190410-22          20190410-23
   linux419-virtualbox-guest-modules             6.0.10-7             6.0.10-8
    linux419-virtualbox-host-modules             6.0.10-7             6.0.10-8
                        linux419-zfs             0.8.1-15             0.8.1-16
                   linux52-acpi_call             1.1.0-10             1.1.0-11
                    linux52-bbswitch               0.8-10               0.8-11
                 linux52-broadcom-wl      6.30.223.271-10      6.30.223.271-11
                 linux52-ndiswrapper               1.62-6               1.62-7
                      linux52-nvidia           1:430.40-4           1:430.40-5
                linux52-nvidia-340xx           340.107-11           340.107-12
                linux52-nvidia-390xx            390.129-5            390.129-6
                    linux52-nvidiabl              0.88-10              0.88-11
                       linux52-r8168          8.047.02-11          8.047.02-12
                    linux52-tp_smapi              0.43-10              0.43-11
                 linux52-vhba-module          20190410-10          20190410-11
    linux52-virtualbox-guest-modules             6.0.10-9            6.0.10-10
     linux52-virtualbox-host-modules             6.0.10-9            6.0.10-10
                         linux52-zfs             0.8.1-11             0.8.1-12
                           pamac-cli              8.0.4-5              8.0.4-6
                        pamac-common              8.0.4-5              8.0.4-6
                           pamac-gtk              8.0.4-5              8.0.4-6
             pamac-tray-appindicator              8.0.4-5              8.0.4-6


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-08-09           2019-08-10
-------------------------------------------------------------------------------
                            chromium       76.0.3809.87-1      76.0.3809.100-1
                               cmake             3.15.1-1             3.15.2-1
                           memcached             1.5.14-1             1.5.14-2
                               ndctl                 65-1                 66-1
                           pgbouncer              1.9.0-1              1.9.0-2
                        python-numpy             1.16.4-1             1.17.0-1
                    python-packaging               19.0-1               19.1-2
                   python2-packaging               19.0-1               19.1-2
                       qt5-webengine             5.13.0-3             5.13.0-4
                           ristretto              0.8.5-1             0.10.0-1
                               scons              3.1.0-2              3.1.1-1
                          subversion             1.12.0-3             1.12.2-1
                             tomcat8             8.5.38-1             8.5.41-1
                    transmission-cli               2.94-1               2.94-2
                    transmission-gtk               2.94-1               2.94-2
                     transmission-qt               2.94-1               2.94-2
                        zabbix-agent              4.2.5-1              4.2.5-2
                 zabbix-frontend-php              4.2.5-1              4.2.5-2
                        zabbix-proxy              4.2.5-1              4.2.5-2
                       zabbix-server              4.2.5-1              4.2.5-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Asian/CJK characters display as blocks

Install noto-fonts-cjk or another font of your choice. The problem seems related to a ttf-droid update.

https://bugs.archlinux.org/task/63205


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

this update is good for me: linux52+zfs+nvidia+cinnamon

No issues to report with this update.
LXQT+kernel 5.2+AMD free
Thanks!

All 3 Demon Machines™ updated without issue.

  • KDE/linux52/AMDgpu
  • KDE/linux52/nvidia(non-free)
  • Mate/linux53/intelGpu

:partying_face:

No issues anymore on my gnome desktop. An issue I had with colors of virtualbox interface resolved with kvantum-theme-matcha 20190810-1

No new issues here on 2 KDE machines. Looks fine.

It's Ok for Xfce(Gtk2+) + Steam(OpenGL)+Nvidia + vbox

Pamac locked up with a screen showing the updates but a grayed out "Apply" button. Would not quit with the corner button or Close from Panel. Had to reboot and then get new mirrors because of "error cannot update databases" trying to run update in Terminal. Then run [sudo pacman -Syyu] Solved.

1 Like

did you do this @beardedragon? I usually wait until 3 of the 4 mirrors for my locale are synchronised so there is a redundancy for the package manager to fall back on and avoid partial updates or errors updating databases due to dropped connections to a single updated mirror.

1 Like

uh Duh, I think I said that "Had to reboot and then get new mirrors because of "error cannot update databases" I thought the Pamac should have already updated the database. I will always use Terminal or TTY2 from now on.

1 Like

that's as maybe but there's a difference to rebuilding the mirror list and checking if the mirrors are synchronised before trying to update. If they weren't when you ran pamac after it alerted you then it will spit out those errors usually caused by a synchronisation of mirrors under way when it checks for itself what is available. that's why i always check what octopi thinks is a full update set is actually completely ready for download and install on the repo website before committing to an update.

1 Like

Would you @philm release VLC update (version 3.0.7.1-3) released today? I have problems with video output (unknown the causes) with this software, I would like to check if it has been fixed. Apparently VLC is not present in this update. Most importantly it is crashing in the machine (Plasma with Nvidia).

@ micsim35
Your chronology is wrong. Pamac Froze, no warning, no errors, just froze, could not stop it or make it do anything. The error came when I tried to run pacman in terminal while the pamac was still on the screen. Then I rebooted, started terminal and ran pacman-mirrors etc.
P.S. I do not like octopi

Even about Pamac developing tray with QT support to signal better when has update in Plasma notification area. It would be interesting for to make it default on version 18.1.0.

1 Like

That version is just a rebuild against a library. I'm afraid it will fix anything

1 Like

I saw that it was a rebuild, but as I said the cause of the problem I still don't know. I will be continuing the investigation of the cause.
This version is now present in

However, this update does not resolve the issue.

Thank you for the advice to avoid partially updates.

1 Like

Just want to let you know that I love 18.1.0, it's much better than 18.0.4 because:

  1. Option to select office package during installation.
  2. Most of bloatware (duplicated office apps, Microsoft stuff, tons of development utilities that average user will never run, etc.) is removed for good.
  3. pamac instead of octopi. Just great.

I also hope that once a stable version is released, it will be possible to remove bloat from previous installations (made using 18.0.4). Now, I can't even remove stuff like QT Designer and similar because I get a warning that doing so will also remove Dolphin file manager and tons of KDE stuff. So I need to live with this crap, which (thankfully) doesn't exist in RC version anymore.

sudo pacman -Rdd (package name)

use with care as it only uninstalls named package so check for orphans afterwards.
Note once the package is removed Dolphin won't be an orphan.

3 Likes

Forum kindly sponsored by Bytemark