[Testing Update] 2019-08-04 - XFCE, KDE-Git, Calamares, Manjaro 18.1-rc7

Calligra for KDE, for sure as premium option :stuck_out_tongue:
I dunno why Calligra isn't more popular when it works nicely.

It's a very basic suite compared to LibreOffice. It fits well for home usage but absolutely not usable in corporate environment.

2 Likes

Yes, but it can rotate picture by something else besides 45 degrees :stuck_out_tongue:

I have never used Calligra before. I use LibreOffice for years.
But now I'm on KDE and I assume Calligra is better integrated...

So I have a couple of questions:

How is Calligra's compatibility with MS Office documents, especially docx? Is it better or worse than LibreOffice? (Latest versions of LibreOffice are very compatible, especially if you have the original MS Windows 7 ttf fonts inside your ~/.fonts directory)

How is Calligra's stability? From my experience LibreOffice is pretty much stable

Thanks in advance

I don't use Windows, I don't use anything MS. Considering subscribing to Softmaker as wife sometimes brings some ms spreadsheets/documents from work. Don't know about Calligra but editing excel is not good (visually) with LibreOffice. She tried once and gave up. I will try Calligra next time.

1 Like

Oh I see..

I had the impression you use Calligra. I was mistaken.
LibreOffice is very good for documents. My Excel sheets are very rudimentary to tell...

PS: I also do not use Windows. Only their fonts :slight_smile: (for compatibility reasons)
Thx

After latest testing update I am experiencing mouse lag over bluetooth. Connection over logitech unifying receiver works fine. Tried increasing mouse polling rate but still lags.

evhz results:

bluetooth - 22Hz
logitech unifying receiver - 122hz

Odd.
Kernel? Firmware?
Anything you think is related?
(you werent using workaround before like bt_coex or similar?)
[maybe share inxi -Fxxxz --no-host and/or have a look at /var/log/pacman.log for what changed?]
Oh yeah .. also
pacdiff -o

I have not done a thorough benchmark, but my impression is that with Calligra you get better integration with KDE, at some loss in fidelity when dealing with MS document formats.

But, as I posted somewhere, even MS-Office Online seems to have trouble with complex fat client MS-Office documents.

Clear enough...
Thank you!

Using kernel 5.2.5, tried installing 5.1.21 and 4.19.63.
I wasn't using workarounds before. Checked pacman.log, had 2 system upgraded. Tried downgrading last one. I will try downgrade first upgrade also.
Same issue accures on live iso KDE and Gnome rc7, kde-dev-19.08.03.

kde-dev-19.07.22 works fine.

inxi:

System:    Kernel: 5.2.5-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 
           info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 02MJVY v: A00 serial: <filter> UEFI: Dell v: 1.12.0 date: 06/27/2019 
Battery:   ID-1: BAT0 charge: 26.6 Wh condition: 87.1/97.0 Wh (90%) volts: 11.9/11.4 model: LGC-LGC8.33 DELL 5XJ2886 
           type: Li-ion serial: <filter> status: Charging 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 1100 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1100 5: 1100 6: 1100 
           7: 1100 8: 1100 9: 1100 10: 1100 11: 1100 12: 1100 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8c 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.1.3 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Sound Server: ALSA v: k5.2.5-2-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks 
           driver: ath10k_pci v: kernel port: efa0 bus ID: 3b:00.0 chip ID: 168c:003e 
           IF: wlp59s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:3 chip ID: 0cf3:e300 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4-1.2:3 
           chip ID: 0bda:8153 serial: <filter> 
           IF: ens20u1u2 state: down mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: <filter> 
           IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 325.50 GiB (68.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: EXA73D1Q scheme: GPT 
Partition: ID-1: / size: 400.00 GiB used: 325.43 GiB (81.4%) fs: btrfs dev: /dev/nvme0n1p1 
           ID-2: /home size: 400.00 GiB used: 325.43 GiB (81.4%) fs: btrfs dev: /dev/nvme0n1p1 
Sensors:   System Temperatures: cpu: 63.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2519 fan-2: 2496 
Info:      Processes: 349 Uptime: 6m Memory: 15.29 GiB used: 3.84 GiB (25.1%) Init: systemd v: 242 Compilers: 
           gcc: 9.1.0 clang: 8.0.1 Shell: zsh v: 5.7.1 running in: tilix inxi: 3.0.35 

pacdiff:

/etc/geoclue/geoclue.conf.pacnew
/etc/default/grub.pacnew
/etc/pam.d/sddm.pacsave

You can rotate pictures "nearly" arbitrary.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark