[Testing Update] 2019-07-29 - Kernels, XFCE 4.14-pre3, Haskell

No problem here, on the contrary solved problems.
Fixed: Problem with wireless connection

1080 display is a given here, correct?

Having problems with pango 1:1.44.1-1 do not want to render correctly in nautilus.
Solved the problem by downgrading to 1: 1.43.0-2

1 Like

it works on XFCE BUT the boot default gets changed to the 5.2 kernel which still has the graphics 'large pixel problem'......ditto for 5.3........my graphics are fine booting my KDE ssd.....
Soooo as 5.1 is EOL I'm gonna be forced to move to KDE!!!???
Does the XFCE 'Weather Report' panel app run on KDE? :thinking:

Screenshot_20190730_160232
Running it since the release of rc1. Apart from the absense of some out-of-tree modules, everything works great.

Wow, didn't know about FreeOffice until now!
Tried to open several MS Office files and everything looks very correct, let alone blazing fast app launching compared to LibreOffice. One more reason to abandon Windows.

Another flawless update, although there was an unusual wait at

(8/14) Reloading system manager config.

But it came back after maybe a minute or so and finished just fine, no problems after rebooting.
Upgrade via yay: kernel 5.2.x, KDE, btrfs, luks, nVidia, Virtualbox

I tried FreeOffice a while back and it failed on the first (albeit complicated) Powerpoint file I have thrown at it. Back then I decided that if not even the original product is compatible to it's earlier versions, how can I expect other products to do better.
Conclusion was to stay with LibreOffice and use MS Office in a VM if genuine MS Office formatting is essential/compatibility is required.

The Manjaro defaults seem to differ more and more from what I need so if I have to install again I think I'd start with Manjaro Architect from now on to avoid the bloat...

2 Likes

Have just done the update of my Testing KDE VM, with Pamac-GTK. Whilst the updates themselves seemed to go ok, judging by watching the transcript roll by line by line in real time, Pamac simply has not ended the overall process... it is stuck on "Running post-transaction hooks..." [so i've still not been willing to reboot it yet]. This is not the first time this has occurred.


Eventually i gave up waiting & rebooted it. No more obvious problems arose.


Now Tower's real Manjaro KDE is also updated via Pamac-GTK. Unlike in the VM, it did not hang during the final hooks, ie, it cleanly finished. Reboot fine.

People who want to know about all the changes made in RC6 of 18.1 can hear it live in couple of minutes or download it later ...

4 Likes

Welp, after I updated, I didn't notice right away but I have an issue with systemsettings5 in KDE Plasma on Frank. I'm getting massive errors.
When I open System Settings I can go to any category except Application Style-> GNOME/GTK Application style. When I click it it hangs for about 40 -50 seconds then crashes with this Pastebin-libc-error.
When I open system settings, I get this Pastebin-widget-error.

I've tried reinstalling glibc, but no luck. I wanted to post this before I did anything drastic (Downgrade glibc sounds like a bad move).
Current theme is Arc Dark. I tried other themes but it exhibits the same behavior.

EDIT: Going to repost this in #support-for-official-editions

Fresh installed : KDE ,, Manjaro 18.1 RC.6 ,,
on Threadripper ,, GTX.1080 ,,, all is wery SMOOTH , Not found any problem .!.:innocent::smiling_face_with_three_hearts::smiling_face_with_three_hearts:

Since the people with actual update issues weren't getting any attention I moved the FreeOffice debate to this topic. I also re-opened that topic so people who wish to discuss it further have a venue to do so.

5 Likes

A post was merged into an existing topic: Including FreeOffice is a bad idea (Was: Manjaro Roadmap)

Um, do you mean Application Style? If yes, then it's still ok here, fwiw:

1 Like

cough. Er... Yes.

Well, here's some relevant Testing feedback since it's been getting "lost":

Who am I kidding, both are the same bug! :joy:

If there is a hardware incompatibility with newer kernels, the sensible solution is to not use those kernels, not blame the distro for giving us the option of running newer kernels.

2 Likes

Problem here also with xfce4-terminal and xos4 terminus font. Font displays as boxes. (Xfce 4.12)

Downgrading to pango 1:1.43.0-2 fixed for me as well.


This seems to affect all bitmap fonts now. And has been flagged as not a bug by Arch upstream.

1 Like

I was just about to mention the same.

I am using Dina in the terminal...
Does anyone know a similar non-bitmap font? edit going for fixedsys i guess

Hum looks like you're going update to the 3rd release instead of the final that came July 30 ?

What could possibly go wrong? :thinking:

error: could not open file /var/lib/pacman/local/linux419-4.19.63-1/desc: No such file or directory

mkinitcpio -p linux419
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-i686.img
==> ERROR: Unable to write to /boot/initramfs-4.19-i686.img
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-i686-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-4.19-i686-fallback.img

mkinitcpio -p linux
/bin/mkinitcpio: line 261: /etc/mkinitcpio.d/linux.preset: No such file or directory
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux.preset'

Forum kindly sponsored by Bytemark