[Testing Update] 2019-07-19 - Firefox, Vulkan, Deepin, Virtualbox, Haskell

Hello community,

I am happy to announce another Testing Update. Mostly we have Firefox and Deepin updates with this one.

Some might noticed that since the #snapcraftsummit a lot of package changes went into Manjaro and our available RCs. Also we didn't yet announce 18.1.0-rc5 officially yet. We are still polishing the snap experience for our users. XFCE and Gnome will come with Gnome-Software and our KDE edition has Discover, both with snap support enabled.

This way everybody can easily access the snap store by a click and don't has to hassle to get snaps enabled. This enables us to ship even more proprietary software, which we couldn't before. For example check out on how you may install Spotify on Manjaro.

This update holds the following changes:

  • Most of our Deepin packages got updated
  • Firefox is at 68.0.1
  • Virtualbox is at 6.0.10
  • Latest efforts by KDE can be reviewed via our current KDE-Dev ISO
  • Manjaro Juhraya ISOs got updated, including flatpak and snap support pre-activated: XFCE, KDE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.70
  • linux44 4.4.185 (no legacy nvidia-340 module!)
  • linux49 4.9.185
  • linux414 4.14.133
  • linux419 4.19.59
  • linux51 5.1.18
  • linux52 5.2.1 (no catalyst module!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.21_rt16

Package Updates (Fri Jul 19 06:48:30 CEST 2019)

  • testing community x86_64: 652 new and 646 removed package(s)
  • testing core x86_64: 6 new and 7 removed package(s)
  • testing extra x86_64: 160 new and 159 removed package(s)
  • testing multilib x86_64: 9 new and 9 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


libbloom>=1.6-2 update requires manual intervention

(Taken from Arch Linux website, 2019-07-11 by Felix Yan. Source: https://www.archlinux.org/news/libbloom16-2-update-requires-manual-intervention/)

The libbloom package prior to version 1.6-2 was missing a soname link. This has been fixed in 1.6-2, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libbloom: /usr/lib/libbloom.so.1 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

to perform the upgrade.

No problems so far with Kernel 5.2.x, VirtualBox with Xfce.

Have a nice weekend you all. :slight_smile:

Oh Snap, do we really need another way to access software?

All works fine.:grinning:
LXQT+kernel 5.2
Thanks!

ok except I've picked up this 'oddity' xfce4-session-logout not themed

What happens if you downgrade xfce4-session-gtk3 to the version before?

There must have been some glitch, I did not receive the last testing update???? :thinking:
At least I received this one. :smiley:

i was confused for a while :roll_eyes: cos I couldn't find an old version of xfce4-session-gtk3 in my cache......
then I rolled back this package and it fixed it :nerd_face:
sudo pacman -U /var/cache/pacman/pkg/manjaro-xfce-gtk3-minimal-settings-20190609-1-any.pkg.tar.xz

Hi for what snap is preactived ?
Snapd send more informations on Canonical and this no respect the GDPR.
The better is make a information for users "if you active snap you accept to send information of your computer on canonical" !

Please : Do not make manjaro the next Windows 10

Best Regards

3 Likes

The plan is to be able to add more proprietary software such as Spotify and some VPN clients (those are only examples) but snap and flatpak can still be uninstalled by the user if you wish to do that. Honestly don't see what's the big deal is than again I'm not a privacy ordinated person

1 Like

After applying the updated my XFCE actions dialog is not themed anymore, everything else seems to be fine:
image

Seeing the same thing after the XFCE update, also only on log out so no big deal :slight_smile:

Kernel: 5.1.18-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.13.5git-58bf69 

We readded the workaround. Have to see with upstream still to find a proper solution.

The problem is simple I indicated them and I do not speak of flatpak which to a greater respect of the user.

I have a problem with dropbox not loading on Xfce startup it appears for sometime in conky but then disappears, if I click on the icon after all init session ends it loads or if I logout and login. I could not found a solution as it looks like is a thing to do with the session initialization of Xfce.

IMHO we do not need Token, Flatpak, or Snapd, pre-installed. Put it in the Repositories and let the users sort it out. Freeoffice belongs with Windows, stay with Libreoffice. Just saying.

3 Likes

[UPDATE]

The problem is solved by adding an EFI boot partition to a disk and installing GRUB on it. The "/" partition fully accessible now and works. I think, after the updates were done, something happened to GRUB.

[INITIAL MESSAGE]

Hello! I faced an issue with starting Manjaro after rebooting it.

After the update had being done, I restarted the system and got a blinking cursor. Ctrl + Alt +F2(6) didn't respond. So, I booted from the LiveUsb with Manjaro of the same kernel and used chroot to access to the broken system. Then, in chroot, I executed "sudo pacman -Syyuu", it updated two packages of xfce-... and 3 or 4 packages of pacman. Then, I dismount the system (some file on sys was busy, so I used umount with the "--lazy" option), and rebooted. Nothing changed: a bliknking cursor.

What can I do in this situation to recover the system?

On a new install from the GNOME rc5 iso:

/etc/systemd/system/timers.target.wants is not a folder, but a symlink to a single timer (/usr/lib/systemd/system/pamac-mirrorlist.timer)

This prevents enabling other timers, becase the folder they would get symlinked into doesn't exist.

Ouch, then I've created a mistake with last packaging of Pamac. Let me fix that.

1 Like