[Testing Update] 2019-06-24 - Kernels, KDE Plasma, Texlive, Haskell, Python

Hello community,

I am happy to announce another Testing Update.

This update holds the following changes:

  • most of our Kernels got updated. All EOL kernels got removed!
  • KDE Git got updated
  • Texlive got it's first 2019 update
  • latest python and haskell updates
  • Manjaro Juhraya ISOs got updated, including snap support pre-activated: XFCE, Gnome

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.69
  • linux44 4.4.183 (no legacy nvidia-340 module!)
  • linux49 4.9.183
  • linux414 4.14.129
  • linux419 4.19.55
  • linux51 5.1.14
  • linux52 5.2-rc6 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.14_rt9

Package Updates (Sat Jun 22 09:55:58 CEST 2019)

  • testing community x86_64: 241 new and 230 removed package(s)
  • testing core x86_64: 27 new and 34 removed package(s)
  • testing extra x86_64: 213 new and 379 removed package(s)
  • testing multilib x86_64: 7 new and 7 removed package(s)

A detailed list can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Some KDE System Settings may have been re-set to their defaults

  • System Settings > Input Devices > Touchpad > Tap-to-click
  • Scrolling
  • The compositor could get disabled during the upgrade which will stop all of the KDE eye-candy

Kvantum theme reset

If you are using the Matcha theme in kvantum you may experience a theme reset. Simply install kvantum-theme-matcha if not happend yet and select the new provided variants. Manjaro 18.1 releases will ship with the new themes by default.


Issues with Octopi

Currently several users report different issues for Octopi. So if you encounter some of them, you may switch to pamac for now: sudo pacman -Sy pamac


Items from previous update sets

Small cleanup of Manjaro official repositories

Please note that the following packages got removed from our repositories.

  • chromium-chromevox
  • gimp-gtk3
  • pamac-classic
  • pamac-dev
  • pamac-dev-tray-appindicator

ZFS 0.8 fails to import ZFS pool during boot

As noted for testing update 2019-05-29, it can be permanently fixed
by removing and re-adding the pool's cachefile :

zpool set cachefile=none <name of your pool>
zpool set cachefile=/etc/zfs/zpool.cache <name of your pool>

More details in [Testing Update] 2019-05-29 - Kernels, XFCE, Deepin, Mesa, Nvidia, KDE-Dev (search for 'ZFS' there)


Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.


Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.


vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, remove vlc-nightly, then install the vlc package.

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

1 Like

Since it was released yesterday, some people discussed about that update set in the previous announcement thread. Here's a link just for the sake of reference.

Worked well for me. No issues whatsoever.
Xfce via TTY, Kernel 5.2

1 Like

It all started with Perl.

My 2700X system (keep forgetting to grab the inxi) updated via TTY with only a minor hiccup. Firefox randomly becomes unmovable. Haven't had time to run that one down. Otherwise all good on that front.

This machine (Frank). /sigh
Updated via TTY. When pacman got to perl during the install phase it just... died. I don't know if pacman crashed or if perl glitched or what.
When I tried to reboot systemctl reboot I was told that service was not available. Tried other commands... reboot, poweroff, systemctl poweroff, and even the reboot stupid
command didn't help.
Reset button time. :zap:
Got to dekstop and after a moment the system became unresponsive (Hi, partial upgrade, nice to meet you). ctrl+alt+F2 (I can't figure out how people use the little buttons for the ctrl and alt snazziness) thankfully worked. sudo pacman -Syu
Now it says all my keys are invalid. Fix it.
Reboot, get to desktop, check journalctl, some kind of huge string of I/O errors. System locks.
Live USB time.:woman_superhero:
Fearing my new SSD was on it's way to the trash I ran many tests in Live. The SSD was fine.
Restored Timeshift backup, then tried sudo pacman -Syu (and hope) with no problems.
Still have no idea what happened and like a moron I forgot to save the journalctl outputs in my panic. :frowning:
Apologies for the novel.

Updated and no major issues. Keyboard volume control disappeared, bad latency on Calf plugin screen draws, and Plasma lost the configuration for 3 monitors. Using the Plasma monitor configuration tool isnt persistent between logouts, suspends or reboots. I consider most of this minor that can be fixed with tinkering.

System is Asus I7-4790, 5.2.0-1 kernel NVIDIA GT-730 graphics. Both XFCE and Plasma. XFCE desktop didnt change monitor configuration from before the update. Volume control and Calf draw latency problems persist across both DE's. Still a good update with lighter CPU usage on many tasks. Thanks philm for the great work.

Edit- all solved

This update broke my computer. I think it was the photo.

pacman -Rns philip_mueller_pic

8 Likes

c00ter
philm is gonna get you for that

1 Like

seems you liked bernhard_landauer_pic then :stuck_out_tongue:

4 Likes

Updated 3 computers: a work machine, an optimus laptop, and a gaming tower. All updated without a hitch.

I'm happy to report that with the recent upstream revert of the commit that broke connectivity to some bluetooth devices, I can use my PS4 controller via bluetooth again without needing to use a realtime kernel. Tested using kernel 4.19.55.

Hopefully this will benefit some of the people reporting issues with bluetooth devices since last month.

1 Like

All good for me.:grinning:
LXQT+ Kernel 5.1
Thanks!

1 Like

After running the update a bit, I notice experiencing slight screen latency. Ran glxgears and find that (screen refresh rate is 60Hz) occasionally drops down as far as 55FPS majority at 59+FPS. This affects other things like the calf plugins which occasionally hesitate. System is Asus I7-4790, 5.2.0-1 kernel NVIDIA GT-730 graphics. Both XFCE and Plasma. Driver is Nvidia 430.26, X22 Server XOrg 1.20.5. Change NVidia drivers? The etc/X11/mhwd.d/nvidia.conf file does not include Section "Extensions" Option Composite Enable. I have edited nvidia.conf to include this and it does not seem to make any difference. Interestingly, glxgears only exhibits this on the Plasma desktop, not on XFCE.
Regards

edit- started a separate thread with these questions.

i have this message

mjro systemd[1]: Failed to bump fs.file-max, ignoring: Invalid argument

waiting for fix ( see also how they want to close before really check...)

Another smooth upgrade!

Upgrade via tty, Kernel 5.2.x, KDE, btrfs, luks, nVidia, Virtualbox

Update is fine so far.

Is it just me or are there browsers missing from the testing repos? Wanted to install vivaldi this morning, but could not find it:

$ sudo pacman -Ss vivaldi
$ 

Opera beta seems to be missing as well. Tried to update the databases and switched mirror, but nothing changed.
inxi output

[rene@e325 ~]$ sudo inxi -Fcx
System:    Host: e325 Kernel: 5.1.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Xfce 4.13.4git-be04da 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 1297A26 v: ThinkPad Edge E325 serial: LRM18M9 
           Mobo: LENOVO model: 1297A26 serial: 1ZK9U2790GV UEFI: LENOVO v: 8SET32WW (1.14 ) date: 09/26/2011 
CPU:       Topology: Dual Core model: AMD E-450 APU with Radeon HD Graphics bits: 64 type: MCP arch: Bobcat L2 cache: 512 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a ssse3 svm bogomips: 6588 
           Speed: 825 MHz min/max: 825/1650 MHz Core speeds (MHz): 1: 950 2: 828 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320] vendor: Lenovo driver: radeon v: kernel 
           bus ID: 00:01.0 
           Display: server: X.Org 1.20.5 driver: ati,radeon unloaded: modesetting tty: N/A 
           OpenGL: renderer: AMD PALM (DRM 2.50.0 / 5.1.14-1-MANJARO LLVM 8.0.0) v: 3.3 Mesa 19.1.0 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Wrestler HDMI Audio driver: snd_hda_intel v: kernel bus ID: 00:01.1 
           Device-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Sound Server: ALSA v: k5.1.14-1-MANJARO 
Network:   Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce v: kernel port: 3000 bus ID: 01:00.0 
           IF: wlp1s0 state: up mac: e0:06:e6:c1:cc:81 
           Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Lenovo driver: atl1c v: 1.0.1.1-NAPI port: 2000 
           bus ID: 02:00.0 
           IF: enp2s0 state: down mac: 08:9e:01:00:8b:ee 

I installed Vivaldi earlier this evening from the Aur along with the widevine plugin and codecs on my stable install , no problems , works like a charm .

vivaldi and opera used to be in the community repo, no need to use the AUR

Eh , Doesn't bother me either way , as long as it works .

1 Like

Opera is there again in the community repo, Vivaldi still is not...maybe this is related to the switch to gcc 9.1?

For Vivaldi [Stable & Snapshot]... Use the herecura repo. It works a treat... and btw, this has been covered many times in many places in the forum.

2 Likes