[Testing Update] 2019-06-20 - Kernels, KDE Plasma, Browsers, Mesa, Qt5

No.
Not in front of my KDE computer now, I'll check again later, but from what I remember from yesterday, it is enabled, but doesn't work.

Thank you. I wonder how my cache would affect the ability of pages to load. I wonder if the underlying 'database' supplying the cache could get corrupted.

Anyway, the lesson is: Just because a problem surfaces immediately after an update, that does not mean the problem is caused by an update.

2 Likes

No problems on XFCE with Linux 5.1.12, everything seems to be working.

Upgraded from Pamac GTK both on desktop (with GTX 970 on non-free drivers) and on laptop (with Intel GPU on free drivers). The upgrade in itself went flawlessly on my side, no weird freeze or lock in middle of upgrade.

I'll do another post if I find anything weird or wrong on my side.

Both systems are on Manjaro Cinnamon, dual-booting with Windows 10.


Working fine on my side, I can launch it and use it without problem. I am using qbittorrent from official repos, and everything is up is synchronized with repos (no downgraded packages).

I am on Manjaro Cinnamon though, not Gnome. It might matter.

EDIT: Nevermind, it is not working as bad on my side, but not as well as I first though.


Could you detail that part more exactly? What changed compared to before, outside apparmor being shipped by default?

Well, I guess I got part of the answer by trying out quickly Manjaro XFCE 18.1.0 RC2 in a virtual machine. In addition to ship AppArmor by default:

  • The required kernel parameters are set in GRUB on the freshly installed system.
	linux	/boot/vmlinuz-5.1-x86_64 root=[...] rw  quiet apparmor=1 security=apparmor udev.log_priority=3 audit=0
  • The apparmor.service unit is now enabled by default after installation.
[lachancla grub]# systemctl status apparmor.service
● apparmor.service - Load AppArmor profiles
   Loaded: loaded (/usr/lib/systemd/system/apparmor.service; enabled; vendor preset: disabled)
   Active: active (exited) since Fri 2019-06-21 21:33:55 EDT; 13min ago
 Main PID: 272 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4712)
   Memory: 0B
   CGroup: /system.slice/apparmor.service

jun 21 21:33:49 lachancla apparmor.systemd[272]: Restarting AppArmor
jun 21 21:33:49 lachancla apparmor.systemd[272]: Reloading AppArmor profiles
jun 21 21:33:55 lachancla systemd[1]: Started Load AppArmor profiles.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
[lachancla grub]# systemctl is-enabled apparmor.service
enabled
[lachancla grub]# 

Well, essentially following the recommendations on Arch Linux wiki.
https://wiki.archlinux.org/index.php/AppArmor

Neither of those two things are retroactive: older installations don't have those new kernel parameters, and older installation doesn't have apparmor.service enabled by default. Which is perfectly fine for me, considering that in that way, we won't needlessly disturb older installation for people who are used not to have AppArmor; outside of having to keep apparmor package, older installation will simply work as it used to.

Now the question is if there is someone who is willing to do a detailed guide on how to enable AppArmor for older installations, for people who might actually be interested to use it.

EDIT: I manually enabled AppArmor on my desktop machine just to see if having it enabled on my machine would actually disturb my old habits or if it wouldn't make a difference at all. I do not plan to use and configure AppArmor more "seriously". My idea behind that is to see if AppArmor will have a negative impact on users that do not care at all about AppArmor and won't bother to configure it, if they are even aware that it is enabled, running and actually know what AppArmor is to begin with.

[awesome@i56400 ~]$ aa-enabled
Yes
[awesome@i56400 ~]$ aa-status
apparmor module is loaded.
You do not have enough privilege to read the profile set.
[awesome@i56400 ~]$ sudo aa-status
[sudo] password for awesome: 
apparmor module is loaded.
49 profiles are loaded.
49 profiles are in enforce mode.
[...]
[awesome@i56400 ~]$ systemctl status apparmor.service
● apparmor.service - Load AppArmor profiles
   Loaded: loaded (/usr/lib/systemd/system/apparmor.service; enabled; vendor preset: disabled)
   Active: active (exited) since Fri 2019-06-21 22:52:29 EDT; 1min 37s ago
  Process: 254 ExecStart=/lib/apparmor/apparmor.systemd reload (code=exited, status=0/SUCCESS)
 Main PID: 254 (code=exited, status=0/SUCCESS)

[...]
[awesome@i56400 ~]$ systemctl is-enabled apparmor.service
enabled

2 Likes

[burster@liza ~]$ pamac-qt
QML debugging is enabled. Only use this in a safe environment.
QQmlApplicationEngine failed to load component
qrc:/src/qml/MainWindow.qml:-1 File was compiled ahead of time with an incompatible version of Qt and the original file cannot be found. Please recompile

@philm Does pamac-qt needs to be recompiled against QT 5.12.4?

Well, in addition to the configuration of AppArmor, snapd is also installed by default on XFCE 18.1.0 RC2.

[issou@lachancla Bureau]$ pacman -Q snapd
snapd 2.39.2-4
[issou@lachancla Bureau]$ pamac info snapd
Nom                       : snapd
Version                   : 2.39.2-4
Description               : Service and tools for management of snap packages.
URL                       : https://github.com/snapcore/snapd
Licences                  : GPL3
DĂ©pĂŽt                     : community
Taille                    : 67,6 Mo
DĂ©pend de                 : squashfs-tools libseccomp libsystemd apparmor
DĂ©pendances optionnelles  : bash-completion: bash completion support
                            [Installés]
Est en conflit avec       : snap-confine
Paqueteur                 : Philip MĂŒller <philm@manjaro.org>
Compilé le                : 2019-06-13
Installé le               : 2019-06-20
Motif d’installation      : Explicitement installĂ©

[issou@lachancla Bureau]$ snap
The snap command lets you install, configure, refresh and remove snaps.
Snaps are packages that work across many different Linux distributions,
enabling secure delivery and operation of the latest apps and utilities.

Usage: snap <command> [<options>...]

Commands can be classified as follows:

         Basics: find, info, install, list, remove
        ...more: refresh, revert, switch, disable, enable
        History: changes, tasks, abort, watch
        Daemons: services, start, stop, restart, logs
       Commands: alias, aliases, unalias, prefer
  Configuration: get, set, wait
        Account: login, logout, whoami
    Permissions: connections, interface, connect, disconnect
      Snapshots: saved, save, check-snapshot, restore, forget
          Other: version, warnings, okay, ack, known
    Development: run, pack, try, download, prepare-image

For more information about a command, run 'snap help <command>'.
For a short summary of all commands, run 'snap help --all'.
[issou@lachancla Bureau]$ 

This will surely be pretty controversial.

(Sorry for the triple post, but it was either that or a mega-long thread with three distinct idea written at three different moments.)

1 Like

It does not crash on Xfce 4.12, but qBittorrent no longer restores from minimize to tray. There is only an outline, and the program becomes unusable and must be quit.

downgrade qt5-base qt5-multimedia qt5-svg qt5-x11extras qt5-styleplugins

To:
qt5-base-5.12.3-2.1
qt5-multimedia-5.12.3-1
qt5-svg-5.12.3-1
qt5-x11extras-5.12.3-1
qt5-styleplugins-5.0.0.20170311-13

LOL, all it takes is an all expenses paid conference ... the more the world changes the more it stays the same.

Just something else to remove immediately post install.

6 Likes

There was a LOOOOOOOONG thread about this before this release.
The inclusion shouldn't be news to anyone.

Mein Gott, this daemon :japanese_goblin: pretending to be innocent service for enhancing user access to various apps will eat all your disk space, slow down your PC, enslave your children and kill your cat! Oh, these malicious Manjaro devs and their dodgy traps! They are turning Manjaro into Ubuntu!

PS: of course I don't use it btw :joy:

2 Likes

Thanks korealinux works great now :smiley:

Ah yes, indeed, I do confirm that part. It launches fine on Cinnamon, but if I try to restore it from tray, I only have the outline of the window and I have to quit it. Good catch.

I wonder if a simple rebuild against 5.12.4 would do the trick, or if it is more complicated than that.

Although it's odd that I find nothing similar on Arch Linux.

EDIT: Tried out to rebuild qBittorrent using build files from AUR and it doesn't improve the situation on my side. It's seems more complicated than that. Returned to the original package.

EDIT2 : I can restore the window completely by maximizing/minimizing it when on QT 5.12.4. Annoying, but less than having to close it completely I guess?

2 Likes

Sorry @Frog, accidentally used the reply button on your post, cant seem to remove it now.

Everything went smoothly but any idea why my task bar and application menu looks grainy after this update? (it looks good tho) :rofl:

I have the same thing. I thought it was me since both machines running KDE have it.
Both are running Sweet KDE theme. I switched to a different theme and it's not grainy so I guess it must be the texture used isn't scaling right or something?

I installed a fresh copy of the testing branch on virtual box and it doesn't appear grainy.

Alright, so i tried changing the compositor, it appears to be grainy on OpenGL 3.1 (the one im using) & OpenGL 2.0, but not grainy on XRender

I'm using openGL 3.1 as well. Just checked on both machines switching to XRender. No graininess as you said.
weird.... where the heck do you report that bug?

Not sure where to report, guess we wait and a dev will read the posts?

How weird, its only effecting the application menu and taskbar, nothing else.

Do you have blur enabled?

You may need to adjust the blur noise strength in System Settings -> Desktop Behavior -> Desktop Effects.

3 Likes

Forum kindly sponsored by Bytemark