[Testing Update] 2019-06-17 - Kernels, KDE Plasma, Browsers, XFCE, Deepin, Nvidia, Haskell, Perl

Hello community,

I am happy to announce another Testing Update.

This update holds the following changes:

  • most of our Kernels got updated
  • KDE Plasma is now at 5.16.0
  • we added some Browser updates
  • Nvidia driver got update to 430.26
  • XFCE and Deepin packages got renewed
  • dbus and dbus-x11 depend now on apparmor to support snaps with strict confinement. Test it with the upcoming 18.1.0-rc2 releases. XFCE
  • the usual Haskell and Python updates

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.67
  • linux318 3.18.140 [EOL]
  • linux44 4.4.181 (no legacy nvidia-340 module!)
  • linux49 4.9.181
  • linux414 4.14.126
  • linux419 4.19.51
  • linux420 4.20.17 [EOL]
  • linux50 5.0.21 [EOL]
  • linux51 5.1.10
  • linux52 5.2-rc5 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.50_rt22
  • linux50-rt 5.0.14_rt9

Package Updates (Mon Jun 17 07:31:40 CEST 2019)

  • testing community x86_64: 1274 new and 1266 removed package(s)
  • testing core x86_64: 31 new and 29 removed package(s)
  • testing extra x86_64: 527 new and 695 removed package(s)
  • testing multilib x86_64: 6 new and 6 removed package(s)

A detailed list can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

12 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Some KDE System Settings may have been re-set to their defaults

  • System Settings > Input Devices > Touchpad > Tap-to-click
  • Scrolling
  • The compositor could get disabled during the upgrade which will stop all of the KDE eye-candy

Kvantum theme reset

If you are using the Matcha theme in kvantum you may experience a theme reset. Simply install kvantum-theme-matcha if not happend yet and select the new provided variants. Manjaro 18.1 releases will ship with the new themes by default.


Issues with Octopi

Currently several users report different issues for Octopi. So if you encounter some of them, you may switch to pamac for now: sudo pacman -Sy pamac


Items from previous update sets

Small cleanup of Manjaro official repositories

Please note that the following packages got removed from our repositories.

  • chromium-chromevox
  • gimp-gtk3
  • pamac-classic
  • pamac-dev
  • pamac-dev-tray-appindicator

ZFS 0.8 fails to import ZFS pool during boot

As noted for testing update 2019-05-29, it can be permanently fixed
by removing and re-adding the pool's cachefile :

zpool set cachefile=none <name of your pool>
zpool set cachefile=/etc/zfs/zpool.cache <name of your pool>

More details in [Testing Update] 2019-05-29 - Kernels, XFCE, Deepin, Mesa, Nvidia, KDE-Dev (search for 'ZFS' there)


Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.


Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.


vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, remove vlc-nightly, then install the vlc package.

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Hi Philm.
Everythings ok but just need to --overwrite snapd.
Brand new profile with firefox.

Hello!

I just updated and seems that everything went smooth so far but the new Firefox asked if it should create a new profile and me idiot clicked yes. So everything was gone, I think that's a little too dangerous?

I was able to import at least my bookmarks from automated backups in ~/.mozilla/firefox/{somenumber}/bookmarkbackups/

1 Like

Also got the firefox problem. Solved by running

MOZ_ALLOW_DOWNGRADE=1 firefox

as suggested here: firefox 67.0.2-1 in unstable
(Don't know how to edit empty wiki post, perhaps someone can add once it exists?)

Also got a new systemd warning message in the journal

Relevant code in systemd is here: https://github.com/systemd/systemd/blob/master/src/core/main.c
but I can't read that stuff... :wink:

7 Likes

Thank you very much!

2 Likes

Same Firefox issue, but the fix proposed above works.

This update also removed the link to my keyfile to automatically decrypt / and /home. I was able to type the password manually so able to boot, but this is a pretty unexpected surprise.
Need to check what exactly happened but got other work to do first.

Upgrade via tty, Kernel 5.1.x, KDE, btrfs, luks, nVidia, Virtualbox

Update: I cleaned all (but one) of my luks slots, recreated the keyfile, basically went through all the steps outlined here Decryption problem again, but I still get prompted for my password. Strange...

The Firefox issue seems to have gone away after I started FF once with the MOZ_ALLOW switch. I will nevertheless upgrade to firefox-67.0.2-1.0 which became available just now.

Nvidia 430.26 still same problems as 430.14. CUDA/NVENC/VDPAU issues.

With this update my KDE started with k5.2 ) So far good.

Yes issue with Firefox:

ff message:

Screenshot_20190617_103654

Thanks to @grinner it was fixed.

1 Like

I also have had the issue with Firefox and also have had fixed it with the proposed solution.
:grinning:

I probably would have also had the Firefox issue, but I just applied the fix without trying it without the fix and everything went smoothly.

Same here, I applied the Firefox fix in first place after reboot. All good.

Check if your old profile is still there with the Profilemanager:
firefox -P
Normally, Firefox should never delete a profile, just create a new one...

BTW, I had no problem whatsoever with my Firefox after I did the update just now.

3 Likes

83 Package update successfully, after reboot works fine.:+1:
LXQT with Kernel 5.1.
Thanks!

I had no time this morning to announce it properly. Please point me to the Firefox issue.

3 Likes

Some KDE System Settings may have been re-set to their defaults.
For me, System Settings > Input Devices > Touchpad > Tap-to-click

If somebody can reproduce, would a privileged user please add this to the wiki post?

1 Like

rtorrent crashed twice (core dump) after no crashes in months after today's update.

Downgraded curl 7.65.1-2 -> 7.65.1-1. Just guessing. Will see if crashes continue.

rtorrent log
1560765526 N rtorrent main: Starting thread.                                                                                                                                                  
1560765526 N rtorrent scgi: Starting thread.                                                                                                                                                  
1560765568 C Caught signal: 'Segmentation fault.                                                                                                                                              
---DUMP---                                                                                                                                                                                    
Caught Segmentation fault, dumping stack:                                                                                                                                                     
rtorrent(+0x37a4e) [0x55ba0bb62a4e]                                                                                                                                                           
/usr/lib/libpthread.so.0(+0x124d0) [0x7ffa9acc14d0]                                                                                                                                           
/usr/lib/libtorrent.so.20(_ZN7torrent9PollEPoll11insert_readEPNS_5EventE+0x74) [0x7ffa9ad52b54]                                                                                               
rtorrent(+0x1279ab) [0x55ba0bc529ab]                                                                                                                                                          
/usr/lib/libcurl.so.4(+0x32fbc) [0x7ffa9b067fbc]                                                                                                                                              
/usr/lib/libcurl.so.4(+0x3615f) [0x7ffa9b06b15f]                                                                                                                                              
/usr/lib/libcurl.so.4(curl_multi_socket_action+0x25) [0x7ffa9b06b315]                                                                                                                         
rtorrent(+0x1254db) [0x55ba0bc504db]                                                                                                                                                          
/usr/lib/libtorrent.so.20(_ZN7torrent9PollEPoll7performEv+0xee) [0x7ffa9ad5268e]                                                                                                              
/usr/lib/libtorrent.so.20(_ZN7torrent9PollEPoll7do_pollEli+0x91) [0x7ffa9ad527a1]                                                                                                             
/usr/lib/libtorrent.so.20(_ZN7torrent11thread_base10event_loopEPS0_+0x118) [0x7ffa9ad8d3d8]                                                                                                   
rtorrent(+0x36a15) [0x55ba0bb61a15]                                                                                                                                                           
/usr/lib/libc.so.6(__libc_start_main+0xf3) [0x7ffa9a963ce3]                                                                                                                                   
rtorrent(+0x372fe) [0x55ba0bb622fe]                                                                                                                                                           
                                                                                                                                                                                              
---END---                                                                                                                                                                                     
1 Like

Let me know if anyone has a profile backup which they can use to replicate the issue.

I can rebuild 67.0.2 as 67.0.2-1.0 with whatever options I used before which might avoid this problem when the package reaches stable.


Edit: actually, I wonder whether this is caused by people sharing a profile between Release and Beta/Aurora/Developer/Nightly editions...

Just to keep it in one place please discuss on the other thread, firefox 67.0.2-1 in unstable

Oh boy. This is this time of year, eh?

100% successful update first of my Testing VM, then my real Tower. In both cases:

  1. Did NOT suffer the reported Firefox problem, ergo did not need to fix anything.
  2. Did NOT suffer the reported LUKS problem, but then again it's only my /home partition that's LUKS'd, not the full disk.
  3. Had to uninstall shutter & its dozens of dependencies before i could proceed with the updates, per the chat i initiated on this in the [Unstable Update] 2019-05-03 - Kernels, Backintime, Palemoon thread, then reinstall it all again afterwards.

All good, ta @philm & colleagues.


Oh, Plasma 5.16.0 changed one setting in its Task Manager from my preference, so given the mentions by others before me here & elsewhere in the forum, i expect over coming day/s i'll likely stumble across random other settings it has reset.