[Testing Update] 2019-05-29 - Kernels, XFCE, Deepin, Mesa, Nvidia, KDE-Dev

Nvidia 430.14 broke mpv hardware decoding.

vo=gpu (the default mode) with hwdec=yes results in Segmentation fault (core dumped). hwdec=cuda and copy-back modes also segfaults.

dmesg output:

[  702.543306] mpv[2262]: segfault at e ip 00007f0b65b0d0c0 sp 00007ffdc802e4e0 error 4 in libnvcuvid.so.430.14[7f0b65acc000+312000]
[  702.543312] Code: 48 c7 40 08 00 00 00 00 48 c7 40 10 00 00 00 00 c3 90 90 90 90 90 90 90 90 90 f6 07 08 53 48 89 fb 75 10 48 8b 97 50 01 00 00 <0f> b7 42 0e 66 ff c0 74 07 5b 31 c0 c3 0f

vo=vdpau works with hwdec=yes, but there is now stutter in 60fps videos. It can be fixed by turning compositor off (it does not seem to matter which compositor is used, tested with xfwm4 and compton glx).

vo=vdpau 60fps stutter can also be fixed (mostly) with these additional mpv options:

vo-vdpau-queuetime-windowed=0
vo-vdpau-queuetime-fs=0

vo=vdpau and hwdec=cuda still segfaults.

It depends if prime or bumblebee is used. Non-glnvd libs are however broken in 430.

this will not be easy

" Given the recent work on glxvnd in Xorg, can we assume a native solution for Optimus is in the pipeline? With the dynamic power switching problem being already solved natively in the kernel for newer Optimus hardware, if glxvnd/glvnd can solve the bringing problem then we won't need bumblebee and primus anymore with new hardware and a recent software stack. We can keep them for the legacy driver series.

#38

Posted 05/26/2019 06:05 PM

simon.k.whiteley

I similar problems on Arch Linux but only the DisplayPort output is affected. HDMI output runs perfectly.

I have returned to 390xx drivers.

Simon.

on nvidia notes
https://devtalk.nvidia.com/default/topic/1032650/linux/unix-graphics-feature-deprecation-schedule/
Support for non-GLVND OpenGL and EGL libraries on Linux
The release 430 series will be the last to support installing Linux OpenGL and EGL client libraries that do not use the GL Vendor Neutral Dispatch (GLVND) loader library.

on notes
"The first post has been updated to note that support for Linux non-GLVND OpenGL and EGL client libraries will be removed in a future release."

Aaron Plattner
NVIDIA Linux Graphics

#6

Posted 04/29/2019 09:23 PM

4 version drivers , depreciation as they want that not always indicated on version , and breaks dance for optimus / primus .... ( laptop )

Opera menu bug looks like a long term Chromium issue I reported years ago about popup descriptions being screwed up too. Try with hardware acceleration turned off

1 Like

Thanks. This fixed the bug.
Strange thing is that I see this bug first time. It appears after 05/29 update wich included Opera minor update.

Seems there is an issue with new version of network-manager-applet 1.8.22-1.

Passwords for VPN connections don't seem to be stored when "Store the password only for this user" is selected. When entering the password in the configuration and pressing save, next time you open settings again, the password field is empty. Also it'll ask you for the password on connecting...

downgrading to 1.8.21dev+3+gb4c365b1 fixes the problem.

btw. when working in a single user environment one can choose "Store the password for all users". That still works.

edit
reported it here: https://gitlab.gnome.org/GNOME/network-manager-applet/issues/59

Seems to be a regression. Will check the code.

...done
15508 Thunar General xfce-bugs NEW --- Thunar 1.8.6-2 is crashing, when ejecting USB stick properly. Thunar-volman is verson 0.9.2-1 10:54:18

1 Like

I do not understand how GLVND interacts with vdpau and cuda. I am not using prime or bumblebee however.

Maybe this bug report is related to the mpv hwdec segfaults?

I don't know how to downgrade Nvidia without rolling back my entire system using Timeshift however... :panda_face:


Edit: OK downgrading nvidia and all kernels worked.

sudo pacman -U /var/cache/pacman/pkg/{linux414-4.14.121-1-x86_64.pkg.tar.xz,linux414-nvidia-1:418.74-6-x86_64.pkg.tar.xz,linux414-r8168-8.047.01-5-x86_64.pkg.tar.xz,linux419-4.19.45-1-x86_64.pkg.tar.xz,linux419-nvidia-1:418.74-5-x86_64.pkg.tar.xz,linux419-r8168-8.047.01-4-x86_64.pkg.tar.xz,linux50-5.0.18-1-x86_64.pkg.tar.xz,linux50-nvidia-1:418.74-6-x86_64.pkg.tar.xz,linux50-r8168-8.047.01-4-x86_64.pkg.tar.xz,mhwd-nvidia-1:418.74-1-any.pkg.tar.xz,nvidia-utils-1:418.74-1-x86_64.pkg.tar.xz,lib32-nvidia-utils-1:418.74-1-x86_64.pkg.tar.xz}

Seems we have to revert to the previous driver as it seems.

1 Like

Always point to the exact git-commit we are using:

petsam wrote to mbod

It would be nice if you updated the known issues

As I use ZFS I might need a reminder when eventually updating to 0.8 in stable, so I've put a brief note in the wiki-posts for this update and May 30th. Hope mbod doesn't mind.

1 Like

...yup,

is fixed in gtk3 version with todays update. :smiley:

ti's the second time i see this
if you have with sudo pacman -Qdt
openssl appears , missing depencies explicit

i have tried under vbox i3 and you lose immedialy any rights sudoers & whel and you cant do any exec after with pacman

@philm, did you forget to push the latest extramodules source to GitLab?

I also think that with the latest DKMS update, the line
find "$pkgdir" -name '*.ko' -exec gzip -9 {} +
is not necessary anymore in virtualbox-host-sources, because the modules are already compressed with XZ.
(compare 6.0.8-3 and 6.0.8-4 packages, first uses GZIP compressed modules, second XZ).

EDIT: oops, this should have gone into the 2019-06-01 update thread.
@moderators, can you please move this post over?

1 Like

Installed the last three testing upgrades at once today as I was on vacation the last week. Upgrade procedure went well for me using KDE, LTS kernel 4.19, LUKS encrypted /home and nvidia-proprietary@bumblebee. No installation issues occurred.

I noticed only one small (I would call it) "inconsistency" for my setup. The Nvidia drivers were updated to version 430.14 even though this new release doesn't support my Kepler based Geforce GT 650m card.

The "Manjaro Settings Manager [MSM]" displays only the "compatible" video-hybrid-intel-nvidia-bumblebee options for 340xxx and 390xxx and not for the already installed one in version 430.14 (418xxx series were fine for my setup and displayed). Regarding the MSM, no (compatible?) driver was installed. Trying to install the correct drivers via "Auto Install Proprietary Driver" failed with an error message, that 390xxx version collides with currently installed packages.

Solution was to detect installed drivers via mhwd in terminal, removing some dependencies (opencl, nvidia-xrun, primus_vk) and uninstalling video-hybrid-intel-nvidia-bumblebee via mhwd. Afterwards, "Auto Install Proprietary Driver" worked without any issues. No big deal but worth to mention.

There was a problem with libinput-gestures:

Le fichier /var/cache/pacman/pkg/libinput-gestures-2.44-1-any.pkg.tar.xz est corrompu (paquet non valide ou corrompu (signature PGP))

TL;DR (or don't read French): problem with the PGP signature for that package. Doing what is advised here did not solve the problem. The only way forward was to remove gestures and libinput-gestures.

I've got this problem with Mesa 19.0.5: https://bugs.freedesktop.org/show_bug.cgi?id=110721

(yep I know it says 19.1, but the bug exists in 19.0.5 as well)

Downgrading to 19.0.3 or upgrading to 19.0.6 fixes it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark