[Testing Update] 2019-05-29 - Kernels, XFCE, Deepin, Mesa, Nvidia, KDE-Dev

Hello community,

I am happy to announce another Testing Update!

This update holds the following changes:

  • We updated most of our kernels. Remember that linux318 now really had it's last build last week!
  • Another set of KDE-git packages. KDE-Dev-ISOs, KDE-Vanilla-ISOs
  • XFCE is now at 4.14-pre1. Checkout our new ISO!
  • Mesa is now at 19.0.5
  • Nvidia driver got updated to 430.14
  • We added more Deepin package updates
  • Haskell, python and other packages got updated to their latest build

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.67
  • linux318 3.18.140 [EOL] (it is now really EOL!)
  • linux44 4.4.180 (no legacy nvidia-340 module!)
  • linux49 4.9.178
  • linux414 4.14.122
  • linux419 4.19.46
  • linux420 4.20.17 [EOL]
  • linux50 5.0.19
  • linux51 5.1.5
  • linux51 5.2-rc1 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.14_rt9

Package Updates (Wed May 29 07:43:58 CEST 2019)

  • testing community x86_64: 854 new and 818 removed package(s)
  • testing core x86_64: 15 new and 15 removed package(s)
  • testing extra x86_64: 204 new and 211 removed package(s)
  • testing multilib x86_64: 23 new and 23 removed package(s)

A list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Small cleanup of Manjaro official repositories

Please note that the following packages got removed from our repositories.

  • chromium-chromevox
  • gimp-gtk3
  • pamac-classic
  • pamac-dev
  • pamac-dev-tray-appindicator

ZFS 0.8 fails to import ZFS pool during boot

As noted by @mbod, it can be permanently fixed
by removing and re-adding the pool's cachefile :

zpool set cachefile=none <name of your pool>
zpool set cachefile=/etc/zfs/zpool.cache <name of your pool>

Items from previous update sets

Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.

Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.

vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, remove vlc-nightly, then install the vlc package.

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Caution ZFS users: This update brings zfs-0.8. And this fails to import my ZFS pool during boot.

zfs-import-cache.service is failing because it somehow can not handle the cache file. When I excecute the import command manually I get the following error:

2# zpool import -c /etc/zfs/zpool.cache -aN
invalid or corrupt cache file contents: invalid or missing cache file

Manual import via zpool import -f works fine.

If I remove the cache file, it creates a new one with the next manual import but it is still showing the same error. And a diff of the caches files shows that the new cache file is exactly the same as the old cache file.

I will create an issue on github for this.



Flawless update on Xfce (VBox) and LXDE. Thanks!

Smooth update. Xfce, Nvidia, linux51. :grinning:

Did notice that js52 was left over as an orphan. Should it be removed by default when replaced by js60, since nothing in the repo's depends on it?

Updated KDE edition on 3 different hardware. On 2 of them (Dell XPS laptop and Home build Desktop) no issues. On a BTO laptop bought at "ubuntustore.be" (Manjaro hardware partner) I was unable to connect with Wi-Fi and kernel 5.1. on first reboot.
I reboot with Kernel 4.19 and after a quite long time I could connect to my network. Then, I reboot again with 5.1 and this time I got a normal connection..... So it's OK now, but strange.

44 packages updated without problems, after a reboot everything is fine.:+1:
LXQT + AMD free + Kernel 5.1.
Thank you!

...same as I posted last xfce update:

(thunar:1476): thunar-WARNING **: 11:11:49.300: Content type loading failed for C143-1420: Fehler beim Holen der Informationen für Datei »/run/media/jan/C143-1420«: Datei oder Verzeichnis nicht gefunden
Speicherzugriffsfehler (Speicherabzug geschrieben)

Thunar is crashing, when ejecting USB stick properly.

1 Like

Krita 4.2 is using the Fusion widget style decoration. A bug or an intentional decision? I can use the KRITA_NO_STYLE_OVERRIDE=1 krita workaround, but i'm just curios if this will be the default from now on. :slight_smile:

there's something with Opera


(mouse right click menu on empty space)

1 Like

While this version of xfwm4-gtk3 fixes cpu issues for those of us on nvidia xfce, I'm just recently noticing subtle input lag when the compositor is enabled. For you testers who are running the latest xfce 4.13 packages and have non-free nvidia installed: test out your library of games (make sure any in-game setting of "wait for vertical sync" is disabled) and look for any input lag change with xfce's compositor both enabled and disabled.

xfwm4-gtk3: 4.13.2-4
nvidia-utils: 1:430.14-1
linux51: 5.1.5-1
mouse: Logitech G Pro Gaming

No problems, but it looks as if I got a couple of orphans:

$ pacman -Qdt
js52 52.9.0-2
taglib-extras 1.0.1-5

Taglib-extras is listed in the list of package changes.

Xfce (Gtk+) + linux5.1.5+Steam(OpenGl) + youtube (1080px60fps ) + Nvidia430.14 ok

only 3 orphans

sudo pacman -Qdt
gnome-icon-theme 3.12.0-5
js52 52.9.0-2
python-msgpack 0.6.1-1

only this

-- Logs begin at Sun 2017-07-02 09:46:47 CEST, end at Wed 2019-05-29 13:08:00 CEST. --
mai 29 12:04:35 mjro kernel: MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
mai 29 12:04:35 mjro kernel:  #5 #6 #7

it always says that microcode for this cpu is 2019-04-01

Update worked great and new nvidia driver greatly improved Davinci Resolve Studio performance.

Same happened on Windows once updated to the 430 generation.

Thanks. I also got issues during boot (/ on ZFS). initramfs zfs module failed to import the pool, it claimed that the pool is imported on a different device (Which is not the case).

Fix/Workaround: force import and export pool, reboot (works directly in initramfs):

zpool import -f <mypool>
zpool export <mypool>

I also noticed, that mkinitramfs warns during build of ZFS module. Fortunately this didn't seem to have caused any issues.

  -> Running build hook: [zfs]
==> ERROR: module not found: `zpios'
==> ERROR: module not found: `splat'
==> ERROR: file not found: `zpios'
==> ERROR: file not found: `splat'

Seems to be a timing issue with the services. When I add a 5 sec delay to zfs-import-cache.service` it works fine:

ExecStartPre=/bin/sleep 5
ExecStart=/usr/bin/zpool import -c /etc/zfs/zpool.cache -aN

Weird. ZFS 0.7 did not have that issue.

All good here with Xfce and Kernel 5.1.5 + new Nvidia driver on a 960A. :slight_smile:

Schönen Vatertag!

Upgrade via ttty went flawless, after the reboot Latte-Dock didn't show any icons but only the bottom part with the dots. Killing and starting Latte again fixed this.

I also have a new application, Plasma Renderer, showing up in my system tray. It's set to "Software Rendering", I now switched to "Automatic" but didn't notice any visible change?
Has this got anything to do with the updated nVidia driver?

Kernel 5.0.x, KDE, btrfs, luks, nVidia, Virtualbox

Edit: Found this one https://forum.kde.org/viewtopic.php?f=289&t=153559
Looks like somehow my nVidia driver crashed which made the renderer appear. I can't reboot right now so will have to look into this later tomorrow or Friday.

Please add the plasma-wayland-session-git package to the KDE Dev Isos.

Everything quick and smooth, xfce on intel i3 chip, free drivers, 4.19 kernel