[Testing Update] 2019-05-22 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice

with Xfce 4.13.4git-2a9104
there is now a little less flickering at the desktop startup.

Hello everybody,

i noticed some kernel errors after latest testing update:

journalctl -p err:

-- Reboot --
Mai 23 12:39:56 LXKA-10HFQN2 kernel: DMAR: DRHD: handling fault status reg 2
Mai 23 12:39:56 LXKA-10HFQN2 kernel: DMAR: [INTR-REMAP] Request device [f0:1f.0] fault index 3c3d [fault reason 37] Blocked a compatibility format interrupt request
Mai 23 12:40:12 LXKA-10HFQN2 ModemManager[688]: <error> SIM is missing and SIM hot swap is configured, but ports are not opened.
Mai 23 12:40:27 LXKA-10HFQN2 systemd[1]: Failed to start Network Manager Wait Online.
Mai 23 12:45:20 LXKA-10HFQN2 lightdm[1054]: gkr-pam: unable to locate daemon control file

inxi -Fz:

System:    Host: some host Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 Desktop: Cinnamon 4.0.10 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude 7390 v: N/A serial: <filter> 
           Mobo: Dell model: 09386V v: A00 serial: <filter> UEFI: Dell v: 1.9.3 date: 04/26/2019 
Battery:   ID-1: BAT0 charge: 57.8 Wh condition: 57.8/60.0 Wh (96%) 
CPU:       Topology: Quad Core model: Intel Core i5-8350U bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 700 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 728 2: 718 3: 727 4: 748 5: 751 6: 780 7: 726 8: 767 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.4 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Device-2: Realtek type: USB driver: snd-usb-audio 
           Device-3: Sennheiser Headset [PC 8] type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k4.19.45-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp2s0 state: down mac: <filter> 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           IF: enp59s0u1u2 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
           IF-ID-2: wwp0s20f0u2i12 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 47.55 GiB (10.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM961 NVMe SED 512GB size: 476.94 GiB 
Partition: ID-1: / size: 451.46 GiB used: 47.54 GiB (10.5%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 16.96 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 50.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4205 
Info:      Processes: 265 Uptime: 5h 45m Memory: 15.42 GiB used: 2.22 GiB (14.4%) Shell: zsh inxi: 3.0.34 

sudo systemctl status --failed:

sudo systemctl --failed
  UNIT                               LOAD   ACTIVE SUB    DESCRIPTION                
● NetworkManager-wait-online.service loaded failed failed Network Manager Wait Online

Tumbler 0.2.4 (used by Thunar) now has max file size limits for thumbnails. 2 Gb for video files and 200 Mb for photo/pdf files according to this commit.

To get back all thumbnails, the user will need to create a local config file per Xfce documentation.

mkdir -p ~/.config/tumbler
cp /etc/xdg/tumbler/tumbler.rc ~/.config/tumbler/

kill tumblerd process then log back in.

The config file will probably get updated so this is what it looks like without file size limits.

tumbler.rc
###
# [TypeNameOfPlugin]
# Disabled:    Set to true to avoid loading the plugin. By default all
#              plugins are loaded.
# Priority:    Priority of the plugin if more plugins support the same
#              uri-scheme / mime-type combination.
# Locations:   ;-separated path list the plugin will be used in. If the
#              source file is not a child of one of the locations, the
#              plugin won't be used and another plugin with a lower
#              priority will be tried.
#              Absolute paths, environement variables, ~/ and ~username/
#              are allowed. Leave empty to allow all locations.
# MaxFileSize: Maximum size of the source file the plugin will still
#              try to generate a plugin for. The size is in bytes,
#              0 disabled the check.
#
# For more information see http://docs.xfce.org/xfce/thunar/tumbler
###

###
# Image Thumbnailers
###

# Jpeg thumbnailer (from exif data if possible)
[JPEGThumbnailer]
Disabled=false
Priority=3
Locations=
MaxFileSize=0

# Supports all type GdkPixbuf supports
[PixbufThumbnailer]
Disabled=false
Priority=2
Locations=
MaxFileSize=0

# RAW image files using libopenraw
[RawThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0

###
# Video Thumbnailers
###

# Download cover from omdbapi.com or themoviedb.org if an
# API key is given. This plugin is disabled because it
# sends your (private) movie names over the internet.
[CoverThumbnailer]
Disabled=true
Priority=3
Locations=~/movies
MaxFileSize=0
#APIKey=your-api-key-from-themoviedb.org

# ffmpegthumbnailer plugin
[FfmpegThumbnailer]
Disabled=false
Priority=2
Locations=
MaxFileSize=0

# GStreamer plugin
[GstThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0

###
# Other Thumbnailers
###

# FreeType thumbnailer
[FontThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0


# PDF/PS thumbnailer
[PopplerThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0

# Open document thumbnailer (ODF)
[OdfThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0

# thumnailers provided by .thumbnailer desktop files
[DesktopThumbnailer]
Disabled=false
Priority=1
Locations=
MaxFileSize=0
2 Likes

TTY update with Xfce, intel chips, using 4.19 kernel. Smooth as always.

Gotta say, since I switched to testing half a year ago, have had no issues. Of course, this is as close to a vanilla install as you're likely to see, only addition from AUR is chrome. And BTW thanks for the update to mcomix. It's not critical but I enjoy using it to look in archived photo galleries.

1 Like

@oberon preparing the future Linux Mint Manjaro Edition? lol

Checking file conflicts...
Checking available disk space...
Installing mint-themes (1.7.8-1)...
Upgrading manjaro-cinnamon-settings (20181128-1 -> 20190523-1)...
Running post-transaction hooks...

Personally, I do not care much about that additional "bloat", but I wouldn't be very surprised if there is like one on two people screaming that Manjaro is forcing them to install unwanted GTK themes. :smile:

For curiosity, was there any reason to actually make it a hard dependency of manjaro-cinnamon-settings instead of merely an optional dependency?

My lightdm drops to a blank screen for a second, after entering password, then comes back for a second before the desktop comes on. Curious. This was a problem in MX Linux when they had "slim" installed. It causes a double login but slim is not installed.

git version of zfs builds no problem.

Version 0.8 is now ready. We will see.

Yes, I updated the cinnamon-settings package for what is coming :wink:
We always have the default themes of an edition as a dependency of the settings package because the package actually doesn't do much without them... People who don't want Manjaro styling and/or absolutely want to remove the default theme can always remove the settings package of course. :sunglasses:

1 Like

This should have been fixed with an earlier update of 6.0.6 already, yes!

Hi, curious, i do not have this problem. Only blinking at startup. At the version before, i could see the last screenshot of my desktop, and heavy flickering of all colors. This is now gone. Only 2 minor blinks. The taskbar is still a bit of a construction area.. means blinking.. but so far.. this is only cosmetic (;

After this update, applications that rellied on python all failed to start, throwing a permission error.

Those were : qutebrowser, streamlink, youtube-dl.

The cause was that a PKG-INFO file was readable only by root, and these app need to read it.

The file in question :

/usr/lib/python3.7/site-packages/wxPython-4.0.5-py3.7.egg-info/PKG-INFO

The fix is

sudo chmod +r /usr/lib/python3.7/site-packages/wxPython-4.0.5-py3.7.egg-info/PKG-INFO

2 Likes

It didn't affect me personally, because I do not have wxPython. However, for fun, I did install python-wxpython 4.0.5-3 intentionally just to see what it would do on my system and indeed, it broke youtube-dl completely (somehow, Cinnamon Settings seemed not to be affected).

Very good catch. It was reported to Arch Linux and got fixed on their site with version 4.0.5-3. Here's the ticket: https://bugs.archlinux.org/task/62712

Several files in python-wxpython 4.0.5-2 are readable only by the owner (root), thus rendering the package unusable. Not only that, since /usr/lib/python3.7/site-packages/wxPython-4.0.5-py3.7.egg-info/PKG-INFO is also only readable by root, apps that don't even use wxpython, e.g. community/synapse, fails to start.

Closed by Filipe Laíns (FFY00)
Wednesday, 22 May 2019, 19:47 GMT
Reason for closing: Fixed
Additional comments about closing: python-wxpython 4.0.5-3

@philm @oberon It is a pretty critical problem, because it means that merely having python-wxpython 4.0.5-2 on your system can break programs that relies on Python even if they do not use
wxPython at all, which means that potentially a lot of programs can be affected. IMO by that alone, the current Testing environment is not ready yet to be on Stable; we need python-wxpython 4.0.5-3 on Testing before.

3 Likes

Host: Manjaro-Unstable Kernel: 5.1.4-1-MANJARO x86_64 bits: 64
compiler: gcc v: 8.3.0 Desktop: Xfce 4.13.4git-2a9104
Distro: Manjaro Linux

What is missing here?


I believe this ISO has unstable branch enabled by default so all you packages are up to date

1 Like

It is not fair to make hyperlinks that revert to the comments, instead of the original URL.

##
## /etc/pacman-mirrors.conf
##

## Branch Pacman should use (stable, testing, unstable)
Branch = unstable

## Generation method
## 1) rank   - rank mirrors depending on their access time
## 2) random - randomly generate the output mirrorlist
# Method = rank

## Define protocols and priority
##   separated by comma 'https,http' or 'http,https'
## ATM available protocols are: http, https, ftp
## Not specifying a protocol will ban the protocol from being used
## If a mirror has more than one protocol defined only the first is written to the mirrorlist
## Empty means all in reversed alphabetic order
# Protocols =

## When set to False - all certificates are accepted.
## Use only if you fully trust all ssl-enabled mirrors.
# SSLVerify = True

I moved to unstable and Xfce is looking good and nice

Yeah, it's the macha sea theme.

1 Like

Thunar (xfce) is crashing when ejecting USB stick properly.

(thunar:1578): thunar-WARNING **: 10:20:32.968: Content type loading failed for C143-1420: Fehler beim Holen der Informationen für Datei »/run/media/jan/C143-1420«: Datei oder Verzeichnis nicht gefunden

Tried with linux419 and 51. Two different USB sticks, same result.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark