[Testing Update] 2019-05-11 - Kernels, Deepin, Plasma, Haskell, LibreOffice, Calamares

update
testing
#1

Hello community,

I am happy to announce another Testing Update!

This update holds the following changes:

  • Some Kernels got renewed
  • Calamares got updated and rebuild against kpmcore 4.0
  • Grub package got redesigned to support also 32bit UEFI installs. Hopefully the languages bug is also solved by this
  • Manjaro-Tools got fixed to work with dd again
  • XFCE-GTK3 got renewed packages
  • Plasma is now at 5.15.5
  • LibreOffice is now att 6.1.6
  • For all using Haskell, you find now the latest updates in our repos.

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.139 [EOL]
  • linux44 4.4.179 (no legacy nvidia-340 module!)
  • linux49 4.9.173
  • linux414 4.14.116
  • linux419 4.19.42
  • linux420 4.20.17 [EOL]
  • linux50 5.0.15
  • linux51 5.1.0 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.14_rt9

Package Updates (Thu May 9 07:13:00 CEST 2019)

  • testing community x86_64: 382 new and 387 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing extra x86_64: 340 new and 439 removed package(s)
  • testing multilib x86_64: 4 new and 4 removed package(s)

The full list of package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.


Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.


vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, remove vlc-nightly, then install the vlc package.

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

No Sound:
Please edit at the Loudspeaker / Configuration tab, your analog or digital sounddriver. Currently it will not be saved until the next boot, so one has to edit the Configuration tab again.
grafik

1 Like
#3

All good for me: linux419+nvidia+zfs+cinnamon

#4

No issues during update, all looks good!
Kernel 5.0.15-1, KDE, btrfs, luks, nVidia drivers

1 Like
#5

boot is ok
find this message ( with kernel 5.0.15)

mai 11 12:00:19 mjro kernel: GPT:Primary header thinks Alt. header is not at the end of the disk.
mai 11 12:00:19 mjro kernel: GPT:6300155 != 31326207
mai 11 12:00:19 mjro kernel: GPT:Alternate GPT header not at the end of the disk.
mai 11 12:00:19 mjro kernel: GPT:6300155 != 31326207
mai 11 12:00:19 mjro kernel: GPT: Use GNU Parted to correct GPT errors.

same errors with others kernel , cannot repair with gparted from USB install ( 18.04 )

checked with gdisk no reports errors ( old version )
solved , coming from others disks missing dev/sdX in log

1 Like
#6

Apart from a stop job for thermal daemon holding the reboot up a little everything went through fine.

One thing to note for KDE users, Plasma Desktop 5.15.5 is the last release for the 5.15 series which is now end of life. The next Plasma Desktop update will be 5.16 and is due 11th June 2019 unless there are any release blockers.

3 Likes
#7

No problems, but I never noticed this before, but perhaps because I recently started dual-booting KDE-Dev along with my more normal KDE Testing? Also, instead of the normal plain-text GRUB-looking boot selection, I seem to be getting a more graphical-looking selection, similar to what I see on my live Manjaro ISO.

( 3/11) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.156 (2019-03-22) and kernel driver (unknown version).
Command failed.

Edit to add: I do not see this error on the machine I do not dual-boot.

#8

Is Libreoffice at version 6.2.4 or 6.1.6 ?

1 Like
#9

All fine here.
32 Packages updated successfully. :+1:
LXQT+ Kernel 5.0.
Thanks!

#10

For me, Version: 6.2.3.2, from an older KDE-Testing installation.

$ pacman -Qi libreoffice-fresh 
Name            : libreoffice-fresh
Version         : 6.2.3-2
Description     : LibreOffice branch which contains new features and program enhancements
Architecture    : x86_64
URL             : https://www.libreoffice.org/
Licenses        : LGPL3
Groups          : None
Provides        : libreoffice  libreoffice-en-US
Depends On      : curl>=7.20.0  hunspell>=1.2.8  python>=3.7  libwpd>=0.9.2  libwps  neon>=0.28.6  pango  nspr
                  libjpeg  libxrandr  libgl  libxslt  redland  hyphen  lpsolve  gcc-libs  sh  graphite  icu  lcms2
                  poppler>=0.24.0  libvisio  libetonyek  libodfgen  libcdr  libmspub  harfbuzz-icu  nss  clucene
                  hicolor-icon-theme  desktop-file-utils  shared-mime-info  libpagemaker  libxinerama  libabw  libmwaw
                  libe-book  libcups  liblangtag  libexttextcat  libcmis  liborcus  libtommath  libzmf  libatomic_ops
                  xmlsec  gpgme  libnumbertext  libfreehand  libstaroffice  libepubgen  libqxp  libepoxy
Optional Deps   : java-runtime: adds java support [installed]
                  java-environment: required by extension-wiki-publisher and extension-nlpsolver [installed]
                  pstoedit: translates PostScript and PDF graphics into other vector formats
                  libmythes: for use in thesaurus
                  beanshell: interactive java -- good for prototyping/macros
                  libwpg: library for importing and converting WordPerfect Graphics format [installed]
                  sane: for scanner access [installed]
                  unixodbc: adds ODBC database support
                  gst-plugins-base-libs: for multimedia content, e.g. in Impress [installed]
                  libpaper: takes care of papersize [installed]
                  postgresql-libs: for postgresql-connector
                  mariadb-libs: for mysql-connector
                  coin-or-mp: required by the Calc solver
                  gtk2: for GTK2 integration [installed]
                  gtk3: for GTK3 integration [installed]
                  kio: for KF5 KDE desktop integration [installed]
Required By     : None
Optional For    : None
Conflicts With  : libreoffice-still
Replaces        : None
Installed Size  : 382.73 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Tue 23 Apr 2019 04:17:46 PM EDT
Install Date    : Sun 28 Apr 2019 10:17:01 AM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

I believe newer KDE-Testing ISO install Calligra by default.

1 Like
#11

I can't get x to load on xfce. I'm running out of ideas to try on tty. Does anyone remember how to regenerate the default xorg config file from mhwd-gpu?

#12

with xfwm4-gtk3 4.13.1-9 the screen is totally white with the mouse cursor in the middle of the screen.
no problem with version 4.13.1-8

inxi
System:
  Host: GionnoLinux Kernel: 5.0.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: N/A Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: MICRO-STAR model: P43T-C51 (MS-7519) v: 1.0 
  serial: <filter> BIOS: American Megatrends v: 2.6 date: 07/15/2010 
CPU:
  Topology: Quad Core model: Intel Core2 Quad Q9450 bits: 64 type: MCP 
  arch: Penryn rev: 7 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 21394 
  Speed: 2498 MHz min/max: 2003/2670 MHz Core speeds (MHz): 1: 2005 2: 2005 
  3: 2018 4: 2005 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI 
  driver: nvidia v: 418.74 bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.4 driver: nvidia 
  resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel 82801JI HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.0.15-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 05:00.0 
  IF: enp5s0 state: down mac: <filter> 
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB 
  driver: r8188eu bus ID: 9-1:2 
  IF: wlp4s0u1 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.42 TiB used: 23.51 GiB (1.6%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10JPCX-24UE4T0 
  size: 931.51 GiB 
  ID-2: /dev/sdb vendor: OCZ model: VERTEX2 size: 55.90 GiB 
  ID-3: /dev/sdc vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
Partition:
  ID-1: / size: 54.77 GiB used: 10.84 GiB (19.8%) fs: ext4 dev: /dev/sdb1 
  ID-2: /home size: 457.44 GiB used: 12.67 GiB (2.8%) fs: ext4 
  dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 31.0 C mobo: 18.0 C gpu: nvidia temp: 50 C 
  Fan Speeds (RPM): cpu: 1350 fan-1: 1440 fan-3: 0 fan-4: 0 gpu: nvidia 
  fan: 50% 
  Voltages: 12v: N/A 5v: N/A 3.3v: 3.25 vbat: 3.18 
Info:
  Processes: 180 Uptime: 17m Memory: 7.79 GiB used: 1.48 GiB (19.0%) 
  Init: systemd Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 inxi: 3.0.34 


2 Likes
#13

Same issue here. I'll just downgrade that package and see what happens.

#14

libreoffice-still is 6.1.6-1

#15

And libreoffice-fresh is showing version: 6.2.3.2

#16

grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet rd.udev.log-priority=3 audit=0 loglevel=3"

grub.pacnew:
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 audit=0"

:thinking: :exploding_head:

From https://wiki.archlinux.org/index.php/Silent_boot:

If you also want to stop systemd from printing its version number when booting, you should also append udev.log_priority=3 to your kernel commandline (source). If systemd is used in an initramfs, append rd.udev.log_priority=3 instead.

So, is it a problem that the proposed new entry has dropped the rd. suffix?

My current grub vs grub.pacnew
#17

I've described my findings yesterday.
TCLSS: use syntax from pacnew if you have some weird text messages when your PC goes to reboot instead of OEM logo and you would like to eliminate them. quiet + loglevel=3 sometimes produce watchdog did not stop! messages during reboot. Actually quiet is enough to suppress most log messages during [re]boot. loglevel=3 may be necessary when there's no quiet option at all, e.g., like I said, when using bootsplash, because quiet suppresses bootsplash too.

Check your /etc/mkinitcpio.conf. If it contains systemd in HOOKS section, then rd.udev.log_priority=3 is what you need, if it contains udev hook (by default in Manjaro), then you need udev.log_priority=3.

4 Likes
#18

Oh cool, ta. My VM rebooted fine with that pacnew line replacing the grub line.

Now i've seen your edit, for which i offer this line from my file:
HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck".

Thus based on your advice, exactly as you said, the new line is right, the old line was wrong... so i wonder why on earth the old version wrongly contained `rd.udev.log-priority=3'?

Thanks.

#19

Same for me . Blank screen with just a basic cursor.
Solved after uninstall nvidia-390xx and back to nouveau with xfdesktop-gtk3 4.13.3-2.
I think I have to look for a full amd hardware in the future...

#20

Ok that worked for now. Due to multiple reports, I'd advise nvidia xfce users to hold off on xfwm4-gtk3 4.13.1-9. Xfwm's cpu bug needs to be addressed however, I've found that even the basic visualization in audacious allows xfwm to eat ~15% cpu and disabling xfce's own compositor has some unintended effects in other apps -- and it might be my imagination but there may be additional FF screen tearing with it off (but with nvidia composition pipeline on.)