[Testing Update] 2019-04-14 - Nvidia, Systemd, Deepin, Gnome

update
testing
#1

Hi community,

I am happy to announce our sixteenth testing update for 2019.
This one includes

  • latest Nvidia driver 418.56
  • Systemd 242
  • gtk3 3.24.8
  • updates for Firefox, Thunderbird and Chromium
  • Evolution 3.32.1
  • some updated Deepin and Gnome packages
  • kernels Linux 3.16.65 and realtime kernel 5.0.7_rt5 (in which we agreed to try CONFIG_HZ_1000 as opposed to CONFIG_HZ_300 in linux419-rt
  • for Appimagelauncher we now have a stable relase 1.2.2
  • vte3 receives its update to 0.56.1

PLEASE NOTE: For now we drop maintaining brave browser in our repos. Please update it from the AUR!

We hope everything continues to work as awesome as you expect. In case you experience issues please report them here and help troubleshoot before the next stable update


Merch

Get our new T-Shirt collection #CLT2019! They are the latest design we did exclusively for Chemnitz Linux Days.

Manjaro v18.0.4 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.168
  • linux414 4.14.111
  • linux419 4.19.34
  • linux420 4.20.17 [EOL]
  • linux50 5.0.7
  • linux51 5.1-rc1 (no extramodules yet)
  • linux418-rt 4.18.16_rt9
  • linux419-rt 4.19.25_rt16
  • linux50-rt 5.0.7_rt5

The list of updated packages can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

10 Likes

chromium-vaapi-bin needs ICU 64
#2

gcc7 and gcc7-libs where "promoted" as AUR packages (same in unstable branch).
Same with gamin package (even tho is not in the update list) but now is as AUR package.

Is this intentional ?
Thanks!

0 Likes

#3

See here
https://aur.archlinux.org/cgit/aur.git/commit/?h=gamin&id=0680e9f3274ac24f07a563ba880a26fe3b24f601

0 Likes

#4

Ah, so all 3 are removed from Arch repositories too.
No issue then, all good here after reboot :wink:

1 Like

#5

86 Packages updated successfully. :+1:
LXQT+Kernel 5.0.
Thanks!

1 Like

#6

Xfce(Gtk+) + systemd 2.42 + video(youtube) + steam(OpenGl) is ok

0 Likes

#7

all good for me:
linux419+nvidia+zfs+cinnamon

1 Like

#8

Xfce4-gtk3 Kernel 5 : Everything is in order, but still the issue with right-click > new file in Thunar. (I know it' s upstream issue).
Works with xfce4-popup-applicationsmenu -r

2 Likes

#9

99 packages here. All went well... @lemust83: until Xfce 4.14 is officially released (2019? 2020?), these kind of bugs will annoy user life.

0 Likes

#10

I changed gtk3 to gt3-classic (gtk3-mushrooms) and downgraded it to 3.24.5. Is the one that worked for me. Don't know if this could caused other problems, but the right-click -> new file in Thunar is working.

*My Thunar is gtk2, why gtk3 affected it, maybe some dependency in common.

**The problem is: where to find gtk3-classic-3.24-5? I have it on /var/cache/pacman/pkg, other people may not.

***I found here that could be a theming problem:

1 Like

Thunar, Context menu, New file
#11

All went well on cinnamon and kernel 5.0

1 Like

#12

145 updates, on my Xfce-gtk2, kernel 5.0.7-1. All went well.

1 Like

#13

Everything works well here. Time for a stable update?

2 Likes

#14

some

journalctl -b -p err

-- Logs begin at Mon 2017-09-11 22:07:44 CEST, end at Sun 2019-04-14 19:59:16 CEST. --
Apr 14 17:03:28  systemd-vconsole-setup[332]: /usr/bin/loadkeys failed with exit status 1.
Apr 14 17:03:28  systemd-vconsole-setup[331]: /usr/bin/loadkeys failed with exit status 1.
Apr 14 17:05:17  colord-sane[1082]: io/hpmud/pp.c 627: unable to read device-id ret=-1
0 Likes

#15

Unless you have thunar-gtk2 installed from AUR, you have a gtk3-based thunar.
The current version of the repos is at 1.8.4-1, which is gtk3-based. Thunar is released independently of xfce, starting from thunar 1.7.0 thunar is gtk3-based. https://git.xfce.org/xfce/thunar/tag/?h=thunar-1.7.0. Hence, it is caused by gtk3 as described in previous update sets.

1 Like

#16

But, there is a thunar-gtk3-1.8.4-2, so I thought thunar-1.8.4-1 is gtk2 based, both are in the repos.
Maybe it's time for me to upgrade to Xfce-gtk3...

0 Likes

#17

Update went well for me except I had to restart pulseaudio after the update, didn't have sound on Manjaro Deepin initially after first boot

0 Likes

#18

Upgrade went fine but I noticed, that the following 32-bit packages are not upgraded to mesa 19.0.2:

  1. lib32-mesa 19.0.1-1
  2. lib32-vulkan-intel 19.0.1-1
0 Likes

#19

Same thing on Arch Linux, the 32-bit version is lagging behind currently.

So it will come later, unless the team decide to push "-0" package for the 32 bit version.

1 Like

#20

Ok, thanks a lot for the clarification.

0 Likes