[Testing Update] 2019-04-01 - Mate, KDE-Dev, Cinnamon, Deepin, Browsers, Systemd

Problem for create document in thunar, anyone know of any solution? I’ve been testing some possible solutions, but without success, that is remove thunar-archive-plugin-gtk3 0.4.0-1.

Package: thunar-gtk3 1.8.4-2

Captura%20de%20tela_2019-04-03_15-19-52

I can confirm this in thunar-gtk3 1.8.4-2, Xfce in a VM

The solution would downgrade the package mentioned in the topic

1 Like

This seems to be a gtk3 issue introduced by this commit. I tested it with 1.8.4-1 and 1.8.3-1. So not a thunar issue per-se. Will check with upstream.

Could I compile the previous version of lib32-gtk3-classic? This may solve the problem, but may cause others.

By being in Testing (and Unstable), you are already accepting to be a guinea pig for Manjaro. :smiley:

6 Likes

I’m getting this warning now checking for updates.

:: Starting full system upgrade...
warning: lib32-systemd: local (241.1096-1) is newer than multilib (241.607-1)
warning: systemd: local (241.1135-1) is newer than core (241.607-1)
warning: systemd-libs: local (241.1135-1) is newer than core (241.607-1)
warning: systemd-sysvcompat: local (241.1135-1) is newer than core (241.607-1)
 there is nothing to do

If I’m unencrypted and have no issues (that I’m aware of), should I just leave them at their current versions?? Or would it be safer to downgrade / pacman -Syuu??

Thanks!

They revert back systemd packages for the today update release in Stable.

As for if you should downgrade or not, well, it is most likely that we will get a new version of systemd soon on Testing, so I don’t think you should care that much.

1 Like

Ok got it, thanks @Frog :sunglasses::+1:

KDE 5.15.80 aka 5.16.0 beta1? So soon?

In other words, it provides KDE Neon Testing (aka git stable previously) like experience on top of Manjaro/Arch base, which I consider an excellent idea. Combo-wombo (untranslatable)!

1 Like

I understand now. Thanks for the info!

So I just had a successful install to a VM, thanks.

kinfocenter

Operating System: Manjaro Linux
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.2
Kernel Version: 5.0.5-1-MANJARO
OS Type: 64-bit
Processor: 1 × Intel® Core™ i7-6600U CPU @ 2.60GHz
Memory: 1.9 GiB of RAM

But, if I simply keep updating, eventually I will be on unstable package versions, as they catch up to KDE-git, correct? The only way to be on the latest KDE-git versions would be to install every weekend? It would be more work (and I do not want to add distractions) to add an extra repo for KDE-git, correct?

Thanks again.

awesome wm, kde, openbox installs all finished without issue, all boot fine, no observable problems.

pacman via terminal
4.19 and 5.0 kernels
intel/nvidia optimus

all good :+1:

short info: after the latest updates and the “downgrade”, which was basically an upgrade to mesa 19 :wink: - vmware does work again! xserver is starting and kde plasma works like a charm! thx :slight_smile: so i guess it was an mesa 18 bug.

That’s the joy of using “+really+” versioning or epoch. :stuck_out_tongue:

What a weird situation:

  • There are people having problems with Mesa 19.0.1 and are okay with Mesa 18.3.5;
  • There are people that got problems with Mesa 18.3.5 and are okay with Mesa 19.0.1.

It blows my mind. :boom:

I think the problem is with mesa-19.0.1-1, not mesa-19.0.1-2, I don’t have problem
with the last.

1 Like

Thunar 1.8.4-1 is still showing part of the submenu "create document", it brokes horizontally, on my Xfce testing

thunar

I found it, it was this workaround:

But I don't have gtk3-classic-3.24.7 installed, don't have 3.24.5 to downgrade , only have gtk3 1:3.24.7+25+g17665f06e3-1, anyway I didn't use thunar all the time, just some times, this is the reason why I didn't want to try solve it that time.
Doing this downgrande in Unstable in a VM solved the issue.

*I transfer gtk3-classic-3.24.5-x86_64.pkg.tar.xz and lib32-gtk3-classic3.24.5.-x86_64.pkg.tar.xz from my VM Unstable to my normal Testing and installed both, looks good. Thunar back to normal;

I maked downgrade the versions of the corresponding packages from this problem. Problem solved.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark