[Testing Update] 2019-03-14 - Kernels, Plasma, Deepin, Pamac, Python, Ruby

update
testing
#66

still usb keyboard and mouse frezing problems.

#67

@bogdancovaciu
solved (-:

#68

After update and reboot, Gnome is restarting again and again after login. It begins to show desktop, some app, but then goes black and I have to start session again. Working good with i3, so it seems a Gnome problem.

dmesg show this error:
[ 90.836400] gnome-shell[1029]: segfault at 30 ip 00007fa454796f42 sp 00007ffdd47340d0 error 4 in libsoup-2.4.so.1.8.0[7fa454787000+4c000]
[ 96.624789] gnome-shell[1837]: segfault at 30 ip 00007f69806cdf42 sp 00007ffe5c0d55e0 error 4 in libsoup-2.4.so.1.8.0[7f69806be000+4c000]

#69

I completely forgot that vlc-nightly has been dropped. Added information in the Wiki post in case there are still people using this package.

3 Likes
#70

Yes, this is what I did. I back to the stable version of Vlc

#71

Hi everyone.:raised_hand_with_fingers_splayed:
I post here because I think the problem is related to the latest updates. I’m relaying here a small issue that users report on manjaro.fr. I’m on testing branch since long time and with xfce4-gtk3 .

2019-03-14 21:38] [PACMAN] Running 'pacman -Syu'

2 things:

  1. Some have problems with xfce4-screenshooter in unstable with a message such ’ “Unable to open ~/Write images: is a folder”’. I have no problem, but it’s look like a bug.
    2/ In Thunar, a right clic > create new file give a very small empty window and I can’t do anything with it.

    But typingxfce4-popup-applicationsmenu -p works fine. I can see a window under the cursor with all options to create a new file.

It seams that some unstable and testing users are impacted with this issue, but not today users with stable.
Of course, I did not modify anything and it works before some of us detect this small problem.
Any idea ?

1 Like
Thunar right-click menu not expanded
#72

I noticed I have this problem in Testing

#73

For the screenshooter problem see this thread: Saving a screenshot fails after upgrading to xfce4-screenshooter-1.9.4-1. :smiley:

#74

Downgraded to last libsoup version and Gnome is working again

#75

I can confirm this on my side in my XFCE VM. It works fine on the desktop, but not inside a Thunar window. Perhaps a regression introduced when GTK3 got upgraded to version 3.24.7.

This issue is also on Arch Linux, according to their forum. They worked around the issue by downgrading gtk3 to a previous version.
https://bbs.archlinux.org/viewtopic.php?id=245027
https://bbs.archlinux.org/viewtopic.php?pid=1837105#p1837105

Reported to upstream too: https://bugzilla.xfce.org/show_bug.cgi?id=15200

EDIT: I could work around the issue by downgrading first lib32-gtk3-classic, then gtk3-classic from 3.24.7-1 to 3.24.5-1. I rebooted right after doing the downgrade, although a simple log out-log in might be enough to fix the issue. (Most likely downgrading the regular gtk3 package, if you use this one instead, will produce the same result.)

Before
thunar-before
After
thunar-after
I do not guarantee that downgrading gtk3-classic/gtk3 packages will not cause other issues elsewhere.

? Downgraded to last? From which version to which version more precisely?

2 Likes
Right click cut New File on Thunar
[Stable Update] 2019-03-21 - Kernels, Deepin, Browsers, Pamac, Plasma, Python
[Stable Update] 2019-03-29 - Kernels, Gnome, LibreOffice, Mesa, Budgie, Browsers, Qt
thunar dies at least once a day
[Stable Update] 2019-04-03 - Mate, KDE-Dev, Cinnamon, Deepin, Browsers
Create from template menu bug
#76

Haven’t noticed this as my prt sc key is mapped to xfce4-screenshooter -fs [location of screenshot folder] – using this instead may work.

Confirmed on my desktop as well – seeing it on all themes.

context-menu-createDocument1

I noticed in the upstream bug report, @ToZ also mentioned a slight “scrollable” context menu on individual files – I can also confirm seeing that. Pinging @korealinux to see if you’re seeing the same items coming from a rolling update position.

I noticed on my install I still have gtk3-classic (versus gtk3)…I’m coming from v18’s iso…is gtk3 still not quite ready for “prime time” yet?

#77

GTK3, or a full GTK3 XFCE desktop?

Anyway, it looks more like an unexpected issue introduced with changes within GTK3 than XFCE (or Thunar in this case) not being ready. It worked fine before, right?

#78

Simply the package gtk3. I noticed gtk3-classic is also known as gtk3-mushrooms whose maintainer is apparently looking for a replacement in the next few months…

#79

Sorry, I was playing with my new SSD. I am following the thread but not rolling at the moment. We will resume rolling momentarily. :red_car:~

2 Likes
#80

I get it but if I stuff around a little it disappears. Try this: (right) click to open the menu then close it. Click the same file (or a different one but still in the same window) and scroll up. Then the menu consistently becomes solid/unscrollable for me. Once this happens opening the menu from any file in that window works as it should (i.e. does not have a scroll) until the window is closed. There are a couple of other methods to trigger the correct menu behaviour but they are less consistent. (By the way this differs a little from what is described in the bug report…)

No moss on me. :grin:

#81

That was my real KDE+GNOME on-SSD. This afternoon i have belatedly also updated my two Testing VMs [both = KDE+Cinnamon; one VM is a clone of t’other]. I updated one in tty2, but the clone i did within the desktop using Pamac. BOTH went just fine, even though it was a big update involving systemd* & Plasma. It seems more & more that Pamac has become pretty fine even for these major changes… despite our collective “excitement” in the forum some weeks back.

* From a previous Testing Update; i’d not done these VMs for a few weeks.

#82

I get Create Document / Empty File and it works, see scrn shots. 1.8.4git-955b94a Thunar ver.


Screenshot_2019-03-18_08-00-37

[Solved] Create Document in Thunar
#83

Are you using gtk3 packages? Version of your xfdesktop-gtk3 and gtk3-classic?

#84

Yes, I am:
Classic = 3.24.5-1
Desktop = 4.13.2-14

#85

gtk3-classic 3.24.7-1 is affected, it’s not a big deal as I’ll just wait for an upstream fix. Maybe worth mentioning as a “known issue” if it gets pushed to a stable announcement but again, minor issues.:slightly_smiling_face: