[Testing Update] 2019-02-19 - Systemd, Wine-Staging-Nine, Python

update
testing

#21

does it matter that I use pamac ?


#23

Would it matter if I try with sudo pacman -Syyu ?


#24

Everything went well in xfce Testing update.
[Shhhhh, don’t tell anyone, the Stable upgrade is already in the Repo LOL]


#25

And I have updated 2 running stable KDE the tty way and they both is up and running like they should!
Yeah, don’t tell anyone :wink:


#26

Back again
I tried from TTY3 : pacman -Syyu
It went flawlessly.
I’m very disappointed that running pamac for updates it’s not the same as in terminal.
If I wouldn’t have Timeshift, now I would have to reinstall the whole sistem.


#27

Are you running pamac in KDE Plasma? Is the Qt5 one or the GTK+? Think that some updates in KDE Plasma i do from TTY, especially when there are over 50 packages. :wink:


#28

I got this update in the stable branch!


#29

Yes. The only thing missing is the announcement in fact.


#30

This update moved from testing to stable branch after 1 day of testing?!


#31

I’m afraid that the announcement being delayed may come back to bite , people are going to see there’s an update available , apply it via GUI and the fun will begin . I hope I’m wrong .


#32

The today stable release is a cumulative from 2019-02-10 to this one.


#33

It refuse to update

error: failed to commit transaction (conflicting files)
python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc exists in filesystem
Errors occurred, no packages were upgraded.


#34

"sudo rm /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__ .cpython-37.pyc" and upgrade again


#35

The response to rm is : no file.


#36

He put a space in the command. Copy this one:

sudo rm /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc


#37

well phil has a life. hopefully the clued up users will look for the testing update threads and find the solutions to the potential problems before they update. as for the others a gentle nudge in this direction for the future wouldn’t hurt


#38

latest “stable” update asks me: Replace libsystemd with core/systemd-libs? [Y/n]

is this safe to do?

asking because 3h ago I pressed the yes buttons and am now sitting in front of a vanilla install haha :sweat_smile:

learned my lesson, question the unknown :expressionless:

edit: update worked out this time


#39

Like more or less everyone else.

Yes: libsystemd got renamed to systemd-libs since 241.159-1. Not accepting the replacement is the riskiest move here: at best you won’t be able to do the update at all.


#40

I hope that you and your girlfriend enjoy a beer after you get safely to Munich. I miss the beer gardens in Germany with my family.


#41

After this bunch of updates after any reboot/poweron/login I get 100% usage on one thread for NetworkManager --no-deamon on Manjaro KDE 18.0.3. CPU temp gets to 70C within 1min of login, expected behaviour is 45-50C with 2/3% CPU usage (Laptop).

Please see attached htop screen clip

Would anyone have any idea for a permanent fix? Killing the process fixes until I login again. Should I consider downgrading networkmanager?

Many thanks