[Testing Update] 2019-02-19 - Systemd, Wine-Staging-Nine, Python

update
testing

#1

Hi community,

Welcome to our eleventh testing update for 2019. These are additional package needed to our last update. So what do we have with this one?

  • we updated systemd to v241 - it has issues with encrypted devices (upstream needs your feedback to solve it properly). However, we added 159 additional patches so far to v241 series.
  • wine-staging-nine is now at 4.1
  • the usual python updates

We hope with all these changes Manjaro to be more efficient for you all.


CLT19

Manjaro will take part on the Chemnitz Linux Days in March this year. You may want to visit our booth with the latest Manjaro hardware and Core Developers present to answer your questions. Feel free to bring your devices if you want to have Manjaro installed on them or problems fixed from our experts.

Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @fhdk. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.

Manjaro v18.0.3-pre3 released!

We updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.15 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.134 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.158
  • linux414 4.14.101
  • linux419 4.19.22
  • linux420 4.20.10
  • linux414-rt 4.14.93_rt53
  • linux418-rt 4.18.16_rt9

Package Updates (Tue Feb 19 10:20:57 CET 2019)

  • testing community x86_64: 31 new and 49 removed package(s)
  • testing core x86_64: 5 new and 5 removed package(s)
  • testing extra x86_64: 5 new and 6 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-02-18           2019-02-19
-------------------------------------------------------------------------------
                                agda    2.5.99.20190207-4    2.5.99.20190207-5
                      doublecmd-gtk2              0.9.0-2              0.9.1-1
                       doublecmd-qt5              0.9.0-2              0.9.1-1
                              eslint             5.14.0-1             5.14.1-1
                          fingerterm              1.3.7-1              1.3.8-1
              firefox-tree-style-tab             2.7.18-1             2.7.20-1
                              flake8            1:3.7.5-1            1:3.7.6-1
                               ginac              1.7.4-2              1.7.5-1
                 haskell-equivalence              0.3.3-4              0.3.4-1
                         offlineimap              7.2.2-1              7.2.3-1
                     percona-toolkit             3.0.12-1             3.0.13-1
                         python-acme             0.31.0-1             0.31.0-2
                    python-braintree             3.51.0-1             3.51.0-2
                     python-cchardet              2.1.4-1              2.1.4-2
                 python-linux-procfs                0.6-1                0.6-2
                       python-pytest              4.2.1-1              4.3.0-1
                        python-regex         2019.02.06-1         2019.02.18-1
                   python-schedutils                0.6-4                0.6-5
                 python-testfixtures              6.5.0-1              6.5.2-1
                    python-typogrify              2.0.7-5              2.0.7-6
                        python2-acme             0.31.0-1                    -
                      python2-augeas              0.5.0-2                    -
                   python2-braintree             3.51.0-1                    -
                    python2-cchardet              2.1.4-1                    -
                      python2-flake8            1:3.7.5-1            1:3.7.6-1
                python2-linux-procfs                0.6-1                    -
                       python2-nose2              0.8.0-1                    -
                      python2-piexif              1.1.2-1                    -
                      python2-pyalsa              1.1.6-4                    -
                     python2-pyliblo             0.10.0-5                    -
                 python2-pymediainfo                3.0-1                    -
                   python2-pyrss2gen                1.1-8                    -
                      python2-pytest              4.2.1-1              4.3.0-1
        python2-pytest-rerunfailures                6.0-1                    -
             python2-pytest-xprocess             0.12.1-4                    -
                       python2-regex         2019.02.06-1         2019.02.18-1
                  python2-schedutils                0.6-4                    -
      python2-sphinxcontrib-newsfeed              0.1.4-6                    -
                    python2-tabulate              0.8.3-2                    -
                python2-testfixtures              6.5.0-1              6.5.2-1
                   python2-typogrify              2.0.7-5                    -
                     python2-vobject            0.9.6.1-2                    -
              python2-wsgi-intercept              1.8.0-3                    -
                           rng-tools                6.6-2                6.7-1
                               sigil             0.9.10-3             0.9.12-1
                            solidity              0.5.3-1              0.5.4-1
                       speakup-utils              3.1.6-4              3.1.6-5
                      udp2raw-tunnel         20180225.1-1         20181113.0-1
                          youtube-dl         2019.02.08-1         2019.02.18-1
                              libp11                    -              0.4.9-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-02-18           2019-02-19
-------------------------------------------------------------------------------
                     manjaro-release             18.0.2-1             18.0.3-1
                             systemd            241.155-1            241.159-1
                        systemd-libs            241.155-1            241.159-1
                  systemd-resolvconf            241.155-1            241.159-1
                  systemd-sysvcompat            241.155-1            241.159-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-02-18           2019-02-19
-------------------------------------------------------------------------------
                            graphene              1.8.2-1              1.8.4-1
                         imagemagick           7.0.8.27-1           7.0.8.28-1
                     imagemagick-doc           7.0.8.27-1           7.0.8.28-1
                           libmagick           7.0.8.27-1           7.0.8.28-1
                      python2-pysmbc           1.0.15.8-2                    -
                xfce4-sensors-plugin              1.3.0-2             1.3.92-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-02-18           2019-02-19
-------------------------------------------------------------------------------
                       lib32-systemd            241.155-1            241.159-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-02-18           2019-02-19
-------------------------------------------------------------------------------
                          lib32-rust             1.32.0-2             1.32.0-3
                   wine-staging-nine                4.0-1                4.1-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Announcement of the latest Stable update?
Unknown update of 218 packages to install in my XFCE Edition w/ Stable Repo!
Announcement of the latest Stable update?
Announcement of the latest Stable update?
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.


Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#3

That’s a lot of testing updates recently…


#4

Did libnm-gtk got removed from the repository? My trizen -Syu keeps searching for it in AUR after this update… :thinking:


#5

Isn’t that a good thing?

Yes.


#6

Everything is OK.

I wish Pamac could handle tty requests btw… Only pacman can do this.

Adding temporary LUKS TPM key...
Unsealing keyfile...
Preparing to set a temporary LUKS passphrase for /dev/nvme0n1p6...
/usr/bin/luks-tpm2: line 99: /dev/tty: No such device or address
A temporary passphrase was not set
Error: command failed to execute correctly

#7

Did you pushed it already on stable? At least I got update notifications and am on stable…


#8

not quite because when I check kde plasma packages they are still 5.14.5( correct me if I am wrong)


#9

Yes. Packages has been pushed to stable.

https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20190218/021371.html
https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20190218/021372.html

The announcement will appear eventually today.

Give time to the mirrors to download the new packages. :smile:


#10

Please report it as an issue, thx.

Yes, as announced on our mailing list and twitter.


#11

Ahh forgive me. Didn’t look at my mirror last sync time. That explains it


#12

Shouldn’t this also be announced in
https://forum.manjaro.org/c/announcements/stable-updates?

The update went well on stable.


#13

Be patient, it will be there soon


#14

New ISO images just finished uploading. I’ve to drive my girlfriend to Munich and will announce it later tonight. Be patient for it.


Announcement of the latest Stable update?
#15


At one point everything stopped and plasma wasn’t working anymore
I’m trying to restore with Timeshift


#16

no need to restore … click ok and reboot from TTY using
systemctl reboot
it will load after that


#17

Back,
There where a lot of errors before loading plasma, including the Network initialization.
I tried a couple of restarts/resets and I managed to restore with Timeshift.
After I tried again to update the system and I got again the same error. So the problem is at some point one of the updates.

you mean from terminal ?


#18

Ctrl+Alt+F3 = TTY3


#19

I undestand now, but restarting was not the problem
one of the update messes up my Plasma, I think


#20

I think you also had all the updates from February 10 to today, and that was quite large update, with a lot of changes. If you restore from TimeShift, make sure you do the update entirely from TTY …