[Testing Update] 2019-02-14 - Kernels, Systemd, Browsers, Calamares, Firmware, Plasma5, KDE Framework

update
testing

#101

Anyone expecting a quick turn around for the cryptsetup bug rendering encrypted /home systems unbootable on v241…

poettering added bug cryptsetup labels Feb 15, 2019
poettering added this to the v242 milestone Feb 15, 2019

LOL.

:roll_eyes:


#102

I stand corrected, & thank you. I confirmed this now by cloning my Testing VM [with its LUKS-encrypted /home] then rebooting the clone, AND to my surprise now i AM offered to enter my decryption password. When i wrote that filenote in 2017, my reason was that every time i tried cloning VMs with encryption, upon reboot they skipped the password prompt step, hence their /home never got mounted & decrypted, hence their boots never completed successfully. Over the interim something has changed for the better; either i have stopped making the putative error i repeatedly made back then, or newer VB versions have fixed some putative bug. Either way, this is now very cool to know.


#103

I guess they just don’t bother (or just don’t give a f-, rather) to release a new systemd version just to correct a few bugs, even if they’re very critical like this one or are actually security vulnerabilities. They only do major, super big releases once a few months and let the distro maintainers do the dirty job of looking in all the commits made in between, cherry-picking all the fixes they need and hope everything just doesn’t explode (not like the official newest version of systemd were really good to begin with (ok, I’m starting to troll now)).

Very helpful model for rolling release distros. They have to maintain it like fixed release distro does instead of just grabbing the lastest version. :roll_eyes:

(Sorry for the rant.)


#104

Is KDE Plasma getting any love on wayland or is it still to buggy to use ?
I went for coffee and i was black screen and frozen when i got back, and on stable I always get empty session after idle and need to log back in have tried to change all setting in settings manager / startup and shutdown / desktop session with no luck


closed #105

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.