[Testing Update] 2019-02-10 - KDE Apps, Gambas, Qt5, VirtualBox, LibreOffice, Wine, Firefox

Is this only on Plasma default panel, or Latte as well? As I said, I don’t have it (with Latte) but no-one said it 's also on Latte… :worried:

1 Like

The same in Latte or the Panel … but happens (in my case) only with Libre Office. All other GTK+ applications work nice. I don’t use GM on my main rig because it interferes with my workflow.

1 Like

I reported a bug. Now we’ll see where it takes us:

https://bugs.documentfoundation.org/show_bug.cgi?id=123416

3 Likes

You don’t need to have run Python as root directly. If you run a program as root (or maybe it asks you for root privilege), and then the program uses PyQt5, the .pyc file could be created. There isn’t always anything obvious that shows you the program you’re starting is written in Python.

PyQt5 is a wrapper that enables Python programs to have Qt5 GUI windows.

When bytecode (.pyc) files are present, a python app can load faster. An app run by a non-root user cannot create bytecode files under /usr/lib/, so would load relatively slowly every time. So the python-pyqt5 package adds bytecode files at install/upgrade time, while it has root access.

I’m still not totally clear what’s happening.
The page linked by Jonathan shows that python-pyqt5 is adding another level of optimized bytecode files, and some bytecode files should have been there already.
Note that the top line here has no ‘-’ before it; it was there, and it stays there:

   python -m compileall -d / "$pkgdir"/usr/lib
+  python -O -m compileall -d / "$pkgdir"/usr/lib

My PyQt5 install has no bytecode at all, but I might have installed it via ‘pip’, as root. (I know now to install via pip with the --user option, so the files are placed in /home/jh/.local/lib/python3.7/site-packages/.) I don’t remember about my PyQt5 install because I switched to using PySide2 soon after I did it.

Anyway, this issue should be transient; the next time python-pyqt5 updates, it should recognize all the bytecode files as its own, and simply replace them.
If I understood things right.
Expert corrections welcome … :slight_smile:

OK, thanks for that more detailed explanation. It is much more balanced & nuanced than some other Manjaroos’ earlier posts, which had an overt scolding tone of finger-wagging accusation that those of us who’d experienced that scenario must have been stupid enough to have done something wilfully dumb. I will always own my own [plentiful] errors, but i don’t rush with quite the same zeal to accept false &/or misguided accusations.

After all, til recently i did not even know that python was some kind of programming language, much less do [or know how to] make it be run as root. Prior to becoming a Manjaroo, i’d have simply said that Python was simply the best sextuplet of comedians Gaia has ever produced. I can only ponder what those naughty schoolboys would have made of the concept that they had been run as root.

Done.

2 Likes

Edit (2019-2-18) : Do not downgrade or hold back curl (or you may have to restore system without network connection). Patch should be in curl 7.64.0-5.

There is a regression with curl 7.64.0-1 and rtorrent 0.9.7 as reported here (https://github.com/curl/curl/issues/3542) which on my system results in rtorrent using one CPU core 100% of the time with no active connections.

Downgrade curl to 7.63.0-4 fixes for now.

1 Like

Fixed in LO-fresh 6.2.0-3 (arch). I can confirm.

1 Like

Perhaps we should push new updates in Testing then, hoping that the newer stuff doesn’t create more problem that we already have?

It would also give us the newest KDE Plasma too.

1 Like

New KDE and LibreOffice in the testing branch…i say send it up from unstable!

Well, we already have the new Libre Office right now. Just that Arch published a new version of the package which is said to fix a bug with Libre Office when using the global menus in KDE.

It seems the only difference on libreoffice is that /etc/profile.d/libreoffice-fresh.sh has this:

# to force a certain look'n feel

#export SAL_USE_VCLPLUGIN=gen
#export SAL_USE_VCLPLUGIN=gtk3_kde5
export SAL_USE_VCLPLUGIN=kde5
#export SAL_USE_VCLPLUGIN=qt5
#export SAL_USE_VCLPLUGIN=gtk
#export SAL_USE_VCLPLUGIN=gtk3

but both qt5 or kde5 have the same result (a working global menu) in KDE Plasma …

4 Likes

AFAIK&IIRC this can be overridden in the session
~/.profile

At least it can be tried if it works. :wink:

1 Like

Arch Linux with KDE Plasma doesn’t have a ~/.profile and all the entries in /etc/profile.d/libreoffice-fresh.sh are commented, yet the Global Menu works for LibreOffice … I wonder where we get over complicated and we add too much to what already is … :man_shrugging:

3 Likes

The same for me.
I was just referring to users with the problem for checking or workaround. Also, I’m in favor of local env handling when it comes to DE issues. :wink:

I would have one :smiley: (xfce,i3)

export QT_QPA_PLATFORMTHEME="qt5ct"
export EDITOR=/usr/bin/nano
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
# fix "xdg-open fork-bomb" export your preferred browser from here
export BROWSER=/usr/bin/palemoon

Always something new.
Ready to change “BROWSER”.

1 Like

2 Likes

I’m using KDE Plasma and have a .bash_profile that is used instead of a .profile. I can’t remember if Manjaro installed it or if I added it.

I also confirm, updating to libreoffice 6.2.0-3 (along with KDE framework 5.55 and Plasma 5.15) not only fixed the issue but made menus having icons as it was a regular in-app menu! Previously we got only text, no graphics, now it’s all there! Awesome! :heart_eyes:

@philm we can skip bugged libreoffice 6.2.0-2 and ship 6.2.0-3 in stable when the time comes.

1 Like

I look at your always-exquisitely-beautiful desktops, & still don’t feel even an iota of belief that i either need or want GMs. Their purported attraction / benefit continues to elude me.

This illustrates the wonderful nature of the choices we have at our disposal by using Plasma [Is Great!]. Were GM mandatory with no alternative, i’d be mighty irritated. Were they not available at all, you’d be mighty irritated. However, care of the Plasma Devs spoiling us with choice, both of us feel happy. Nice.

4 Likes