[Testing Update] 2018-12-09 - Kernels, Nvidia, Matcha, Pamac, Thunderbird, Wine

Hi community,

Welcome to another testing update.
So what do we have with this one?

  • We updated most of our Kernels
  • Nvidia 415.22 got added
  • The Matcha theme got further fixes and updates
  • Pamac got released as v7.3.2
  • Thunderbird got updated to v60.3.3
  • Wine 4.0 comes along. Test the first release candidate
  • all the regular haskell, php and python updates

We hope with all these changes Manjaro to be more efficient for you all.


#ManjaroBook - shipping worldwide since this Winter!

manjarobook

We are happy to announce our partnership with LINUX-SERVICE.BE BVBA from Belgium. With them we established a wider range of laptops and PCs optimized for Manjaro - starting from 390 €- available to be shipped worldwide. All models are customizable as you may need them. Check out our new line-up in the shop.


Manjaro v18.0.1 RC1 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.128 [EOL]
  • linux44 4.4.166
  • linux49 4.9.144
  • linux414 4.14.87
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.8
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Sun Dec 9 13:45:39 CET 2018)

Upstream

  • testing multilib x86_64: 7 new and 7 removed package(s)
  • testing extra x86_64: 91 new and 91 removed package(s)
  • testing community x86_64: 282 new and 280 removed package(s)

Overlay

  • testing core x86_64: 7 new and 7 removed package(s)
  • testing multilib x86_64: 2 new and 7 removed package(s)
  • testing extra x86_64: 44 new and 50 removed package(s)
  • testing community x86_64: 4 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
                  linux414-rt-nvidia           1:415.18-1           1:415.22-1
                  linux416-rt-nvidia           1:415.18-1           1:415.22-1
                  linux418-rt-nvidia           1:415.18-1           1:415.22-1
                    matcha-gtk-theme           20181204-1           20181208-1
                           osinfo-db           20181116-0                    -


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
                                agda    2.5.99.20181017-6    2.5.99.20181017-7
                       android-tools           9.0.0_r3-1          9.0.0_r18-1
                       cabal-install           2.4.0.0-15           2.4.0.0-16
                             calibre             3.34.0-1             3.35.0-1
                               cgrep           6.6.25-103           6.6.25-104
                             cryptol             2.6.0-61             2.6.0-62
                               csfml                2.5-1                2.5-2
                               darcs            2.14.1-93            2.14.1-94
                          drbd-utils              9.6.0-1              9.7.0-1
                              eslint              5.9.0-1             5.10.0-1
                           firewalld              0.6.3-1              0.6.3-2
                           git-annex         7.20181205-4         7.20181205-5
                       haskell-aeson            1.4.2.0-1            1.4.2.0-2
         haskell-aeson-better-errors           0.9.1.0-92           0.9.1.0-93
                haskell-aeson-compat             0.3.9-11             0.3.9-12
                haskell-aeson-pretty             0.8.7-44             0.8.7-45
                    haskell-aeson-qq             0.8.2-84             0.8.2-85
                  haskell-attoparsec          0.13.2.2-33          0.13.2.2-34
          haskell-attoparsec-iso8601            1.0.1.0-7            1.0.1.0-8
                haskell-authenticate            1.3.4-212            1.3.4-213
          haskell-authenticate-oauth               1.6-54               1.6-55
                         haskell-aws             0.20-120             0.20-121
              haskell-binary-conduit              1.3.1-7              1.3.1-8
              haskell-binary-orphans           0.1.8.0-68           0.1.8.0-69
               haskell-binary-tagged            0.1.5.1-9           0.1.5.1-10
                  haskell-bower-json           1.0.0.1-90           1.0.0.1-91
                       haskell-brick               0.43-1               0.43-2
            haskell-bsb-http-chunked            0.0.0.4-4            0.0.0.4-5
   haskell-bytestring-strict-builder           0.4.5.1-41           0.4.5.1-42
     haskell-bytestring-tree-builder           0.2.7.2-12           0.2.7.2-13
                       haskell-cairo           0.13.5.0-8           0.13.5.0-9
                     haskell-cassava           0.5.1.0-48           0.5.1.0-49
          haskell-cassava-megaparsec              2.0.0-1              2.0.0-2
                  haskell-cheapskate            0.1.1.1-5            0.1.1.1-6
                haskell-chunked-data             0.3.1-10             0.3.1-11
               haskell-clash-prelude            0.99.3-12            0.99.3-13
               haskell-clientsession           0.9.1.2-85           0.9.1.2-86
                     haskell-concise           0.1.0.1-70           0.1.0.1-71
                     haskell-conduit             1.3.1-10             1.3.1-11
               haskell-conduit-extra             1.3.0-73             1.3.0-74
                  haskell-config-ini            0.2.4.0-1            0.2.4.0-2
                haskell-configurator           0.3.0.0-58           0.3.0.0-59
             haskell-configurator-ng           0.0.0.1-47           0.0.0.1-48
                   haskell-cprng-aes             0.6.1-77             0.6.1-78
                     haskell-critbit           0.2.0.0-13           0.2.0.0-14
                   haskell-criterion            1.5.3.0-9           1.5.3.0-10
       haskell-criterion-measurement           0.1.1.0-17           0.1.1.0-18
              haskell-crypto-numbers             0.2.7-76             0.2.7-77
               haskell-crypto-pubkey             0.2.8-89             0.2.8-90
               haskell-crypto-random             0.0.9-78             0.0.9-79
          haskell-cryptohash-conduit            0.1.1-235            0.1.1-236
          haskell-cryptonite-conduit            0.2.2-129            0.2.2-130
                    haskell-css-text           0.1.3.0-31           0.1.3.0-32
             haskell-data-serializer             0.3.4-39             0.3.4-40
                haskell-data-textual           0.3.0.2-79           0.3.0.2-80
                         haskell-dav              1.3.3-3              1.3.3-4
                        haskell-dbus              1.1.1-2              1.1.1-3
              haskell-deferred-folds             0.9.10-1             0.9.10-2
                 haskell-descriptive             0.9.5-15             0.9.5-16
                         haskell-dns             3.0.4-39             3.0.4-40
                haskell-doctemplates           0.2.2.1-49           0.2.2.1-50
              haskell-email-validate            2.3.2.9-1            2.3.2.9-2
                   haskell-esqueleto    2.5.3.20180402-98    2.5.3.20180402-99
                  haskell-fdo-notify            0.3.1-112            0.3.1-113
                        haskell-feed            1.0.1.0-4            1.0.1.0-5
                       haskell-foldl              1.4.5-9             1.4.5-10
                       haskell-gauge              0.2.4-4              0.2.4-5
                     haskell-githash            0.1.3.0-2            0.1.3.0-3
                        haskell-glib           0.13.6.0-8           0.13.6.0-9
                         haskell-gtk             0.15.0-3             0.15.0-4
           haskell-gtk2hs-buildtools           0.13.4.0-8           0.13.4.0-9
             haskell-haddock-library              1.7.0-5              1.7.0-6
                      haskell-hakyll          4.12.4.0-84          4.12.4.0-85
                  haskell-hashtables            1.2.3.1-6            1.2.3.1-7
                       haskell-hasql           1.3.0.3-35           1.3.0.3-36
                  haskell-hasql-pool               0.5-35               0.5-36
           haskell-hasql-transaction               0.7-35               0.7-36
                        haskell-here            1.2.13-46            1.2.13-47
                haskell-hjsonpointer              1.5.0-5              1.5.0-6
                 haskell-hjsonschema            1.9.0-127            1.9.0-128
                 haskell-hledger-lib               1.12-1               1.12-2
                    haskell-hopenpgp           2.7.4.1-12           2.7.4.1-13
                       haskell-hpack             0.31.1-7             0.31.1-8
                       haskell-hslua              1.0.1-7              1.0.1-8
           haskell-hslua-module-text              0.2.0-8              0.2.0-9
                   haskell-hspec-wai            0.9.0-121            0.9.0-122
              haskell-hspec-wai-json            0.9.0-141            0.9.0-142
                haskell-html-conduit              1.3.2-6              1.3.2-7
                        haskell-http         4000.3.12-87         4000.3.12-88
               haskell-http-api-data             0.3.10-7             0.3.10-8
                 haskell-http-client             0.5.14-1             0.5.14-2
             haskell-http-client-tls           0.3.5.3-87           0.3.5.3-88
                haskell-http-conduit              2.3.4-4              2.3.4-5
                   haskell-http-date             0.0.8-10             0.0.8-11
                haskell-http-streams           0.8.6.1-74           0.8.6.1-75
                  haskell-http-types             0.12.2-9            0.12.2-10
                       haskell-http2              1.6.4-5              1.6.4-6
          haskell-incremental-parser            0.3.2.1-1            0.3.2.1-2
               haskell-infer-license             0.2.0-10             0.2.0-11
                         haskell-ini             0.3.6-22             0.3.6-23
   haskell-insert-ordered-containers          0.2.1.0-127          0.2.1.0-128
                 haskell-interpolate             0.2.0-53             0.2.0-54
    haskell-interpolatedstring-perl6              1.0.1-4              1.0.1-5
                  haskell-io-streams           1.5.0.1-35           1.5.0.1-36
          haskell-io-streams-haproxy           1.0.0.2-34           1.0.0.2-35
                 haskell-ixset-typed            0.4.0.1-4            0.4.0.1-5
                        haskell-jose           0.7.0.0-66           0.7.0.0-67
                   haskell-js-jquery            3.3.1-157            3.3.1-158
                    haskell-json-ast             0.3.1-11             0.3.1-12
                 haskell-juicypixels              3.3.2-3              3.3.2-4
                        haskell-lens              4.17-23              4.17-24
                  haskell-lens-aeson            1.0.2-109            1.0.2-110
                      haskell-libmpd           0.9.0.8-42           0.9.0.8-43
                     haskell-libyaml            0.1.0.0-6            0.1.0.0-7
                    haskell-listlike               4.6-11               4.6-12
              haskell-math-functions            0.3.1.0-1            0.3.1.0-2
             haskell-microlens-aeson             2.3.0-49             2.3.0-50
          haskell-microlens-platform             0.3.11-1             0.3.11-2
                 haskell-microstache           1.0.1.1-68           1.0.1.1-69
                haskell-monad-logger             0.3.30-6             0.3.30-7
                   haskell-monad-par           0.3.4.8-25           0.3.4.8-26
            haskell-mono-traversable           1.0.9.0-23           1.0.9.0-24
           haskell-monoid-subclasses            0.4.6.1-3            0.4.6.1-4
                    haskell-mustache            2.3.0-122            2.3.0-123
                  haskell-mwc-random           0.14.0.0-6           0.14.0.0-7
                  haskell-network-ip           0.3.0.2-68           0.3.0.2-69
          haskell-openpgp-asciiarmor             0.1.1-19             0.1.1-20
             haskell-openssl-streams           1.2.1.3-34           1.2.1.3-35
                haskell-pandoc-types           1.17.5.4-4           1.17.5.4-5
                       haskell-pango           0.13.5.0-8           0.13.5.0-9
                     haskell-parsers            0.12.9-17            0.12.9-18
                        haskell-path             0.6.1-73             0.6.1-74
                     haskell-path-io             1.4.0-19             1.4.0-20
                  haskell-persistent            2.8.2-100            2.8.2-101
           haskell-persistent-sqlite             2.8.2-46             2.8.2-47
         haskell-persistent-template            2.5.4-126            2.5.4-127
                haskell-pgp-wordlist           0.1.0.2-30           0.1.0.2-31
                  haskell-pipes-http            1.0.5-175            1.0.5-176
           haskell-postgresql-binary           0.12.1.2-2           0.12.1.2-3
               haskell-prettyprinter             1.2.1-20             1.2.1-21
 haskell-prettyprinter-ansi-terminal           1.1.1.2-30           1.1.1.2-31
haskell-prettyprinter-convert-ansi-wl-pprint       1.1-27               1.1-28
              haskell-process-extras             0.7.4-33             0.7.4-34
            haskell-project-template          0.2.0.1-103          0.2.0.1-104
        haskell-quickcheck-instances             0.3.19-5             0.3.19-6
                      haskell-rebase                1.3-9               1.3-10
                    haskell-rerebase                1.3-9               1.3-10
               haskell-resource-pool           0.2.3.2-52           0.2.3.2-53
                         haskell-rio            0.1.6.0-1            0.1.6.0-2
                    haskell-safecopy            0.9.4.2-1            0.9.4.2-2
                       haskell-sandi              0.4.3-4              0.4.3-5
                         haskell-sbv              7.12-30              7.12-31
                     haskell-servant             0.14.1-1             0.14.1-2
              haskell-servant-server             0.14.1-2             0.14.1-3
             haskell-servant-swagger              1.1.6-7              1.1.6-8
                       haskell-shake             0.17.3-3             0.17.3-4
                 haskell-shakespeare             2.0.20-2             2.0.20-3
             haskell-simple-sendfile            0.2.27-99           0.2.27-100
                  haskell-singletons              2.5.1-1              2.5.1-2
                 haskell-skylighting              0.7.5-2              0.7.5-3
            haskell-skylighting-core              0.7.5-2              0.7.5-3
                   haskell-snap-core           1.0.3.2-37           1.0.3.2-38
                 haskell-snap-server           1.1.0.0-75           1.1.0.0-77
                   haskell-sourcemap            0.1.6-100            0.1.6-101
                    haskell-src-meta           0.8.0.3-26           0.8.0.3-27
                  haskell-statistics          0.14.0.2-88          0.14.0.2-89
                       haskell-store          0.4.3.2-163          0.4.3.2-164
                    haskell-swagger2             2.2.2-70             2.2.2-71
           haskell-tagstream-conduit          0.5.5.3-223          0.5.5.3-224
         haskell-tamarin-prover-term             1.4.0-24             1.4.0-25
       haskell-tamarin-prover-theory             1.4.0-47             1.4.0-48
                     haskell-texmath           0.11.1.2-4           0.11.1.2-5
                haskell-text-builder             0.6.4-11             0.6.4-12
                haskell-text-metrics             0.3.0-12             0.3.0-13
                  haskell-text-short             0.1.2-33             0.1.2-34
                 haskell-text-zipper            0.10.1-12            0.10.1-13
                  haskell-th-desugar                1.9-4                1.9-5
           haskell-th-lift-instances            0.1.11-23            0.1.11-24
                  haskell-th-orphans            0.13.6-15            0.13.6-16
                haskell-th-utilities           0.2.0.1-62           0.2.0.1-63
                   haskell-tree-diff              0.0.2-3              0.0.2-4
                    haskell-trifecta                  2-5                  2-6
                      haskell-turtle            1.5.12-11            1.5.12-12
                   haskell-unixutils            1.54.1-65            1.54.1-66
              haskell-uri-bytestring            0.3.2.1-5            0.3.2.1-6
                      haskell-vector          0.12.0.1-12           0.12.0.2-1
           haskell-vector-algorithms            0.8.0.1-3            0.8.0.1-4
     haskell-vector-binary-instances            0.2.5.1-2            0.2.5.1-3
              haskell-vector-builder              0.3.6-3              0.3.6-4
            haskell-vector-instances               3.4-92               3.4-93
             haskell-vector-th-unbox           0.2.1.6-14           0.2.1.6-15
                         haskell-vty             5.25.1-2             5.25.1-3
                         haskell-wai           3.2.1.2-44           3.2.1.2-45
              haskell-wai-app-static          3.1.6.2-139          3.1.6.2-140
                 haskell-wai-conduit           3.0.0.4-83           3.0.0.4-84
                    haskell-wai-cors             0.2.6-69             0.2.6-70
                   haskell-wai-extra          3.0.24.3-14          3.0.24.3-15
          haskell-wai-handler-launch           3.0.2.4-99          3.0.2.4-100
                  haskell-wai-logger            2.3.2-151            2.3.2-153
       haskell-wai-middleware-static             0.8.2-44             0.8.2-45
              haskell-wai-websockets           3.0.1.2-58           3.0.1.2-59
                        haskell-warp            3.2.25-35            3.2.25-36
                    haskell-warp-tls          3.2.4.3-118          3.2.4.3-119
                  haskell-websockets          0.12.5.2-11          0.12.5.2-12
                        haskell-wreq           0.5.2.1-82           0.5.2.1-83
                      haskell-xcffib             0.6.0-72             0.6.0-73
                 haskell-xml-conduit           1.8.0.1-19           1.8.0.1-20
                  haskell-xml-hamlet             0.5.0-80             0.5.0-81
                haskell-xss-sanitize             0.3.6-11             0.3.6-12
                        haskell-yaml           0.11.0.0-7           0.11.0.0-8
                       haskell-yesod            1.6.0-170            1.6.0-171
                  haskell-yesod-auth             1.6.5-22             1.6.5-23
                  haskell-yesod-core              1.6.9-4              1.6.9-5
               haskell-yesod-default            1.2.0-436            1.2.0-437
                  haskell-yesod-form             1.6.3-20             1.6.3-21
            haskell-yesod-persistent           1.6.0.1-23           1.6.0.1-24
                haskell-yesod-static           1.6.0.1-18           1.6.0.1-19
                  haskell-yesod-test           1.6.5.1-25           1.6.5.1-26
                            hasktags             0.71.2-9            0.71.2-10
                           hedgewars          0.9.24.1-76          0.9.24.1-77
                             hindent             5.2.7-51             5.2.7-52
                             hledger             1.12.1-1             1.12.1-2
                         hledger-api               1.12-6               1.12-7
                          hledger-ui               1.12-6               1.12-7
                         hledger-web               1.12-6               1.12-7
                               hlint             2.1.11-1             2.1.11-2
                              hoogle         5.0.17.3-131         5.0.17.3-132
                      hopenpgp-tools            0.21.2-67            0.21.2-68
                               idris             1.3.1-12             1.3.1-13
                          jconvolver              1.0.2-1              1.0.3-1
                               jruby            9.2.4.1-1            9.2.5.0-1
                      libretro-citra               5903-1               6959-1
                    libretro-desmume               5333-1               6239-1
                   libretro-gambatte                736-1                785-1
            libretro-genesis-plus-gx               1366-1               1471-1
                    libretro-melonds                541-2                560-1
                       libretro-mgba               4963-1               5856-1
                libretro-mupen64plus              1:633-1              1:680-1
                   libretro-nestopia                867-1                947-1
                   libretro-overlays                106-2                149-1
               libretro-parallel-n64               4910-3               5013-1
                     libretro-ppsspp              24309-1              24922-1
                    libretro-redream               1077-1               1083-1
                    libretro-reicast               3321-1               3485-1
                    libretro-scummvm              84203-1              84242-1
                              pandoc                2.5-4                2.5-5
                     pandoc-citeproc           0.15.0.1-5           0.15.0.1-6
                     pandoc-crossref            0.3.4.0-7            0.3.4.0-8
                           php-geoip              1.1.1-3              1.1.1-4
                        php-memcache              3.0.8-6              3.0.8-7
                       php-memcached              3.0.4-2              3.0.4-3
                         php-mongodb              1.5.3-3              1.5.3-4
                           postgrest           0.5.0.0-77           0.5.0.0-78
                      python-awkward              0.5.6-1              0.6.0-1
                       python-cftime              1.0.3-1            1.0.3.4-1
             python-diff-match-patch           20121119-4           20181111-1
                   python-hypothesis             3.82.1-1             3.82.5-1
                   python-tensorflow             1.12.0-1             1.12.0-3
              python-tensorflow-cuda             1.12.0-1             1.12.0-3
               python-tensorflow-opt             1.12.0-1             1.12.0-3
          python-tensorflow-opt-cuda             1.12.0-1             1.12.0-3
                      python2-cftime              1.0.3-1            1.0.3.4-1
                  python2-hypothesis             3.82.1-1             3.82.5-1
                              reptyr              0.6.2-2              0.7.0-1
                        rust-bindgen             0.42.2-1             0.44.0-1
                          shellcheck              0.6.0-4              0.6.0-5
                               stack              1.9.3-5              1.9.3-6
                     stylish-haskell           0.9.2.0-92           0.9.2.0-93
                      tamarin-prover            1.4.0-150            1.4.0-151
                          tensorflow             1.12.0-1             1.12.0-3
                     tensorflow-cuda             1.12.0-1             1.12.0-3
                      tensorflow-opt             1.12.0-1             1.12.0-3
                 tensorflow-opt-cuda             1.12.0-1             1.12.0-3
                       wireshark-cli              2.6.4-2              2.6.5-1
                    wireshark-common              2.6.4-2              2.6.5-1
                       wireshark-gtk              2.6.4-2              2.6.5-1
                        wireshark-qt              2.6.4-2              2.6.5-1
                              xdebug              2.6.1-1         2.7.0beta1-1
                              xmobar             0.28.1-5             0.28.1-6
                               zapcc         7.0.325000-1         7.0.325000-2
                               scdoc                    -              1.6.0-2
                        wl-clipboard                    -              1.0.0-4


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
                            linux414            4.14.86-1            4.14.87-1
                    linux414-headers            4.14.86-1            4.14.87-1
                            linux419             4.19.7-2             4.19.8-2
                    linux419-headers             4.19.7-2             4.19.8-2
                             linux49            4.9.143-1            4.9.144-1
                     linux49-headers            4.9.143-1            4.9.144-1
                         mhwd-nvidia           1:415.18-1           1:415.22-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
                 calamares-git 3.2.3.r5127.a33cd43d0-1 3.2.3.r5141.404cfc451-1
                   libva-mesa-driver           18.2.6-0.1                    -
                     linux316-nvidia           1:415.18-1           1:415.22-1
                     linux318-nvidia           1:415.18-1           1:415.22-1
                  linux414-acpi_call             1.1.0-69             1.1.0-70
                   linux414-bbswitch               0.8-69               0.8-70
                linux414-broadcom-wl      6.30.223.271-69      6.30.223.271-70
                   linux414-catalyst     1:15.201.1151-69     1:15.201.1151-70
                linux414-ndiswrapper              1.61-69              1.61-70
                     linux414-nvidia           1:415.18-4           1:415.22-2
               linux414-nvidia-340xx           340.107-28           340.107-29
               linux414-nvidia-390xx            390.87-14            390.87-15
                   linux414-nvidiabl              0.88-69              0.88-70
                      linux414-r8168          8.045.08-57          8.045.08-58
                  linux414-rt3562sta        2.4.1.1_r4-69        2.4.1.1_r4-70
                        linux414-spl             0.7.11-9            0.7.11-10
                   linux414-tp_smapi              0.41-69              0.41-70
                linux414-vhba-module          20161009-69          20161009-70
   linux414-virtualbox-guest-modules             5.2.22-6             5.2.22-7
    linux414-virtualbox-host-modules             5.2.22-6             5.2.22-7
                        linux414-zfs             0.7.11-9            0.7.11-10
                     linux417-nvidia           1:415.18-1           1:415.22-1
                     linux418-nvidia           1:415.18-1           1:415.22-1
                     linux419-nvidia           1:415.18-4           1:415.22-1
                  linux419-rtl8723bu   4.3.9.3.13200-6.71    4.3.9.3.13200-8.2
                      linux44-nvidia           1:415.18-1           1:415.22-1
                   linux49-acpi_call            1.1.0-105            1.1.0-106
                    linux49-bbswitch              0.8-105              0.8-106
                 linux49-broadcom-wl     6.30.223.271-105     6.30.223.271-106
                    linux49-catalyst    1:15.201.1151-105    1:15.201.1151-106
                 linux49-ndiswrapper             1.61-103             1.61-104
                      linux49-nvidia           1:415.18-2           1:415.22-2
                linux49-nvidia-340xx           340.107-24           340.107-25
                linux49-nvidia-390xx            390.87-13            390.87-14
                    linux49-nvidiabl             0.88-105             0.88-106
                       linux49-r8168          8.045.08-45          8.045.08-46
                   linux49-rt3562sta       2.4.1.1_r4-103       2.4.1.1_r4-104
                         linux49-spl             0.7.11-8             0.7.11-9
                    linux49-tp_smapi             0.41-105             0.41-106
                 linux49-vhba-module         20161009-103         20161009-104
    linux49-virtualbox-guest-modules             5.2.22-5             5.2.22-6
     linux49-virtualbox-host-modules             5.2.22-5             5.2.22-6
                         linux49-zfs             0.7.11-8             0.7.11-9
                                mesa           18.2.6-0.1                    -
                          mesa-vdpau           18.2.6-0.1                    -
                        nvidia-utils           1:415.18-1           1:415.22-1
                         opencl-mesa           18.2.6-0.1                    -
                       opencl-nvidia           1:415.18-1           1:415.22-1
                        vulkan-intel           18.2.6-0.1                    -
                       vulkan-radeon           18.2.6-0.1                    -


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
                             glslang           7.9.2888-2          7.10.2984-1
                             gphoto2             2.5.17-1             2.5.20-1
                                gvim           8.1.0542-1           8.1.0570-1
                          libgphoto2             2.5.19-1             2.5.20-1
                   libva-mesa-driver             18.2.5-2             18.2.6-1
                                mesa             18.2.5-2             18.2.6-1
                          mesa-vdpau             18.2.5-2             18.2.6-1
                    noto-fonts-emoji           20180810-1           20180810-2
                         opencl-mesa             18.2.5-2             18.2.6-1
                                 php             7.2.13-1              7.3.0-1
                          php-apache             7.2.13-1              7.3.0-1
                            php-apcu             5.1.12-1             5.1.15-2
                         php-apcu-bc              1.0.4-1              1.0.4-2
                             php-cgi             7.2.13-1              7.3.0-1
                           php-dblib             7.2.13-1              7.3.0-1
                           php-embed             7.2.13-1              7.3.0-1
                         php-enchant             7.2.13-1              7.3.0-1
                             php-fpm             7.2.13-1              7.3.0-1
                              php-gd             7.2.13-1              7.3.0-1
                            php-imap             7.2.13-1              7.3.0-1
                            php-intl             7.2.13-1              7.3.0-1
                            php-odbc             7.2.13-1              7.3.0-1
                           php-pgsql             7.2.13-1              7.3.0-1
                          php-phpdbg             7.2.13-1              7.3.0-1
                          php-pspell             7.2.13-1              7.3.0-1
                            php-snmp             7.2.13-1              7.3.0-1
                          php-sodium             7.2.13-1              7.3.0-1
                          php-sqlite             7.2.13-1              7.3.0-1
                            php-tidy             7.2.13-1              7.3.0-1
                             php-xsl             7.2.13-1              7.3.0-1
                         thunderbird             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ar             60.3.2-1             60.3.3-1
                thunderbird-i18n-ast             60.3.2-1             60.3.3-1
                 thunderbird-i18n-be             60.3.2-1             60.3.3-1
                 thunderbird-i18n-bg             60.3.2-1             60.3.3-1
                 thunderbird-i18n-br             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ca             60.3.2-1             60.3.3-1
                 thunderbird-i18n-cs             60.3.2-1             60.3.3-1
                 thunderbird-i18n-cy             60.3.2-1             60.3.3-1
                 thunderbird-i18n-da             60.3.2-1             60.3.3-1
                 thunderbird-i18n-de             60.3.2-1             60.3.3-1
                thunderbird-i18n-dsb             60.3.2-1             60.3.3-1
                 thunderbird-i18n-el             60.3.2-1             60.3.3-1
              thunderbird-i18n-en-gb             60.3.2-1             60.3.3-1
              thunderbird-i18n-en-us             60.3.2-1             60.3.3-1
              thunderbird-i18n-es-ar             60.3.2-1             60.3.3-1
              thunderbird-i18n-es-es             60.3.2-1             60.3.3-1
                 thunderbird-i18n-et             60.3.2-1             60.3.3-1
                 thunderbird-i18n-eu             60.3.2-1             60.3.3-1
                 thunderbird-i18n-fi             60.3.2-1             60.3.3-1
                 thunderbird-i18n-fr             60.3.2-1             60.3.3-1
              thunderbird-i18n-fy-nl             60.3.2-1             60.3.3-1
              thunderbird-i18n-ga-ie             60.3.2-1             60.3.3-1
                 thunderbird-i18n-gd             60.3.2-1             60.3.3-1
                 thunderbird-i18n-gl             60.3.2-1             60.3.3-1
                 thunderbird-i18n-he             60.3.2-1             60.3.3-1
                 thunderbird-i18n-hr             60.3.2-1             60.3.3-1
                thunderbird-i18n-hsb             60.3.2-1             60.3.3-1
                 thunderbird-i18n-hu             60.3.2-1             60.3.3-1
              thunderbird-i18n-hy-am             60.3.2-1             60.3.3-1
                 thunderbird-i18n-id             60.3.2-1             60.3.3-1
                 thunderbird-i18n-is             60.3.2-1             60.3.3-1
                 thunderbird-i18n-it             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ja             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ko             60.3.2-1             60.3.3-1
                 thunderbird-i18n-lt             60.3.2-1             60.3.3-1
              thunderbird-i18n-nb-no             60.3.2-1             60.3.3-1
                 thunderbird-i18n-nl             60.3.2-1             60.3.3-1
              thunderbird-i18n-nn-no             60.3.2-1             60.3.3-1
                 thunderbird-i18n-pl             60.3.2-1             60.3.3-1
              thunderbird-i18n-pt-br             60.3.2-1             60.3.3-1
              thunderbird-i18n-pt-pt             60.3.2-1             60.3.3-1
                 thunderbird-i18n-rm             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ro             60.3.2-1             60.3.3-1
                 thunderbird-i18n-ru             60.3.2-1             60.3.3-1
                 thunderbird-i18n-si             60.3.2-1             60.3.3-1
                 thunderbird-i18n-sk             60.3.2-1             60.3.3-1
                 thunderbird-i18n-sl             60.3.2-1             60.3.3-1
                 thunderbird-i18n-sq             60.3.2-1             60.3.3-1
                 thunderbird-i18n-sr             60.3.2-1             60.3.3-1
              thunderbird-i18n-sv-se             60.3.2-1             60.3.3-1
                 thunderbird-i18n-tr             60.3.2-1             60.3.3-1
                 thunderbird-i18n-uk             60.3.2-1             60.3.3-1
                 thunderbird-i18n-vi             60.3.2-1             60.3.3-1
              thunderbird-i18n-zh-cn             60.3.2-1             60.3.3-1
              thunderbird-i18n-zh-tw             60.3.2-1             60.3.3-1
                                 vim           8.1.0542-1           8.1.0570-1
                         vim-runtime           8.1.0542-1           8.1.0570-1
                        vulkan-intel             18.2.5-2             18.2.6-1
                       vulkan-radeon             18.2.5-2             18.2.6-1
                    xfce4-mpc-plugin              0.5.0-2              0.5.1-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver           18.2.6-0.1                    -
                          lib32-mesa           18.2.6-0.1                    -
                    lib32-mesa-vdpau           18.2.6-0.1                    -
                  lib32-nvidia-utils           1:415.18-1           1:415.22-1
                 lib32-opencl-nvidia           1:415.18-1           1:415.22-1
                  lib32-vulkan-intel           18.2.6-0.1                    -
                 lib32-vulkan-radeon           18.2.6-0.1                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-07           2018-12-09
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver             18.2.5-2             18.2.6-1
                          lib32-mesa             18.2.5-2             18.2.6-1
                    lib32-mesa-vdpau             18.2.5-2             18.2.6-1
                  lib32-vulkan-intel             18.2.5-2             18.2.6-1
                 lib32-vulkan-radeon             18.2.5-2             18.2.6-1
                                wine               3.21-1             4.0rc1-1
                        wine-staging               3.21-1             4.0rc1-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

7 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


“warning: systemd: local (239.303-1) is newer than core (239.6-2)” What do I do?

As said in this announcement, systemd packages has been downgraded to an older version. Hence, as long as the version installed on your system will be on a higher version, you’ll receive a warning.

If you already have systemd 239.303 on your system and you have no problem with it, you can just ignore it and continue to use systemd 239.303. There’s no need to do any action.

If you are still interested to downgrade systemd to 239.6, you can do the downgrade with pamac upgrade --enable-downgrade or sudo pacman -Syyuu.


Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

All smooth :slight_smile:

Thank you!

No problems, everything works. Thank you. :grinning:

OS: Manjaro 18.0.0 Illyria
Kernel: x86_64 Linux 4.19.8-2-MANJARO
DE: Xfce4.13.2git

Update went smoothly, but should this update supply wine 4.0 or wine 3.21?

wine               3.21-1             4.0rc1-1
                        wine-staging               3.21-1   

(Please excuse if dumb question, I’m new to Manjaro)

No regression introduced on my side.

Still has this really weird issue though, that no one else among the few Cinnamon users here seems to have encountered though.

So far, I tried without success to:

  • Change theme settings in general (icons, controls, windows…);
  • Using gtk-update-icon-cache;
  • Remove “Windows List” applet and put it back;
  • Reinstall my icon theme;
  • Reinstall Cinnamon;
  • Try out the package used on Arch instead of Manjaro.

I’m really sure it worked correctly before updating my system two days ago.

EDIT: Workaround found: Downgrading Muffin from 4.0.4 to 4.0.3 solves this issue.

LXQT, kernel 4.19 no issues.:+1:
Thanks!

KDE, kernel 4.19 lts no issues.

This time I had some weird behaviour.

First of all I am seeing a new error message in the log:
Dez 09 17:55:27 rakete avahi-daemon[2136]: chroot.c: open() failed: No such file or directory
Any idea what that is?

I rebooted to see if that helps but the PC got locked up (the GUI) with a black screen and a green line at the top. I was able top login via ssh and tried to reboot but neither reboot nor poweroff did work immediately. I waited a few minutes before I issued a systemctl poweroff. That did the trick, but only after waiting for another some minutes.

The log file of this failed reboot is showing 552883 messages of this kind:

Dez 09 17:39:56 rakete kernel: NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 0000004c 00000000 00000003 00000000
Dez 09 17:39:56 rakete kernel: NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 00000050 00002000 00000003 00000000
Dez 09 17:39:56 rakete kernel: NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 00000054 00000000 00000003 00000000
Dez 09 17:39:56 rakete kernel: NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 00000058 00800000 00000003 00000000

Looks like something nvidia related.
The scond reboot went fine. No error messages other than the above mentioned avahi-daemon message. I keep my fingers crossed that that was it.

Xfce ( Gtk2+ ) + Kernel 4.19.8 + video + steam ( opengl ) is ok

The issue is reported with debian and fedora too. I found this solution for debian which also works here for me: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800643#28

Appending this line:
After=network-online.target
to the [Unit] section of /lib/systemd/system/avahi-daemon.service

Which version of systemd is affected by this?

I can not tell for debian or fedora but the debian bug has also been forwarded to systemd: https://github.com/systemd/systemd/issues/848

I was asking which systemd version of Manjaro is affected by this …

I this today for the first time in an up-to-date Manjaro testing.

4# pacman -Q | grep systemd
lib32-systemd 239.6-2
libsystemd 239.6-2
systemd 239.6-2
systemd-resolvconf 239.6-2
systemd-sysvcompat 239.6-2

and I am using systemd-resolved.service

Reported to Linux Mint github. Hope to get an answer about it soon. One of the weirdest bug I’ve seen so far.

wine 4.0-rc1

In the large scrolling box just above the poll in the OP there is a list packages that have been changed with this update. For wine/wine-staging scroll to the very bottom and see that it is reported that on 2018-12-07 the repository for the testing branch had ‘wine 3.21-1’ but from 2018-12-09 it has ‘wine 4.0rc1-1’.

(If your machine still has wine 3.21-1 it is likely that the mirror you are using has not updated and you haven’t installed this update yet.)

No problem at all. Not even the before reported issue with the passphrase-input for the encrypted partition.

the WINE is a good vintage, no issues whatsoever with my PlayOnLinux games

1 Like

12/10/18 upgrade went well in xfce:
[2018-12-10 11:57] [ALPM] upgraded android-tools (9.0.0_r3-1 -> 9.0.0_r18-1)
[2018-12-10 11:57] [ALPM] upgraded glslang (7.9.2888-2 -> 7.10.2984-1)
[2018-12-10 11:57] [ALPM] upgraded lib32-libva-mesa-driver (18.2.6-0.1 -> 18.2.6-1)
[2018-12-10 11:57] [ALPM] upgraded mhwd-nvidia (1:415.18-1 -> 1:415.22-1)
[2018-12-10 11:57] [ALPM] upgraded nvidia-utils (1:415.18-1 -> 1:415.22-1)
[2018-12-10 11:57] [ALPM-SCRIPTLET] xorg configuration symlink valid…
[2018-12-10 11:57] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m If you run into trouble with CUDA not being available, run nvidia-modprobe first.e[1;0m
[2018-12-10 11:57] [ALPM] upgraded mesa (18.2.6-0.1 -> 18.2.6-1)
[2018-12-10 11:57] [ALPM] upgraded lib32-nvidia-utils (1:415.18-1 -> 1:415.22-1)
[2018-12-10 11:57] [ALPM-SCRIPTLET] xorg configuration symlink valid…
[2018-12-10 11:57] [ALPM] upgraded lib32-mesa (18.2.6-0.1 -> 18.2.6-1)
[2018-12-10 11:57] [ALPM] upgraded libgphoto2 (2.5.19-1 -> 2.5.20-1)
[2018-12-10 11:57] [ALPM] upgraded libva-mesa-driver (18.2.6-0.1 -> 18.2.6-1)
[2018-12-10 11:57] [ALPM] upgraded linux419 (4.19.7-2 -> 4.19.8-2)
[2018-12-10 11:57] [ALPM] upgraded linux419-nvidia (1:415.18-4 -> 1:415.22-1)
[2018-12-10 11:58] [ALPM] upgraded matcha-gtk-theme (20181204-1 -> 20181208-1)
[2018-12-10 11:58] [ALPM] upgraded thunderbird (60.3.2-1 -> 60.3.3-1)
[2018-12-10 11:58] [ALPM] upgraded thunderbird-i18n-en-us (60.3.2-1 -> 60.3.3-1)
[2018-12-10 11:58] [ALPM] upgraded xfce4-mpc-plugin (0.5.0-2 -> 0.5.1-1)

Forum kindly sponsored by