[Testing Update] 2018-12-02 - Kernels, Pamac, Thunderbird, Texlive

update
testing

#1

Hi community,

Welcome to another testing update.
So what do we have with this one?

  • We updated most of our Kernels
  • Worked on a regression with Virtualbox and Pamac
  • Thunderbird is now at 60.3.2
  • Texlive got newer packages and regular package-cleanups were done

We hope with all these changes Manjaro to be more efficient for you all.


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


Manjaro v18.0.1 Preview2 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.128 [EOL]
  • linux44 4.4.166
  • linux49 4.9.142
  • linux414 4.14.85
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.6
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Sun Dec 2 08:47:30 CET 2018)

  • testing community x86_64: 24 new and 23 removed package(s)
  • testing core x86_64: 11 new and 13 removed package(s)
  • testing extra x86_64: 108 new and 109 removed package(s)
  • testing multilib x86_64: 2 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                               light                1.0-2                    -
                          xprintidle              0.2.2-1                    -


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                             ansible              2.7.2-1              2.7.4-1
                               biber             1:2.11-1             1:2.12-1
                         go-ethereum             1.8.18-1             1.8.19-1
                                hugo               0.51-1               0.52-1
                               lldpd              1.0.1-3              1.0.2-1
                                 ois                1.4-1                1.5-1
                               opera      56.0.3051.116-1       57.0.3098.76-2
                 opera-ffmpeg-codecs      69.0.3497.100-1      70.0.3538.102-1
                     parity-ethereum              2.1.6-1              2.1.8-1
                            prettier             1.15.2-1             1.15.3-1
               python-docker-pycreds              0.3.0-2              0.4.0-1
              python2-docker-pycreds              0.3.0-2              0.4.0-1
                        python2-pafy            0.5.3.1-1                    -
                     python2-restkit              4.2.2-1              4.2.2-2
                                qcad           3.21.3.9-1          3.21.3.10-1
                           rapidjson              1.1.0-2              1.1.0-3
                      ruby-test-unit              3.2.8-2              3.2.9-1
                          spawn-fcgi              1.6.4-2              1.6.4-3
                              stylus             0.54.5-1             0.54.5-2
                            three.js                r98-1                r99-1
                              xnoise             0.2.21-4             0.2.21-5
                           gocryptfs                    -                1.6-2
                             kak-lsp                    -             5.10.0-2
                               light                    -                1.2-2
                        python-black                    -             18.9b0-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                           amd-ucode   20181026.1cb4e51-0                    -
                      linux-firmware 20181026.1cb4e51-0.1                    -
                            linux318           3.18.127-1           3.18.128-1
                    linux318-headers           3.18.127-1           3.18.128-1
                            linux414            4.14.84-1            4.14.85-1
                    linux414-headers            4.14.84-1            4.14.85-1
                            linux419             4.19.5-2             4.19.6-1
                    linux419-headers             4.19.5-2             4.19.6-1
                             linux44            4.4.165-1            4.4.166-1
                     linux44-headers            4.4.165-1            4.4.166-1
                             linux49            4.9.141-1            4.9.142-1
                     linux49-headers            4.9.141-1            4.9.142-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                             openssl              1.1.1-1            1.1.1.a-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                                cogl1.22.2+11+g811f285a-1                    -
                  linux414-acpi_call             1.1.0-67             1.1.0-68
                   linux414-bbswitch               0.8-67               0.8-68
                linux414-broadcom-wl      6.30.223.271-67      6.30.223.271-68
                   linux414-catalyst     1:15.201.1151-67     1:15.201.1151-68
                linux414-ndiswrapper              1.61-67              1.61-68
                     linux414-nvidia           1:415.18-2           1:415.18-3
               linux414-nvidia-340xx           340.107-26           340.107-27
               linux414-nvidia-390xx            390.87-12            390.87-13
                   linux414-nvidiabl              0.88-67              0.88-68
                      linux414-r8168          8.045.08-55          8.045.08-56
                  linux414-rt3562sta        2.4.1.1_r4-67        2.4.1.1_r4-68
                        linux414-spl             0.7.11-7             0.7.11-8
                   linux414-tp_smapi              0.41-67              0.41-68
                linux414-vhba-module          20161009-67          20161009-68
   linux414-virtualbox-guest-modules             5.2.22-4             5.2.22-5
    linux414-virtualbox-host-modules             5.2.22-4             5.2.22-5
                        linux414-zfs             0.7.11-7             0.7.11-8
                  linux419-acpi_call              1.1.0-5              1.1.0-6
                   linux419-bbswitch                0.8-5                0.8-6
                linux419-broadcom-wl       6.30.223.271-5       6.30.223.271-6
                   linux419-catalyst      1:15.201.1151-5      1:15.201.1151-6
                linux419-ndiswrapper               1.61-5               1.61-6
                     linux419-nvidia           1:415.18-2           1:415.18-3
               linux419-nvidia-340xx            340.107-5            340.107-6
               linux419-nvidia-390xx             390.87-5             390.87-6
                   linux419-nvidiabl               0.88-5               0.88-6
                      linux419-r8168           8.045.08-5           8.045.08-6
                  linux419-rtl8723bu    4.3.9.3.13200-5.2      4.3.9.3.13200-6
                        linux419-spl             0.7.11-5             0.7.11-6
                   linux419-tp_smapi               0.41-5               0.41-6
                linux419-vhba-module           20161009-5           20161009-6
   linux419-virtualbox-guest-modules             5.2.22-5             5.2.22-6
    linux419-virtualbox-host-modules             5.2.22-5             5.2.22-6
                        linux419-zfs             0.7.11-5             0.7.11-6
                               pamac              7.3.1-3              7.3.1-4
             pamac-tray-appindicator              7.3.1-3              7.3.1-4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                            lighttpd             1.4.51-1             1.4.52-1
                 texlive-bibtexextra         2018.48548-1         2018.49283-1
                        texlive-core         2018.48566-1         2018.49285-1
                  texlive-fontsextra         2018.48561-1         2018.49197-1
                texlive-formatsextra         2018.47496-1         2018.48634-1
                       texlive-games         2018.48514-1         2018.49111-1
                  texlive-humanities         2018.48491-1         2018.49287-1
                 texlive-langchinese         2018.48534-1         2018.49019-1
                texlive-langcyrillic         2018.48484-1         2018.49022-1
                   texlive-langextra         2018.48507-1         2018.49258-1
                texlive-langjapanese         2018.48562-1         2018.49288-1
                  texlive-latexextra         2018.48568-1         2018.49282-1
                    texlive-pictures         2018.48511-1         2018.49201-1
                    texlive-pstricks         2018.48533-1         2018.49223-1
                  texlive-publishers         2018.48567-1         2018.49284-1
                     texlive-science         2018.48515-1         2018.49286-1
                         thunderbird             60.3.1-2             60.3.2-1
                 thunderbird-i18n-ar             60.3.1-1             60.3.2-1
                thunderbird-i18n-ast             60.3.1-1             60.3.2-1
                 thunderbird-i18n-be             60.3.1-1             60.3.2-1
                 thunderbird-i18n-bg             60.3.1-1             60.3.2-1
                 thunderbird-i18n-br             60.3.1-1             60.3.2-1
                 thunderbird-i18n-ca             60.3.1-1             60.3.2-1
                 thunderbird-i18n-cs             60.3.1-1             60.3.2-1
                 thunderbird-i18n-cy             60.3.1-1             60.3.2-1
                 thunderbird-i18n-da             60.3.1-1             60.3.2-1
                 thunderbird-i18n-de             60.3.1-1             60.3.2-1
                thunderbird-i18n-dsb             60.3.1-1             60.3.2-1
                 thunderbird-i18n-el             60.3.1-1             60.3.2-1
              thunderbird-i18n-en-gb             60.3.1-1             60.3.2-1
              thunderbird-i18n-en-us             60.3.1-1             60.3.2-1
              thunderbird-i18n-es-ar             60.3.1-1             60.3.2-1
              thunderbird-i18n-es-es             60.3.1-1             60.3.2-1
                 thunderbird-i18n-et             60.3.1-1             60.3.2-1
                 thunderbird-i18n-eu             60.3.1-1             60.3.2-1
                 thunderbird-i18n-fi             60.3.1-1             60.3.2-1
                 thunderbird-i18n-fr             60.3.1-1             60.3.2-1
              thunderbird-i18n-fy-nl             60.3.1-1             60.3.2-1
              thunderbird-i18n-ga-ie             60.3.1-1             60.3.2-1
                 thunderbird-i18n-gd             60.3.1-1             60.3.2-1
                 thunderbird-i18n-gl             60.3.1-1             60.3.2-1
                 thunderbird-i18n-he             60.3.1-1             60.3.2-1
                 thunderbird-i18n-hr             60.3.1-1             60.3.2-1
                thunderbird-i18n-hsb             60.3.1-1             60.3.2-1
                 thunderbird-i18n-hu             60.3.1-1             60.3.2-1
              thunderbird-i18n-hy-am             60.3.1-1             60.3.2-1
                 thunderbird-i18n-id             60.3.1-1             60.3.2-1
                 thunderbird-i18n-is             60.3.1-1             60.3.2-1
                 thunderbird-i18n-it             60.3.1-1             60.3.2-1
                 thunderbird-i18n-ja             60.3.1-1             60.3.2-1
                 thunderbird-i18n-ko             60.3.1-1             60.3.2-1
                 thunderbird-i18n-lt             60.3.1-1             60.3.2-1
              thunderbird-i18n-nb-no             60.3.1-1             60.3.2-1
                 thunderbird-i18n-nl             60.3.1-1             60.3.2-1
              thunderbird-i18n-nn-no             60.3.1-1             60.3.2-1
                 thunderbird-i18n-pl             60.3.1-1             60.3.2-1
              thunderbird-i18n-pt-br             60.3.1-1             60.3.2-1
              thunderbird-i18n-pt-pt             60.3.1-1             60.3.2-1
                 thunderbird-i18n-rm             60.3.1-1             60.3.2-1
                 thunderbird-i18n-ro             60.3.1-1             60.3.2-1
                 thunderbird-i18n-ru             60.3.1-1             60.3.2-1
                 thunderbird-i18n-si             60.3.1-1             60.3.2-1
                 thunderbird-i18n-sk             60.3.1-1             60.3.2-1
                 thunderbird-i18n-sl             60.3.1-1             60.3.2-1
                 thunderbird-i18n-sq             60.3.1-1             60.3.2-1
                 thunderbird-i18n-sr             60.3.1-1             60.3.2-1
              thunderbird-i18n-sv-se             60.3.1-1             60.3.2-1
                 thunderbird-i18n-tr             60.3.1-1             60.3.2-1
                 thunderbird-i18n-uk             60.3.1-1             60.3.2-1
                 thunderbird-i18n-vi             60.3.1-1             60.3.2-1
              thunderbird-i18n-zh-cn             60.3.1-1             60.3.2-1
              thunderbird-i18n-zh-tw             60.3.1-1             60.3.2-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                      lib32-glew1.10             1.10.0-2                    -
                          lib32-popt               1.16-6                    -
                         lib32-smpeg              0.4.5-2                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-12-01           2018-12-02
-------------------------------------------------------------------------------
                   lib32-openssl-1.0            1.0.2.p-1            1.0.2.q-1
                       lib32-openssl            1:1.1.1-1          1:1.1.1.a-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


“warning: systemd: local (239.303-1) is newer than core (239.6-2)” What do I do?

As said in this announcement, systemd packages has been downgraded to an older version. Hence, as long as the version installed on your system will be on a higher version, you’ll receive a warning.

If you already have systemd 239.303 on your system and you have no problem with it, you can just ignore it and continue to use systemd 239.303. There’s no need to do any action.

If you are still interested to downgrade systemd to 239.6, you can do the downgrade with sudo pacman -Syyuu.

When checking for updates, Pamac (GUI) freeze at a certain percentage.

Devs are aware of this problem.

Fortunately, this problem doesn’t happens everytime. If you have the patience to kill the process each time Pamac freezes, eventually, you should be able to get through the process and be able to apply updates.

As far as we know, Pamac CLI doesn’t seems to be affected by this problem at all.


Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#3

The info on this page seems to be out of sync.

Example: mirror.alpix.eu/manjaro is listed as “Up to date”, last sync a few minutes ago. But when you check it, it is not. Newest packages are from end of November: https://mirror.alpix.eu/manjaro/testing/core/x86_64/?C=M;O=D
The same is true for other mirrors which are shown as up to date.


#4

I can confirm. After more than one hour, the two mirrors i use are reported as updated, when i check them, are not updated, and there are no updates for me.


#5

You have to check when the page got generated: Generated on 2018-12-01 12:03. You you have to refresh it. As of posting the page was last generated at: Generated on 2018-12-02 11:03. Alpix is there up-to-date.


Arg, I forgot to do the actual snap … tilt.


#6

Check if your mirror has already synced:

Is ftp.tsukuba.wide.ad.jp missing?


#7

So far so good.
LXQT with Kernel 4.19.


#8

Ok with Xfce , Steam (opengl)


#9

I got an error in the post-install grub script about device-mapper:

Error
(3/7) Updating Grub-Bootmenu
Generando un fichero de configuración de grub...
Encontrado tema: /usr/share/grub/themes/manjaro/theme.txt
Encontrada imagen de linux: /boot/vmlinuz-4.19-x86_64
Encontrada imagen de memoria inicial: /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
/dev/mapper/control: open failed: No existe el dispositivo
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: No existe el dispositivo
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: No existe el dispositivo
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: No existe el dispositivo
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
/dev/mapper/control: open failed: No existe el dispositivo
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.152 (2018-10-30) and kernel driver (unknown version).
Command failed.
Found memtest86+ image: /boot/memtest86+/memtest.bin
hecho
(4/7) Updating icon theme caches...
(5/7) Creating temporary files...
(6/7) Arming ConditionNeedsUpdate...
(7/7) Updating the desktop file MIME type cache...
pacman -Qi device-mapper
Nombre                    : device-mapper
Versión                   : 2.02.182-1
Descripción               : Device mapper userspace library and tools
Arquitectura              : x86_64
URL                       : http://sourceware.org/dm/
Licencias                 : GPL2  LGPL2.1
Grupos                    : base
Provee                    : Nada
Depende de                : glibc  libsystemd
Dependencias opcionales   : Nada
Exigido por               : cryptsetup  dmraid  grub  lvm2  nfs-utils  parted
Opcional para             : Nada
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la instalación  : 830,00 KiB
Encargado                 : Christian Hesse <arch@eworm.de>
Fecha de creación         : mié 31 oct 2018 21:38:08 CET
Fecha de instalación      : dom 25 nov 2018 16:28:58 CET
Motivo de la instalación  : Instalado explícitamente
Guion de instalación      : No
Validado por              : Firma

ls -l /usr/lib/*devmapper*
lrwxrwxrwx 1 root root     46 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2mirror.so -> device-mapper/libdevmapper-event-lvm2mirror.so
lrwxrwxrwx 1 root root     44 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2raid.so -> device-mapper/libdevmapper-event-lvm2raid.so
lrwxrwxrwx 1 root root     48 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2snapshot.so -> device-mapper/libdevmapper-event-lvm2snapshot.so
lrwxrwxrwx 1 root root     31 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2.so -> libdevmapper-event-lvm2.so.2.02
-r-xr-xr-x 1 root root  17472 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2.so.2.02
lrwxrwxrwx 1 root root     44 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2thin.so -> device-mapper/libdevmapper-event-lvm2thin.so
lrwxrwxrwx 1 root root     43 oct 31 21:38 /usr/lib/libdevmapper-event-lvm2vdo.so -> device-mapper/libdevmapper-event-lvm2vdo.so
lrwxrwxrwx 1 root root     26 oct 31 21:38 /usr/lib/libdevmapper-event.so -> libdevmapper-event.so.1.02
-r-xr-xr-x 1 root root  36400 oct 31 21:38 /usr/lib/libdevmapper-event.so.1.02
lrwxrwxrwx 1 root root     20 oct 31 21:38 /usr/lib/libdevmapper.so -> libdevmapper.so.1.02
-r-xr-xr-x 1 root root 392824 oct 31 21:38 /usr/lib/libdevmapper.so.1.02

#10

:grin:

Now it works for me!

No issues: linux419+gnome+nvidia+zfs


#11

Take a look here


#12

Thank you Philm, I already did. Unfortunately:

❯ sudo modinfo dm-mod
modinfo: ERROR: Module alias dm-mod not found.

❯ sudo modprobe dm-mod
modprobe: FATAL: Module dm-mod not found in directory /lib/modules/4.19.5-2-MANJARO

I have no idea, but it seems like it’s searching in the previous kernel version folder, but right now in that location there is only the folder for the new 4.19.6-1 one, so no luck. Maybe a reboot is needed? I didn’t reboot because of fear of a no working system so far.

EDIT: well, after a reboot I did another update-grub and it finished without errors, so it seems like it could be an false alarm. Sorry for wasting your time Phillip.


#13

I got a problem with an corrupt? package:
Fehler: linux-firmware: signature from “Laurent Carlier lordheavym@gmail.com” is invalid

Server = https://mirror.philpot.de/manjaro/testing/$repo/$arch
Anyone else?

Update: hmm, now on the 4. 5.? try, pacman did sucessfully update, so probably temporary bad connection?


#14

everything went fine! manjaro 18 kde. it’s a VM install, so no real hardware, but i have cloned all my software to the VM, so i can at least test, if an update breaks a compatibility with my software. only thing i cannot test is nvidia drivers.

everything else - no problems!


#15

still no 4.20 Kernel install/test option?


#16

Manjaro-Gnome + Kernel 4.19 + Virtualbox: I guess with the next testing update we’ll see whether pamac freezes at a certain percentage or not (In my setup it got stuck at 45% every time).

Apart from that issue, everything else worked fine.


#17

So far so good, no problems with this update.


#18

[DEPEND] Dependency failed for Local File Systems

/sbin/mount.fuse: error while loading shared libraries: libfuse3.so.3: cannot open shared object file:No such file or directory

Installing fuse3 fixed it.

Update to Pamac 7.3.1-4 seems to have fixed stalled update checking in Cinnamon (running system in VMware).


#19

Yes, after reboot update-grub doesn’t result in the error. But is isn’t a sign of the problem has gone. Just wait for the next update. For me the error still takes place on every update.


#20

Oh, this is a freshly installed system this week by the 18.0.1 RC1 iso, so it didn’t took many updates yet, so I didn’t noticed. It didn’t happened in my previous 1yr old installation.

Thank you for warning me. I will keep an eye on it and try to investigate posible causes and solutions.