[Testing Update] 2018-11-28 - Kernels, Plasma5, Cinnamon, Deepin, XFCE, Firefox, Systemd

update
testing

#1

Hi community,

Welcome to another testing update.
So what do we have with this one?

  • We updated Plasma to 5.14.4
  • Newer packages got added to Cinnamon, Deepin and XFCE
  • Firefox is now at its 13th beta release of v64 development series
  • Vulkan got a refresh
  • Systemd got further patches
  • Regular Haskell and Python updates

We hope with all these changes Manjaro to be more efficient for you all.


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


Manjaro v18.0.1 Preview2 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.127 [EOL]
  • linux44 4.4.165
  • linux49 4.9.141
  • linux414 4.14.84
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.5
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Wed Nov 28 18:49:21 CET 2018)

  • testing community x86_64: 395 new and 385 removed package(s)
  • testing core x86_64: 18 new and 17 removed package(s)
  • testing extra x86_64: 137 new and 137 removed package(s)
  • testing multilib x86_64: 10 new and 12 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#3

Yay :smiley:

:: Starting full system upgrade…
there is nothing to do

Aw :cry:


#4

Got only updates on my Unstable VM and some warnings:

(7/8) Aktualisiere samba                                                                                                       [#############################################################################] 100%
Warnung: Verzeichnis-Berechtigungen unterscheiden sich für /var/lib/samba/
Dateisystem: 311  Paket: 755
Warnung: Verzeichnis-Berechtigungen unterscheiden sich für /var/lib/samba/private/
Dateisystem: 311  Paket: 700

#5

no problems in my end on a baytrail-powered acer 2in1 running on gnome, but i’m still trying to find a solution for the missing webcam, fixing the axis on the screen rotation (90º and 270º are swapped) and for a seamless transition between the speakers and headphones


#6

Everything went well, no problems. :grinning:


#7

All ok. Updated via pamac (gui). XFCE.


#8

No error in update with gnome !

But still have little heating problem :confused:


#10

fist attempt to update stalled so i had to cancel the install.
the second attempt as follows.
Transaction Successfully finished apart from pamac gave the following warning/issue:

“Warning: failed retrieving file ‘linux419-headers-4.19.5-2-x86_64.pkg.tar.xz’ from ftp.cc.uoc.gr : The requested URL returned error: 404 Not Found”


#11

for those who got no updates or failed part way through, before starting an update always check on the mirror-check service link to see if the servers are actually synchronised.


#12

My update on 2018-11-27 (pacman -Syyuu) seemed to go well until I rebooted. Cinnamon crashed immediately and I had a degraded desktop without my app menu. However, today I was able to update (pacman -Syu) and reboot from a terminal. After updating some Cinnamon applets, everything is fine again. Great Job, devs! (i7-7500U Dell laptop, not my baytrail x32, which is also fine at the moment)


#13

Don’t use this mirror, use the ones from Germany as they get updated faster. Greek here


#14

Good update. No problems here.

System:    Kernel: 4.19.5-2-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: H170M-PLUS v: Rev X.0x serial: <root required> UEFI: American Megatrends v: 3805 
           date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 18.2.5 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.5-2-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: eth0 state: up speed: 1000 Mbps duplex: full
Drives:    Local Storage: total: 232.89 GiB used: 157.42 GiB (67.6%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 227.94 GiB used: 157.42 GiB (69.1%) fs: ext4 dev: /dev/sda2 
Info:      Uptime: 12m Memory: 7.65 GiB used: 3.49 GiB (45.7%) Shell: bash inxi: 3.0.27

#15

Following this update the sandbox error came back in brave.

sudo sysctl kernel.unprivileged_userns_clone=1’ sorted the problem.

is there a way to fix this permanently from the terminal?


#16

Yes, should be:
sudo echo ‘kernel.unprivileged_userns_clone=1’ > /etc/sysctl.d/00-local-userns.conf


#17

Thanks EDO,
i am sure i tried that previously but got an error. it worked today so maybe i made a syntax error.


#18

updated my vm with yakuake - no problems - manjaro KDE


#19

all good on kde


#20

Ooh, Scheduler has now changed with this kernel bump.

[kdemeoz@Manjaro18KDE_beta_VM ~]$ sudo tlp-stat -d|grep Sch
[sudo] password for kdemeoz: 
  Scheduler = mq-deadline

[kdemeoz@Manjaro18KDE_beta_VM ~]$ uname -a
Linux Manjaro18KDE_beta_VM 4.19.5-2-MANJARO #1 SMP PREEMPT Wed Nov 28 18:19:10 UTC 2018 x86_64 GNU/Linux
[kdemeoz@Manjaro18KDE_beta_VM ~]$

With 4.19.4 & below it was Scheduler = cfq


[Testing Update] 2018-12-09 - Kernels, Nvidia, Matcha, Pamac, Thunderbird, Wine
#21

Hello, block multi-queue (blk-mq) mode is enabled in 4.19.5-2.

cfq is a single queue scheduler so it is not available in this mode.

Testing…

$ cat /sys/block/sd*/queue/scheduler
[mq-deadline] kyber bfq none

To get back cfq

  1. Disable blk-mq mode in grub boot option.
    GRUB_CMDLINE_LINUX_DEFAULT="quiet scsi_mod.use_blk_mq=0"
  2. update-grub
  3. Reboot.

[Stable Update] 2018-12-04 - Systemd