[Testing Update] 2018-11-25 - The "I shoot you outta Orbit" Update

update
testing

#4

all good for me: linux419+nvidia+gnome+zfs


#5

Well, we had an issue with systemd last time. So I was not sure if we would repeat it …


#6

I am not recommending this, but I did not drop to a TTY, but upgraded from the konsole instead, and had no issues.

Thanks for the warning.


#7

Got this during update via Terminal:

** (process:5624): CRITICAL **: 08:12:00.307: Failed to get connection to xfconfd: Error spawning command line ?dbus-launch --autolaunch=ff146721d1d3494c8c5578959eb687e8 --binary-syntax --close-stderr?: Child process exited with code 1


#8

Well… Only 363.8 Mb of update here for 178 updates. Kinda huge, but not that much finally :slight_smile:

Graphical update using pamac 7.3.1

All is ok on my “customized” Manjaro Mate with testing enabled. Yes, I’m stark raving mad :slight_smile:


#9

I had a similar message during building XFCE v18.0-rc1 which is not based on this update. So this message is not as critical as it was marked …


[Testing Update] 2019-01-03 - Pacman, Pamac, Deepin, Haskell, Python
[Stable Update] 2018-12-31 - Kernels, KDE Apps, KDE Frameworks, VirtualBox, LibreOffice, Deepin, ZFS
#10

Nothing seems wrong after reboot, thanks for answering.


#11

Have Brave installed. Message at start:

You are using an unsupported command-line flag: --no-sandbox. This affects stability and safety.


[SOLVED] Brave Browser Sandbox + Standardbrowser
#12

This is normal. You can enable sandboxing via:

sudo echo ‘kernel.unprivileged_userns_clone=1’ > /etc/sysctl.d/00-local-userns.conf
sudo sysctl kernel.unprivileged_userns_clone=1

Second cmd is only used for your current session.


Brave should be in Manjaro repos
[Stable Update] 2018-11-25 - Kernels, Firefox-KDE, Nvidia, Pamac
How to Permanently Enable User Namespaces in Manjaro Linux
How to Permanently Enable User Namespaces in Manjaro Linux
#14

Its not using shortcut. Creates new icon :confused:


#15

Did the update in a terminal. Everything went well! No problems so far…
Thx!


#16

gnome, full encrypted system no problems upgrading from tty


#17

Update without problems. After reboot is all good.:+1:
LXQT with Kernel 4.19.


#18

It is creating a sandbox and starts the application new. This is wanted. You can also use it without, which may be more risky. Your choice.


#19

Nope. Just editted .local/share/applications/brave.desktop
StartupWMClass=brave-browser

everything is normal now :slight_smile:


#20

all ok Xfce with terminal & pacman ( 2258 packages for 2 000mb to update )
ok steam (opengl) & video ( 1080p x60fps )
301 is better than 300 !


#21

It really went wrong on my side: Cinnamon crashed while upgrading packages. It hurts a lot.

I used Pamac GUI. Yeah, it wasn’t recommended.

Now I’m in an adventure of repairing my system. :grin:

EDIT 1: Managed to get a clean and functionning system by reverting entirely to Stable branch (sudo pacman-mirrors -aB stable and sudo pacman -Syyuu in tty).

EDIT 2: Updated with Pamac CLI in a terminal, went fine (no crash during upgrade). Rebooted, seems fine at first glance.


#22

I find this a troubling trend if the recommendation translates over to the stable branch again. Are gui helpers now being discouraged due to increasing risks of corrupting packages? I can’t remember who said this before but, are most people on stable not checking the forum announcement before upgrading?

@Frog: same thing happened to me a couple months ago, it was a good learning experience for me on chrooting into a luks partition and reinstalling a ton of corrupted packages, but I ended up scrapping the entire thing and nuked/paved a new install, became gui-shy, removed pamac, and now using yay solely (due to yaourt being stale.)


#23

Have a look at philm’s comment in post#5. Worse than recommending doing the update in TTY is sending a bunch of users to blackscreen after update… Seems like it might not be necessary here but I for one admire the precaution. :grin:

Did the update from the TTY and update went perfectly. :joy:


#25

Still in geosynchronous orbit here, no problems with my hardware. good work people :smiley: