[Testing Update] 2018-11-25 - The "I shoot you outta Orbit" Update

update
testing

#1

Hi community,

Welcome to another testing update. This is again a huge one and we recommend to do it within a TTY via pamac upgrade or sudo pacman -Syyu.
So what do we have with this one?

  • We updated Systemd to it’s latest stable-snapshot. Tell us, if your X-Session get crashed due this.
  • We added the latest Cinnamon and Gnome packages
  • The Brave browser is now officially part of Manjaro Linux
  • Firefox is now on it’s twelved beta release of v64 development series
  • The linux-firmware got updated to 20181026.1cb4e51-1
  • Nvidia driver got updated again to 415.18
  • Lots of python updates
  • Most packages are rebuilds due to the BUILDINFO rebuild

We hope with all these changes Manjaro to be more efficient for you all.


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


Manjaro v18.0.1 Preview2 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.126 [EOL]
  • linux44 4.4.164
  • linux49 4.9.140
  • linux414 4.14.83
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.4
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Sun Nov 25 12:19:28 CET 2018)

  • testing community x86_64: 1366 new and 1327 removed package(s)
  • testing core x86_64: 29 new and 30 removed package(s)
  • testing extra x86_64: 542 new and 694 removed package(s)
  • testing multilib x86_64: 82 new and 82 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Request for update branch between pacman & pamac
[Stable Update] 2018-12-02 - Kernels, Plasma, Mesa, Cinnamon, Gnome, Deepin, XFCE, Vulkan
[Stable Update] 2018-12-02 - Kernels, Plasma, Mesa, Cinnamon, Gnome, Deepin, XFCE, Vulkan
Brave should be in Manjaro repos
Request for update branch between pacman & pamac
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#3

Tried to bork my btrfs mate vm by updating through pamac, everything was cool :smile:


#4

all good for me: linux419+nvidia+gnome+zfs


#5

Well, we had an issue with systemd last time. So I was not sure if we would repeat it …


#6

I am not recommending this, but I did not drop to a TTY, but upgraded from the konsole instead, and had no issues.

Thanks for the warning.


#7

Got this during update via Terminal:

** (process:5624): CRITICAL **: 08:12:00.307: Failed to get connection to xfconfd: Error spawning command line ?dbus-launch --autolaunch=ff146721d1d3494c8c5578959eb687e8 --binary-syntax --close-stderr?: Child process exited with code 1


#8

Well… Only 363.8 Mb of update here for 178 updates. Kinda huge, but not that much finally :slight_smile:

Graphical update using pamac 7.3.1

All is ok on my “customized” Manjaro Mate with testing enabled. Yes, I’m stark raving mad :slight_smile:


#9

I had a similar message during building XFCE v18.0-rc1 which is not based on this update. So this message is not as critical as it was marked …


#10

Nothing seems wrong after reboot, thanks for answering.


#11

Have Brave installed. Message at start:

You are using an unsupported command-line flag: --no-sandbox. This affects stability and safety.


[SOLVED] Brave Browser Sandbox + Standardbrowser
#12

This is normal. You can enable sandboxing via:

sudo echo ‘kernel.unprivileged_userns_clone=1’ > /etc/sysctl.d/00-local-userns.conf
sudo sysctl kernel.unprivileged_userns_clone=1

Second cmd is only used for your current session.


Brave should be in Manjaro repos
[Stable Update] 2018-11-25 - Kernels, Firefox-KDE, Nvidia, Pamac
#14

Its not using shortcut. Creates new icon :confused:


#15

Did the update in a terminal. Everything went well! No problems so far…
Thx!


#16

gnome, full encrypted system no problems upgrading from tty


#17

Update without problems. After reboot is all good.:+1:
LXQT with Kernel 4.19.


#18

It is creating a sandbox and starts the application new. This is wanted. You can also use it without, which may be more risky. Your choice.


#19

Nope. Just editted .local/share/applications/brave.desktop
StartupWMClass=brave-browser

everything is normal now :slight_smile:


#20

all ok Xfce with terminal & pacman ( 2258 packages for 2 000mb to update )
ok steam (opengl) & video ( 1080p x60fps )
301 is better than 300 !


#21

It really went wrong on my side: Cinnamon crashed while upgrading packages. It hurts a lot.

I used Pamac GUI. Yeah, it wasn’t recommended.

Now I’m in an adventure of repairing my system. :grin:

EDIT 1: Managed to get a clean and functionning system by reverting entirely to Stable branch (sudo pacman-mirrors -aB stable and sudo pacman -Syyuu in tty).

EDIT 2: Updated with Pamac CLI in a terminal, went fine (no crash during upgrade). Rebooted, seems fine at first glance.