[Testing Update] 2018-11-09 - Systemd, KDE Apps, Deepin, Haskell



Hi community,

Welcome to another testing update. So what do we have with this one?

  • We downgraded Systemd, since a bug report and an additional reddit discussion came up.
  • KDE Apps is now at 18.08.3
  • Some more Deepin updates
  • The usual upstream haskell, and python rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

Manjaro v18.0 released!

If you are curious about the latest Manjaro-Illyria 18.0 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.124 [EOL]
  • linux44 4.4.162
  • linux49 4.9.135
  • linux414 4.14.79
  • linux417 4.17.19 [EOL]
  • linux418 4.18.17
  • linux419 4.19.1
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Package Updates (Thu Nov 8 19:11:48 CET 2018)

  • unstable core x86_64: 34 new and 34 removed package(s)
  • unstable extra x86_64: 227 new and 227 removed package(s)
  • unstable community x86_64: 746 new and 745 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.

AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


No problems, everything runs after a reboot. Ignoring these warnings when updating:

Warnung: freetype2: Lokale Version (2.9.1-1.1) ist neuer als extra (2.9.1-1)
Warnung: lib32-systemd: Lokale Version (239.300-1) ist neuer als multilib (239.6-1)
Warnung: libsystemd: Lokale Version (239.300-1) ist neuer als core (239.6-1)
Warnung: systemd: Lokale Version (239.300-1) ist neuer als core (239.6-1)
Warnung: systemd-sysvcompat: Lokale Version (239.300-1) ist neuer als core (239.6-1)


systemd is not in the list of changes… :eyes:


KDE. Updated via tty2 and get the same set of warnings. Rebooted, returned to gui, all is working OK.


After downgrade Systemd to 239.6-1, hibernation show on power option.


So this is due to the systemd downgrade?

Warnung: freetype2: Lokale Version (2.9.1-1.1) ist neuer als extra (2.9.1-1)
Warnung: lib32-freetype2: Lokale Version (2.9.1-1.1) ist neuer als multilib (2.9.1-1)
Warnung: lib32-systemd: Lokale Version (239.300-1) ist neuer als multilib (239.6-1)
Warnung: libsystemd: Lokale Version (239.300-1) ist neuer als core (239.6-1)
Warnung: systemd: Lokale Version (239.300-1) ist neuer als core (239.6-1)
Warnung: systemd-sysvcompat: Lokale Version (239.300-1) ist neuer als core (239.6-1)


I did not downgrade,

warning: freetype2: local (2.9.1-1.1) is newer than extra (2.9.1-1)
warning: lib32-systemd: local (239.300-1) is newer than multilib (239.6-1)
warning: libsystemd: local (239.300-1) is newer than core (239.6-1)
warning: systemd: local (239.300-1) is newer than core (239.6-1)
warning: systemd-sysvcompat: local (239.300-1) is newer than core (239.6-1)

but everything seems fine after the upgrade.


Did the update + downgrade with pacman -Syyuu and all is good. :grin:


I know that, why should I do that? Everything works.


Of course the world revolves around you. :smiling_imp:


Oh no, I’m just relatively relaxed and I’m waiting for updates and information.


Seems to me you are quite paranoid when you think my general feedback is addressed to you. :face_with_raised_eyebrow:


Then maybe I did not understand that from English. English is not necessarily my second language. Okay, let’s go back to the topic. Thank you for pointing down.

Confident, downgrade executed. :wink:


I was looking for this arguments for pacman to downgrade systemd! Thanks a lot


freetype2 message is unrelated to systemd “sparta edition.” There is info in past testing threads about it.


for the issues listed above with systemd you need to run sudo pacman -Syyuu

this will bring all the packages warned about back in line with those in the testing repository that are not bugged like the builds you have installed now


In the meantime, I have cleaned up. :wink:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.