[Testing Update] 2018-10-16 - Linux419, Plasma, KDE Apps, Deepin, Mkinitcpio, VB, Xorg

update
testing

#7

I hesitated to update after reading this, but took the plunge and am finding that all 10 of my kernal 4.19 DE’s are booting and running fine after the update. I didn’t notice any error messages while booting.


#8

Thank you very much Phil – today’s Testing update has solved the previous [relatively longterm] problem] – my Shared Folders are now good again. :joy: :+1: :clap:

[kdemeoz@Manjaro_KDE_VM ~]$ uname -a
Linux Manjaro_KDE_VM 4.19.0-1-MANJARO #1 SMP PREEMPT Tue Oct 16 18:21:31 UTC 2018 x86_64 GNU/Linux
[kdemeoz@Manjaro_KDE_VM ~]$

Per my post though for my previous Testing Update [Testing Update] 2018-10-11 - Kernels, Gnome, KDE, PHP, Python, Haskell, the new PulseAudio EQ remains broken… certainly that should be fixed before pushing to Stable.


#9

as per Arch wiki says:

**Warning:** The equalizer module is considered unstable and might be removed from PulseAudio. For more, see the [mailing list](https://lists.freedesktop.org/archives/pulseaudio-discuss/2014-March/020174.html).

pulseeffects is the suggested module.

if really want to use pulseaudio-equalizer, this should fix this no-effect issue (at least on my end)

**Note:** If qpaeq has no effect, install [pavucontrol](https://www.archlinux.org/packages/?name=pavucontrol) and change "ALSA Playback on" to "FFT based equalizer on ..." while the media player is running.

https://wiki.archlinux.org/index.php/PulseAudio


#10

Thanks for your info. Atm i don’t really understand what i need to do to fix it, so i shall study those links carefully tomorrow. Hopefully i’ll get on top of it.

This might be an unnecessary remark, but btw: The EQ did not just “break” for no reason with that recent Manjaro update; it specifically included a new version, per @philm’s initial post back in that thread:
pulseaudio-equalizer-ladspa 2.7.1-1
I’ve not tried it yet, but i presume that if i were to Downgrade to its previous version, it would work fine once again [given in my Stable Manjaro i use it all day every day & it works fine].

EDIT-1: Oh dear - i was wrong; the Stable version [good] is also 2.7.1-1, so my previous claim was rubbish. Groan.

EDIT-2: With respect, are you certain that you & i are talking about the same thing? Maybe i’m misunderstanding you, but aren’t you talking about pulseaudio-equalizer, whereas i am talking about pulseaudio-equalizer-ladspa, re which i quote this from the Arch PA wiki https://wiki.archlinux.org/index.php/PulseAudio:

Alternative equalizers
pulseaudio-equalizer-ladspa (based on swh-plugins) can be used as an alternative to pulseaudio-equalizer.

pulseeffects applies peak limiting, compression, reverberation, auto volume and 15 bands equalization to Pulseaudio applications output.

To my reading of the wiki, the Warning you quoted specifically applies to pulseaudio-equalizer, which is the PulseAudio has an integrated 10-band equalizer system. That’s not what i’m using, & which recently broke in Testing. “My” one instead is the Description: A 15-band equalizer for PulseAudio https://www.archlinux.org/packages/community/any/pulseaudio-equalizer-ladspa/ [which weirdly is at version 3.0.0-1, so now this is even more confusing]


#11

57 updates all good.
Thanks!

Host: xxx-pc Kernel: 4.19.0-1-MANJARO x86_64 bits: 64
Desktop: LXQt 0.13.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASRock model: FM2A88M-HD+ R3.0
serial: UEFI [Legacy]: American Megatrends v: P1.50
date: 01/11/2016
CPU:
Topology: Quad Core
model: AMD A8-7670K Radeon R7 10 Compute Cores 4C+6G bits: 64
type: MCP L2 cache: 2048 KiB
Speed: 1892 MHz min/max: 1900/3600 MHz Core speeds (MHz):
1: 1890 2: 1895 3: 2392 4: 2395
Graphics:
Device-1: AMD Kaveri [Radeon R7 Graphics] driver: radeon
v: kernel
Display: x11 server: X.org 1.20.2 driver: modesetting


#12

With 4.19rc8.1016.gb955a91-1 I’ve added a patch to fix following issue. Did the last rc7 work for you? I’ve to test it also on the #bladebook to see if I’d added a regression.


#13

sorry for the confusing. i normally do no install pulseaudio if i can avoid so assumed pulseaudio-equalizer to be similar to pulseaudio-equalizer-ladspa.

anyways, i did try ladspa and it work on this testing branch using the 4.19 kernel. you should probably check(install pavucontrol) and see if your streams and being sent through lasdpa


(look example at lower-left pic of screenshot)


#14

4.19 looking good on this update. Thanks.


#15

Yes, did not have any problem with the touchpad. This is the output from dmesg:

dmesg | grep input
[    0.842538] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[    0.842589] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
[    0.842638] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input2
[    0.842679] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    1.356998] input: HID 04d9:1135 as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:04D9:1135.0001/input/input4
[    1.357065] hid-generic 0003:04D9:1135.0001: input,hidraw0: USB HID v1.10 Mouse [HID 04d9:1135] on usb-0000:00:14.0-2/input0
[    1.712667] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[    8.957242] input: SYN1B7C:01 06CB:2970 Mouse as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input6
[    8.957275] input: SYN1B7C:01 06CB:2970 Touchpad as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input7
[    8.957333] hid-generic 0018:06CB:2970.0002: input,hidraw1: I2C HID v1.00 Mouse [SYN1B7C:01 06CB:2970] on i2c-SYN1B7C:01
[    9.487697] input: PC Speaker as /devices/platform/pcspkr/input/input9
[   10.741862] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   10.809187] input: HD WebCam: HD WebCam as /devices/pci0000:00/0000:00:14.0/usb2/2-7/2-7:1.0/input/input10
[   10.976971] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input11
[   11.494140] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input12
[   11.505477] input: Acer WMI hotkeys as /devices/virtual/input/input13
[   11.576701] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input14
[   11.576789] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input15
[   11.576870] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input16
[   11.576959] input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card0/input17
[   11.577043] input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card0/input18
[   12.074300] input: SYN1B7C:01 06CB:2970 Touchpad as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input20
[   12.074485] hid-multitouch 0018:06CB:2970.0002: input,hidraw1: I2C HID v1.00 Mouse [SYN1B7C:01 06CB:2970] on i2c-SYN1B7C:01
[  313.067405] input: HID 04d9:1135 as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:04D9:1135.0003/input/input22
[  313.067645] hid-generic 0003:04D9:1135.0003: input,hidraw0: USB HID v1.10 Mouse [HID 04d9:1135] on usb-0000:00:14.0-2/input0

#16

Tried re-installing the 4.19RC8. No strange output when installing, but the same issue when booting up. And now my touchpad is not working anymore: (EDIT: Also SUSPEND not working anymore (probably because of touchpad-issue?))

dmesg | grep SYN
[    9.509046] i2c_hid i2c-SYN1B7C:01: i2c-SYN1B7C:01 supply vdd not found, using dummy regulator
[    9.509072] i2c_hid i2c-SYN1B7C:01: Linked as a consumer to regulator.0
[    9.509075] i2c_hid i2c-SYN1B7C:01: i2c-SYN1B7C:01 supply vddl not found, using dummy regulator

#17

I really do appreciate your help, but unfortunately we are still talking about different things. My original post specified the symptom… it is NOT that sound is not coming through the updated EQ, because the sound is fine through the EQ. The specific issue is

In other words, if i change the EQ profile from “Flat” to “Full Bass & Treble” to “Techno” to “Pop”, etc, the sliders do not move at all. Until that recent Testing update, they worked correctly. Yes i can manually drag each slider up & down, & the sound output changes accordingly, but that is not the point… i wish to continue being able to use the various sound profiles.


#18

im using the pulseaudio-equalizer-ladspa fron AUR which doesnt have this issue. install the one from aur if you want this behaviour. if you want to stay with the community version,
copy contents from /usr/share/pulseaudio-equalizer-ladspa/presets/* to $HOME/.config/pulse/presets/


#19

Using for daily! Every update is better than previous :heart_eyes:

And grub-quiet working awesome :sunglasses:


#20

All good here with kernel419 and those sweet sweet KDE updates.

System:    Host: zoki-pc Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.1 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: H170M-PLUS v: Rev X.0x serial: <root required> 
           UEFI: American Megatrends v: 3805 date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.2 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 18.2.2 
Audio:     Device-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 
Drives:    Local Storage: total: 232.89 GiB used: 152.16 GiB (65.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 227.94 GiB used: 152.16 GiB (66.8%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 27.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0

#21

Had an issue with my trackpad on 4.19 on a dell xps 9575. Moving back to 4.18 seemed to resolve it.


#22

My trackpoint was erratic - like if it was on speed and had a stroke - for about 5 minutes - with any aparrent change it fixed itself though - and with (17-10-2018) version of 4.19 it did NOT occur again - give the todays version a try.


#23

My trackpad would not work at all. xinput --list did not include it as an available device, but 4.18 does.


#24

This worked… for ~10 - 30", after which suddenly all the presets duplicated themselves in the EQ Presets dropdown list, with my “copied” ones continuing to work, but the “suddenly duplicated” ones once more not moving the sliders. I deleted then repeated this procedure, & the misbehaviour happened again. Weird.

Given the above, i next tried this. Initially the installation failed repeatedly, until i first uninstalled the Community version [despite https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=pulseaudio-equalizer-ladspa-git not mentioning that the git version was incompatible with the Community version; in hindsight i should have realised they’d fight with each other]. Now, exactly as you advised, this new version of the PA EQ is fully-functional again. Thank you! :hugs:

If the Community version remains broken when the next Stable Update occurs, i’ll replicate this workaround again then in my Stable KDE.


#25

FYI: given that the quoted mailing list link points to an email from March of 2014, I’d question the current accuracy of that warning, especially since pulseaudio-equalizer seems to be installed by default (and seems to work fine…). It could very well still be relevant, but the warning that it “might be removed” was over 4 years ago…


closed #26

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.