[Testing Update] 2018-09-06 - KDE Apps, Deepin, XFCE4-GTK3, Manjaro-Tools, Firefox-Dev

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • KDE Apps got updated to 18.08.1
  • updated our deepin and xfce4-gtk3 packages
  • manjaro-tools v0.15.9 released
  • latest firefox-dev
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.121 [EOL]
  • linux44 4.4.154
  • linux49 4.9.125
  • linux414 4.14.68
  • linux417 4.17.19 [EOL]
  • linux418 4.18.6
  • linux419 4.19-rc2
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Thu Sep 6 18:39:03 CEST 2018)

  • testing community x86_64: 189 new and 178 removed package(s)
  • testing core x86_64: 3 new and 1 removed package(s)
  • testing extra x86_64: 235 new and 236 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                       bspwm-manjaro              0.9.5-6              0.9.5-7
                   deepin-session-ui          4.5.1.2-1.1          4.5.1.3-1.1
              manjaro-bspwm-settings           20180905-3           20180906-1
                           sterminal                0.9-1               0.10-1
        manjaro-openbox-basic-config                    -            1.18.12-2
          manjaro-openbox-grub-theme                    -                1.3-1
     manjaro-openbox-grub-theme-18.0                    -                1.0-6
     manjaro-openbox-grub-theme-blue                    -                1.0-1
manjaro-openbox-grub-theme-glassfield                   -                1.0-2
      manjaro-openbox-minimal-config                    -            1.18.12-2
      manjaro-openbox-regular-config                    -            1.18.12-2
            manjaro-openbox-settings                    -           20180530-2


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                                4ti2              1.6.7-1              1.6.9-1
                               audit              2.8.3-2                    -
                                c2hs            0.28.5-17            0.28.5-18
                             certbot             0.26.1-1             0.27.0-1
                      certbot-apache             0.26.1-1             0.27.0-1
              certbot-dns-cloudflare             0.26.1-1             0.27.0-1
                certbot-dns-cloudxns             0.26.1-1             0.27.0-1
            certbot-dns-digitalocean             0.26.1-1             0.27.0-1
                certbot-dns-dnsimple             0.26.1-1             0.27.0-1
             certbot-dns-dnsmadeeasy             0.26.1-1             0.27.0-1
                  certbot-dns-google             0.26.1-1             0.27.0-1
                  certbot-dns-luadns             0.26.1-1             0.27.0-1
                   certbot-dns-nsone             0.26.1-1             0.27.0-1
                 certbot-dns-rfc2136             0.26.1-1             0.27.0-1
                 certbot-dns-route53             0.26.1-1             0.27.0-1
                       certbot-nginx             0.26.1-1             0.27.0-1
                               darcs            2.14.1-46            2.14.1-47
                 deepin-file-manager            1:4.6.8-1          1:4.6.8.3-1
                     deepin-metacity            3.22.20-1            3.22.21-1
                   deepin-session-ui            4.5.1.2-1            4.5.1.3-1
                              drupal              8.5.6-1              8.6.0-1
                             dtkcore            1:2.0.9-1          1:2.0.9.4-1
                           dtkwidget            2.0.9.3-1            2.0.9.4-1
           firefox-developer-edition             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-ach             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-af             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-an             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ar             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-as             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-ast             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-az             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-be             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-bg             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-bn-bd             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-bn-in             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-br             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-bs             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ca             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-cak             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-cs             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-cy             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-da             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-de             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-dsb             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-el             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-en-gb             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-en-us             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-en-za             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-eo             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-es-ar             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-es-cl             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-es-es             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-es-mx             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-et             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-eu             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-fa             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ff             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-fi             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-fr             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-fy-nl             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-ga-ie             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-gd             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-gl             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-gn             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-gu-in             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-he             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-hi-in             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-hr             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-hsb             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-hu             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-hy-am             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ia             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-id             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-is             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-it             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ja             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ka             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-kab             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-kk             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-km             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-kn             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ko             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-lij             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-lt             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-lv             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-mai             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-mk             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ml             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-mr             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ms             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-my             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-nb-no             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-ne-np             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-nl             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-nn-no             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-or             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-pa-in             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-pl             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-pt-br             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-pt-pt             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-rm             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ro             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ru             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-si             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-sk             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-sl             63.0b2-1             63.0b3-1
  firefox-developer-edition-i18n-son             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-sq             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-sr             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-sv-se             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ta             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-te             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-th             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-tr             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-uk             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-ur             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-uz             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-vi             63.0b2-1             63.0b3-1
   firefox-developer-edition-i18n-xh             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-zh-cn             63.0b2-1             63.0b3-1
firefox-developer-edition-i18n-zh-tw             63.0b2-1             63.0b3-1
              gnome-activity-journal             0.8.0-10             0.8.0-11
               haskell-data-accessor            0.2.2.7-8            0.2.2.8-1
      haskell-data-accessor-template           0.2.1.16-1           0.2.1.16-2
  haskell-data-accessor-transformers            0.2.1.7-8            0.2.1.7-9
                    haskell-fsnotify            0.3.0.1-8            0.3.0.1-9
                      haskell-gnuidn             0.2.2-61             0.2.2-62
                      haskell-hakyll         4.12.3.0-110         4.12.3.0-111
                haskell-http-streams           0.8.6.1-49           0.8.6.1-50
                    haskell-mustache             2.3.0-79             2.3.0-80
       haskell-network-protocol-xmpp             0.4.8-72             0.4.8-73
                      haskell-shelly             1.8.1-19             1.8.1-20
                 haskell-snap-server           1.1.0.0-42           1.1.0.0-43
               haskell-system-fileio          0.3.16.3-13           0.3.16.4-1
                      haskell-turtle            1.5.10-21            1.5.10-22
                        haskell-wreq           0.5.2.1-52           0.5.2.1-53
                          hledger-ui              1.10-28              1.10-29
                               idris             1.3.0-51             1.3.0-52
                              kresus             0.13.2-1             0.13.3-1
                                 ldc           1:1.11.0-1           2:1.11.0-1
                          liblphobos           1:1.11.0-1           2:1.11.0-1
                             liteide                 34-1               34.1-1
                           nextcloud             13.0.6-1             14.0.0-1
                 nextcloud-app-tasks              0.9.6-2              0.9.7-1
                     pandoc-crossref           0.3.2.1-76           0.3.2.1-77
                              picard              2.0.3-1              2.0.4-1
                         python-acme             0.26.1-1             0.27.0-1
                      python-aiohttp              3.4.2-1              3.4.4-1
              python-cached-property              1.4.3-2              1.5.1-1
                   python-hypothesis             3.70.2-1             3.70.3-1
              python-openstackclient             3.16.0-1             3.16.1-1
                   python-oslo-utils             3.36.4-1             3.37.0-1
                      python-path.py             11.0.1-2             11.1.0-1
                       python-pytest              3.7.4-1              3.8.0-1
                   python-pytest-cov              2.5.1-2              2.6.0-1
                    python-structlog             18.1.0-2             18.2.0-1
                        python2-acme             0.26.1-1             0.27.0-1
             python2-cached-property              1.4.3-2              1.5.1-1
                  python2-hypothesis             3.70.2-1             3.70.3-1
             python2-openstackclient             3.16.0-1             3.16.1-1
                  python2-oslo-utils             3.36.4-1             3.37.0-1
                     python2-path.py             11.0.1-2             11.1.0-1
                      python2-pytest              3.7.4-1              3.8.0-1
                  python2-pytest-cov              2.5.1-2              2.6.0-1
                   python2-structlog             18.1.0-2             18.2.0-1
                                qcad           3.21.2.6-1           3.21.2.6-2
                             radare2              2.8.0-2              2.9.0-1
                      radare2-cutter                1.7-1              1.7.1-1
                        riot-desktop             0.16.1-1             0.16.3-1
                            riot-web             0.16.1-1             0.16.3-1
                              sqlmap              1.2.8-1              1.2.9-1
                               stack            1.7.1-121            1.7.1-122
                            startdde           3.1.35.1-1           3.1.35.2-1
                                 urh              2.2.4-2              2.2.4-3
                  certbot-dns-gehirn                    -             0.27.0-1
                  certbot-dns-linode                    -             0.27.0-1
                     certbot-dns-ovh                    -             0.27.0-1
             certbot-dns-sakuracloud                    -             0.27.0-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                    manjaro-hotfixes            2018.08-5            2018.08-6


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                               audit                    -              2.8.3-2
                           libcap-ng                    -              0.7.9-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                            chromium       69.0.3497.81-0                    -
                  manjaro-tools-base             0.15.8-3             0.15.9-1
                   manjaro-tools-iso             0.15.8-4             0.15.9-1
                   manjaro-tools-pkg             0.15.8-1             0.15.9-1
                  manjaro-tools-yaml             0.15.8-1             0.15.9-1
                         thunar-gtk3             1.8.1-13             1.8.1-14
                  xfce4-session-gtk3             4.13.1-2             4.13.1-3
                 xfce4-settings-gtk3             4.13.4-3             4.13.4-4
                      xfdesktop-gtk3             4.13.2-2             4.13.2-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                           aisleriot             3.22.5-1             3.22.6-1
                             akonadi            18.08.0-1            18.08.1-1
                    akonadi-calendar            18.08.0-1            18.08.1-1
              akonadi-calendar-tools            18.08.0-1            18.08.1-1
                    akonadi-contacts            18.08.0-1            18.08.1-1
               akonadi-import-wizard            18.08.0-1            18.08.1-1
                        akonadi-mime            18.08.0-1            18.08.1-1
                       akonadi-notes            18.08.0-1            18.08.1-1
                      akonadi-search            18.08.0-1            18.08.1-1
                      akonadiconsole            18.08.0-1            18.08.1-1
                           akregator            18.08.0-1            18.08.1-1
                            analitza            18.08.0-1            18.08.1-1
                                 ark            18.08.0-1            18.08.1-1
                          artikulate            18.08.0-1            18.08.1-1
                         audiocd-kio            18.08.0-1            18.08.1-1
                       baloo-widgets            18.08.0-1            18.08.1-1
                             blinken            18.08.0-1            18.08.1-1
                              bomber            18.08.0-1            18.08.1-1
                                bovo            18.08.0-1            18.08.1-1
                     calendarsupport            18.08.0-1            18.08.1-1
                              cantor            18.08.0-5            18.08.1-1
                            cervisia            18.08.0-1            18.08.1-1
                             dolphin            18.08.0-1            18.08.1-1
                     dolphin-plugins            18.08.0-1            18.08.1-1
                              dragon            18.08.0-1            18.08.1-1
                          eventviews            18.08.0-1            18.08.1-1
                        ffmpegthumbs            18.08.0-1            18.08.1-1
                           filelight            18.08.0-1            18.08.1-1
                           granatier            18.08.0-1            18.08.1-1
                     grantlee-editor            18.08.0-1            18.08.1-1
                       grantleetheme            18.08.0-1            18.08.1-1
                            gwenview            18.08.0-1            18.08.1-1
                     incidenceeditor            18.08.0-1            18.08.1-1
                                 juk            18.08.0-1            18.08.1-1
                                 k3b          1:18.08.0-1          1:18.08.1-1
               kaccounts-integration            18.08.0-1            18.08.1-1
                 kaccounts-providers            18.08.0-1            18.08.1-1
                        kaddressbook            18.08.0-1            18.08.1-1
                             kajongg            18.08.0-1            18.08.1-1
                              kalarm            18.08.0-1            18.08.1-1
                           kalarmcal            18.08.0-1            18.08.1-1
                            kalgebra            18.08.0-1            18.08.1-1
                             kalzium            18.08.0-2            18.08.1-1
                              kamera            18.08.0-1            18.08.1-1
                              kamoso            18.08.0-1            18.08.1-1
                            kanagram            18.08.0-1            18.08.1-1
                              kapman            18.08.0-1            18.08.1-1
                        kapptemplate            18.08.0-1            18.08.1-1
                                kate            18.08.0-1            18.08.1-1
                             katomic            18.08.0-1            18.08.1-1
                             kbackup            18.08.0-1            18.08.1-1
                           kblackbox            18.08.0-1            18.08.1-1
                             kblocks            18.08.0-1            18.08.1-1
                               kblog            18.08.0-1            18.08.1-1
                             kbounce            18.08.0-1            18.08.1-1
                           kbreakout            18.08.0-1            18.08.1-1
                              kbruch            18.08.0-1            18.08.1-1
                         kcachegrind            18.08.0-1            18.08.1-1
                  kcachegrind-common            18.08.0-1            18.08.1-1
                               kcalc            18.08.0-1            18.08.1-1
                            kcalcore            18.08.0-1            18.08.1-1
                           kcalutils            18.08.0-1            18.08.1-1
                         kcharselect            18.08.0-1            18.08.1-1
                       kcolorchooser            18.08.0-1            18.08.1-1
                           kcontacts            18.08.0-1            18.08.1-1
                               kcron            18.08.0-1            18.08.1-1
                                kdav            18.08.0-1            18.08.1-1
                     kde-dev-scripts            18.08.0-1            18.08.1-1
                       kde-dev-utils            18.08.0-1            18.08.1-1
                     kde-syndication            18.08.0-1            18.08.1-1
                      kdebugsettings            18.08.0-1            18.08.1-1
                         kdeedu-data            18.08.0-1            18.08.1-1
              kdegraphics-mobipocket            18.08.0-1            18.08.1-1
            kdegraphics-thumbnailers            18.08.0-1            18.08.1-1
              kdenetwork-filesharing            18.08.0-1            18.08.1-1
                            kdenlive            18.08.0-1            18.08.1-1
                       kdepim-addons            18.08.0-1            18.08.1-1
                    kdepim-apps-libs            18.08.0-1            18.08.1-1
                      kdepim-runtime            18.08.0-2            18.08.1-1
                    kdesdk-kioslaves            18.08.0-1            18.08.1-1
                 kdesdk-thumbnailers            18.08.0-1            18.08.1-1
                                 kdf            18.08.0-1            18.08.1-1
                             kdialog            18.08.0-1            18.08.1-1
                            kdiamond            18.08.0-1            18.08.1-1
                      keditbookmarks            18.08.0-1            18.08.1-1
                               kfind            18.08.0-1            18.08.1-1
                             kfloppy            18.08.0-1            18.08.1-1
                         kfourinline            18.08.0-1            18.08.1-1
                          kgeography            18.08.0-1            18.08.1-1
                                kget            18.08.0-1            18.08.1-1
                         kgoldrunner            18.08.0-1            18.08.1-1
                                kgpg            18.08.0-1            18.08.1-1
                            khangman            18.08.0-1            18.08.1-1
                         khelpcenter            18.08.0-1            18.08.1-1
                 kidentitymanagement            18.08.0-1            18.08.1-1
                                 kig            18.08.0-1            18.08.1-1
                                kigo            18.08.0-1            18.08.1-1
                            killbots            18.08.0-1            18.08.1-1
                     kimagemapeditor            18.08.0-1            18.08.1-1
                               kimap            18.08.0-1            18.08.1-1
                          kio-extras            18.08.0-2            18.08.1-1
                              kiriki            18.08.0-1            18.08.1-1
                               kiten            18.08.0-1            18.08.1-1
                          kitinerary            18.08.0-1            18.08.1-1
                        kjumpingcube            18.08.0-1            18.08.1-1
                               kldap            18.08.0-1            18.08.1-1
                           kleopatra            18.08.0-1            18.08.1-1
                            klettres            18.08.0-1            18.08.1-1
                            klickety            18.08.0-1            18.08.1-1
                              klines            18.08.0-1            18.08.1-1
                                kmag            18.08.0-1            18.08.1-1
                           kmahjongg            18.08.0-1            18.08.1-1
                               kmail            18.08.0-1            18.08.1-1
                kmail-account-wizard            18.08.0-1            18.08.1-1
                      kmailtransport            18.08.0-1            18.08.1-1
                               kmbox            18.08.0-1            18.08.1-1
                               kmime            18.08.0-1            18.08.1-1
                              kmines            18.08.0-1            18.08.1-1
                                kmix            18.08.0-1            18.08.1-1
                          kmousetool            18.08.0-1            18.08.1-1
                              kmouth            18.08.0-1            18.08.1-1
                              kmplot            18.08.0-1            18.08.1-1
                        knavalbattle            18.08.0-1            18.08.1-1
                            knetwalk            18.08.0-1            18.08.1-1
                              knotes            18.08.0-1            18.08.1-1
                                kolf            18.08.0-1            18.08.1-1
                           kollision            18.08.0-1            18.08.1-1
                         kolourpaint            18.08.0-1            18.08.1-1
                             kompare            18.08.0-1            18.08.1-1
                           konqueror            18.08.0-1            18.08.1-1
                            konquest            18.08.0-1            18.08.1-1
                             konsole            18.08.0-1            18.08.1-1
                             kontact            18.08.0-1            18.08.1-1
                    kontactinterface            18.08.0-1            18.08.1-1
                              kopete            18.08.0-1            18.08.1-1
                          korganizer            18.08.0-1            18.08.1-1
                           kpatience            18.08.0-2            18.08.1-1
                        kpimtextedit            18.08.0-1            18.08.1-1
                             kpkpass            18.08.0-1            18.08.1-1
                      kqtquickcharts            18.08.0-1            18.08.1-1
                                krdc            18.08.0-1            18.08.1-1
                            kreversi            18.08.0-1            18.08.1-1
                                krfb            18.08.0-1            18.08.1-1
                  kross-interpreters            18.08.0-1            18.08.1-1
                              kruler            18.08.0-1            18.08.1-1
                             kshisen            18.08.0-1            18.08.1-1
                               ksirk            18.08.0-1            18.08.1-1
                               ksmtp            18.08.0-1            18.08.1-1
                          ksnakeduel            18.08.0-1            18.08.1-1
                          kspaceduel            18.08.0-1            18.08.1-1
                            ksquares            18.08.0-1            18.08.1-1
                             ksudoku            18.08.0-1            18.08.1-1
                          ksystemlog            18.08.0-1            18.08.1-1
                            kteatime            18.08.0-1            18.08.1-1
                              ktimer            18.08.0-1            18.08.1-1
                               ktnef            18.08.0-1            18.08.1-1
                              ktouch            18.08.0-1            18.08.1-1
                          ktuberling            18.08.0-1            18.08.1-1
                             kturtle            18.08.0-1            18.08.1-1
                             kubrick            18.08.0-1            18.08.1-1
                      kwalletmanager            18.08.0-1            18.08.1-1
                               kwave            18.08.0-1            18.08.1-1
                           kwordquiz            18.08.0-1            18.08.1-1
                              kwrite            18.08.0-1            18.08.1-1
                                 ldb            1:1.3.5-1            1:1.3.6-1
                           libcap-ng              0.7.9-1                    -
                         libgravatar            18.08.0-1            18.08.1-1
                            libkcddb            18.08.0-1            18.08.1-1
                     libkcompactdisc            18.08.0-1            18.08.1-1
                           libkdcraw            18.08.0-2            18.08.1-1
                         libkdegames            18.08.0-1            18.08.1-1
                           libkdepim            18.08.0-1            18.08.1-1
                  libkeduvocdocument            18.08.0-1            18.08.1-1
                           libkexiv2            18.08.0-1            18.08.1-1
                            libkgapi            18.08.0-1            18.08.1-1
                          libkgeomap            18.08.0-1            18.08.1-1
                             libkipi            18.08.0-1            18.08.1-1
                             libkleo            18.08.0-1            18.08.1-1
                        libkmahjongg            18.08.0-1            18.08.1-1
                     libkomparediff2            18.08.0-1            18.08.1-1
                            libksane            18.08.0-1            18.08.1-1
                           libksieve            18.08.0-1            18.08.1-1
                         libwbclient              4.8.4-1              4.8.5-1
                            lokalize            18.08.0-1            18.08.1-1
                               lskat            18.08.0-1            18.08.1-1
                          mailcommon            18.08.0-1            18.08.1-1
                        mailimporter            18.08.0-1            18.08.1-1
                              marble            18.08.0-1            18.08.1-1
                       marble-common            18.08.0-1            18.08.1-1
                           marble-qt            18.08.0-1            18.08.1-1
                       mbox-importer            18.08.0-1            18.08.1-1
                          messagelib            18.08.0-1            18.08.1-1
                              minuet            18.08.0-1            18.08.1-1
                              okular            18.08.0-1            18.08.1-1
                            palapeli            18.08.0-1            18.08.1-1
                              parley            18.08.0-1            18.08.1-1
                               picmi            18.08.0-1            18.08.1-1
                   pim-data-exporter            18.08.0-1            18.08.1-1
                    pim-sieve-editor            18.08.0-1            18.08.1-1
                           pimcommon            18.08.0-1            18.08.1-1
                               poxml            18.08.0-1            18.08.1-1
                       print-manager            18.08.0-1            18.08.1-1
                         qcachegrind            18.08.0-1            18.08.1-1
                                rocs            18.08.0-1            18.08.1-1
                               rygel             0.36.1-1             0.36.2-1
                               samba              4.8.4-1              4.8.5-1
            signon-kwallet-extension            18.08.0-1            18.08.1-1
                           smbclient              4.8.4-1              4.8.5-1
                           spectacle            18.08.0-1            18.08.1-1
                                step            18.08.0-2            18.08.1-1
                             svgpart            18.08.0-1            18.08.1-1
                             sweeper            18.08.0-1            18.08.1-1
          telepathy-kde-accounts-kcm            18.08.0-1            18.08.1-1
              telepathy-kde-approver            18.08.0-1            18.08.1-1
          telepathy-kde-auth-handler            18.08.0-1            18.08.1-1
               telepathy-kde-call-ui            18.08.0-1            18.08.1-1
      telepathy-kde-common-internals            18.08.0-1            18.08.1-1
          telepathy-kde-contact-list            18.08.0-1            18.08.1-1
        telepathy-kde-contact-runner            18.08.0-1            18.08.1-1
       telepathy-kde-desktop-applets            18.08.0-1            18.08.1-1
  telepathy-kde-filetransfer-handler            18.08.0-1            18.08.1-1
    telepathy-kde-integration-module            18.08.0-1            18.08.1-1
             telepathy-kde-send-file            18.08.0-1            18.08.1-1
               telepathy-kde-text-ui            18.08.0-1            18.08.1-1
                               tslib               1.16-1               1.17-1
                            umbrello            18.08.0-1            18.08.1-1
                    zeroconf-ioslave            18.08.0-1            18.08.1-1
                         dbus-broker                    -                 15-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-05           2018-09-06
-------------------------------------------------------------------------------
                          lib32-nspr               4.19-1               4.20-1
                           lib32-nss               3.38-1               3.39-1
                               smlnj             110.83-1             110.84-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Witcher 3 worked fine few hours ago, now it crashes
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Items from previous update sets

Something using Perl/Python/glibc broke

Rebuilds needed! If it’s an AUR package, rebuild it. If it’s a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

Same problem I had on Stable with FF-KDE, but otherwise OK.

$ sudo pacman -Syyu
[sudo] password for mparillo: 
:: Synchronizing package databases...
 core                                          147.9 KiB  1848K/s 00:00 [########################################] 100%
 extra                                        1763.7 KiB  2.39M/s 00:01 [########################################] 100%
 community                                       4.8 MiB  1868K/s 00:03 [########################################] 100%
 multilib                                      181.5 KiB  1650K/s 00:00 [########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: firefox and firefox-kde-opensuse are in conflict. Remove firefox-kde-opensuse? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: firefox and firefox-kde-opensuse are in conflict
[mparillo@marco-T61 ~]$ sudo pacman -Rsn firefox-kde-opensuse
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: firefox-i18n-en-us: removing firefox-kde-opensuse breaks dependency 'firefox>=61.0.2'
[mparillo@marco-T61 ~]$ sudo pacman -Rsn firefox-i18n-en-us
checking dependencies...

Packages (1) firefox-i18n-en-us-61.0.2-1

Total Removed Size:  0.44 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/1) removing firefox-i18n-en-us                                       [########################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[mparillo@marco-T61 ~]$ sudo pacman -Rsn firefox-kde-opensuse
checking dependencies...

Packages (2) kmozillahelper-5.0.2-1  firefox-kde-opensuse-61.0.2-1

Total Removed Size:  126.65 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/2) removing firefox-kde-opensuse                                     [########################################] 100%
(2/2) removing kmozillahelper                                           [########################################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...
[mparillo@marco-T61 ~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                          147.9 KiB  1848K/s 00:00 [########################################] 100%
 extra                                        1763.7 KiB  2.37M/s 00:01 [########################################] 100%
 community                                       4.8 MiB  2.37M/s 00:02 [########################################] 100%
 multilib                                      181.5 KiB  2.53M/s 00:00 [########################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (107) adapta-breath-theme-3.94.0.149-1  ark-18.08.1-1  baloo-widgets-18.08.1-1  bluedevil-1:5.13.5-1
               breeze-5.13.5-1  breeze-gtk-5.13.5-1  ca-certificates-mozilla-3.39-1  cantarell-fonts-1:0.111-1
               chromium-69.0.3497.81-1  cups-filters-1.21.2-1  dbus-1.12.10-2  dolphin-18.08.1-1
               dolphin-plugins-18.08.1-1  ffmpegthumbs-18.08.1-1  filelight-18.08.1-1
               fontconfig-2:2.13.0+15+gc60ed9e-1  gcc-8.2.1+20180831-1  gcc-libs-8.2.1+20180831-1  ghostscript-9.24-2
               gnupg-2.2.10-1  gsettings-desktop-schemas-3.28.1-1  gsfonts-20180524-1  gwenview-18.08.1-1
               kaccounts-integration-18.08.1-1  kaccounts-providers-18.08.1-1  kactivitymanagerd-5.13.5-1
               kamera-18.08.1-1  kate-18.08.1-1  kcalc-18.08.1-1  kde-cli-tools-5.13.5-1  kde-gtk-config-5.13.5-1
               kdecoration-5.13.5-1  kdegraphics-thumbnailers-18.08.1-1  kdenetwork-filesharing-18.08.1-1
               kdeplasma-addons-5.13.5-1  kdialog-18.08.1-1  keditbookmarks-18.08.1-1  kfind-18.08.1-1
               kgamma5-5.13.5-1  kget-18.08.1-1  khelpcenter-18.08.1-1  khotkeys-5.13.5-1  kinfocenter-5.13.5-1
               kio-extras-18.08.1-1  kmenuedit-5.13.5-1  knetattach-5.13.5-1  kompare-18.08.1-1  konsole-18.08.1-1
               kscreen-5.13.5-1  ksshaskpass-5.13.5-1  ksysguard-5.13.5-1  ksystemlog-18.08.1-1  kteatime-18.08.1-1
               kwallet-pam-5.13.5-1  kwalletmanager-18.08.1-1  kwayland-integration-5.13.5-1  kwin-5.13.5-1
               kwrited-5.13.5-1  ldb-1:1.3.6-1  lib32-gcc-libs-8.2.1+20180831-1  lib32-libdrm-2.4.94-1
               libdrm-2.4.94-1  libjpeg-turbo-2.0.0-1  libkdcraw-18.08.1-1  libkexiv2-18.08.1-1  libkipi-18.08.1-1
               libkomparediff2-18.08.1-1  libksane-18.08.1-1  libkscreen-5.13.5-1  libksysguard-5.13.5-1
               libtirpc-1.1.4-1  libwbclient-4.8.5-1  linux418-4.18.6-1  linux418-nvidia-340xx-340.107-2
               lm_sensors-3.4.0+5176+dcf23676-1  manjaro-hotfixes-2018.08-6  milou-5.13.5-1  nspr-4.20-1  nss-3.39-1
               okular-18.08.1-1  oxygen-5.13.5-1  p11-kit-0.23.14-1  pipewire-0.2.3-1  plasma-desktop-5.13.5-1
               plasma-integration-5.13.5-1  plasma-nm-5.13.5-1  plasma-pa-5.13.5-1  plasma-workspace-5.13.5-1
               plasma-workspace-wallpapers-5.13.5-1  polkit-kde-agent-5.13.5-1  powerdevil-5.13.5-1
               print-manager-18.08.1-1  re2-20180901-1  samba-4.8.5-1  sddm-kcm-5.13.5-1
               signon-kwallet-extension-18.08.1-1  smbclient-4.8.5-1  spectacle-18.08.1-1  steam-manjaro-1.0.0.55-4
               systemsettings-5.13.5-1  tslib-1.17-1  user-manager-5.13.5-1  vlc-3.0.4-1  wayland-protocols-1.16-1
               xdg-desktop-portal-kde-5.13.5-1  zita-alsa-pcmi-0.3.2-1  zita-resampler-1.6.2-1

Total Download Size:    385.89 MiB
Total Installed Size:  1191.72 MiB
Net Upgrade Size:        -2.34 MiB

#4

I suspect cups-filters 1.21.2-1 update to be responsible for network printer not printing any more although I am not 100% sure. My Lexmark MS 317dn stopped printing after this (error message starting “printer troubleshooting” dialog). Reverting to stable fixes the issue.
Can you please check?


#5

There is no new version of this package available yet. Therefore I removed it again from our repos. Since we don’t build that package you may want to use the AUR-repo:

[home-thaodan]
Server = https://thaodan.de/home/bidar/home-thaodan/x86_64/

Import the key:

sudo pacman-key --recv-keys BBFE2FD421597395E4FC8C8DF6C85FEE79D661A4
pacman-key --finger BBFE2FD421597395E4FC8C8DF6C85FEE79D661A4

@AJSlye: sorry, seems the user thaodan doesn’t keep it in sync with Arch.
@jonathon: since you build the firefox packages when needed as security effort, how long and how much effort is needed to build also firefox-kde?


#6

Don’t apologize to me, I’m not the one that originally asked about it.

We don’t need it in sync, especially since Firefox 62+ rapid release is supposed to break all legacy customization methods anyway. Mozilla wants enterprise deployments to use to the new policy system going forward.



An update to FF 62 may break our Netrunner cck2 customization’s, which would not be good, I hope this is not the case.

I’d also assume that these upstream changes would require thaodan to rework those patches as well, hence the delay. Personally, I would have checked with thaodan before removing that package, but that’s just me. :wink:

With that said, some info on how you we’re importing his packages into the manjaro repo would be nice so I can continue to do the same for the netrunner repo.


#7

OK. I found the culprit that breaks network printing for me. It is ghostscript. Downgrading to version 9.23-3 (stable) solves the issue.


#8

Seeing the same error on stable using network printing. Printing prints fine, but the error forces a ‘cancel print job’ and removing it from pending. Btw, same Samsung printer, same setup and same 4 year rolling Manjaro install. Hoping for a fix in the next stable, but at least we can still print.

Logs show Ghostscript contains the error, but 9.23-3 on stable still produces the error. I suspect it’s cups-filters 1.21.2-1 but haven’t rolled back.


#9

I don’t know. If the package doesn’t need any changes and takes the same length of time to build as the standard version, possibly an hour or two. If it needs updates to patches or changes to the build environment (e.g. compiler or linker flags) then… more than an hour or two. :wink:


#10

After this update I got some dbus related issues, which makes plasma don’t start.

dbus-update-activation-environment: error: unable to connect to D-Bus: Server address of type unix was missing argument path or abstract
dbus[1307]: Unable to set up transient service directory: XDG_RUNTIME_DIR "/run/user/1000" not available: No such file or directory

#11

@philm @jonathon

Updated today:
https://aur.archlinux.org/packages/firefox-kde-opensuse

https://thaodan.de/home/bidar/home-thaodan/x86_64/firefox-kde-opensuse-62.0-1-x86_64.pkg.tar.xz

Personally, I don’t think 3 days was all that long to wait, considering the patches needed to be updated and made available first, and how much time Firefox takes to properly compile. Sometimes “Patiance is a virtue”.


#12

I was the first to raise the issue, but if I sounded impatient, I apologize. My concern was not the 3-day wait for the FF upgrade, but in the way updates were blocked. Since I am too much of a newbie to risk partial updates, my only solution was to delete FF altogether or install from outside the Manjaro repositories.


#13

Actaully, I was not refering to the standard upstream non-kde/appmenu patched Firefox packages. I was also not refering to the delay between release and Arch updating thier packages, or even the delay between Arch and the Manjaro stable repository, but yea, OK.

I was actually refering to the 3 days it took thaodan to update firefox-kde-opensuse after Arch added v62 to thier stable repo. I’m sure he had to wait for the patches to be updated and made available first.

https://aur.archlinux.org/cgit/aur.git/commit/?h=firefox-kde-opensuse&id=69a2b5a69894f9ddc2338bf70eee94bd25c5237d


#14

Since you have upgraded Unicode last weeks, have you, developers, upgraded the BPG fonts, including Deja Sans, pack as: https://bpgfonts.wordpress.com/2018/09/07/gnu-gpl-license-grant-to-linux-distributors/?

Because see the problem of lack of Georgian uppercase letters in the old fonts:

Bistream, Liberation and Noto have not been upgraded to support new Georgian Unicode glyphs - uppercase letters.


#15

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.