[Testing Update] 2018-08-21 - Linux419, Flatpak 1.0, Adapta, LibreOffice

On KDE, libreoffice applications have lost their window decorations (hence shadows, etc.)

check your GTK Application Style settings then LibreOffice looks fine on my system.

kernel 4.19 is working again properly now on both my systems

1 Like

I think I saw that in unstable KDE this morning (though it might have been a couple of weeks between updates on that laptop). For me, I deleted my old entry, and created a new one, and it seemed to connect quickly after a re-boot (and I re-booted again, just to make sure: Again, a quick connection).

Deleting and recreating the connection profile is not necessary since it’s still be able to connect to saved network automatically after reboot like it should. But it will stop connecting to any saved network right after waking up from sleep and NetworkManager will emit the “No agents were availiable for the request” warning to system log every time it tries to connect to any saved network.
It seems like it is related to race condition issue between NetworkManager and KWallet.

You mean the GTK settings in the KCM? They haven’t changed, which explained why no other GTK app has lost its decoration, only Libreoffice ones.

After latest update running Hakoila 17.1.12 (Originally xfce-18-Beta-5) I get two rather odd notices after booting up:
Screenshot_2018-08-21_13-52-26 Screenshot_2018-08-21_13-55-52

Remove Blueman from your autostart or add a polkit rule.

https://forum.manjaro.org/t/blueman-uses-polkit-to-authenticate-actions-on-system-start/55530/5

2 Likes

@philm Could you give the user some kind of script solving the blueman and polkit issue? I’m thinking especially of those on stable.

I use Blueman for my bluetooth hearing aids Phonac ComPiilot II so I tried your fix and it seems to work, thanks. Added rule to 50-default.rules

The problem is not on stable yet, I am using testing too.

Yes, I wanted to pitch him in time so that we have a solution when it’s going to stable.

1 Like

can you post screenshots to show what is missing? I have two installs of Manjaro KDE testing and neither have broken libreoffice appearance that I am aware of. Which KDE Theme are you using? I use Breeze.

EDIT - this may need splitting to a separate topic to be resolved properly rather than cluttering up this thread so consider starting one please @nortexoid

Will be fixed via a polkit rule in manjaro-hotfixes package with todays update.

1 Like

My update went fine for…

$ uname -a
Linux Manjaro_KDE_VM 4.17.17-1-MANJARO #1 SMP PREEMPT Sat Aug 18 14:38:10 UTC 2018 x86_64 GNU/Linux

…& for bonus-points i was happy to discover that this subtle LO update created a pacnew file, whose new line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh, fixes a moderately longterm grumble i’ve had for LO in Plasma since coming to Manjaro last year from openSUSE Tumbleweed [which already had fixed the problem].

Now at last, with this new option present & enabled, once more i have ALL of: scrollbars, scrollbar arrows, ongoing Toolbars, ongoing Menu. The LO Devs’ earlier attempt was flawed [export SAL_USE_VCLPLUGIN=kde4], coz though enabling it did give me my scrollbar arrows, the price paid was too high… it destroyed the Menu Bar. Now though: cake & eat it. :hugs:

2 Likes

It looks like this

EDIT: Perhaps it’s relevant: I’m running a wayland session.

The solution was already posted @nortexoid.

1 Like

yeah, that would be it, what philm highlights from kdemeoz’ post should resolve it

Setting the variable SAL_USE_VCLPLUGIN=gtk3_kde5 doesn’t work for me–I still get no decoration. However, if I use SAL_USE_VCLPLUGIN=gtk it works.

I suppose it is fixed.


But not in Arch repo yet

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark