[Testing Update] 2018-08-15 - Linux 4.19, LibGLVND, Python, Haskell

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we added linux419 kernel series
  • libglvnd got updated to 1.1.0
  • the usual python/haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.118 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.147
  • linux49 4.9.119
  • linux414 4.14.62
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.14
  • linux418 4.18.0
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Wed Aug 15 00:00:56 CEST 2018)

  • testing community x86_64: 115 new and 111 removed package(s)
  • testing core x86_64: 4 new and 2 removed package(s)
  • testing extra x86_64: 39 new and 19 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                       mattercontrol                    -     1.7.5+gb96bd48-1
                           pacui-git                    -       r911.111c87f-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                             bpython             0.17.1-2             0.17.1-3
                            bpython2             0.17.1-2             0.17.1-3
                       cabal-install           2.2.0.0-57           2.2.0.0-58
                              camlp4               4.06-1               4.07-1
                              camlp5               7.06-1               7.06-2
                                 coq              8.8.1-2              8.8.1-3
                             coq-doc              8.8.1-2              8.8.1-3
                              coqide              8.8.1-2              8.8.1-3
                               cudnn              7.1.4-1              7.2.1-1
                               darcs            2.14.1-36            2.14.1-37
                          deepin-api             3.1.29-1             3.1.30-1
                   deepin-session-ui              4.5.0-1              4.5.1-1
                                dune              1.0.0-1              1.0.0-2
                          fcitx-mozc      2.20.2673.102-2      2.23.2815.102-2
                           git-annex         6.20180807-3         6.20180807-4
                             glslang           6.2.2596-1           7.8.2853-1
                haskell-authenticate            1.3.4-153            1.3.4-154
                         haskell-aws              0.20-61              0.20-62
                       haskell-brick               0.40-2               0.40-3
               haskell-conduit-extra             1.3.0-44             1.3.0-45
                  haskell-config-ini           0.2.2.0-71           0.2.2.0-72
                   haskell-criterion            1.5.1.0-3            1.5.1.0-4
          haskell-cryptohash-conduit            0.1.1-205            0.1.1-206
          haskell-cryptonite-conduit             0.2.2-99            0.2.2-100
                         haskell-dav            1.3.2-108            1.3.2-109
                   haskell-esqueleto    2.5.3.20180402-54    2.5.3.20180402-55
                        haskell-feed           1.0.0.0-97           1.0.0.0-98
                      haskell-hakyll          4.12.3.0-88          4.12.3.0-89
                    haskell-hedgehog               0.6-27               0.6-28
                 haskell-hjsonschema             1.9.0-65             1.9.0-66
                    haskell-hopenpgp              2.7.2-4              2.7.2-5
                haskell-html-conduit             1.3.1-26             1.3.1-27
                        haskell-http         4000.3.12-37         4000.3.12-38
                haskell-http-conduit             2.3.2-27             2.3.2-28
                   haskell-js-jquery            3.3.1-107            3.3.1-108
                haskell-monad-logger             0.3.29-2             0.3.29-3
                  haskell-persistent             2.8.2-56             2.8.2-57
           haskell-persistent-sqlite           2.8.1.2-57           2.8.1.2-58
         haskell-persistent-template             2.5.4-81             2.5.4-82
            haskell-project-template           0.2.0.1-74           0.2.0.1-75
                       haskell-retry           0.7.6.2-36            0.7.6.3-1
                         haskell-rio            0.1.5.0-1            0.1.5.0-2
              haskell-servant-server          0.13.0.1-62          0.13.0.1-63
                       haskell-shake            0.16.4-71            0.16.4-72
             haskell-simple-sendfile            0.2.27-70            0.2.27-71
           haskell-tagstream-conduit          0.5.5.3-191          0.5.5.3-192
              haskell-tasty-hedgehog           0.2.0.0-39           0.2.0.0-40
               haskell-typed-process           0.2.2.0-19            0.2.3.0-1
              haskell-wai-app-static           3.1.6.2-84           3.1.6.2-85
          haskell-wai-handler-launch           3.0.2.4-51           3.0.2.4-52
                        haskell-warp            3.2.23-11            3.2.23-12
                    haskell-warp-tls           3.2.4.3-65           3.2.4.3-66
         haskell-wl-pprint-annotated           0.1.0.0-18            0.1.0.1-1
                 haskell-xml-conduit             1.8.0-46             1.8.0-47
                  haskell-xml-hamlet             0.5.0-40             0.5.0-41
                       haskell-yesod             1.6.0-81             1.6.0-82
                  haskell-yesod-auth             1.6.3-79             1.6.3-80
                  haskell-yesod-core             1.6.6-14             1.6.6-15
               haskell-yesod-default            1.2.0-369            1.2.0-370
                  haskell-yesod-form             1.6.2-15             1.6.2-16
            haskell-yesod-persistent             1.6.0-74             1.6.0-75
                haskell-yesod-static             1.6.0-69             1.6.0-70
                  haskell-yesod-test             1.6.5-13             1.6.5-14
                         hledger-api              1.10-25              1.10-26
                          hledger-ui              1.10-20              1.10-21
                         hledger-web              1.10-32              1.10-33
                              hoogle          5.0.17.3-65          5.0.17.3-66
                      hopenpgp-tools             0.21.2-8             0.21.2-9
                              iperf3                3.5-1                3.6-1
                           mitmproxy              3.0.4-2              4.0.4-1
                            node-gyp              3.7.0-1              3.8.0-1
                        ocaml-biniou              1.2.0-1              1.2.0-2
                   ocaml-easy-format              1.3.1-1              1.3.1-2
                       ocaml-findlib              1.8.0-1              1.8.0-2
                        ocaml-lablgl               1.05-6               1.05-7
                           ocaml-num                1.1-1                1.1-2
                        ocaml-yojson              1.4.1-1              1.4.1-2
                                opam              1.2.2-4              1.2.2-5
                           packer-io              1.2.4-1                    -
                              pandoc            2.2.3.2-3            2.2.3.2-4
                     pandoc-citeproc         0.14.3.1-107         0.14.3.1-108
                     pandoc-crossref           0.3.2.1-58           0.3.2.1-59
                          perl-mouse              2.5.4-2              2.5.6-1
                           postgrest          0.4.4.0-222          0.4.4.0-225
                           powerline                2.6-3                2.7-1
                    powerline-common                2.6-3                2.7-1
                     powerline-fonts                2.6-3                2.7-1
                       powerline-vim                2.6-3                2.7-1
                          powerline2                2.6-3                2.7-1
                             pychess             0.99.1-3             0.99.2-1
              python-async_generator                1.9-2               1.10-1
               python-beautifulsoup4              4.6.1-1              4.6.3-1
                   python-matplotlib              2.2.2-3              2.2.3-1
                    python-powerline                2.6-3                2.7-1
               python-pytest-timeout              1.2.1-2              1.3.1-1
             python-websocket-client             0.48.0-2             0.49.0-1
              python2-beautifulsoup4              4.6.1-1              4.6.3-1
                  python2-matplotlib              2.2.2-3              2.2.3-1
                   python2-powerline                2.6-3                2.7-1
              python2-pytest-timeout              1.2.1-2              1.3.1-1
            python2-websocket-client             0.48.0-2             0.49.0-1
                         qbittorrent              4.1.1-2              4.1.2-1
                     qbittorrent-nox              4.1.1-2              4.1.2-1
                          shellcheck             0.5.0-70             0.5.0-71
                               stack             1.7.1-98            1.7.1-101
                      tamarin-prover             1.4.0-79             1.4.0-80
                          teamspeak3              3.2.0-1              3.2.1-1
                              trojan              1.5.1-1              1.5.2-1
                              xmobar              0.26-69              0.26-70
                              xmonad      0.13.20180419-3               0.14-1
                      xmonad-contrib      0.13.20180518-3               0.14-1
              haskell-parsec-numbers                    -              0.1.0-2
                              packer                    -              1.2.5-1
                         soapyrtlsdr                    -              0.2.5-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                            linux419                 - 4.19rc0.0814.g10f3e23-1
                    linux419-headers                 - 4.19rc0.0814.g10f3e23-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                              dhcpcd             7.0.5b-1              7.0.7-1
                              netctl               1.17-1               1.18-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                  linux419-acpi_call                    -              1.1.0-0
                   linux419-bbswitch                    -                0.8-0
                linux419-broadcom-wl                    -       6.30.223.271-0
                   linux419-catalyst                    -      1:15.201.1151-0
                linux419-ndiswrapper                    -               1.61-0
                     linux419-nvidia                    -           1:396.51-0
               linux419-nvidia-340xx                    -            340.107-0
               linux419-nvidia-390xx                    -             390.77-0
                   linux419-nvidiabl                    -               0.88-0
                      linux419-r8168                    -           8.045.08-0
                        linux419-spl                    -              0.7.9-0
                   linux419-tp_smapi                    -               0.41-0
                linux419-vhba-module                    -           20161009-0
   linux419-virtualbox-guest-modules                    -             5.2.16-0
    linux419-virtualbox-host-modules                    -             5.2.16-0
                        linux419-zfs                    -              0.7.9-0
       manjaro-software-install-tool                    -                0.1-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                         flashplugin         30.0.0.134-1         30.0.0.154-1
                            graphviz            2.40.1-12            2.40.1-13
                            lablgtk2             2.18.6-1             2.18.6-2
                         libblockdev               2.18-2               2.19-1
                            libglvnd              1.0.0-1              1.1.0-1
                           libmspack         1:0.6alpha-1       1:0.7.1alpha-1
                            lighttpd             1.4.49-2             1.4.50-1
                                llvm              6.0.1-3              6.0.1-4
                           llvm-libs              6.0.1-3              6.0.1-4
                          llvm-ocaml              6.0.1-3              6.0.1-4
                           memcached              1.5.8-1             1.5.10-1
                               ocaml             4.06.0-2             4.07.0-1
                 ocaml-compiler-libs             4.06.0-2             4.07.0-1
                        ocaml-ctypes             0.11.5-2             0.14.0-1
                          ocamlbuild             0.12.0-2             0.12.0-3
                        pepper-flash         30.0.0.134-1         30.0.0.154-1
                      python-astroid              2.0.1-1              2.0.4-1
                       python-pylint              2.0.1-1              2.1.1-1
                              unison             2.51.2-1             2.51.2-2
                      ocaml-integers                    -              0.2.2-1
                        ocaml-result                    -                1.3-1
                         ocaml-topkg                    -              0.9.1-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-14           2018-08-15
-------------------------------------------------------------------------------
                   lib32-flashplugin         30.0.0.134-1         30.0.0.154-1
                      lib32-libglvnd              1.0.0-1              1.1.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Something using Perl/Python/glibc broke

Rebuilds needed! If it’s an AUR package, rebuild it. If it’s a repo package, please report and check back regularly for rebuilds.


Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

Xfce with 4.19. Runs well. :smiley:


#4

What is the output of journalctl -b -p 3
I was curious if there is anything that sticks out with 4.19 vs 4.18


#5

On my end, nothing. :joy:

I did get an additional message with -p4:

kernel: kauditd_printk_skb: 4 callbacks suppressed

#6

You may read the early news about it. Changes will be bigger than with 4.18, though. Also it is too early to tell.


#7

This update (I had it yesterday in unstable) broke steam on bumblebee for me :frowning:
Steam alone works, bumblebee alone also works.
When I launched primusrun steam today I got:

 crash_20180815085810_1.dmp[5170]: Uploading dump (out-of-process)
/tmp/dumps/crash_20180815085810_1.dmp
/home/michaldybczak/.local/share/Steam/steam.sh: linia 876: &#160;4947 Naruszenie ochrony pamięci &#160;&#160;(zrzut pamięci)
$STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
crash_20180815085810_1.dmp[5170]: Finished uploading minidump (out-of-process): success = yes
crash_20180815085810_1.dmp[5170]: response: CrashID=bp-c100d0bc-33b3-40b2-91ea-ceb3b2180814
crash_20180815085810_1.dmp[5170]: file ''/tmp/dumps/crash_20180815085810_1.dmp'', upload yes: ''CrashID=bp-c10
0d0bc-33b3-40b2-91ea-ceb3b2180814''

Steam games stopped working
#8

nvidia module is probably not updated yet. :stuck_out_tongue:


#9

Which packages got updated on your end? You know that the steam client updated lately? Most likely downgrade LibGLVND.


#10

Seems to be a huge list of changes, when we would snap this one over …


#11

If there’s nothing major waiting to be released on testing from unstable… I guess there’s no time like the present :wink:

Testing branch feels in a good place right now.


#12

Well, we have still some kernels in queue:


#13

Just had a very quick look at the changes pending… Doesn’t seem to be anything majorly serious, just bug fixes.

I guess it doesn’t matter whether you wait a little longer or push to stable now. It doesn’t appear anyone is at risk (security wise) to anything serious.

You’re the boss anyway so it’s your call :grin:


#14

When update using command, “sudo pacman -Syyu” or “sudo pacman -Syu”, it show message, “warning: pacman-mirrors: local (4.12.6-1) is newer than core (4.12.5-1)”. What should I do? Should I revert to core (4.12.5-1), or nothing to do? Thanks.


#15

sudo pacman-mirrors -f0
sudo pacman -Syyu


#16

Well, are you sure? For Intel it has some needed fixes still in queue.

More about it here.


#17

Thanks… it works now for 20180815 update.


#18

Just having Intel CPU is a security issue in of itself… When I say not at risk I was meaning by remote attack.

I haven’t read much on the “L1 terminal” exploit, but I thought physical access to hardware was needed. I’ll have to double check now.


#19

That’s why I use AMD Ryzen :wink:


#20

Heh, prices of Intel CPU’s drop, I see 7800X now at 35k dinars was 50k :wink:
When cascade lake starts, I expect vulnerable ones to drop even more :wink: