[Testing Update] 2018-08-11 - Firefox, Thunderbird, GlibC, Thunar, Linux418

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated firefox-dev and firefox-kde
  • added a newer snapshot of thunar-gtk3 and linux418
  • fixed the issue of electron apps and glibc
  • fixed loading of language-packs in thunderbird
  • the usual python/haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.118 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.147
  • linux49 4.9.119
  • linux414 4.14.62
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.14
  • linux418 4.18-rc7
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Sat Aug 11 06:27:10 CEST 2018)

  • testing community x86_64: 203 new and 203 removed package(s)
  • testing core x86_64: 3 new and 2 removed package(s)
  • testing extra x86_64: 24 new and 21 removed package(s)
  • testing multilib x86_64: 1 new and 0 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                firefox-kde-opensuse             61.0.1-2             61.0.2-1
   linux-rt-lts-manjaro-nvidia-304xx               4.14-1                    -
       linux-rt-manjaro-nvidia-304xx               4.16-1                    -


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                       cabal-install           2.2.0.0-55           2.2.0.0-56
                             calibre             3.28.0-2             3.29.0-1
                               darcs            2.14.1-34            2.14.1-35
                       deepin-mutter            3.20.32-1            3.20.34-1
                            electron              2.0.6-1              2.0.7-1
           firefox-developer-edition            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-ach            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-af            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-an            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ar            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-as            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-ast            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-az            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-be            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-bg            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-bn-bd            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-bn-in            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-br            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-bs            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ca            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-cak            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-cs            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-cy            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-da            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-de            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-dsb            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-el            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-en-gb            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-en-us            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-en-za            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-eo            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-es-ar            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-es-cl            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-es-es            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-es-mx            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-et            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-eu            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-fa            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ff            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-fi            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-fr            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-fy-nl            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-ga-ie            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-gd            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-gl            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-gn            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-gu-in            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-he            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-hi-in            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-hr            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-hsb            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-hu            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-hy-am            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ia            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-id            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-is            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-it            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ja            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ka            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-kab            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-kk            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-km            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-kn            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ko            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-lij            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-lt            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-lv            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-mai            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-mk            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ml            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-mr            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ms            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-my            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-nb-no            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-ne-np            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-nl            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-nn-no            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-or            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-pa-in            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-pl            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-pt-br            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-pt-pt            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-rm            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ro            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ru            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-si            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-sk            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-sl            62.0b15-1            62.0b16-1
  firefox-developer-edition-i18n-son            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-sq            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-sr            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-sv-se            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ta            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-te            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-th            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-tr            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-uk            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-ur            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-uz            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-vi            62.0b15-1            62.0b16-1
   firefox-developer-edition-i18n-xh            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-zh-cn            62.0b15-1            62.0b16-1
firefox-developer-edition-i18n-zh-tw            62.0b15-1            62.0b16-1
                           git-annex         6.20180807-1         6.20180807-2
                haskell-authenticate            1.3.4-152            1.3.4-153
          haskell-authenticate-oauth               1.6-31               1.6-32
                         haskell-aws              0.20-60              0.20-61
                      haskell-cereal            0.5.5.0-3            0.5.7.0-1
               haskell-cipher-aes128            0.7.0.3-5            0.7.0.3-6
               haskell-clientsession           0.9.1.2-70           0.9.1.2-71
                  haskell-connection             0.2.8-90             0.2.8-91
                   haskell-criterion            1.5.1.0-2            1.5.1.0-3
                  haskell-crypto-api             0.13.3-7             0.13.3-8
            haskell-crypto-api-tests                0.3-7                0.3-8
        haskell-cryptohash-cryptoapi             0.1.4-21             0.1.4-22
             haskell-data-serializer             0.3.4-27             0.3.4-28
                         haskell-dav            1.3.2-107            1.3.2-108
                        haskell-dbus             1.0.1-52             1.0.1-53
                    haskell-dbus0.10           0.10.15-31           0.10.15-32
                        haskell-drbg             0.5.5-22             0.5.5-23
                  haskell-fdo-notify             0.3.1-91             0.3.1-92
                      haskell-hakyll          4.12.3.0-86          4.12.3.0-87
                       haskell-hasql            1.1.1-110            1.1.1-111
                  haskell-hasql-pool            0.4.3-110            0.4.3-111
           haskell-hasql-transaction            0.5.2-113            0.5.2-114
                 haskell-hjsonschema             1.9.0-64             1.9.0-65
                    haskell-hopenpgp              2.7.2-3              2.7.2-4
                       haskell-hpack             0.29.6-2             0.29.6-3
                        haskell-http         4000.3.12-36         4000.3.12-37
             haskell-http-client-tls           0.3.5.3-65           0.3.5.3-66
                haskell-http-conduit             2.3.2-26             2.3.2-27
                 haskell-ixset-typed                0.4-3                0.4-4
                   haskell-js-jquery            3.3.1-106            3.3.1-107
                   haskell-monad-par           0.3.4.8-20           0.3.4.8-21
            haskell-monad-par-extras             0.3.3-13             0.3.3-14
                    haskell-mustache             2.3.0-64             2.3.0-65
                  haskell-network-ip           0.3.0.2-56           0.3.0.2-57
                  haskell-pipes-http            1.0.5-153            1.0.5-154
           haskell-postgresql-binary          0.12.1.1-38          0.12.1.1-39
                     haskell-puremd5             2.1.3-14             2.1.3-15
                         haskell-rsa             2.3.0-23             2.3.0-24
                    haskell-safecopy            0.9.4.1-5            0.9.4.1-6
                       haskell-shake            0.16.4-70            0.16.4-71
                       haskell-skein           1.0.9.4-20           1.0.9.4-21
                       haskell-socks             0.5.6-31             0.5.6-32
                  haskell-statistics          0.14.0.2-64          0.14.0.2-65
                         haskell-tls             1.4.1-35             1.4.1-36
         haskell-tls-session-manager           0.0.0.2-62           0.0.0.2-63
                   haskell-unixutils            1.54.1-53            1.54.1-54
                    haskell-warp-tls           3.2.4.3-64           3.2.4.3-65
                        haskell-wreq           0.5.2.1-47           0.5.2.1-48
                       haskell-yesod             1.6.0-79             1.6.0-80
                  haskell-yesod-auth             1.6.3-77             1.6.3-78
                  haskell-yesod-core             1.6.6-13             1.6.6-14
               haskell-yesod-default            1.2.0-368            1.2.0-369
                  haskell-yesod-form             1.6.2-13             1.6.2-14
            haskell-yesod-persistent             1.6.0-72             1.6.0-73
                haskell-yesod-static             1.6.0-68             1.6.0-69
                  haskell-yesod-test             1.6.5-11             1.6.5-12
                         hledger-web              1.10-30              1.10-31
                              hoogle          5.0.17.3-63          5.0.17.3-64
                      hopenpgp-tools             0.21.2-7             0.21.2-8
                         ibus-hangul              1.5.0-3              1.5.1-1
                              kcptun           20180316-1           20180810-1
                      matrix-synapse             0.33.1-1             0.33.2-1
                       mod_passenger              5.3.3-1              5.3.4-1
                     mysql-workbench             8.0.12-2             8.0.12-3
                 nginx-mod-passenger              5.3.3-1              5.3.4-1
                         nodejs-less              3.8.0-1              3.8.1-1
                              pandoc            2.2.3.2-1            2.2.3.2-2
                     pandoc-citeproc         0.14.3.1-105         0.14.3.1-106
                     pandoc-crossref           0.3.2.1-56           0.3.2.1-57
                           passenger              5.3.3-1              5.3.4-1
                           postgrest          0.4.4.0-220          0.4.4.0-221
             python-binary-memcached             0.26.1-2             0.27.0-1
                       python-btrees              4.5.0-2              4.5.1-1
                    python-cairocffi              0.8.1-3              0.9.0-1
                       python-docker              3.4.1-2              3.5.0-1
                   python-hypothesis            3.66.32-1             3.67.0-1
                    python-ipykernel              4.6.1-2              4.8.2-1
                          python-tox              3.1.3-1              3.2.1-1
                         python-zeep              3.1.0-1              3.1.0-2
                   python-zope-proxy              4.3.0-2              4.3.1-1
                python-zope-security              4.2.2-2              4.2.3-1
            python2-binary-memcached             0.26.1-2             0.27.0-1
                      python2-btrees              4.5.0-2              4.5.1-1
                   python2-cairocffi              0.8.1-3              0.9.0-1
                      python2-docker              3.4.1-2              3.5.0-1
                  python2-hypothesis            3.66.32-1             3.67.0-1
                   python2-ipykernel              4.6.1-2              4.8.2-1
                     python2-scandir                1.8-1              1.9.0-1
                         python2-tox              3.1.3-1              3.2.1-1
                  python2-zope-proxy              4.3.0-2              4.3.1-1
               python2-zope-security              4.2.2-2              4.2.3-1
                          shellcheck             0.5.0-68             0.5.0-69
                               stack             1.7.1-96             1.7.1-97
                              sysdig             0.22.1-1             0.23.0-1
                      tamarin-prover             1.4.0-78             1.4.0-79
                              xmobar              0.26-68              0.26-69
                             you-get           0.4.1120-1           0.4.1128-1
                     python-arpeggio                    -              1.9.0-1
                       python-parver                    -              0.1.1-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                      linux418 4.18rc8.0807.g1236568-1 4.18rc8.0810.gf313b43-1
              linux418-headers 4.18rc8.0807.g1236568-1 4.18rc8.0810.gf313b43-1
                               glibc                    -             2.28-1.1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                 calamares-git 3.2.2.r4878.c8eec9e5f-1 3.2.2.r4882.271a1ffa8-1
               linux318-nvidia-304xx         1:304.137-27                    -
                  linux418-acpi_call           1.1.0-0.10           1.1.0-0.11
                   linux418-bbswitch             0.8-0.10             0.8-0.11
                linux418-broadcom-wl    6.30.223.271-0.10    6.30.223.271-0.11
                   linux418-catalyst   1:15.201.1151-0.10   1:15.201.1151-0.11
                linux418-ndiswrapper            1.61-0.10            1.61-0.11
                     linux418-nvidia        1:396.51-0.10        1:396.51-0.11
               linux418-nvidia-340xx         340.107-0.10         340.107-0.11
               linux418-nvidia-390xx          390.77-0.10          390.77-0.11
                   linux418-nvidiabl            0.88-0.10            0.88-0.11
                      linux418-r8168        8.045.08-0.10        8.045.08-0.11
                   linux418-tp_smapi            0.41-0.10            0.41-0.11
                linux418-vhba-module        20161009-0.10        20161009-0.11
    linux418-virtualbox-host-modules          5.2.16-0.10          5.2.16-0.11
                         thunar-gtk3              1.8.1-9             1.8.1-10


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                           asymptote               2.44-1               2.47-1
                       libatomic_ops              7.6.4-1              7.6.6-1
                             libsoup             2.62.2-1             2.62.3-1
                              libwps              0.4.9-1             0.4.10-1
                         thunderbird               60.0-2               60.0-3
                         python-cson                    -                0.7-1
                         python-speg                    -                0.3-1
                        python2-cson                    -                0.7-1
                        python2-speg                    -                0.3-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                         lib32-glibc                    -             2.28-1.1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


[Testing Update] 2018-08-10 - Kernels, Thunderbird, Firefox, MSM, DBUS, Deepin, Gpodder
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Something using Perl/Python/glibc broke

Rebuilds needed! If it’s an AUR package, rebuild it. If it’s a repo package, please report and check back regularly for rebuilds.


Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

I pushed some more packages …

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-08-10           2018-08-11
-------------------------------------------------------------------------------
                             mugshot              0.3.2-3              0.4.1-1
                               pm2ml            2017.12-1            2017.12-2
                           powerpill             2018.5-1             2018.7-1
                   python3-memoizedb          2017.3.30-1          2017.3.30-2
                        python3-xcgf             2017.3-1             2017.3-2
                        python3-xcpf               2018-1             2018.8-1
                            hw-probe                    -                1.4-1

#4

Since that update introduced issue in electron and broke many AUR programs, I would vote to withhold it 1-2 weeks till AUR catches up. After that it’s all fair game since AUR is not officially supported. Good AUR maintainers will update packages in that time, bad ones… will stay bad.

Probably electron will have this bug for longer time based on my experience (although someone has to check it, electron updates are coming in unstable so maybe they have the fix already) so when moving update to stable, there should be posted a solution/workaround that was given in unstable announcement.
I personally switched to snap with troubling apps and all is well, I don’t have to trouble myself with it anymore.


#5

The AUR not working is not a Manjaro problem. It is also not officially supported and therefor if you have problems with applications from the AUR, rebuild them or contact the maintainer of the application that is at fault.

Manjaro will should not hold back updates because of AUR problems.


#6

the better wording would be: Manjaro should not hold back updates because of AUR problems - that would also be my opinion.


#7

That’s what I said. Manjaro can only make the end user experience smoother by waiting with the stable update. It’s not about AUR itself, it’s about user experience which Manjaro cares about and since there is always some delay, it will happen eventually so no special measures are needed. So I basically agree not paying much to AUR problems, just wait within normal scope of delay which will smooth issue out anyway.


#8

And thats where it starts. I’d say no. If you choose to use the AUR, its up to you to keep your system running. Manjaro should not wait with something because of this.


#9

Exactly, AUR may be an acronym for Arch User Repository but it can also mean Accept(ed) User Responsibility for any kind of breakage. There should be a disclaimer warning pop up when people first enable access to AUR via a octopi or pamac stating Manjaro maintainers cannot be held responsible for kind of stability issues or update errors resulting from using AUR.


#10

There is the added fact that not even Arch supports it. It’s clearly stated everywhere. AUR is convenient, granted, and I use it myself, but managing such an ecosystem for a rolling release is quite daunting to say the least. The way things are done by Manjaro right now is fine, if you ask me.

If my AUR packages break, I rebuild them (sometimes changing the pkgbuild), if there’s nothing to do, there are alternatives: snap, flatpak and Appimages…

Btw, users of the stable repos know that. That’s fine. At most, there could be a warning in the forums when the update pack hits stable. That should be enough.


#11

From one side AUR is not supported officially so we shouldn’t use any problem of AUR to withhold packages but Manjaro stable is anyway usually belayed 1-2 or even more weeks. Like it or not, AUR is important part of Manjaro experience and without it, there would be no Manjaro. So the least what we could do is to wait a bit to smooth experience of Manjaro stable users because system is FOR USERS not for principles (at least in Manjaro case). This is just a common sense.
If there would be something more to do, I would agree that there would be no point of even considering it. AUR is not supported period. But if it’s just a matter of small delay that usually occurs anyway, I see no problem with it. For me it could be even only 1 week delay. I just say not to push updates right away only with reasonable time frame. After all, they just entered testing repo so testing is not done so actually there is nothing to do. Once testing is done and major complaints will be posted here (aside AUR), this will be ready to push to stable.


#12

people don’t read or take it on board though. with a popup message prompting users to accept their fate before they continue or cancel it is rammed home harder.


#13

I now have some orphans, perhaps from either this or a previous update:

$ pacman -Qdt
illyria-wallpaper 1.4-1
mhwd-nvidia-304xx 1:304.137-1
plasma5-theme-adaptabreath 0.1.5-1

#14

Now thunderbird is in german again - which is nice - but why does Ligning now decide to work:

I see it claims to not be compatible - but yesterday it worked with yesterdays version for Thunderbird 60 ^^


#15

Geht suche noch von heute morgen den Link


#16

What “version” of Lightning do you use? O.o Mine claims to be 5.4


#17

lightning-6.2b6.de.xpi


#18

wired - but thanks - I hope you got a link to that xpi? :hugs:


#19

Thunderbird 60: Lightning calendar in my national language?
#20

I think you have misunderstood something.
The AUR packages are updated against Arch Stable, which is more or less Manjaro Unstable.
So if a package is broken when you try updating it in Manjaro Stable, it’s usually because it now relies on newer packages than your system have. So delaying packages further is the opposite of what you want if an AUR package fails to build or run. You would want a quicker update of Manjaro Stable.