[Testing Update] 2018-08-09 - Kernels, Python 3.7, Perl 5.28, LibreOffice, Nvidia, Xorg-Server, Deepin

update
testing

#60

Thanks, until yesterday(+1) I work with 5.7, then philm show “fresh” , web search = 6.0.6 is stable.
I think why do I still have 5.7 if 6.0.6 is stable?
And now you show me why that is and everything is clear :slight_smile:


#61

Which ones?

Atom and Etcher seem to be fine to me.


#62

It looks like apps that use the system electron aren’t effected because it is actually an ldd issue according to the link. Still, it seems to effect a fairly broad group of apps.

I first noticed it on bitwarden-bin as reported above


#63

Seems your problem is with wine-staging?

Regular wine is working fine here. :grin:


#64

Hey guys,
everything good so far…
But one issue that I have been facing with increasing frequency is invalid signature/certificate issues.
Last week I had got it with Atom/electron apps, then with some python packages and today with the libreoffice-still package. The forums do have some work arounds, but just wanted to check if this is something to do with just my PC or is it something that everyone is facing. btw, I do update the databases before I initiate an update…
Cheers…


#65

You might want to have a look at this thread Issues with "signature is marginal trust" or "invalid or corrupted package" (it is in the new FAQ section). Generally deal with them as they arise (infrequently).

pacman -Syy will synchronise the local database. One common way to update is to do

sudo pacman-mirrors -fN (where N is integer of your choosing = number of mirrors to list) then
sudo pacman -Syyu to synchronise the local database to the mirror and update the system.

And since we’re on the topic the Pacman Rosetta is recommended reading.

Hope that helps. :smile:

Edit: I read ‘btw’ as ‘how’, sorry about that - must have c00ter’s eyes today. :flushed:


#66

Or if you are talking about aur packages - heres to guessing the keys changed and you need to import them.


#67

I started finding issues after this update:

  • thunderbird-appmenu (compiled from AUR) won’t work:
$ env UBUNTU_MENUPROXY=0 /usr/lib/thunderbird/thunderbird %u
XPCOMGlueLoad error for file /usr/lib/thunderbird/libxul.so:
libicui18n.so.61: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Solution: temporarily install version from repo

  • firefox-kde-opensuse
    The same error as with thunderbird. Installing again from Manjaro repo doesn’t help. Installing firefox-kde-opensuse-bin from AUR also shows the same error.

Solution: temporarily install firefox from Manjaro repo, it won’t have kde dialogs or global menus thou :frowning:

  • mailspring: segefault
    It’s outdated in AUR

Solution: uninstall mailspring and:

snap install mailspring

The con: configuring mailspring again, unless I can copy configs over? Does someone have idea where?

  • bitwarden-bin: segefault
    It’s outdated in AUR

Solution: uninstall bitwarden and:

snap install bitwarden

So basically, although Manjaro doesn’t officially support AUR and we could say, “it’s AUR, we’re fine”, the update messes with many AUR packages that became outdated. I believe with some time a good quality packages will be updated and start working.
I would be for withholding this update for a 2 weeks for AUR packages to catch up. If they won’t do that, I guess they are badly maintained and Manjaro can’t do more then that.


#68

mailspring & bitwarden are suffering from the issue noted above affecting many electron applications.

There is nothing the aur maintainers can do right now.


#69

Thank you for this sage advice up top @philm. My initial attempt today to update my Testing KDE VM floundered immediately when i got an error message along the lines of [might not be exact words; writing partly from memory now, after the fact]:
perl (5.28.0-1) breaks dependency perl<5.27 required by perl-gtk2-unique.

I assumed i could/should then simply first temporarily uninstall perl-gtk2-unique, do the update, then reinstall it after. However i found that removal of perl-gtk2-unique would force removal of Shutter & its 3million dependencies… eek. Stunned at this revelation i thought i was snookered, til i re-read this thread & rediscovered your quoted advice. Thence in Strangelovian terms i decided to “Learn to Stop Worrying and Love the Bomb Shutter removal & later reinstallation with recompilation of it & all its 3million dependencies”.

All good… so now i know what to do once this later flows down into my KDE Stable.

I love Manjaro. Thanks for your amazing work @philm.


#70

Luckily, not all electron apps are affected. messengerfordesktop and rambox work fine.

These days we are lucky to have many alternative sources so if AUR package won’t work, we can use snap or flatpack, although lately only snaps are of value to me… Flatpacks simply don’t have the needed packages. All in all, snaps become a nice way to patch AUR gaps/problems. Also, snaps do integrate with Plasma’s global menus while flatpacks won’t… Or at least electron based snaps integrate because usually those are the only ones that I use as snaps and electrons are just web-apps. There is no system wide theming so they don’t suffer of lack of system theme integration.


#71

Hard to know, might be my DLL overrides, corrupted wine prefix, staging, patches… Something or all of the above.


#72

My point was vanilla WINE is working fine (for me). The errors you post include …/wine-staging-pba/… references, a location that does not exist in wine vanilla. So my tentative suggestion. :woman_shrugging:


#73

Current sha256sum is:

6a60ef09c777e950d4918f734853a010bf2015513ea96f822554956375e32249  manjaro-kde-18.0-beta-4-testing-x86_64.iso

Will update the files on the server.


#74

Ha ha…that effect does happen :stuck_out_tongue:

Anyways thank you for your response. I have been through that link and tried Jonathan’s solutions. It does work, but the issue seems to be back with a different package the next time…Have tried all the three options. Weird thing is that the pamac GUI on repeated tries seems to be getting rid of the issue…but again only randomly…Today it did not allow me to update libreoffice-still. I had to uninstall it, update it and then install it back. the same case with the atom update over the weekend…

Let’s see if this repeats…
Cheers :+1:


#75

nah…the packages that have given me issues are all from the repos.
libre-office, pythong, atom etc etc…Lets see, for now it is clear…have to see if it repeats itself…


#76

Extramodules will get updates only when there is an ABI change within the kernel. Therefore not always needed to rebuild extramodules.


#77

It is, but 6.0.6 is still listed as “fresh” in the arch repos, although it is flagged out of date. 6.1 isn’t in these repos yet…


#78

For mailspring, or possibly any package affected, the workaround is the same the one posted above regarding the signalapp and can be found here. Note that the new version of mailspring still depends on the old glibc…


#79

Thanks. If the issue was not with electron app I would do that extra step to fix it but snaps are well suited for electron apps so I guess that’s the best approach at this moment IMO. At the moment all my electron apps are either working or from snaps.