[Testing Update] 2018-07-16 - PulseAudio, KDE Frameworks, Themes, Settings, Haskell

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we added the first point-release of PulseAudio v12 series
  • KDE frameworks got updated to v5.48.0
  • we worked mostly on our profile-settings and themes
  • haskell updates/rebuilds.

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:

Our KDE fans may try our beta-build with the latest KDE v5.13 instead.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.115 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.140
  • linux49 4.9.112
  • linux414 4.14.55
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.6
  • linux418 4.18-rc3
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt9

Package Updates (Mon Jul 16 07:41:21 CEST 2018)

Sync Packages

  • testing multilib x86_64: 7 new and 7 removed package(s)
  • testing extra x86_64: 100 new and 102 removed package(s)
  • testing community x86_64: 211 new and 211 removed package(s)

Overlay Packages

  • testing multilib x86_64: 0 new and 5 removed package(s)
  • testing extra x86_64: 3 new and 16 removed package(s)
  • testing community x86_64: 18 new and 23 removed package(s)

A detailed list of all package changes may be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

Had to delete /usr/lib/libutf8proc.so.2 before updating. It complained about file in conflict.

EDIT: Also, nm applet now works with VPN connections ! YES :slight_smile:


#4

It is known


#5

Right, let me automate this …


#6

yup… musta hit in between the syncing. all fine here.


#7

Had the same problem however doing a reboot solved it for me.


#8

And me. All good after the reboot.

$ uname -a
Linux Manjaro_KDE_VM 4.17.6-1-MANJARO #1 SMP PREEMPT Fri Jul 13 21:09:10 UTC 2018 x86_64 GNU/Linux

#9

If you guys want to be really fancy, you may try appimagelauncher. Simply install it via sudo pacman -S appimagelauncher. Then you may want to test some AppImages from AJSlye. Getting additional software was never so easy!


#10

KDE SDDM login screen is incorrect for me.

FS-20180716-173155

Wrong icon theme, text boxes funky too, not sure why.

I think it is defaulting to the new Adapata theme and ignoring the selected Breath theme, or something in the Breath theme got overwritten.

:confused:

FS-20180716-173835

Lock screen and SDDM splash screens are okay, just the SDDM login screen that is somehow using the wrong theme.

Logout then login works too.


AdaptaBreath Theme WIP
#11

Can you try to downgrade the manjaro-kde-settings package and see if that fixes it? If that is the regression we have to see, as we changed the theming with v18.0-beta2. However this should not reflect on already installed systems. @kirek: some idea?


#12

Downgrade to manjaro-kde-settings 20180413-1 worked, now displaying correctly.

FS-20180716-180546


Plasma 5.13.4 update broke system in Testing
#13

That’s what i had first tried but it did not help. Only the reboot fixed it here.


#14

Had to remove geoclue in order for geoclue2 to be installed.

N. B. : geoclue is an AUR package.


#15

OK, so this was not expected that xdg files do that effect. Normally the user files in your home-dir should take affect.


#16

Thank you, it seemed to work perfectly …

Packages (1) manjaro-system-20180716-1

Total Download Size:   0.02 MiB
Total Installed Size:  0.01 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 manjaro-system-20180716-1-any                  16.8 KiB   701K/s 00:00 [########################################] 100%
(1/1) checking keys in keyring                                          [########################################] 100%
(1/1) checking package integrity                                        [########################################] 100%
(1/1) loading package files                                             [########################################] 100%
(1/1) checking for file conflicts                                       [########################################] 100%
(1/1) checking available disk space                                     [########################################] 100%
:: Processing package changes...
(1/1) upgrading manjaro-system                                          [########################################] 100%
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
warning: lock file missing /var/lib/pacman/db.lck

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (92) adapta-breath-theme-3.94.0.7-1  attica-5.48.0-1  baloo-5.48.0-1  bluez-qt-5.48.0-1
              breeze-icons-5.48.0-1  frameworkintegration-5.48.0-1  geoclue2-2.4.10-1  illyria-wallpaper-1.4-1
              kactivities-5.48.0-1  kactivities-stats-5.48.0-1  karchive-5.48.0-1  kauth-5.48.0-1  kbookmarks-5.48.0-1
              kcmutils-5.48.0-1  kcodecs-5.48.0-1  kcompletion-5.48.0-1  kconfig-5.48.0-1  kconfigwidgets-5.48.0-1
              kcoreaddons-5.48.0-1  kcrash-5.48.0-1  kdbusaddons-5.48.0-1  kdeclarative-5.48.0-1  kded-5.48.0-1
              kdesu-5.48.0-1  kdnssd-5.48.0-1  kdoctools-5.48.0-1  kemoticons-5.48.0-1  kfilemetadata-5.48.0-1
              kglobalaccel-5.48.0-1  kguiaddons-5.48.0-1  kholidays-1:5.48.0-1  ki18n-5.48.1-1  kiconthemes-5.48.0-1
              kidletime-5.48.0-1  kimageformats-5.48.0-1  kinit-5.48.0-1  kio-5.48.0-1  kirigami2-5.48.0-1
              kitemmodels-5.48.0-1  kitemviews-5.48.0-1  kjobwidgets-5.48.0-1  kjs-5.48.0-1  knewstuff-5.48.0-1
              knotifications-5.48.0-1  knotifyconfig-5.48.0-1  kpackage-5.48.0-1  kparts-5.48.0-1  kpeople-5.48.0-1
              kpty-5.48.0-1  krunner-5.48.0-1  kservice-5.48.0-1  ktexteditor-5.48.0-1  ktextwidgets-5.48.0-1
              kunitconversion-5.48.0-1  kvantum-manjaro-0.10.6-1  kvantum-qt5-0.10.6-1  kwallet-5.48.0-1
              kwayland-5.48.0-1  kwidgetsaddons-5.48.0-1  kwindowsystem-5.48.0-1  kxmlgui-5.48.0-1
              lib32-libpulse-12.1-1  lib32-mesa-18.1.4-1  lib32-mesa-vdpau-18.1.4-1  lib32-vulkan-intel-18.1.4-1
              lib32-vulkan-radeon-18.1.4-1  libpulse-12.1-1  libva-2.2.0-2  libva-mesa-driver-18.1.4-1
              manjaro-kde-settings-20180715-3  mesa-18.1.4-1  mesa-vdpau-18.1.4-1  modemmanager-qt-5.48.0-1
              networkmanager-qt-5.48.0-1  oxygen-icons-1:5.48.0-1  papirus-icon-theme-20180601-1
              papirus-maia-icon-theme-20180401-2  plasma5-theme-adaptabreath-0.1.2-1  prison-5.48.0-1
              pulseaudio-12.1-1  pulseaudio-bluetooth-12.1-1  pulseaudio-zeroconf-12.1-1  purpose-5.48.0-1
              python-yaml-3.13-1  qqc2-desktop-style-5.48.0-1  solid-5.48.0-1  sonnet-5.48.0-1  subversion-1.10.0-3
              syntax-highlighting-5.48.0-1  threadweaver-5.48.0-1  vulkan-intel-18.1.4-1  vulkan-radeon-18.1.4-1

Total Download Size:   140.67 MiB
Total Installed Size:  512.08 MiB
Net Upgrade Size:       89.82 MiB

:: Proceed with installation? [Y/n]

#17
if ! pacman -Qo /usr/lib/libutf8proc.so.2 2>/dev/null; then
    rm /usr/lib/libutf8proc.so.2
fi

From @jonathon , probably went down somehow. :wink: :slight_smile:

Wrong link??? I think I have clicked on this one. Sorry.


#18

I seem to now default to AdaptaBreath, and that persists across re-boots.


#19

No problems on 4 machines.


#20

After updating KDE, redshift crashes on startup:

$ redshift
Trying location provider `geoclue2'...
Using provider `geoclue2'.
Using method `randr'.
Waiting for initial location to become available...
Unable to start GeoClue client: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: 'redshift' disallowed, no agent for UID 1000.
Access to the current location was denied by GeoClue!
Make sure that location services are enabled and that Redshift is permitted
to use location services. See https://github.com/jonls/redshift#faq for more
information.
Unable to get location from provider.

The FAQ said to check privacy settings but gave an example using Gnome – not sure how to address it in KDE.