[Testing Update] 2018-06-27 - Kernels, Plasma 5.13.2, LibreOffice, Firefox, Haskell, Python

update
testing

#21

After update always restart manjaro setup running in VM. We have suspend feature in VM’s which would cause various issues since it is similar to doing hibernate after updating manjaro setup running on real hardware instead of restarting.

Also under .cache directory within user home delete following folders and files. No worries they will be regenerated.

If desired instead of deleting rename directories only as follows

For eg Rename directory xyz to xyz.bak

& later upon login u can delete backed up directories.

Directory List to delete / rename within .cache

fontconfig
kwin
plasmashell
mesa_shader_cache
qt_shader_cache
systemsettings

In addition to directories listed above u cud delete directories for qt applications within .cache directory provided they contain qmlcache directory with qml cache files (Files ending with .qmlc extension)

Files to delete within .cache

  1. File beginning with ksycoca5. Usually there will be one file only.
  2. All files beginning with plasma_theme_ and ending with .kcache
  3. Delete file icon-cache.kcache

Try installing ttf-ibm-plex from AUR. This font was last updated on 2018-04-17. If i recall correctly opensource font from IBM

Pls be informed with pacman 5.1 some aur helpers may cause issues as alerted by Arch linux wiki page.

Use makepkg -sCc after git cloning ttf-ibm-plex or use pamac / octopi.

Arch Wiki link.
https://wiki.archlinux.org/index.php/AUR_helpers#Discontinued_or_problematic

Finally Run following command logged in as user and root user.

fc-cache -frv


#22

No no no, somehow you made a misunderstanding here. The issue is NEVER that i didn’t reboot after doing updates, as i always do. What you have quoted here is completely out of the correct context.

Everything else you wrote after that is, respectfully, redundant, given that you have already solved my problem. Did you not read what i wrote in the hidden “Summary” section?

Thank you once again for solving my problem… but i’d still like to know how did you know that bad fonts can cause high cpu usage? To me this is amazing that you so correctly identified the apparent problem… i was nowhere near being able to solve it myself.


#23

Dated back in October 2015 there was performance regression in Freetype
engine that was introduced in Qt 5.5.

I read following Bug reports to identify old fontcache / old font as a possible cause since this issue is already fixed in qt5.5

https://bugs.kde.org/show_bug.cgi?id=354082

https://bugs.gentoo.org/show_bug.cgi?id=564666

https://codereview.qt-project.org/#/c/166532

https://bugreports.qt.io/browse/QTBUG-49452


#24

Use ublock origin / Noscript addons or both to block execution of third party scripts in background. They are responsible for causing high cpu usage.

I observed this behavior on waterfox as well. Same approach worked with waterfox.


#25

:slightly_smiling_face: I shud have quoted below text only from ur previous reply. Observe Bold text.

Since Virtual Machine software has Suspend feature i thought may be VM suspend caused this issue.

Although kde user cud reuse previous session in plasma desktop as per settings at System Settings -> Start up & Shutdown -> Desktop Sessions.

Steps to delete .cache folder content helps to ensure clean qml cache exists every time QT / Plasma Desktop package is updated.

Weird problems can happen even after upgrade and restarting with stale qml cache, if user happens to use previously saved plasma session

Contains output for fc-cache executed with sudo. Shouldn’t Fontcache be unique to each user and reside within home directory at .cache/fontconfig/

hence i suggested to execute fc-cache as non-admin user and as root user.


#26

No, sorry, but with respect you’re still taking things out of context. Pls drop any idea that i don’t reboot the VM after upgrades, because i do. The section of my text you quoted is correct… my Plasma Setting is to Restore Previous Session, on Login. Hence the Dolphin window reappeared after the reboot, & after i relogged in. This is of course basic KDE operation.


#27

Seems that i lost all my bookmarks in Fx… :frowning: and also the history and Add-ons.

Has anybody also this problem?


closed #28

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.