[Testing Update] 2018-06-21 - Kernels, KDE, QT 5.11.1, Breath Theme



Whoopsy daisy. I just announced some but didn’t push anything yet to testing. Let me fix that :wink:


Now that we got our “fix” - I moved back to no issues! Thx philm for delivering our dose of… coca… I mean packages :grin:


Ah there it is :slight_smile:
sudo pacman-mirrors -f && sudo pacman -Syyu
gave me the new stuff now (only one local mirror was fully synced)
Then had this
:: Replace pulseaudio-gconf with extra/pulseaudio? [Y/n]
which of course Y - and all went lovely by.

Also kinda gross note -
krunner new feature ‘software center’ is added and enabled after update … which suggests apps to add. Easily undone … but ewwww.


Silky smooth update!:+1: :smiley:


switched my desktop to testing tonight as my SSD is now seemingly stable after a firmware update. no issues with the updates after switching branches whatsoever, looks good to go.


Smooth update of my KDE VM, but noted these two ongoing issues:

  1. https://bugs.kde.org/show_bug.cgi?id=395477 remains unfixed.
  2. Each variant of Plasma 5.13.x so far, in my Testing KDE VM, suffers constant high cpu% due to kwin & Xorg:

    EDIT: Oh, i remembered that i have another KDE VM [albeit this one is Stable branch], which is still on 5.12.5, & shows the lower cpu% typical before the 5.13 upgrade:

[Testing Update] 2018-06-22 - Systemd v239, Pacman-Mirrors, Adapta, Firefox, Rebuilds

No change on the desktop menu issue for me. Xfce (gtk2) with kernel 4.17. Also tried 4.14LTS on the off chance there was a kernel element but made no difference.

Update went smoothly. :grinning:


The desktop context menu works in the beta. Maybe because xfdesktop-gtk3 is installed.

thunar and thunar-gtk3 packages are now both at 1.8.1-1. Are they supposed to be at the same version number considering one is supposed to be the gtk2 and the other gtk3?


Thanks, I had gathered that there was not a similar problem for the gtk3 beta - without having tried it myself.

If the transition to gtk3 is imminent then maybe the problem is not worth pursuing. But I am not sure how close that is… :wink:


Imminent or not, I’ll probably run a Frankenstein machine with a mix of gtk2 and gtk3 packages (I don’t know how reasonable this is). There’s some good things in Xfce 4.13. Some not so good things also. But some good things.


Later is as good as Now. We all forget from time to time, no worries. All good after update!!! :slight_smile:


Was a difficult birth, but then worked out in the end.


I highly doubt it will work from experience testing MATE throughout the transition to GTK+3. I believe the same will apply for XFCE but you can of course try if you want. I recommend you use one or other though not a frankenstein mix.


Sadly I’m not running on KDE Plasma. I think Gnome on testing branch looks more better.


With this update we have a “/etc/pulse/default.pa.pacnew”. I have to replace some lines related to “GSettings” in “/etc/pulse/default.pa” .


I’ve installed xfce4-gtk3 and the goodies package.

  • Some incompatibilities with applets, specifically the network manager which I have disabled because it flickers in the panel.
  • Programs will not go to system tray which is bug or feature unknown.
  • There is some repeated gtk error spam in the xorg.log:
(wrapper-2.0:732): Gtk-WARNING **: 21:57:54.937: Theme parsing error: <data>:1:142: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(wrapper-2.0:734): Gtk-WARNING **: 21:57:54.961: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

Otherwise xfce gtk3 is solid.


Did I got it right that I should just copy those lines from pacnew to default.pa?:

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
load-module module-gsettings

and this lines should be but above those lines:

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value

I compared default.pa and default.pa.pacnew and… they are astonishingly different. Hard to even compare so I’m confused. Should I just use pacnew as default conf? I do have some sound issues (but they were because of the incompatible hardware) but maybe those new configs will set everything right (updates and new kernels fixed many sound issues)?

[Testing Update] 2018-06-18 - Kernels, Mesa, Texlive, XFCE

so far so good


Ditto. :grinning:


For me there are other differences, as I personalize it, but this lines were new for me.
I just posted here to know if I do it right.