[Testing Update] 2018-06-20 - KDE Plasma, Firefox, Python, Haskell

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • lot of fixes for KDE Plasma got added with this
  • Firefox starts v62 series
  • and the usual rebuilds/updates for Haskell and Python

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.113 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.138
  • linux49 4.9.109
  • linux414 4.14.50
  • linux415 4.15.18 [EOL]
  • linux416 4.16.16
  • linux417 4.17.2
  • linux418 4.18-rc1
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.15_rt7

Package Updates (Wed Jun 20 07:13:16 CEST 2018)

Sync Packages

  • testing extra x86_64: 69 new and 71 removed package(s)
  • testing community x86_64: 154 new and 154 removed package(s)

Overlay Packages

  • testing extra x86_64: 1 new and 1 removed package(s)
  • testing community x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-19           2018-06-20
-------------------------------------------------------------------------------
                       budgie-extras              0.4.4-1              0.5.0-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-19           2018-06-20
-------------------------------------------------------------------------------
                          adapta-kde           20180614-1           20180618-1
                                atop              2.3.0-2              2.3.0-3
                        cozy-desktop              3.6.0-1              3.7.0-1
                        d-containers       0.8.0alpha.7-1       0.8.0alpha.8-1
                                dfmt              0.8.1-1              0.8.2-1
           firefox-developer-edition            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-ach            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-af            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-an            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ar            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-as            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-ast            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-az            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-be            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-bg            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-bn-bd            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-bn-in            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-br            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-bs            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ca            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-cak            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-cs            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-cy            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-da            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-de            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-dsb            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-el            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-en-gb            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-en-us            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-en-za            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-eo            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-es-ar            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-es-cl            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-es-es            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-es-mx            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-et            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-eu            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-fa            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ff            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-fi            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-fr            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-fy-nl            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-ga-ie            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-gd            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-gl            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-gn            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-gu-in            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-he            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-hi-in            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-hr            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-hsb            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-hu            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-hy-am            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ia            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-id            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-is            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-it            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ja            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ka            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-kab            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-kk            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-km            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-kn            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ko            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-lij            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-lt            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-lv            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-mai            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-mk            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ml            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-mr            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ms            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-my            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-nb-no            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-ne-np            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-nl            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-nn-no            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-or            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-pa-in            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-pl            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-pt-br            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-pt-pt            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-rm            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ro            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ru            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-si            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-sk            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-sl            61.0b14-1             62.0b1-1
  firefox-developer-edition-i18n-son            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-sq            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-sr            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-sv-se            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ta            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-te            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-th            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-tr            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-uk            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-ur            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-uz            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-vi            61.0b14-1             62.0b1-1
   firefox-developer-edition-i18n-xh            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-zh-cn            61.0b14-1             62.0b1-1
firefox-developer-edition-i18n-zh-tw            61.0b14-1             62.0b1-1
                           git-annex        6.20180529-15        6.20180529-16
                         gnome-boxes             3.28.4-1 3.28.5+7+g0c8a57d5-1
                                gtkd              3.8.3-1              3.8.3-2
                    haskell-aeson-qq             0.8.2-48             0.8.2-49
                   haskell-esqueleto    2.5.3.20180402-19    2.5.3.20180402-20
                        haskell-here            1.2.13-20            1.2.13-21
                       haskell-hpack            0.28.2-22            0.28.2-23
              haskell-hspec-wai-json             0.9.0-86             0.9.0-87
                 haskell-interpolate             0.2.0-24             0.2.0-25
    haskell-interpolatedstring-perl6             1.0.0-59             1.0.0-60
                  haskell-persistent             2.8.2-21             2.8.2-22
           haskell-persistent-sqlite           2.8.1.2-22           2.8.1.2-23
         haskell-persistent-template             2.5.4-46             2.5.4-47
                         haskell-rio           0.1.2.0-12            0.1.3.0-1
             haskell-servant-swagger             1.1.5-17             1.1.5-18
                    haskell-src-meta           0.8.0.2-25            0.8.0.3-1
                    haskell-swagger2             2.2.2-15             2.2.2-16
                       haskell-yesod             1.6.0-28             1.6.0-29
                  haskell-yesod-auth             1.6.3-28             1.6.3-29
                  haskell-yesod-form             1.6.1-28             1.6.1-29
            haskell-yesod-persistent             1.6.0-28             1.6.0-29
                  haskell-yesod-test             1.6.4-28             1.6.4-29
                             hledger             1.9.1-18             1.9.1-19
                         hledger-api             1.9.1-26             1.9.1-27
                          hledger-ui             1.9.1-20             1.9.1-21
                         hledger-web             1.9.2-29             1.9.2-30
                kvantum-theme-adapta           20180614-1           20180618-1
               kvantum-theme-materia           20180614-1           20180618-1
                                 ldc            1:1.9.0-1           1:1.10.0-1
                          liblphobos            1:1.9.0-1           1:1.10.0-1
                         materia-kde           20180614-1           20180618-1
                               minio         2018.04.19-5         2018.06.09-5
                            neofetch              4.0.2-1              5.0.0-1
                              nsjail                2.6-1                2.7-1
                     pandoc-crossref           0.3.2.0-43            0.3.2.1-1
                                pass              1.7.1-1              1.7.2-1
                           postgrest          0.4.4.0-166          0.4.4.0-167
                       python-docker              3.3.0-1              3.4.0-1
                      python-oslo-db             4.38.0-1             4.39.0-1
           python-oslo-serialization             2.26.0-1             2.27.0-1
                   python-oslo-utils             3.36.2-1             3.36.3-1
                     python-psycopg2              2.7.4-1              2.7.5-1
                       python-pyudev             0.21.0-2             0.21.0-3
                      python2-docker              3.3.0-1              3.4.0-1
                     python2-oslo-db             4.38.0-1             4.39.0-1
          python2-oslo-serialization             2.26.0-1             2.27.0-1
                  python2-oslo-utils             3.36.2-1             3.36.3-1
                    python2-psycopg2              2.7.4-1              2.7.5-1
                      python2-pyudev             0.21.0-2             0.21.0-3
                               stack             1.7.1-31             1.7.1-33
                               tilix              1.8.1-2              1.8.1-3


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-19           2018-06-20
-------------------------------------------------------------------------------
                         kinfocenter             5.13.0-1             5.13.1-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-19           2018-06-20
-------------------------------------------------------------------------------
                           bluedevil           1:5.13.0-1           1:5.13.1-1
                              breeze             5.13.0-1             5.13.1-1
                         breeze-grub             5.13.0-1             5.13.1-1
                          breeze-gtk             5.13.0-1             5.13.1-1
                         breeze-kde4             5.13.0-1             5.13.1-1
                            discover             5.13.0-1             5.13.1-1
                             drkonqi             5.13.0-1             5.13.1-1
                           evolution             3.28.2-1             3.28.3-1
                evolution-bogofilter             3.28.2-1             3.28.3-1
               evolution-data-server             3.28.2-1             3.28.3-1
                       evolution-ews             3.28.2-1             3.28.3-1
              evolution-spamassassin             3.28.2-1             3.28.3-1
                              falkon              3.0.1-3              3.0.1-4
                             fribidi              1.0.2-1              1.0.4-1
                                  gc              7.6.4-1              7.6.6-1
                              genius             1.0.23-3             1.0.24-1
                    gnome-calculator             3.28.1-1             3.28.2-1
                             goffice            0.10.40-1            0.10.41-1
                         imagemagick            7.0.8.1-1            7.0.8.2-1
                     imagemagick-doc            7.0.8.1-1            7.0.8.2-1
                        imagemagick6           6.9.10.1-1           6.9.10.2-1
                                js52             52.7.3-2             52.8.0-1
                   kactivitymanagerd             5.13.0-1             5.13.1-1
                       kde-cli-tools             5.13.0-1             5.13.1-1
                      kde-gtk-config             5.13.0-1             5.13.1-1
                         kdecoration             5.13.0-1             5.13.1-1
                    kdeplasma-addons             5.13.0-1             5.13.1-1
                             kgamma5             5.13.0-1             5.13.1-1
                            khotkeys             5.13.0-1             5.13.1-1
                         kinfocenter             5.13.0-1             5.13.1-1
                           kmenuedit             5.13.0-1             5.13.1-1
                          knetattach             5.13.0-1             5.13.1-2
                             kscreen             5.13.0-1             5.13.1-1
                       kscreenlocker             5.13.0-1             5.13.1-1
                         ksshaskpass             5.13.0-1             5.13.1-1
                           ksysguard             5.13.0-1             5.13.1-1
                         kwallet-pam             5.13.0-1             5.13.1-1
                kwayland-integration             5.13.0-1             5.13.1-1
                                kwin             5.13.0-1             5.13.1-1
                             kwrited             5.13.0-1             5.13.1-1
                           libdatrie             0.2.10-2             0.2.12-1
                              libdca              0.0.5-5              0.0.6-1
                            libinput             1.11.0-1             1.11.1-1
                          libkscreen             5.13.0-1             5.13.1-1
                        libksysguard             5.13.0-1             5.13.1-1
                           liblastfm              1.0.9-2                    -
                            liblouis              3.5.0-1              3.6.0-1
                           libmagick            7.0.8.1-1            7.0.8.2-1
                          libmagick6           6.9.10.1-1           6.9.10.2-1
                         libmygpo-qt              1.1.0-1                    -
                      libphonenumber              8.9.4-2              8.9.8-1
                        link-grammar              5.4.4-1              5.5.0-1
                               milou             5.13.0-1             5.13.1-1
                              oxygen             5.13.0-1             5.13.1-1
                         oxygen-kde4             5.13.0-1             5.13.1-1
          plasma-browser-integration             5.13.0-1             5.13.1-1
                      plasma-desktop             5.13.0-1             5.13.1-2
                  plasma-integration             5.13.0-1             5.13.1-1
                           plasma-nm             5.13.0-1             5.13.1-1
                           plasma-pa             5.13.0-1             5.13.1-1
                          plasma-sdk             5.13.0-1             5.13.1-1
                        plasma-vault             5.13.0-1             5.13.1-1
              plasma-wayland-session             5.13.0-1             5.13.1-1
                    plasma-workspace             5.13.0-1             5.13.1-1
         plasma-workspace-wallpapers             5.13.0-1             5.13.1-1
                    polkit-kde-agent             5.13.0-1             5.13.1-1
                          powerdevil             5.13.0-1             5.13.1-1
                            sddm-kcm             5.13.0-1             5.13.1-1
                      systemsettings             5.13.0-1             5.13.1-1
                        user-manager             5.13.0-1             5.13.1-1
              xdg-desktop-portal-kde             5.13.0-1             5.13.1-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Items from previous update sets

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

Here the complete list of our stable review.

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


#4

I voted that “No issue, everything went smoothly”, because IMO all that is within Manjaro’s control did go well.

My lingering issue, which i expected but am still sad to confirm, is the upstream bug https://bugs.kde.org/show_bug.cgi?id=395477

I confirm though that with my theme returned now to 100% Oxygen, the recent 5.13.0 NM bug is fixed here in 5.13.1.

Also, Desktop Cube seems to be good here, but i am only in a VM, & i do not use NVidia, so those might be factors.

[Manjaro_KDE_VM ~]$ uname -a
Linux Manjaro_KDE_VM 4.16.16-1-MANJARO #1 SMP PREEMPT Sat Jun 16 13:45:01 UTC 2018 x86_64 GNU/Linux

PS: Should we not push this to Stable til KDE revokes this warning? https://mail.kde.org/pipermail/release-team/2018-June/010988.html


#5

All good so far on XFCE.


#6

The update stopped due to a server problem, i try later

Vorgang konnte nicht abgeschlossen werden:
Konnte Datei 'lib32-mesa-18.1.2-0-x86_64.pkg.tar.xz' nicht von mirror.netzspielplatz.de übertragen : 
Operation too slow. Less than 1 bytes/sec transferred the last 30 seconds

update was ok

4.17.2-1-MANJARO #1 SMP PREEMPT Sat Jun 16 14:10:10 UTC 2018 x86_64 GNU/Linux


journalctl -p 3 -xb

systemd-vconsole-setup[408]: /usr/bin/loadkeys failed with exit status 1.
systemd-vconsole-setup[492]: /usr/bin/loadkeys failed with exit status 1.


#7

Xfce, all right, no problems. :grinning:


#8

Fixes to Plasma 5.13.1 uploaded today (ht @mparillo):


#10

With Plasma 5.13.1, the theme problem with big icons in plasma-nm are gone and all seems really nice now.
I have two other issues that are a deal breaker for me, at least for Plasma to be in the stable branch.

  1. The system tray bug that makes the system tray act weird (not opening some of the applets, not closing properly etc). Just open “system tray settings”, click on “Entries” and there you have it (no need for “ok” or “apply”). Reproducible every time on 5 different PC’s. (tested on Manjaro KDE and Neon, the same effect). Solution: restart plasmashell

  2. The “folder view” widget in the panel got messed up and the contents are unreadable (only 6 characters from the line and snows only one entry with scroll bar). Before that it was a perfect list with all entries, readable and without a scroll bar). I’ve tried different themes (breeze light|dark and arc themes) to check if maybe it’s theme related. The problem is a show stopper for me. But I can test this only on my machine. If someone else can check this and confirm it, that would be nice.

I would say that Plasma is good to go to stable when these fixes are in.


#11

Seems the new libinputfinally solved the left-click problem in my VM. :+1:


#12

The issue of missing desktop menu entries in Xfce has not been resolved. (Has also been described as a regression in Thunar custom actions.)

I am not sure if this needs to be addressed upstream. Not imporant enough to stall a stable release (presumably) but worth noting the issue again.


#13

Libinput update causes core dump and breaks functionality of libinput-gestures. There is already a patch but I’m not sure how quick it will be available:

Maybe manjaro stable libinput update should be withhold till the fixed version arrives?


#14

All good. I’ll push needed fixes to all mentioned issues within this thread with todays update.


Why is there hate for manjaro?
#15

I’m not having this issue on my end. Unstable branch, Plasma 5.13.1, Intel GPU with xf86-video-modesetting driver.


#16

I am getting this on all my systems also, using Oxygen theme, not Breeze.

What if you change theme to Oxygen?


#17

I spoke too soon. I tried again, and the entries are all gone. Also, I just clicked on the Networks icon in the system tray, and the list of hidden entries appeared. The same thing happens if I click on the volume or clipboard icon now. Only since I went into the Entries setting in the System Tray Settings.


#18

I have found bug reports for the empty entries and the other bug I mentioned in the above post.

https://bugs.kde.org/show_bug.cgi?id=390106
https://bugs.kde.org/show_bug.cgi?id=393630

It seems to me that these 2 bugs are related because both can be triggered by changing an entry from Auto to Hidden and back.


#19

Have you tried the latest testing update which has 5.13.1.1?


#20

I just installed but did not reboot yet.


#21

Is there a way to disable the new lock screen and login screen blur effect?

I really hate it but cannot find a setting to disable it … unselecting the blur desktop effect didn’t help.

EDIT :

No way to enable / disable or even configure this functionality, which has been raised as a bug.

https://bugs.kde.org/show_bug.cgi?id=395534

What were they thinking?