[Testing Update] 2018-06-16 - Kernels, KDE Plasma, Firefox, Haskell, Python

update
testing

#21

Place a :-1: button


#22

it is not recommended to change other users stuff/behaviour/settings at all.

If you really need to do that stuff, /etc/profile.d/ is the place for that.

If you really want to go to that level: So far it is 6 up’s and 4 likes to 0 downs :stuck_out_tongue:


#23

Exactly! So you shouldn’t. Not even /etc/bash.bashrc, so you agree you shouldn’t change this.
AFAIK, local bashrc supersedes etc settings, so no immediate problem.
/etc/skel/.bashrc is only for new users (no changes yet).
I can’t see the problem with the package update… sorry.


#24

Would you mind to explain to me how you want to establish global bash aliases without changing /etc/bash.bashrc ?


#25

Gladly!
It depends on your system multi-user scheme.
In a multi-user system, Administrators design and implement how the users’ standard settings will be, adjusting/editing /etc/skel*, so with each new user creation, they get those settings.
If those “other users” is yourself (multiple accounts), since you are the administrator, you know how to change the local .bashrc and thus controlling it.
If not, then you should let users have their own changes, bypassing system-wide (/etc/bash*.

Questions, please :man_teacher:


#26

Ok. May be I can learn something here.

I need to set PROMPT_COMMAND and PS1. I tried that with a script in /etc/profile.d/ but it did not work. Your help is appreciated.


#27

I need a solution for existing users to set global aliases and PS1 and PROMPT_COMMAND.


#28

We have been Off Topic for too long.
First do some search in Tutorials, the Forum, Manjaro Wiki, Archwiki and if you don’t find something helpful, you should Open a new topic.
Anyway, I am not an expert on your question, I just RTFM.


#29

:grinning:


#30

This and previous update cause some issues. Some are resolvable, some need upstream fixing. Will be posting a topic about that later today or tomorrow and link it here.

In overall, it’s not that bad, but there is at least one bug that is influencing badly workflow if someone uses “minimize all” widget (regression?).


#31

At least with Breeze theme, Plasma 5.13 is behaving nicely so far. No big bugs or regressions that I can see.

I’m having a problem where Manjaro dosn’t recognize anymore my external e-sata enclosure when connected after entering the OS, it does just when it is powered on before turning on the PC, but I don’t know for sure if the regressión was introduced in this update or the one before. Or a screwup from my part in some conf, more likely.

Anyway, thank you Manjaro team for another great update.


#32

It’s a great update to KDE, but…
I don’t like that they removed and changed so much with the mouse settings…
You can no longer pick mouse wheel scroll speed. Acceleration seems to be the new mouse speed? So no actual control over acceleration speed, just if it’s flat or adaptive and no way to turn it off completely?


#33

I got the message

Replace kuiserver with extra/plasma-workspace?

But other then that, everything was fine so far.

Update: I have the issue with the Network applet as well. KDE on Wayland.


#34

How about a heart with a little knife stuck in it next to the regular heart button? That would be good to use as a dislike icon. Or maybe a heart with a crack in the middle.


#35

Do you know what you could do? Give your widget support for the Oxygen theme and the default themes, and all others you can handle…


#36

What does this mean? I have no idea at all if you are helping me or mocking me. If the latter, then i don’t care. If the former, more explanation needed pls.


#37

Can’t say if it is related, but my lightdm screen on my Manjaro Deepin with testing based computer is completely messed up: gray background and white text on it… Nearly unusable :frowning:

Could be a bug in deepin-session-ui version 4.4.5 as lightdm-deepin-greeter is part of it.


#38

Besides, the poll doesn’t differentiate between DE users, so a lot of people will not experience the bugs mentioned for KDE, simply because they are using another DE.


#39

Replying myself. I tested on Archlinux and downgrading deepin-session-ui to 4.4.3 fixes this annoying bug.

See this bug report:

https://bugs.archlinux.org/task/59036

And reported upstream:


#40

Oberon fixed it in testing yesterday…
Same here [Stable Update] 2018-06-10 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin
and here Deepin Wallpaper Chooser Bug

The Deepin developer changed the path for desktop background.