[Testing Update] 2018-06-03 - Linux417, Systemd, Pamac


#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • Systemd got some more fixes and updates
  • Pamac v6.4 introduces an option to auto download updates (disabled by default) and using --search on pamac-manager will start Pamac directly in search-mode.
  • linux417 got updated to a more recent git-commit
  • Usual upstream rebuilds

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.112 [EOL]
  • linux41 4.1.51
  • linux44 4.4.135
  • linux49 4.9.105
  • linux414 4.14.47
  • linux415 4.15.18 [EOL]
  • linux416 4.16.13
  • linux417 4.17-rc7
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5

Package Updates (Sun Jun 3 08:05:57 CEST 2018)

  • testing core x86_64: 7 new and 7 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 20 new and 20 removed package(s)
  • testing community x86_64: 75 new and 67 removed package(s)

Overlay Updates

  • testing multilib x86_64: 1 new and 2 removed package(s)
  • testing core x86_64: 5 new and 5 removed package(s)
  • testing extra x86_64: 22 new and 23 removed package(s)
  • testing community x86_64: 1 new and 0 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                         gksu-polkit2:0.0.2.r3.gd7e3160-1              0.0.3-1
         manjaro-openbox-adapta-maia                1.0-1                1.0-4
              manjaro-openbox-config               1.18-7               1.18-8
     manjaro-openbox-wallpapers-18.0                1.0-5                1.0-6


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                               acorn              5.6.0-1              5.6.1-1
                      acpi_call-dkms            1.1.0-132            1.1.0-133
                                atom             1.27.1-1             1.27.2-1
                       audio-convert            0.3.1.1-7            0.3.1.1-8
                             bin2iso               1.9b-4               1.9b-5
                         broadcom-wl      6.30.223.271-19                    -
                             calibre             3.24.2-1             3.25.0-1
                             ccd2iso                0.3-8                0.3-9
                                cgal               4.11-2               4.12-1
                           chrootuid                1.3-6                1.3-7
                                dhex               0.68-3               0.68-4
                            dkfilter              0.11-10              0.11-11
                            dscanner              0.5.5-1              0.5.6-1
                               esmtp                1.2-6                1.2-7
                           fcrackzip                1.0-4                1.0-5
                     fillets-ng-data              1.0.1-1              1.0.1-2
                           flickcurl               1.26-2               1.26-3
                              hgview              1.9.0-1              1.9.0-2
                               hping              3.0.0-3              3.0.0-4
                             ipguard               1.04-3               1.04-4
                               jshon           20131105-1           20131105-2
              libperconaserverclient          5.7.21_21-2          5.7.22_22-1
                      lockfile-progs             0.1.17-1             0.1.17-2
                           mythes-hu           20101019-1           20101019-2
                           mythes-pl                1.5-2                1.5-3
      networkmanager-dispatcher-ntpd                1.0-6                1.0-7
  networkmanager-dispatcher-openntpd                1.0-5                1.0-6
      networkmanager-dispatcher-sshd                1.0-4                1.0-5
                             nrg2iso                0.4-9               0.4-10
                          open-iscsi            2.0.876-1            2.0.876-2
                     openttd-opengfx              0.5.4-1              0.5.4-2
                     openttd-opensfx              0.2.3-5              0.2.3-6
                  papirus-icon-theme           20180501-1           20180601-1
                      percona-server          5.7.21_21-2          5.7.22_22-1
              percona-server-clients          5.7.21_21-2          5.7.22_22-1
                perl-test-mockmodule               0.13-1               0.15-1
                  perl-text-template               1.52-1               1.53-1
                    python-construct             2.9.34-1             2.9.45-1
     python-google-api-python-client              1.6.7-1              1.7.0-1
                      python-netcdf4              1.4.0-1              1.4.0-2
                       python-pandas             0.22.0-1             0.23.0-1
                     python-pytables              3.4.3-1              3.4.3-2
             python-pytest-benchmark              3.1.1-1              3.1.1-2
                         python-sure              1.4.7-1             1.4.11-1
                   python-xlsxwriter              1.0.4-1              1.0.5-1
              python2-backports.lzma             0.0.10-1             0.0.11-1
                   python2-construct             2.9.34-1             2.9.45-1
    python2-google-api-python-client              1.6.7-1              1.7.0-1
                     python2-netcdf4              1.4.0-1              1.4.0-2
                      python2-pandas             0.22.0-1             0.23.0-1
                       python2-pychm            0.8.4.1-1            0.8.4.1-2
                    python2-pytables              3.4.3-1              3.4.3-2
            python2-pytest-benchmark              3.1.1-1              3.1.1-2
              python2-singledispatch            3.4.0.3-2            3.4.0.3-3
                        python2-sure              1.4.7-1             1.4.11-1
                  python2-xlsxwriter              1.0.4-1              1.0.5-1
                            ruby-ffi             1.9.23-1             1.9.24-1
                             scponly                4.8-9               4.8-10
                          shellcheck    0.4.7.20180521-14              0.5.0-1
                       speakup-utils              3.1.6-3              3.1.6-4
                               tilix              1.8.1-1              1.8.1-2
                                 ucl               1.03-7               1.03-8
                           uglify-js             3.3.28-1              3.4.0-1
                              unhide           20130526-1           20130526-2
                                uucp               1.07-4               1.07-5
                          xloadimage               4.1-13               4.1-14
                            xsensors               0.70-5               0.70-6
                             diffpdf                    -            2.1.3.1-1
                       otf-fira-code                    -              1.205-2
                 perl-test-more-utf8                    -               0.05-1
              python-netcdf4-openmpi                    -              1.4.0-2
                     python-objgraph                    -              3.4.0-1
             python2-netcdf4-openmpi                    -              1.4.0-2
                    python2-objgraph                    -              3.4.0-1
                       ttf-fira-code                    -              1.205-2
                                xpra                    -              2.3.1-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                          libsystemd             238.76-1            238.133-1
                            linux4174.17.r180531.dd52cb8-14.17.r180602.4277e6b-1
                    linux417-headers4.17.r180531.dd52cb8-14.17.r180602.4277e6b-1
                             systemd             238.76-1            238.133-1
                  systemd-sysvcompat             238.76-1            238.133-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                        b43-fwcutter                019-1                019-2
                           ifenslave              1.1.0-8             1.1.0-10
                            jfsutils             1.1.15-4             1.1.15-5
                mkinitcpio-nfs-utils                0.3-5                0.3-6
                             p11-kit            0.23.10-1            0.23.12-1
                           run-parts              4.8.4-1              4.8.6-1
                      wireless_tools            30.pre9-1            30.pre9-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                            devtools           20180528-1           20180531-1
                             librsvg2:2.42.4+8+g915a15b5-1                    -
                  linux417-acpi_call           1.1.0-0.18           1.1.0-0.19
                   linux417-bbswitch             0.8-0.18             0.8-0.19
                linux417-broadcom-wl    6.30.223.271-0.18    6.30.223.271-0.19
                   linux417-catalyst   1:15.201.1151-0.18   1:15.201.1151-0.19
                linux417-ndiswrapper            1.61-0.18            1.61-0.19
                     linux417-nvidia        1:396.24-0.18        1:396.24-0.19
               linux417-nvidia-304xx       1:304.137-0.18       1:304.137-0.19
               linux417-nvidia-340xx         340.106-0.18         340.106-0.19
               linux417-nvidia-390xx          390.59-0.18          390.59-0.19
                   linux417-nvidiabl            0.88-0.18            0.88-0.19
                      linux417-r8168        8.045.08-0.18        8.045.08-0.19
                        linux417-spl           0.7.9-0.18           0.7.9-0.19
                   linux417-tp_smapi            0.41-0.18            0.41-0.19
                linux417-vhba-module        20161009-0.18        20161009-0.19
   linux417-virtualbox-guest-modules          5.2.12-0.18          5.2.12-0.19
    linux417-virtualbox-host-modules          5.2.12-0.18          5.2.12-0.19
                        linux417-zfs           0.7.9-0.18           0.7.9-0.19
                               pamac             6.3.92-1              6.4.0-1
             pamac-tray-appindicator             6.3.92-1              6.4.0-1
                         thunar-gtk3              1.7.2-3              1.7.2-4
                 xfce4-settings-gtk3             4.13.2-1             4.13.2-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                                dkms                2.5-1                2.5-3
                                  go           2:1.10.2-1           2:1.10.2-2
                              go-pie           2:1.10.2-1           2:1.10.2-2
                     grml-zsh-config             0.14.3-1             0.15.0-1
                             ifplugd              0.28-14              0.28-15
                             ilmbase              2.2.1-2              2.2.1-3
                          libmm-glib 1.8rc2+1+g7e949283-1              1.8.0-1
                             librsvg           2:2.42.4-1           2:2.42.5-1
                             metalog                3.0-2                3.0-3
                          mkisolinux            2013.05-1            2013.05-2
                        modemmanager 1.8rc2+1+g7e949283-1              1.8.0-1
                           mythes-fr                2.3-2                2.3-3
                           mythes-ro                3.3-5                3.3-6
                                ossp             1.3.2-15             1.3.2-16
                     perl-date-manip               6.70-1               6.71-1
                          python-pip              9.0.1-3             10.0.1-1
                         python2-pip              9.0.1-3             10.0.1-1
                  ttf-freebanglafont           20130212-2           20130212-3
                      vulkan-headers           1:1.1.75-1           1:1.1.76-1
                    vulkan-html-docs           1:1.1.75-1           1:1.1.76-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                       lib32-librsvg 2.42.4+8+g915a15b5-1                    -
                       lib32-systemd             238.76-1            238.133-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-06-01           2018-06-03
-------------------------------------------------------------------------------
                       lib32-librsvg             2.42.4-1             2.42.5-1
                       lib32-p11-kit            0.23.10-1            0.23.11-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

This is a wiki post; please edit as necessary.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


Items from previous update sets

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension “Workspace to Dock” is bugged

Be careful like there is a bug if you use the Extension “Workspace to Dock”. You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file’s syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name “Everyone” to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There’s a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


#3

Everything goes well. Great!


#4

appears now on to update from AUR

“gnome-mime-data 2.18.0-7 7 -> 8”

yaourt -Qi gnome-mime-data
Nome : gnome-mime-data
Versão : 2.18.0-7
Descrição : The base MIME and Application database for GNOME
Arquitetura : any
URL : http://www.gnome.org
Licenças : GPL
Grupos : Nenhum
Provê : Nenhum
Depende de : shared-mime-info
Depend. opcionais : Nenhum
Necessário para : gnome-vfs
Opcional para : Nenhum
Conflita com : Nenhum
Substitui : Nenhum
Tamanho instalado : 3,45 MiB
Empacotador : Felix Yan felixonmars@gmail.com
Data da compilação : ter 01 jul 2014 12:28:03 -03
Data de instalação : sáb 30 jul 2016 14:03:37 -03
Motivo da instalação : Instalado como dependência de outro pacote
Script de instalação : Não
Validado por : Assinatura

Any problem in installed it?
I mean, from AUR?


#5

A list of errors like python-pip: '/usr/lib/python3.6/site-packages/pip/_internal/models/__init__.py' exists, I had to remove all these files.


#6

Have you mixed pip installs with repo installs? cuz thats usually what that means


#7

Seems that was the reason. I didn’t think of it cuz pip installs were made long ago, I even forgot about that.


#8

Got a lot of messages on python-colorama wanting to install files already in place on the system. (Didn’t save the messages, Sorry!)
Solved it by uninstalling python-reportlab and python-pip. Can’t even remember when or why those packages got installed. Maybe something with some AUR package…


#9

Smooth update, again, but I can’t vote twice. :stuck_out_tongue_winking_eye:


#10

The following were updated:
[2018-06-03 08:51] [ALPM] installed python-msgpack (0.5.6-1)
[2018-06-03 08:51] [ALPM] installed python-cachecontrol (0.12.4-1)
[2018-06-03 08:51] [ALPM] installed python-colorama (0.3.9-1)
[2018-06-03 08:51] [ALPM] installed python-distlib (0.2.7-1)
[2018-06-03 08:51] [ALPM] installed python-distro (1.3.0-1)
[2018-06-03 08:51] [ALPM] installed python-webencodings (0.5.1-1)
[2018-06-03 08:51] [ALPM] installed python-html5lib (1.0.1-2)
[2018-06-03 08:51] [ALPM] installed python-lockfile (0.12.2-2)
[2018-06-03 08:51] [ALPM] installed python-progress (1.3-2)
[2018-06-03 08:51] [ALPM] installed python-pytoml (0.1.15-1)
[2018-06-03 08:51] [ALPM] installed python-retrying (1.3.3-3)


#11

I love the new art and styling! :slight_smile:

Is there a chance some official Manjaro Xfce HiDPI themes could be included?


#12

Sorry for the delay of this update-set. I had a lot of work to start the gitlab migration. With this we have now new kernels. Hope to ship this to stable soon …


#13

Please be aware this bug:

And this plasma-framework commit for fix:
https://cgit.kde.org/plasma-framework.git/commit/?id=d15f0fa8322dc2632f15024457bea41e7dd058d7


#14

linux417-4.17.0-1 is somewhat buggy on my AMD Jaguar machine with Gnome, Wayland and amdgpu.

  • input froze at GDM, maybe because I haven’t logged in immediately. journalctl doesn’t give any hints.

  • inox-dev browser (compiled from AUR with linux416 two days ago) gives this output

eugen@mjro Linux 4.17.0-1-MANJARO x86_64 Thu Jun 7 09:33:44 CEST 2018
~ >>> dnox                                                                     
zsh: segmentation fault  dnox
~ >>> 

inox-dev already failed to start with the previous linux417-rc… version.
This is what journalctl writes about dnox:
Jun 07 09:49:29 mjro kernel: 2222 (dnox): Uhuuh, elf segment at 0000560535d28000 requested but the memory is mapped already


#15

…also in my VirtualBox VM [all sorts of strange things happened, trying to click some normally-clickable screen elements does nothing, but other screen elements that should remain static on-screen get “dragged around” by the pointer]. I had to boot the VM back down into 4.16 before normality returned. Exciting! :wink:


[Testing Update] 2018-06-09 - Kernels, KDE Apps, LibreOffice, Firefox, GCC, Gambas, Deepin
#16

I am running the 417 line for weeks now on my bare metal laptop (all intel) and have not experienced anything like that.
So far it behaves very well, also the recend move to final point release did not bring up any negative things for me (so far)


#17

Error, don’t understand why:


#18

It looks like an AUR package.
Try to uninstall it first. Finish the normal upgrade (no AUR) and install it then.


#19

I did have a google-chrome added to the update. When I got the error I caught it on Screenshot to report it, then, closed and got another notice about an update of google-chrome. After the second update I did not have the error, that must be it. I understand github was bought out by Microsoft? Is nothing sacred?


#20

Everything and nothing has to do with that!!
The whole world is falling apart!
Though your issue has no relation at all to that…