[Testing Update] 2018-05-30 - Deepin, Kernels, Pacman 5.1, Pamac, Firefox, QT 5.11

update
testing

#1

Hi community,

Welcome to another testing update. So what do we have with this one?

  • We worked on our themes
  • Deepin got another set of updates
  • Pacman 5.1 got released. Changes and News can be found here
  • Pamac 6.3.92 adds automatic download of packages and support for the pacman
  • Latest Firefox development edition
  • A lot of Haskell updates
  • Newer Firmwares and updates to Grub
  • Some fixes to Calamares
  • QT 5.11 got added
  • Latest Wine

We hope with all these changes Manjaro to be more efficient for you all.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.110 [EOL]
  • linux41 4.1.51
  • linux44 4.4.133
  • linux49 4.9.103
  • linux414 4.14.44
  • linux415 4.15.18 [EOL]
  • linux416 4.16.12
  • linux417 4.17-rc7
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5

Package Updates (Wed May 30 08:50:41 CEST 2018)

  • testing core x86_64: 5 new and 5 removed package(s)
  • testing multilib x86_64: 18 new and 18 removed package(s)
  • testing extra x86_64: 106 new and 102 removed package(s)
  • testing community x86_64: 930 new and 890 removed package(s)

Overlay Updates

  • testing core x86_64: 8 new and 8 removed package(s)
  • testing multilib x86_64: 0 new and 3 removed package(s)
  • testing extra x86_64: 44 new and 43 removed package(s)
  • testing community x86_64: 53 new and 50 removed package(s)

The full package list can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

wiki post

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64'

Remove ffmpeg2.8 as it is no longer required.


Installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’ required by ffmpeg2.8
[Unstable Update] 2018-05-25 - Kernels, QT5, Xorg-Server, Mesa
#3

Why is Mesa 18.1 being held back?


#4

Oops sorry: just realized this is for testing branch, I’m on unstable.


#5

So far so good updating the KDE edition.
Just had to verify and merge grup.pacnew, and also pamac.conf.pacnew
I had also a warning message about different permissions in /var/lib/samba/private , where filesystem is 700 and package 750. I cannot see any issue for the moment, but should I change those permissions ?


#6

Hi,

@pierrep56

you can find the information concerning samba permissions here.


#7

This is a good thing. There’s normally always a few “show stoppers” in the Mesa *.0 releases. Waiting for 18.1.1 is a good idea. Not that I know this is the case… Just my opinion and theory :grin:


#8

Big KDE update … around 100 packages and 700MB download.

No issues so far.

New krusader version though has introduced a massively intrusive mouse over tooltip window, and they haven’t provided a setting to tune it or turn it off … :poop:


#9

All goes well besides a little message on my Deepin installation: I had to “downgrade” deepin-dock to 4.3.6.4-2.


#10

Be a little more specific on the issue.


#11

I got:

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64'
pacman -Qo libx265.so.151
/usr/lib/libx265.so.151 is owned by x265 2.7-1

Edit: seems ffmpeg2.8 is an AUR package, at least now. No idea why/when I intstalled. Not listed as required by anything.

Edit2: looks like it was required (by at least vlc) but got removed from Arch repositories some time ago - see: https://bbs.archlinux.org/viewtopic.php?id=235203. There is now an AUR version if anyone does end up needing it.


#12

I’ve been getting this warning in pamac recently:
procps-ng: local (3.3.15-1.0) is newer than core (3.3.14-1.2)

Someone said to downgrade the package earlier…should I just ignore it?


RSSOwl crashes after last system update
#13

Hi,

something similar is here. May this helps somehow.


#14

I downgraded it 1-2 days ago (# pacman -S procps-ng) and everything is fine


#15

3.3.15 has a soname version bump so breaks various bits of software. If none of your software is broken you can ignore this.


#16

On my system /usr/bin/pacsort from package pacman-5.1.0 relies on libalpm.so.10 but only libalpm.so.11 is provided. This also breaks paccache -r. As a temporary workaround I have symlinked libalpm.so.11.0.0 to /usr/local/lib/libalpm.so.10 (and /usr/local/lib is in my ld.so search path).


#17

I simply got a warning: deepin-dock 4.6.4-1 (local) is newer than deepin-dock 4.3.6.4-2.

So, in order to be clean, I “downgraded” deepin-dock. As simple as that. Besides this? Nothing at all.


#18

Typo
[2018-05-30 15:49] [ALPM] downgraded deepin-dock (4.6.4-1 -> 4.6.3.4-2)


#19
$ uname -a
Linux Manjaro_KDE_VM 4.16.12-1-MANJARO #1 SMP PREEMPT Fri May 25 18:39:04 UTC 2018 x86_64 GNU/Linux

I thought the update went ok, but discovered that the new Octopi Cache Cleaner UI is now broken… both its window panes are blank, & refreshing does not help.


#20

paccache and pamac-clean-cache giving error

pacsort: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

Reported to Pacman v5.1.0 breaks some tools