[Testing Update] 2018-05-25 - Kernels, Nvidia, Xorg-Server, Mesa, Browsers, Deepin, Calamares, Pamac

update
testing

#1

Since I worked on our testing branch without announcing anything on the 19th of May, it seemed I’d broken some systems (see below). Therefore I’d briefly track my work log for the coming days here. Ongoing updates may be followed here.

Issues we had on the 19th:



Updates so far

2018-05-25

2018-05-24

2018-05-23

2018-05-22

2018-05-21

2018-05-20

2018-05-19


Update Preview

As always please test and report back any issues you may find!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Make Branch separation on lists.manjaro.org
#2

For me it’s O.K. in my system with Xfce4. Looks like everything is working. Anyway I will wait:

Pacotes (1) lib32-wayland-1.15.0-0

Tamanho total download:   0,14 MiB
Tamanho total instalado:  0,47 MiB
Alteração no tamanho:   0,31 MiB

:: Continuar a instalação? [S/n] n

I have mesa 18.0.4-0 installed and is working.


#3

This was the only thing i got as error, fixed by removing the files and making the update again

lib32-wayland: /usr/lib32/libwayland-egl.so exists in filesystem
lib32-wayland: /usr/lib32/libwayland-egl.so.1 exists in filesystem
lib32-wayland: /usr/lib32/libwayland-egl.so.1.0.0 exists in filesystem
lib32-wayland: /usr/lib32/pkgconfig/wayland-egl.pc exists in filesystem

#4

@philm
I did a check on which package owned this, and wonder if we should wait until lib-32mesa is updated?

pacman -Qo /usr/lib32/libwayland-egl.so
/usr/lib32/libwayland-egl.so is owned by lib32-mesa 18.1.0-0


#5

Here same as bogdancovaciu(thanks for posting that btw), removed the Wayland files he outlined-- I received the same error message as did he, removed the files and the pacman -Syyu update went fine. I went through the business yesterday with Wayland and recovered from that(Wayland/mesa dependency) so after removing the offending files no problem.

`inxi -Fzc0
System:
  Host: OrphanedInode3 Kernel: 4.16.10-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.12.4 Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:
  Type: Desktop System: ASUS product: All Series v: N/A serial: N/A 
  Mobo: ASUSTeK model: SABERTOOTH Z97 MARK 1/USB 3.1 v: Rev 1.xx serial: N/A 
  UEFI [Legacy]: American Megatrends v: 2801 date: 11/11/2015 
CPU:
  Topology: Quad Core model: Intel Core i7-4790 bits: 64 type: MT MCP 
  L2 cache: 8192 KiB 
  Speed: 3624 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3807 2: 3728 
  3: 3783 4: 3742 5: 3725 6: 3671 7: 3637 8: 3700 
Graphics:
  Card-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 396.24 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 

the pacman error and packages before Wayland file removal

Packages (17) lib32-nvidia-utils-1:396.24-2  lib32-wayland-1.15.0-0
              linux414-4.14.42-1  linux414-headers-4.14.42-1
              linux414-nvidia-1:396.24-3  linux414-r8168-8.045.08-26
              linux416-4.16.10-1  linux416-headers-4.16.10-1
              linux416-nvidia-1:396.24-3  linux416-r8168-8.045.08-9
              linux49-4.9.101-1  linux49-headers-4.9.101-1
              linux49-nvidia-1:396.24-3  linux49-r8168-8.045.08-18
              mhwd-nvidia-390xx-390.59-1  nvidia-utils-1:396.24-2
              vertex-maia-themes-20180519-1
error: failed to commit transaction (conflicting files)
lib32-wayland: /usr/lib32/libwayland-egl.so exists in filesystem
lib32-wayland: /usr/lib32/libwayland-egl.so.1 exists in filesystem
lib32-wayland: /usr/lib32/libwayland-egl.so.1.0.0 exists in filesystem
lib32-wayland: /usr/lib32/pkgconfig/wayland-egl.pc exists in filesystem
Errors occurred, no packages were upgraded.


``
Hope this might help someone else.

#6

Third wave of this update went well, but i was wondering if i should wait, or keep checking them as they come and install ?

resolving dependencies...
looking for conflicting packages...
Packages (30) atom-1.27.0-1 c-ares-1.14.0-1 ca-certificates-mozilla-3.37-1 dolphin-18.04.1-2 e2fsprogs-1.44.2-1
gst-libav-1.14.1-1 gst-plugins-bad-1.14.1-1 gst-plugins-base-1.14.1-1 gst-plugins-base-libs-1.14.1-1
gst-plugins-good-1.14.1-1 gst-plugins-ugly-1.14.1-1 gstreamer-1.14.1-1 imagemagick-7.0.7.33-1
intel-tbb-2018_20180312-1 jemalloc-1:5.1.0-1 k3b-1:18.04.1-3 libcurl-compat-7.60.0-1 libdrm-2.4.92-1
libinput-1.10.7-1 libmagick-7.0.7.33-1 libmagick6-6.9.9.45-1 libnetfilter_conntrack-1.0.7-1 libsrtp-1:2.2.0-1
neofetch-4.0.2-1 nss-3.37-1 plasma5-applets-thermal-monitor-1.2.9-1 python-setuptools-1:39.2.0-1
python2-setuptools-1:39.2.0-1 qqc2-desktop-style-5.46.2-1 wayland-protocols-1.14-1
Total Download Size: 69,75 MiB
Total Installed Size: 435,41 MiB
Net Upgrade Size: 2,95 MiB

#7

lib32-mesa has been successfully fixed in unstable :smile: No longer get conflict.


#8

So far so good. This awful update was done right :slight_smile:


#9

When we have some showstopper bugs in unstable I’ve to use testing similar and therefore it become also unstable some times …


#10

Ouch! At least, I know that now. Thanks for the info.

And my inxi:

inxi -Fxz
System:
  Host: fredo-manja-laptop Kernel: 4.16.10-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.1.0 Desktop: MATE 1.20.0 
  Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:
  Type: Laptop System: TOSHIBA product: Satellite L300 v: PSLB8E-162014FR 
  serial: N/A 
  Mobo: TOSHIBA model: Portable PC serial: N/A BIOS: INSYDE v: 1.90 
  date: 06/04/2009

#11

fixed the lib32-wayland issue with the --force parameter on pacman -Syu. So far so good except that it tells me that it doesn’t want to update linux-firmware and linux417 because I have newer one installed.
Unstable branch with mesa 18.1, xorg-server 1.20.


#12

For those 2 packages you have to downgrade to upgrade as @philm said in another thread about the firmaware. Do as I did:

sudo pacman -Sy linux-firmware

which does the upgrade :stuck_out_tongue: for the firmware.


#13
==> Software upgrade (new version) :
core/linux-firmware 20180507.8fc2d4e-1 -> 20180518.2a9b2cf-1
extra/mesa          18.0.3-1           -> 18.0.4-0
extra/pamac         6.3.1-1            -> 6.3.2-1
extra/wayland       1.14.0-1           -> 1.15.0-0
multilib/lib32-mesa 18.0.3-1           -> 18.0.4-0

Manjaro Testing, Kernel 4.16.x, GNOME w/ GDM, nVidia 1060 GTX (w/ Proprietary Drivers) on System 76 Oryx Pro 3.

Issues to Report: None, GNOME and GDM both started as per usual.


#14

My “third wave” went fine as well…no issues at all 52 packages updated, restarted, no messages on boot other than the usual. My inxi is in an earlier post here.


#15

From reading those other threads, it seems as long as mesa 18.0.4 and wayland 1.15.0 are updating together, everything should be fine (maybe also the lib32 versions). They did, and it did.

Except I got:
warning: linux-firmware: local (20180518.86d39f8-1) is newer than core (20180518.2a9b2cf-1)

But

fixed it.

This is on linux 416 Xfce btw.


#16

Upgrading from terminal on 2 machines with KDE edition… No problem so far, rebooted and all seems OK. It was too difficult to wait and keep looking at the red octopus… :innocent:


#17

Ah, what an admirable, intrepid crew! When told not to update, you take it as a challenge. Full speed ahead, and damn the torpedoes!

(Not that great at taking orders, though…)


#18

This was a versioning problem in the repos, actually you have to downgrade to upgrade. :stuck_out_tongue_closed_eyes:


#19

Aye, aye, cap’n! :wink: Taking the plunge now…fingers crossed…

Edit: So far, so good!


#20

Whoops, did not read about problems, update booted fine.

bob@Manjaro-Testing~$ inxi-Fxz

[bob@Manjaro-Testing ~]$ inxi -Fxz
System:
  Host: Manjaro-Testing Kernel: 4.17.0-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.1.0 Desktop: N/A Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e serial: N/A 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: N/A BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
CPU:
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25549 
  Speed: 798 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Card-1: NVIDIA GK208 [GeForce GT 720] driver: nvidia v: 396.24 
  bus ID: 01:00.0 
  Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 
  direct render: Yes 
Audio:
  Card-1: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Card-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.17.0-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  HDD Total Size: 1.82 TiB used: 24.67 GiB (1.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: Elements 25A2 
  size: 931.48 GiB 
Partition:
  ID-1: / size: 449.57 GiB used: 24.67 GiB (5.5%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 47 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Info:
  Processes: 198 Uptime: 4m Memory: 7.73 GiB used: 692.9 MiB (8.8%) 
  Init: systemd Compilers: gcc: 8.1.0 Shell: bash v: 4.4.19 inxi: 3.0.08