[Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. This time our most effort went into updating our toolchain with GCC v8.1.0. This needed updates or recompiling of all our kernels.

Other than that, we had the following updates:

  • LibreOffice is now at v6.0.4
  • KDE Apps got updated to v18.04.1
  • Gnome is now at v3.28.2, which is the last point release of that series
  • Small fixes to Cinnamon got added as well
  • Last, we updated Palemoon and Firefox with the latest security fixes

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.99
  • linux414 4.14.40
  • linux415 4.15.18 [EOL]
  • linux416 4.16.8
  • linux417 4.17-rc4
  • linux414-rt 4.14.39_rt29
  • linux416-rt 4.16.7_rt1

Package Updates (Fri May 11 11:47:30 CEST 2018)

  • testing community x86_64: 442 new and 431 removed package(s)
  • testing core x86_64: 34 new and 35 removed package(s)
  • testing extra x86_64: 588 new and 591 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)

A detailed list of all package changes may be found here.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

This is a wiki post; please edit as necessary.


gcc54 and gcc5 are in conflict.

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


#3

Everything fine after the reboot. Everything is running, no problems. Thanks for the good work.


#4

NOTE, 4.15.18 is the last release of the 4.15.y kernel.
It is now end-of-life.

It is recommend to move on to linux416-series.
Use followed cmd to do that: 'sudo mhwd-kernel -i linux416'
[mint@deepin ~]$ sudo mhwd-kernel -i linux416
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update.

That confuses me now.* pacman -Syu is ok? :wink: Fixed with

sudo mhwd-kernel -r linux415
  • found Markdown syntax :smiley:

Everything else is fine :slight_smile:

Upgrade
Synchronisiere Paketdatenbanken...
Starte komplettes System-Upgrade...

Abhängigkeiten werden aufgelöst...
Interne Konflikte werden ĂĽberprĂĽft...
Lade herunter...
Herunterladen von tzdata-2018e-1-any.pkg.tar.xz...
Herunterladen von glibc-2.27-3-x86_64.pkg.tar.xz...
Herunterladen von binutils-2.30-4-x86_64.pkg.tar.xz...
Herunterladen von gcc-libs-8.1.0-1-x86_64.pkg.tar.xz...
Herunterladen von libgpg-error-1.31-1-x86_64.pkg.tar.xz...
Herunterladen von libpsl-0.20.2-1-x86_64.pkg.tar.xz...
Herunterladen von pinentry-1.1.0-3-x86_64.pkg.tar.xz...
Herunterladen von libtirpc-1.0.3-2-x86_64.pkg.tar.xz...
Herunterladen von libtool-2.4.6+40+g6ca5e224-6-x86_64.pkg.tar.xz...
Herunterladen von gcc-8.1.0-1-x86_64.pkg.tar.xz...
Herunterladen von lib32-glibc-2.27-3-x86_64.pkg.tar.xz...
Herunterladen von lib32-gcc-libs-8.1.0-1-x86_64.pkg.tar.xz...
Herunterladen von linux414-4.14.40-1-x86_64.pkg.tar.xz...
Herunterladen von linux415-4.15.18-2-x86_64.pkg.tar.xz...
Herunterladen von linux416-4.16.8-1-x86_64.pkg.tar.xz...
Herunterladen von blas-3.8.0-2-x86_64.pkg.tar.xz...
Herunterladen von cblas-3.8.0-2-x86_64.pkg.tar.xz...
Herunterladen von mesa-18.0.3-1-x86_64.pkg.tar.xz...
Herunterladen von librsvg-2:2.42.4-1-x86_64.pkg.tar.xz...
Herunterladen von libsoup-2.62.2-1-x86_64.pkg.tar.xz...
Herunterladen von gnome-desktop-1:3.28.2-1-x86_64.pkg.tar.xz...
Herunterladen von webkit2gtk-2.20.2-1-x86_64.pkg.tar.xz...
Herunterladen von evolution-data-server-3.28.2-1-x86_64.pkg.tar.xz...
Herunterladen von evolution-3.28.2-1-x86_64.pkg.tar.xz...
Herunterladen von firefox-60.0-0.2-x86_64.pkg.tar.xz...
Herunterladen von libmypaint-1.3.0-4-x86_64.pkg.tar.xz...
Herunterladen von mypaint-brushes-1.3.0-2-any.pkg.tar.xz...
Herunterladen von lapack-3.8.0-2-x86_64.pkg.tar.xz...
Herunterladen von gnome-keyring-1:3.28.2-1-x86_64.pkg.tar.xz...
Herunterladen von gvfs-1.36.2-1-x86_64.pkg.tar.xz...
Herunterladen von gvfs-afc-1.36.2-1-x86_64.pkg.tar.xz...
Herunterladen von gvfs-gphoto2-1.36.2-1-x86_64.pkg.tar.xz...
Herunterladen von gvfs-mtp-1.36.2-1-x86_64.pkg.tar.xz...
Herunterladen von gvfs-smb-1.36.2-1-x86_64.pkg.tar.xz...
Herunterladen von libraw-0.18.11-1-x86_64.pkg.tar.xz...
Herunterladen von libreoffice-fresh-6.0.4-1-x86_64.pkg.tar.xz...
Herunterladen von libreoffice-fresh-de-6.0.4-1-any.pkg.tar.xz...
Herunterladen von libuv-1.20.3-1-x86_64.pkg.tar.xz...
Herunterladen von libxnvctrl-396.24-1-x86_64.pkg.tar.xz...
Herunterladen von linux414-broadcom-wl-6.30.223.271-37-x86_64.pkg.tar.xz...
Herunterladen von linux414-nvidia-1:396.24-2-x86_64.pkg.tar.xz...
Herunterladen von linux414-r8168-8.045.08-25-x86_64.pkg.tar.xz...
Herunterladen von linux415-broadcom-wl-6.30.223.271-18-x86_64.pkg.tar.xz...
Herunterladen von linux415-nvidia-1:396.24-2-x86_64.pkg.tar.xz...
Herunterladen von linux415-r8168-8.045.08-18-x86_64.pkg.tar.xz...
Herunterladen von linux416-broadcom-wl-6.30.223.271-8-x86_64.pkg.tar.xz...
Herunterladen von linux416-nvidia-1:396.24-2-x86_64.pkg.tar.xz...
Herunterladen von linux416-r8168-8.045.08-8-x86_64.pkg.tar.xz...
Herunterladen von python-packaging-17.1-1-any.pkg.tar.xz...
Herunterladen von wget-1.19.5-1-x86_64.pkg.tar.xz...
Herunterladen von compton-0.1_beta2.5-11-x86_64.pkg.tar.xz...
Herunterladen von deepin-qt5dxcb-plugin-1.1.8.6-1-x86_64.pkg.tar.xz...
Herunterladen von dtkwidget-2.0.8-3-x86_64.pkg.tar.xz...
Herunterladen von libfilezilla-0.12.2-1-x86_64.pkg.tar.xz...
Herunterladen von filezilla-3.33.0-1-x86_64.pkg.tar.xz...
Herunterladen von gendesk-0.7-2-x86_64.pkg.tar.xz...
Herunterladen von gimp-plugin-gmic-2.2.2-2-x86_64.pkg.tar.xz...
Herunterladen von gmic-2.2.2-2-x86_64.pkg.tar.xz...
Herunterladen von hdf5-1.10.1-3-x86_64.pkg.tar.xz...
Herunterladen von xapps-1.2.1-1-x86_64.pkg.tar.xz...
Herunterladen von nemo-3.8.2-1-x86_64.pkg.tar.xz...
Herunterladen von nodejs-10.1.0-1-x86_64.pkg.tar.xz...
Herunterladen von npm-6.0.1-1-any.pkg.tar.xz...
Herunterladen von pcsclite-1.8.23-3-x86_64.pkg.tar.xz...
ĂśberprĂĽfe SchlĂĽsselring...
Integrität wird überprüft...
Paketdateien werden geladen...
Dateikonflikte werden ĂĽberprĂĽft...
ĂśberprĂĽfe verfĂĽgbaren Speicherplatz...
Starte Pre-Transaction-Hooks...
Remove DKMS modules
==> No kernel 4.15.18-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.16.7-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.14.39-1-MANJARO headers. You must install them to use DKMS!
Remove Firefox Distribution Settings
Erneuere tzdata (2018d-1 -> 2018e-1)...
Erneuere glibc (2.27-2 -> 2.27-3)...
Generating locales...
  de_DE.UTF-8... done
  de_DE.ISO-8859-1... done
  de_DE.ISO-8859-15@euro... done
Generation complete.
Erneuere binutils (2.30-3 -> 2.30-4)...
Erneuere gcc-libs (7.3.1+20180406-1 -> 8.1.0-1)...
Erneuere blas (3.8.0-1 -> 3.8.0-2)...
Erneuere cblas (3.8.0-1 -> 3.8.0-2)...
Erneuere libgpg-error (1.29-1 -> 1.31-1)...
Erneuere mesa (18.0.3-0 -> 18.0.3-1)...
Erneuere libpsl (0.20.2-0 -> 0.20.2-1)...
Erneuere pinentry (1.1.0-2 -> 1.1.0-3)...
Erneuere libtirpc (1.0.3-1 -> 1.0.3-2)...
Erneuere compton (0.1_beta2.5-10 -> 0.1_beta2.5-11)...
Erneuere deepin-qt5dxcb-plugin (1.1.8.4-1 -> 1.1.8.6-1)...
Erneuere librsvg (2:2.42.3-1 -> 2:2.42.4-1)...
Erneuere dtkwidget (2.0.8-2 -> 2.0.8-3)...
Erneuere libtool (2.4.6+40+g6ca5e224-5 -> 2.4.6+40+g6ca5e224-6)...
Erneuere libsoup (2.62.1-1 -> 2.62.2-1)...
Erneuere gnome-desktop (1:3.28.1+3+g436ca8f0-1 -> 1:3.28.2-1)...
Erneuere webkit2gtk (2.20.1-1 -> 2.20.2-1)...
Erneuere evolution-data-server (3.28.1-1 -> 3.28.2-1)...
Erneuere evolution (3.28.1-1 -> 3.28.2-1)...
Erneuere libfilezilla (0.12.1-1 -> 0.12.2-1)...
Erneuere filezilla (3.32.0-1 -> 3.33.0-1)...
Erneuere firefox (60.0-0 -> 60.0-0.2)...
Erneuere gcc (7.3.1+20180406-1 -> 8.1.0-1)...
Erneuere gendesk (0.7-1 -> 0.7-2)...
Erneuere libmypaint (1.3.0-3 -> 1.3.0-4)...
Erneuere mypaint-brushes (1.3.0-1 -> 1.3.0-2)...
Erneuere gimp-plugin-gmic (2.2.2-1 -> 2.2.2-2)...
Erneuere lapack (3.8.0-1 -> 3.8.0-2)...
Erneuere gmic (2.2.2-1 -> 2.2.2-2)...
Erneuere gnome-keyring (1:3.28.0.2-1 -> 1:3.28.2-1)...
Erneuere gvfs (1.36.1-1 -> 1.36.2-1)...
Erneuere gvfs-afc (1.36.1-1 -> 1.36.2-1)...
Erneuere gvfs-gphoto2 (1.36.1-1 -> 1.36.2-1)...
Erneuere gvfs-mtp (1.36.1-1 -> 1.36.2-1)...
Erneuere gvfs-smb (1.36.1-1 -> 1.36.2-1)...
Erneuere hdf5 (1.10.1-2 -> 1.10.1-3)...
Erneuere lib32-glibc (2.27-2 -> 2.27-3)...
Erneuere lib32-gcc-libs (7.3.1+20180406-1 -> 8.1.0-1)...
Erneuere libraw (0.18.10-1 -> 0.18.11-1)...
Erneuere libreoffice-fresh (6.0.3-2 -> 6.0.4-1)...
Erneuere libreoffice-fresh-de (6.0.3-2 -> 6.0.4-1)...
Erneuere libuv (1.20.2-1 -> 1.20.3-1)...
Erneuere libxnvctrl (390.48-1 -> 396.24-1)...
Erneuere linux414 (4.14.39-1 -> 4.14.40-1)...
Erneuere linux414-broadcom-wl (6.30.223.271-36 -> 6.30.223.271-37)...
Erneuere linux414-nvidia (1:396.24-1 -> 1:396.24-2)...
Erneuere linux414-r8168 (8.045.08-24 -> 8.045.08-25)...
Erneuere linux415 (4.15.18-1 -> 4.15.18-2)...
>>> NOTE, 4.15.18 is the last release of the 4.15.y kernel.
    It is now end-of-life.
    
    It is recommend to move on to linux416-series.
    Use followed cmd to do that: 'sudo mhwd-kernel -i linux416'
    
Erneuere linux415-broadcom-wl (6.30.223.271-17 -> 6.30.223.271-18)...
Erneuere linux415-nvidia (1:396.24-1 -> 1:396.24-2)...
Erneuere linux415-r8168 (8.045.08-17 -> 8.045.08-18)...
Erneuere linux416 (4.16.7-1 -> 4.16.8-1)...
Erneuere linux416-broadcom-wl (6.30.223.271-7 -> 6.30.223.271-8)...
Erneuere linux416-nvidia (1:396.24-1 -> 1:396.24-2)...
Erneuere linux416-r8168 (8.045.08-7 -> 8.045.08-8)...
Erneuere xapps (1.2.0-1 -> 1.2.1-1)...
Erneuere nemo (3.8.1-1 -> 3.8.2-1)...
Erneuere nodejs (10.0.0-1 -> 10.1.0-1)...
Erneuere npm (6.0.0-1 -> 6.0.1-1)...
Erneuere pcsclite (1.8.23-2 -> 1.8.23-3)...
Erneuere python-packaging (16.8-2 -> 17.1-1)...
Erneuere wget (1.19.4-3 -> 1.19.5-1)...
Starte Post-Transaction-Hooks...
Updating linux414 module dependencies...
Updating linux415 module dependencies...
Updating linux416 module dependencies...
Install DKMS modules
==> No kernel 4.14.40-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.16.8-1-MANJARO headers. You must install them to use DKMS!
==> No kernel 4.15.18-2-MANJARO headers. You must install them to use DKMS!
Updating linux414 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
  -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64.img
==> Starting build: 4.14.40-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
  -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64-fallback.img -S autodetect
==> Starting build: 4.14.40-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64-fallback.img
==> Image generation successful
Updating linux415 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux415.preset: 'default'
  -> -k /boot/vmlinuz-4.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.15-x86_64.img
==> Starting build: 4.15.18-2-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.15-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux415.preset: 'fallback'
  -> -k /boot/vmlinuz-4.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.15-x86_64-fallback.img -S autodetect
==> Starting build: 4.15.18-2-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.15-x86_64-fallback.img
==> Image generation successful
Updating linux416 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux416.preset: 'default'
  -> -k /boot/vmlinuz-4.16-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.16-x86_64.img
==> Starting build: 4.16.8-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.16-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux416.preset: 'fallback'
  -> -k /boot/vmlinuz-4.16-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.16-x86_64-fallback.img -S autodetect
==> Starting build: 4.16.8-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.16-x86_64-fallback.img
==> Image generation successful
Updating Grub-Bootmenu
GRUB-Konfigurationsdatei wird erstellt …
Hintergrund gefunden: /usr/share/grub/background.png
Linux-Abbild gefunden: /boot/vmlinuz-4.16-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.16-x86_64.img
Found initrd fallback image: /boot/initramfs-4.16-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.15-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.15-x86_64.img
Found initrd fallback image: /boot/initramfs-4.15-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.14-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Linux Mint 18.3 Sylvia (18.3) auf /dev/sda1 gefunden
Manjaro Linux (17.1.10) auf /dev/sdb3 gefunden
Found memtest86+ image: /boot/memtest86+/memtest.bin
erledigt
Copy Firefox Distribution Settings
Probing GDK-Pixbuf loader modules...
Updating GIO module cache...
Compiling GSettings XML schema files...
Updating icon theme caches...
Reloading GVFS config...
Reloading system manager configuration...
Creating temporary files...
Arming ConditionNeedsUpdate...
Updating the info directory file...
Updating the desktop file MIME type cache...
Updating the MIME type database...
Vorgang erfolgreich abgeschlossen.

System:    Host: deepin Kernel: 4.16.8-1-MANJARO x86_64 bits: 64 Desktop: N/A 
           Distro: Manjaro Linux 17.1.10 Hakoila 

Thank you @BS86
Ready

Zusammenfassung
[mint@deepin ~]$ sudo mhwd-kernel -r linux415
[sudo] Passwort fĂĽr mint: 
Prüfe Abhängigkeiten...
:: conky-lua-nv benötigt optional nvidia: for GT4xx and newer GPUs,

Paket (4)             Alte Version     Netto-Veränderung

linux415              4.15.18-2              -116.79 MiB
linux415-broadcom-wl  6.30.223.271-18          -2.72 MiB
linux415-nvidia       1:396.24-2               -9.10 MiB
linux415-r8168        8.045.08-18              -0.18 MiB

Gesamtgröße der entfernten Pakete:  128.79 MiB

:: Möchten Sie diese Pakete entfernen? [J/n] 
:: Starte pre-transaction hooks...
(1/1) Remove DKMS modules
==> No kernel 4.15.18-2-MANJARO headers. You must install them to use DKMS!
:: Verarbeite Paketänderungen...
(1/4) Entferne linux415-r8168                                                            [###################################################] 100%
(2/4) Entferne linux415-nvidia                                                           [###################################################] 100%
(3/4) Entferne linux415-broadcom-wl                                                      [###################################################] 100%
(4/4) Entferne linux415                                                                  [###################################################] 100%
:: Starte post-transaction hooks...
(1/2) Updating Grub-Bootmenu
GRUB-Konfigurationsdatei wird erstellt …
Hintergrund gefunden: /usr/share/grub/background.png
Linux-Abbild gefunden: /boot/vmlinuz-4.16-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.16-x86_64.img
Found initrd fallback image: /boot/initramfs-4.16-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.14-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Linux Mint 18.3 Sylvia (18.3) auf /dev/sda1 gefunden
Manjaro Linux (17.1.10) auf /dev/sdb3 gefunden
Found memtest86+ image: /boot/memtest86+/memtest.bin
erledigt
(2/2) Arming ConditionNeedsUpdate...


#5

try sudo mhwd-kernel -r linux415 :wink: Your system only sees that an EOL kernel is still installed, which can cause problems for example when kernel packages like the nvidia driver or wifi drivers are updated (the update will fail because of an installed EOL kernel).


#6

So far, so good.

My inxi:

CPU: Dual Core Pentium T4200 (-MCP-) speed/min/max: 1197/1200/2000 MHz 
Kernel: 4.14.40-1-MANJARO x86_64 Up: 1m Mem: 652.3/3819.0 MiB (17.1%) 
HDD: 465.76 GiB (22.4% used) Procs: 144 Shell: zsh 5.5.1 inxi: 3.0.07

Yes, I’m a zsh addict!


#7

GVFS bug is now fixed in this testing update! :grinning:

gvfs             1.36.1-1             1.36.2-1

[SOLVED] G_udev_is_device (device) failed gvfs-metadata


#8

Thanks for updating Sublime Text. That new version message was making me :nauseated_face:


#10

huge update, there is no problem so far

for a couple of days when using linux 4.16.7 my bluetooth sometimes dissapear randomly, but its not happen after updated to 4.16.8, will report back if the bluetooth problem happened again


#11

I don’t think it’s a Cinnamon issue. It’s happening on Xfce also without muffin.


#12

On my machine the update of gcc-libs to 8.1.0 broke numpy (python-numpy 1.14.3-1), which depends on libgfortran.so.4. As a temporary workaround I have copied the corresponding file from gcc-libs-7.3.1 into the ld.so search path. I can imagine that other numerics related packages are affected, too.

Everything else is fine. Thanks for the good work!


#13

It is listed as make dependency. Maybe the package maintainers need to be informed about it.


#14

After update keyboard unresponsive cant even get into tty. Tried both 4.16 kernel and 4.14 kernel. Cannot interact with Gnome shell at all. This is a Lenovo T430 running Manjaro Gnome Testing. Boots normally, login is good, brings you to graphical desktop. Cursor and mouse work but keyboard does not, neither does the mouse allow any interaction with the actual shell, left click, right click, nothing. Not sure how to proceed as I have never had a problem with getting to tty. Any assistance would be appreciated.


#15

@nadb: you may try to start in user level 3 by selecting the boot option in grub, press CTRL+E and add a three at the end of the boot option. With CTRL+X you may start it. Other option would be to use a live media to check which packages got updated on your end.


#16

Got into tty at GDM login. Logged in, in tty, resyncing mirrors, update sucessful. Problem still exists.

Repeating process and reinstalling Gnome packages. Conflict between nautilus and nautilus-typeahead. Removing nautilus.
Conflict between nautilus-extension-typeahead and nautilus-extension. Removing nautilus-extension.
Updating again. No updates. Shutdown.

Booting, Logged in. Problem still exists.

And


#17

@nadb: please install budgie-desktop or xfce4 to see if it is a Gnome issue. So when you still have keyboard in TTY it seems to be a DE issue.


#18

I tried installing xf86-video-intel. Modesetting not the issue.
Attempted to enable wayland. Fails to enable. Option not available in GDM. GDM might have issue.

Installing xfce4 xfce4-goodies. Might as well have a back up DE, and per philm.

Xfce4 works. Looks like a Gnome issue. Something in the update
.


#19

That is why I use it as default. Since you have a working DE now, you may check which packages got updated after the last working state. /var/log/pacman.log is your friend.


#20

I finally tracked down the problem. Apparently something is wrong with the gnome-shell-extensions, and gnome-shell-extension- packages. Removing them and installing extensions from gnome.org and login works, along with the actual DE. Install any of those packages during a session and everything ceases to work. All you can do is move the cursor around. I thought the nodejs update might have caused an issue but that was not the case.

And nevermind a faulty extension was the cause. Workspaces to Dock. Manual installation from github is recommended. This fixed the issue.


#21

I had this too. Gnome-shell was totally frozen. I used the extension dev’s new package and all are fine.