[Testing Update] 2018-05-06 - Pamac, Jade, Linux v4.17

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. Mostly we worked the past days on our toolchain. Please read our Troubleshooting guide for more details.

Other changes are:

  • updating Pamac, which fixes an issue unable to close a mirrorlist generation and shows now a progressbar during updates checking
  • more JADE updates
  • latest Linux v4.17 kernel
  • usual upstream updates

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.98
  • linux414 4.14.39
  • linux415 4.15.18 [EOL]
  • linux416 4.16.7
  • linux417 4.17-rc3
  • linux414-rt 4.14.39_rt29
  • linux416-rt 4.16.7_rt1

Package Updates (Sun May 6 19:19:24 CEST 2018)

  • testing community x86_64: 23 new and 20 removed package(s)
  • testing core x86_64: 3 new and 3 removed package(s)
  • testing extra x86_64: 21 new and 21 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                manjaro-openbox-core              1.3.0-1            1.3.0.1-1
         manjaro-webdad-settings-git        r17.6c9e694-1        r18.8c425dc-1
         python-jade-application-kit              1.3.3-1              1.3.4-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                             corrade            2018.02-1            2018.04-1
                         emby-server            3.3.1.0-1            3.4.0.0-1
                                 fzf             0.17.3-1             0.17.3-2
              libperconaserverclient          5.7.21_21-1          5.7.21_21-2
                              linbox              1.5.2-4              1.5.2-5
                              magnum            2018.02-2            2018.04-1
                      magnum-plugins            2018.02-1            2018.04-1
                      percona-server          5.7.21_21-1          5.7.21_21-2
              percona-server-clients          5.7.21_21-1          5.7.21_21-2
              python-ndg-httpsclient              0.4.4-1              0.5.0-1
                 python-phonenumbers              8.9.4-1              8.9.5-1
             python2-ndg-httpsclient              0.4.4-1              0.5.0-1
                python2-phonenumbers              8.9.4-1              8.9.5-1
                         qbittorrent              4.0.4-2              4.1.0-1
                     qbittorrent-nox              4.0.4-2              4.1.0-1
                            rubinius              3.100-1              3.101-1
                       rubinius-ruby              3.100-1              3.101-1
                                mypy                    -              0.600-2
                    python-typed-ast                    -              1.1.0-2
                           snap-sync                    -              0.4.2-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                        linux417 4.17.r180504.625e200-1 4.17.r180505.c1c0741-1
                linux417-headers 4.17.r180504.625e200-1 4.17.r180505.c1c0741-1
                      manjaro-system           20180506-1           20180506-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                  linux417-acpi_call           1.1.0-0.12           1.1.0-0.13
                   linux417-bbswitch             0.8-0.12             0.8-0.13
                linux417-broadcom-wl    6.30.223.271-0.12    6.30.223.271-0.13
                   linux417-catalyst   1:15.201.1151-0.12   1:15.201.1151-0.13
                linux417-ndiswrapper            1.61-0.12            1.61-0.13
                     linux417-nvidia        1:396.24-0.12        1:396.24-0.13
               linux417-nvidia-304xx       1:304.137-0.12       1:304.137-0.13
               linux417-nvidia-340xx         340.106-0.12         340.106-0.13
               linux417-nvidia-390xx          390.48-0.12          390.48-0.13
                   linux417-nvidiabl            0.88-0.12            0.88-0.13
                      linux417-r8168        8.045.08-0.12        8.045.08-0.13
                        linux417-spl           0.7.8-0.12           0.7.8-0.13
                   linux417-tp_smapi            0.41-0.12            0.41-0.13
                linux417-vhba-module        20161009-0.12        20161009-0.13
   linux417-virtualbox-guest-modules          5.2.10-0.12          5.2.10-0.13
    linux417-virtualbox-host-modules          5.2.10-0.12          5.2.10-0.13
                        linux417-zfs           0.7.8-0.12           0.7.8-0.13
                               pamac              6.2.7-1              6.3.1-1
             pamac-tray-appindicator              6.2.7-1              6.3.1-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                            composer              1.6.4-1              1.6.5-1
                         kwallet-pam             5.12.5-2             5.12.5-3


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-05           2018-05-06
-------------------------------------------------------------------------------
                        lib32-libaio            0.3.110-1            0.3.111-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Include actual changes in Announcements topics
#2

This is a wiki post; please edit as necessary.


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24 support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


#3

Updated with no problems, and everything looking good so far. :slight_smile:

This also corrected the dependency issue I had with libaio/lib32-libaio from the previous testing release.

Manjaro KDE
Kernel 4.17.0-1


#4

Works flawlessly here. Nothing to report!


#5

So if we use Samba, does this mean we need to re-enable the Samba settings at startup

from: systemctl enable smbd nmbd

to: systemctl enable smb nmb


#6

I would think so, since smbd and nmbd no longer exists, so systemctl would just show errors when trying to activate them.


#7

I had to refresh my mirrors to get the update. But no other issues.Worked well on xfce 4.17 and on my vbox installations (gnome & awesome) with no issues.


#8

I have an odd issue here.

My GTK3 apps are not getting themed on wayland session, plus they are missing the titlebar.

Anyone else have this? Or even know a fix?


#9

Not issues noticed, XFCE.


#10

Smooth on KDE


#11

I got the same error with yay as the last update:

==> Error: Could not find all required packages:
    pacman>=4.2

I bypassed this error by using pacman again. Not a big problem.


#12

I would stop using an aur helper for normal updates if I were you.


#13

Yes, you are right.
But… yay is shorter than sudo pacman -Syu! :wink:


#14

So make an alias called “update” that runs

sudo pacman -Syyu

Still longer than typing yay but is a better method.


#15

I think I’ve removed the un-needed quirk and it should work now …


Also I added some more packages:

### BoxIt memo ###

User philip created a snapshot of branch 'unstable' to 'testing'.

 - testing community x86_64:  21 new and 21 removed package(s)
 - testing core x86_64:  4 new and 4 removed package(s)
 - testing extra x86_64:  2 new and 2 removed package(s)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                  appmenu-gtk-module             0.6.92-1             0.6.94-1
                                 pix1.6.2+master.mint19-1              1.8.0-1
                          vala-panel             0.3.74-1             0.3.75-1
           vala-panel-appmenu-budgie             0.6.92-1             0.6.94-1
             vala-panel-appmenu-mate             0.6.92-1             0.6.94-1
        vala-panel-appmenu-registrar             0.6.92-1             0.6.94-1
     vala-panel-appmenu-translations             0.6.92-1             0.6.94-1
        vala-panel-appmenu-valapanel             0.6.92-1             0.6.94-1
             vala-panel-appmenu-xfce             0.6.92-1             0.6.94-1
                                 xed              1.6.3-1              1.8.0-1
                             xplayer              1.6.1-1              1.8.0-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                                 iwd                0.1-3                0.2-1
                             keepass               2.38-1               2.39-1
                               kitty              0.9.0-1              0.9.1-1
                             liteide               33.2-1               33.3-1
                           nltk-data              3.2.5-1                3.3-1
                    otf-font-awesome             5.0.11-1             5.0.12-1
                         python-nltk              3.2.5-1                3.3-1
                        python2-nltk              3.2.5-1                3.3-1
                               tint2               16.2-1               16.4-1
                    ttf-font-awesome             5.0.11-1             5.0.12-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                            dbus-x11             1.12.6-1             1.12.8-1
                      manjaro-system           20180506-2           20180507-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                                dbus             1.12.6-1             1.12.8-1
                           dbus-docs             1.12.6-1             1.12.8-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                                 gjs           1:1.52.2-1           1:1.52.3-1
                                vino  3.22.0+7+g74dd40f-1 3.22.0+11+g3977943-1

#16

Thank you for the fix and another update!

Now I got another error:

==> Error: Could not find all required packages:
    pacman>=5.0

I don’t know what is going on. Does it mean that yay cannot handle version restrictions at all?

Now I am going to use pacman for normal updates as @cscs and @Yorper suggested. :wink:

Thanks!


#17

These two are great. pacup…aup…or in your case pacup/yayup :slight_smile:
https://wiki.manjaro.org/index.php?title=Aliases_in_.bashrc

alias pacup="sudo pacman -Syu" 
alias aup="yaourt -Syu --aur"

and for cleaning if you feel so inclined (used with care)
alias paclean='sudo pacman -Rsn $(pacman -Qqdt)'


#18

I am coming from the debian world and therefore have these aliases:

alias t-u='trizen -Syyu'
alias p-u='pacman -Syyu'
alias p-m='sudo pacman-mirrors -c Denmark,Germany,France,Italy'

#19

Error: could not open file /var/lib/pacman/local/js52-52.7.3-1/files: No such file or directory
Warning: could not fully load metadata for package js52-52.7.3-1
Update failed

Then I had to leave for an appointment, and a retry after I got back went perfectly, other than a bunch of hplip warnings - "Could not get information about yadda yadda…


#20

It could be a bug/unhandled edge-case in yay’s dependency resolution. Or, it could be an issue with the manjaro-system package (it provides pacman=4.1.2 to fix a much earlier update issue). I don’t know which.