[Testing Update] 2018-05-03 - Kernels, Mesa v18.0.2, Nvidia v396.24

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. Mostly we worked yesterday on our toolchain. This includes the following changes:

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Additionally we updated pam. pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Other changes are:

  • added Mesa v18.0.2
  • updated Nvidia driver to v396.24
  • most of our kernels got updated and include bluetooth and wifi fixes
  • usual upstream updates

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.98
  • linux414 4.14.39
  • linux415 4.15.18 [EOL]
  • linux416 4.16.7
  • linux417 4.17-rc3
  • linux-rt 4.14.34_rt27

Package Updates (Thu May 3 07:17:07 CEST 2018)

  • testing community x86_64: 75 new and 68 removed package(s)
  • testing core x86_64: 13 new and 13 removed package(s)
  • testing extra x86_64: 119 new and 124 removed package(s)
  • testing multilib x86_64: 4 new and 8 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                              etcher              1.4.1-1              1.4.4-1
                  linux414-rt-nvidia           1:396.18-2           1:396.24-1
              manjaro-openbox-common              1.2.3-1           20180502-2
            manjaro-openbox-settings           20180426-1           20180502-1
          manjaro-xfce-gtk3-settings           20180429-1           20180502-1
                        nemo-preview            3.6.2-0.1                    -
             manjaro-openbox-minimal                    -           20180502-1
    manjaro-openbox-settings-minimal                    -           20180502-1
       manjaro-openbox-theming-fonts                    -           20180502-1
       manjaro-openbox-theming-icons                    -           20180502-1
       manjaro-openbox-theming-theme                    -           20180502-1
  manjaro-xfce-gtk3-minimal-settings                    -           20180502-1
                        wicd-patched                    -              1.7.4-1
                              xcmenu                    -        20140816.23-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-125            1.1.0-126
                         broadcom-wl      6.30.223.271-12      6.30.223.271-13
                          clementine             1.3.1-16             1.3.1-17
                              devede              4.9.0-1             4.11.0-1
                                 dmd          1:2.079.1-1          1:2.080.0-1
                            dmd-docs          1:2.079.1-1          1:2.080.0-1
                         dns-lexicon              2.2.1-1              2.2.2-1
                              dtools            2.079.0-1            2.080.0-1
                                 dub              1.8.1-1              1.9.0-1
                           etherwall              2.2.0-1              2.2.1-1
                             gnucash                3.0-6                3.1-1
                        gnucash-docs                3.0-2                3.1-1
                         go-ethereum              1.8.6-1              1.8.7-1
                      grafana-zabbix              3.9.0-1              3.9.1-1
                                gtkd              3.8.2-1              3.8.2-2
                            gunicorn             19.8.0-1             19.8.1-1
                         haskell-rio            0.1.1.0-1            0.1.2.0-1
                          ibus-table             1.9.18-1             1.9.19-1
                             jenkins              2.118-1              2.119-1
                            kaffeine             2.0.14-1             2.0.15-1
                                 ldc            1:1.8.0-3            1:1.9.0-1
                             libbson              1.9.4-1              1.9.5-1
                          liblphobos            1:1.8.0-3            1:1.9.0-1
                           libmongoc              1.9.4-1              1.9.5-1
                           libphobos          1:2.079.1-1          1:2.080.0-1
                    nodejs-lts-argon              4.9.1-1                    -
                    nodejs-lts-boron             6.14.1-1             6.14.2-1
                           notepadqq              1.4.0-1              1.4.4-1
                              nuitka           0.5.29.5-1             0.5.30-1
                              obconf              2.0.4-4              2.0.4-5
                    otf-font-awesome             5.0.10-1             5.0.11-1
                      python-mockito             1.0.12-1              1.1.0-1
                    python-netifaces             0.10.6-1             0.10.7-1
                      python-oslo-db             4.37.0-1             4.38.0-1
                     python-oslotest              3.4.1-1              3.4.2-1
                       python-peewee              3.3.1-1              3.3.2-1
                  python-pytest-mock              1.9.0-1             1.10.0-1
                     python-tenacity             4.11.0-1             4.12.0-1
                 python-testfixtures              6.0.1-1              6.0.2-1
                         python-tqdm             4.23.1-1             4.23.2-1
                    python2-gunicorn             19.8.0-1             19.8.1-1
                     python2-mockito             1.0.12-1              1.1.0-1
                   python2-netifaces             0.10.6-1             0.10.7-1
                     python2-oslo-db             4.37.0-1             4.38.0-1
                    python2-oslotest              3.4.1-1              3.4.2-1
                      python2-peewee              3.3.1-1              3.3.2-1
                 python2-pytest-mock              1.9.0-1             1.10.0-1
                    python2-tenacity             4.11.0-1             4.12.0-1
                python2-testfixtures              6.0.1-1              6.0.2-1
                        python2-tqdm             4.23.1-1             4.23.2-1
                                qcad           3.20.1.3-1           3.20.1.3-2
                            ruby-atk              3.2.4-1              3.2.5-1
                          ruby-cairo            1.15.12-1            1.15.13-1
                  ruby-cairo-gobject              3.2.4-1              3.2.5-1
                    ruby-gdk_pixbuf2              3.2.4-1              3.2.5-1
                           ruby-gio2              3.2.4-1              3.2.5-1
                          ruby-glib2              3.2.4-1              3.2.5-1
          ruby-gobject-introspection              3.2.4-1              3.2.5-1
                           ruby-gtk2              3.2.4-1              3.2.5-1
                          ruby-pango              3.2.4-1              3.2.5-1
                               tilix              1.7.7-2              1.7.9-1
                    ttf-font-awesome             5.0.10-1             5.0.11-1
                            qrupdate                    -              1.1.2-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                      linux-firmware   20180416.b562d2f-1   20180501.397a604-1
                            linux318           3.18.107-1           3.18.108-1
                    linux318-headers           3.18.107-1           3.18.108-1
                            linux414            4.14.38-1            4.14.39-1
                    linux414-headers            4.14.38-1            4.14.39-1
                            linux416             4.16.6-3             4.16.7-1
                    linux416-headers             4.16.6-3             4.16.7-1
                             linux44            4.4.130-1            4.4.131-1
                     linux44-headers            4.4.130-1            4.4.131-1
                             linux49             4.9.97-1             4.9.98-1
                     linux49-headers             4.9.97-1             4.9.98-1
                         mhwd-nvidia           1:396.18-1           1:396.24-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                      linux-firmware   20180314.4c0bf11-1   20180416.b562d2f-1
                           man-pages               4.15-1               4.16-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                   libva-mesa-driver             18.0.2-0                    -
                     linux316-nvidia           1:396.18-1           1:396.24-1
                  linux318-acpi_call             1.1.0-53             1.1.0-54
                   linux318-bbswitch               0.8-53               0.8-54
                linux318-broadcom-wl      6.30.223.271-29      6.30.223.271-30
                   linux318-catalyst     1:15.201.1151-43     1:15.201.1151-44
                linux318-ndiswrapper              1.61-29              1.61-30
                     linux318-nvidia           1:396.18-2           1:396.24-1
               linux318-nvidia-304xx         1:304.137-18         1:304.137-19
               linux318-nvidia-340xx            340.106-8            340.106-9
                   linux318-nvidiabl              0.88-43              0.88-44
      linux318-open-vm-tools-modules      2:2013.09.16-53      2:2013.09.16-54
                      linux318-r8168           8.045.08-8           8.045.08-9
                  linux318-rt3562sta        2.4.1.1_r4-29        2.4.1.1_r4-30
                        linux318-spl              0.7.8-2              0.7.8-3
                   linux318-tp_smapi              0.41-53              0.41-54
                linux318-vhba-module          20161009-29          20161009-30
   linux318-virtualbox-guest-modules             5.2.10-2             5.2.10-3
    linux318-virtualbox-host-modules             5.2.10-2             5.2.10-3
                        linux318-zfs              0.7.8-2              0.7.8-3
                      linux41-nvidia           1:396.18-1           1:396.24-1
                  linux414-acpi_call             1.1.0-35             1.1.0-36
                   linux414-bbswitch               0.8-35               0.8-36
                linux414-broadcom-wl      6.30.223.271-35      6.30.223.271-36
                   linux414-catalyst     1:15.201.1151-35     1:15.201.1151-36
                linux414-ndiswrapper              1.61-35              1.61-36
                     linux414-nvidia           1:396.18-6           1:396.24-1
               linux414-nvidia-304xx         1:304.137-35         1:304.137-36
               linux414-nvidia-340xx           340.106-23           340.106-24
                   linux414-nvidiabl              0.88-35              0.88-36
                      linux414-r8168          8.045.08-23          8.045.08-24
                  linux414-rt3562sta        2.4.1.1_r4-35        2.4.1.1_r4-36
                        linux414-spl              0.7.8-7              0.7.8-8
                   linux414-tp_smapi              0.41-35              0.41-36
                linux414-vhba-module          20161009-35          20161009-36
   linux414-virtualbox-guest-modules             5.2.10-4             5.2.10-5
    linux414-virtualbox-host-modules             5.2.10-4             5.2.10-5
                        linux414-zfs              0.7.8-7              0.7.8-8
                     linux415-nvidia           1:396.18-3           1:396.24-1
                  linux416-acpi_call              1.1.0-6              1.1.0-7
                   linux416-bbswitch                0.8-6                0.8-7
                linux416-broadcom-wl       6.30.223.271-6       6.30.223.271-7
                   linux416-catalyst      1:15.201.1151-6      1:15.201.1151-7
                linux416-ndiswrapper               1.61-6               1.61-7
                     linux416-nvidia           1:396.18-6           1:396.24-1
               linux416-nvidia-304xx          1:304.137-6          1:304.137-7
               linux416-nvidia-340xx            340.106-6            340.106-7
                   linux416-nvidiabl               0.88-6               0.88-7
                      linux416-r8168           8.045.08-6           8.045.08-7
                        linux416-spl              0.7.8-5              0.7.8-6
                   linux416-tp_smapi               0.41-6               0.41-7
                linux416-vhba-module           20161009-6           20161009-7
   linux416-virtualbox-guest-modules             5.2.10-5             5.2.10-6
    linux416-virtualbox-host-modules             5.2.10-5             5.2.10-6
                        linux416-zfs              0.7.8-5              0.7.8-6
                     linux417-nvidia        1:396.18-0.11        1:396.24-0.11
                   linux44-acpi_call             1.1.0-91             1.1.0-92
                    linux44-bbswitch               0.8-91               0.8-92
                 linux44-broadcom-wl      6.30.223.271-61      6.30.223.271-62
                    linux44-catalyst     1:15.201.1151-91     1:15.201.1151-92
                 linux44-ndiswrapper              1.61-59              1.61-60
                      linux44-nvidia           1:396.18-2           1:396.24-1
                linux44-nvidia-304xx         1:304.137-26         1:304.137-27
                linux44-nvidia-340xx           340.106-13           340.106-14
                    linux44-nvidiabl              0.88-91              0.88-92
       linux44-open-vm-tools-modules      2:2013.09.16-91      2:2013.09.16-92
                       linux44-r8168          8.045.08-13          8.045.08-14
                   linux44-rt3562sta        2.4.1.1_r4-59        2.4.1.1_r4-60
                         linux44-spl              0.7.8-2              0.7.8-3
                    linux44-tp_smapi              0.41-91              0.41-92
                 linux44-vhba-module          20161009-59          20161009-60
    linux44-virtualbox-guest-modules             5.2.10-2             5.2.10-3
     linux44-virtualbox-host-modules             5.2.10-2             5.2.10-3
                         linux44-zfs              0.7.8-2              0.7.8-3
                   linux49-acpi_call             1.1.0-75             1.1.0-76
                    linux49-bbswitch               0.8-75               0.8-76
                 linux49-broadcom-wl      6.30.223.271-75      6.30.223.271-76
                    linux49-catalyst     1:15.201.1151-75     1:15.201.1151-76
                 linux49-ndiswrapper              1.61-73              1.61-74
                      linux49-nvidia           1:396.18-4           1:396.24-1
                linux49-nvidia-304xx         1:304.137-34         1:304.137-35
                linux49-nvidia-340xx           340.106-15           340.106-16
                    linux49-nvidiabl              0.88-75              0.88-76
                       linux49-r8168          8.045.08-15          8.045.08-16
                   linux49-rt3562sta        2.4.1.1_r4-73        2.4.1.1_r4-74
                         linux49-spl              0.7.8-4              0.7.8-5
                    linux49-tp_smapi              0.41-75              0.41-76
                 linux49-vhba-module          20161009-73          20161009-74
    linux49-virtualbox-guest-modules             5.2.10-3             5.2.10-4
     linux49-virtualbox-host-modules             5.2.10-3             5.2.10-4
                         linux49-zfs              0.7.8-4              0.7.8-5
              manjaro-settings-samba           20180422-2           20180502-1
              manjaro-tools-base-git      r2665.1262b50-1      r2666.fdb222f-1
               manjaro-tools-iso-git      r2665.1262b50-1      r2666.fdb222f-1
               manjaro-tools-pkg-git      r2665.1262b50-1      r2666.fdb222f-1
              manjaro-tools-yaml-git      r2665.1262b50-1      r2666.fdb222f-1
                                mesa             18.0.2-0                    -
                          mesa-vdpau             18.0.2-0                    -
                        nvidia-utils           1:396.18-2           1:396.24-1
                         opencl-mesa             18.0.2-0                    -
                       opencl-nvidia           1:396.18-1           1:396.24-1
                        vulkan-intel             18.0.2-0                    -
                       vulkan-radeon             18.0.2-0                    -
                            libepoxy                    -   1.5.1+6+gb80ea6a-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                             flatpak             0.11.5-1             0.11.6-1
                           freetype2                2.9-2              2.9.1-1
                     freetype2-demos                2.9-2              2.9.1-1
                      freetype2-docs                2.9-2              2.9.1-1
                                 gcr             3.28.0-2             3.28.0-3
                      gnome-calendar             3.28.1-1             3.28.2-1
                                  go           2:1.10.1-1           2:1.10.2-1
                              go-pie           2:1.10.1-1           2:1.10.2-1
                               hplip             3.18.3-2             3.18.4-2
                   libva-mesa-driver             18.0.1-1             18.0.2-1
                              libzip              1.5.0-1              1.5.1-1
                             liferea             1.12.2-1             1.12.3-1
                                mesa             18.0.1-1             18.0.2-1
                          mesa-vdpau             18.0.1-1             18.0.2-1
                         opencl-mesa             18.0.1-1             18.0.2-1
                               solid             5.45.0-1             5.45.0-2
                    transmission-cli               2.93-1               2.94-1
                    transmission-gtk               2.93-1               2.94-1
                     transmission-qt               2.93-1               2.94-1
                        vulkan-intel             18.0.1-1             18.0.2-1
                       vulkan-radeon             18.0.1-1             18.0.2-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                  lib32-nvidia-utils           1:396.18-2         1:396.24-1.1
                 lib32-opencl-nvidia           1:396.18-1           1:396.24-1
                      lib32-libepoxy                    -   1.5.1+6+gb80ea6a-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-02           2018-05-03
-------------------------------------------------------------------------------
                     lib32-freetype2                2.9-2              2.9.1-1
             lib32-libva-mesa-driver             18.0.1-1             18.0.2-1
                          lib32-mesa             18.0.1-1             18.0.2-1
                    lib32-mesa-vdpau             18.0.1-1             18.0.2-1
                  lib32-vulkan-intel             18.0.1-1             18.0.2-1
                 lib32-vulkan-radeon             18.0.1-1             18.0.2-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


[Stable Review] 2018-05-05 - Kernels, Plasma5, Nvidia, Mesa, GlibC, Firefox, Deepin
#2

This is a wiki post; please edit as necessary.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24 support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v340xx driver series. Currently we are deciding if we do a v390xx package. Nvidia did not yet had released any driver update to the legacy drivers.


#3

Just this came up:

warning: dependency cycle detected:
warning: nvidia-utils will be installed before its mesa dependency

#4

You can happily ignore it :wink:


#5

Yeah, the reboot was ok, and it seems all went as it should. No problems here with the new nvidia.
Cheers and thanks!!! :smiley:


#6

Just to be sure before I update: Do I have to do anything respective pam, when I never touched anything in /etc/pam.d?


#7

I didn’t, and all went well … In fact i never touched anything there ever.


#8

For pam_unix.so, it’s pam_unix2 and pam_unix_*.so are not supported anymore.
Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


#9

Thank you. I would recommend that you write in just this advice in the announcement when that package is going up to stable.


#10

Edit: forget it, it was just my computer being weird, rebooting did the trick, I was able to reboot since it didn’t end up writing my grub config file


#11

This is BAD IDEA cause 340 have some issues with fermi and bumblebee:

  • 396.x NVIDIA driver does not support Fermi (630M GT here)
  • Removing video-hybrid-intel-nvidia-bumblebee went fine.
  • Installing video-hybrid-intel-nvidia-340xx-bumblebee went fine.
    HERE starting happen something weird, all plasma programs crashes with this code:

systemsettings5[2603]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DoubleBuffer), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile QSurfaceFormat::OpenGLContextProfile(NoProfile))

IGNORE THIS. Reboot aand:
Plasma shell cannot works against previous issues with OpenGL 2.0 library loading issue…

(mhwd-chroot SAVED my life time)

BUT

  • in default is used intel iGPU always
  • this only happen when I switch to 340 nvidia bumblee profile.

@philm report month ago >> https://forum.manjaro.org/t/44576


#12

Updates without problems

XFCE with Kernel 4.16


#13

OK here…

Linux Manjaro_KDE_VM 4.16.7-1-MANJARO #1 SMP PREEMPT Wed May 2 19:14:22 UTC 2018 x86_64 GNU/Linux

…except as a couple of us already posted in previous update, Timeshift GUI still does not launch from Application Menu.

[kdemeoz@Manjaro_KDE_VM ~]$ timeshift-launcher
Unable to init server: Could not connect: Connection refused

(timeshift-gtk:21159): Gtk-WARNING **: 18:54:34.684: cannot open display: 
[kdemeoz@Manjaro_KDE_VM ~]$

[Stable Review] 2018-05-05 - Kernels, Plasma5, Nvidia, Mesa, GlibC, Firefox, Deepin
#14

What is the actual command within the App Menu?

Quick internet search and this error message seems to be related to launching gtk apps with root privileges.

Been some time since I dabbled with it, does Timeshift require root privileges? It may be trying to launch using kdesudo, which was recently depricated.

Does sudo timeshift from the konsole work?


#15

Nothing to report on my Toshiba laptop. Good :slight_smile:


#16

it opens the authentication dialog while using the menu or with the command of the application timeshift-launcher but it quits immediately
(timeshift-gtk:1713): Gtk-WARNING **: 12:16:24.764: cannot open display:

with sudo timeshift-launcher it will open but there are still some stuff that are strange (to me)


(timeshift-gtk:1724): GLib-GIO-CRITICAL **: 12:18:37.411: g_file_get_path: assertion 'G_IS_FILE (file)' failed

** (timeshift-gtk:1724): CRITICAL **: 12:18:37.412: tee_jee_file_system_path_combine: assertion 'path1 != NULL' failed

** (timeshift-gtk:1724): CRITICAL **: 12:18:37.412: tee_jee_file_system_dir_exists: assertion 'dir_path != NULL' failed

but maybe because this is on a experimental install and is the first time i open it …
@kdemeoz - see above … :slight_smile:

Also it falls back to Adwaita theme


#17

@bogdancovaciu & @sueridgepipe FYI this was my older post:


#18

All nice on Deepin :slight_smile:

too

OS: Manjaro 17.1.9 Hakoila
Kernel: x86_64 Linux 4.16.7-1-MANJARO
Packages: 1138
Shell: bash 4.4.19
Resolution: 3840x2160
DE: Deepin 15.5
WM: Deepin WM [Mutter(DeepinGala)]
WM Theme: Vertex-Maia-Dark
GTK Theme: Vertex-Maia-Dark [GTK2/3]
Icons: Deepin [GTK2/3]
Terminal: deepin-terminal
CPU: Intel Core i7-3770K @ 8x 4.1GHz [37.0°C]
GPU: NVIDIA GeForce GTX 1060 6GB
RAM: 1792MiB / 15982MiB

deepin ~ $ inxi -Fxz
System:    Host: deepin Kernel: 4.16.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 7.3.1 Desktop: N/A 
           Distro: Manjaro Linux 17.1.9 Hakoila 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V DELUXE v: Rev 1.xx serial: N/A BIOS: American Megatrends 
           v: 2104 date: 08/13/2013 
CPU:       Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57714 
           Speed: 4094 MHz min/max: 1600/4100 MHz Core speeds (MHz): 1: 1649 2: 1648 3: 1649 4: 1649 5: 1649 
           6: 1651 7: 1649 8: 1649 
Graphics:  Card-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 396.24 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 direct render: Yes 
Audio:     Card-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Card-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.16.7-1-MANJARO 
Network:   Card-1: Intel 82579V Gigabit Network Connection driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Card-2: Broadcom Limited BCM43228 802.11a/b/g/n driver: wl v: kernel bus ID: 0c:00.0 
           IF: wlp12s0 state: dormant mac: <filter> 
           Card-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: b000 bus ID: 0d:00.0 
           IF: enp13s0 state: down mac: <filter> 
Drives:    HDD Total Size: 3.07 TiB used: 1.56 TiB (50.8%) 
           ID-1: /dev/sda model: Samsung_SSD_850 size: 232.89 GiB 
           ID-2: /dev/sdb model: Corsair_Force_GT size: 111.79 GiB 
           ID-3: /dev/sdc model: WDC_WD10EACS-22D size: 931.51 GiB 
           ID-4: /dev/sdd model: ST2000DM001-9YN1 size: 1.82 TiB 
Partition: ID-1: / size: 27.38 GiB used: 21.88 GiB (79.9%) fs: ext4 dev: /dev/sdb1 
           ID-2: swap-1 size: 15.77 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 33.5 C mobo: 27.8 C gpu: nvidia temp: 57 C 
           Fan Speeds (RPM): cpu: 4299 fan-1: 1124 fan-3: 811 fan-4: 815 fan-5: 782 gpu: nvidia fan: 17% 
Info:      Processes: 259 Uptime: 1h 03m Memory: 15.61 GiB used: 2.45 GiB (15.7%) Init: systemd Compilers: 
           gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07 

Timeshift goes normally to start.


#19

Note: nividia 396.24 changed “Power Miser” settings in NVIDIA X Server settings, the rest of the settings are not changed.

bob@Manjaro-Testing~$ inxi-Fxz
[bob@Manjaro-Testing ~]$ inxi -Fxz
System:
  Host: Manjaro-Testing Kernel: 4.17.0-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 7.3.1 Desktop: N/A Distro: Manjaro Linux 17.1.9 Hakoila 
Machine:
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e serial: N/A 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: N/A BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
CPU:
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25555 
  Speed: 898 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 867 2: 854 
  3: 852 4: 830 
Graphics:
  Card-1: NVIDIA GK208 [GeForce GT 720] driver: nvidia v: 396.24 
  bus ID: 01:00.0 
  Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 
  direct render: Yes 
Audio:
  Card-1: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Card-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.17.0-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  HDD Total Size: 1.82 TiB used: 24.15 GiB (1.3%) 
  ID-1: /dev/sda model: WDC_WD10EZEX-08M size: 931.51 GiB 
  ID-2: /dev/sdb type: USB model: Elements_25A2 size: 931.48 GiB 
Partition:
  ID-1: / size: 453.11 GiB used: 24.15 GiB (5.3%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 56 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:
  Processes: 185 Uptime: 8m Memory: 7.73 GiB used: 703.5 MiB (8.9%) 
  Init: systemd Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07


#20

I have exactly the same behaviour as @kdemeoz, I can start Timeshift with kdesu timeshift-gtk, otherwise nothing happen after I enter my root password in the usual windows which opens asking for it after clicking the launcher icon. The windows closes and … nothing.
I have the same behaviour on 2 machines, both with KDE and last testing channel.