[Testing Update] 2018-04-21 - Kernels, KDE Framework, Mesa, Virtualbox, Browsers, Deepin

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. We added again the latest available features:

  • Virtualbox got updated to v5.2.10
  • KDE Framework is now at v5.45.0
  • We updated most of our kernels; v4.15 series is now EOL
  • Mesa 18.0.1 now implements the OpenGL 4.5 API
  • We added some small features and fixes to our tools
  • Deepin got some small package updates
  • Some of our browsers got updates plus we added the regular upstream package updates as usual

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.105 [EOL]
  • linux41 4.1.51
  • linux44 4.4.128
  • linux49 4.9.95
  • linux414 4.14.35
  • linux415 4.15.18 [EOL]
  • linux416 4.16.3
  • linux417 4.17-rc1
  • linux-rt 4.14.34_rt27

Package Updates (Sat Apr 21 10:45:55 CEST 2018)

  • testing core x86_64: 8 new and 8 removed package(s)
  • testing multilib x86_64: 11 new and 11 removed package(s)
  • testing extra x86_64: 144 new and 152 removed package(s)
  • testing community x86_64: 499 new and 441 removed package(s)

Package Overlay Updates

  • testing multilib x86_64: 1 new and 1 removed package(s)
  • testing core x86_64: 12 new and 12 removed package(s)
  • testing extra x86_64: 112 new and 106 removed package(s)
  • testing community x86_64: 76 new and 73 removed package(s)

A detailed list of all package changes may be found here.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

This is a wiki post; please edit as necessary.


Nautilus - Middle click on any location in other-locations:/// closes tab



#3

Huge testing update, biggest I can remember … 145 packages, nearly 700MB download.


#4

Xfce, i5-3317U, kernel 44 and kernel 416, no issues.
cheers.


#5

Happens when I had no time during the week to push some to testing :wink:


#6

Warnung: mhwd-nvidia: Lokale Version (1:396.18-1) ist neuer als core (1:390.48-1)
Somehow I got myself a newer mhwd-nvidia version - not that this would impact me - not having nvidia GPU anyhow.

I got “just” 330MB of update XD - I feel left out :wink:

Going for reboot now - update if anythings happening.


#7

After reboot no problems.


#8

Don’t forget to test nautilus-legacy if you want use desktop icons in Gnome or Budgie :wink:


#9

This is the nvidia beta driver currently in unstable.


#10

@philm:

In case of a Barebone Intel NUC with Intel GPU the install media 17.1.8 of KDE, Gnome and LXDE doesn’t work anymore. The graphical environment at the end of boot process doesn’t start correctly. You see the messages of boot process and concurrently Manjaro Hello and Yakuake, but not the GUI of KDE, Gnome or LXDE. Only the media 17.1.8 of XFCE works without problems.

This testing update solves the problem. At this moment you can work around this problem to boot with install media 17.1.7 and to update all packages to this testing update.

Probably it could be a good idea, to create a new 17.1.9 after promoting this testing update to stable?

(I found no other suitable topic to this problem, because there is no announcement topic for the 17.1.8 install media of KDE or Gnome).

see other topics:


#11

17.1.8 is based on the current stable update, so XFCE, KDE and Gnome get always released with the same packages. You can download the package lists to see the differences. Core packages should be the same.

I assume you have more an issue with composite or other graphical settings, which may be fixed with this update, due to Mesa. We will see if it makes sense to do a general update of the main ISOs once more.


#12

Hello,

I am still having the issue with Bluetooth. I have tried different kernels 4.1, 4.4, 4.9. and 4.15. But is not working. For 4.1, the system is stuck at boot. This issue was reported earlier and I thought it would be fixed in this upate. See the dmesg.

dmesg | grep -i blue
[   13.788449] Bluetooth: Core ver 2.22
[   13.788506] Bluetooth: HCI device and connection manager initialized
[   13.788511] Bluetooth: HCI socket layer initialized
[   13.788517] Bluetooth: L2CAP socket layer initialized
[   13.788529] Bluetooth: SCO socket layer initialized
[   14.581565] Bluetooth: hci0: don't support firmware rome 0x31010000
[   29.970981] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   29.970984] Bluetooth: BNEP filters: protocol multicast
[   29.970990] Bluetooth: BNEP socket layer initialized

#13

Heehee, yep i thought of you when i saw its size & no. of packages.


#14

My KDE Testing VM, running in my KDE Stable Tower, updated ok, & though it puzzled me with this message at the end, it subsequently rebooted ok & seems to run ok, so i intuit that it is… ok.


#15

Yes, could be. But it must be an error, that was introduced with an update after releasing 17.1.7. Because 17.1.8 doesn’t work for this systems (and probably other) and same problem with 17.1.7 and updating packages to actual stable branch (at this time). And updating to this testing update made it working again without changing (manually) any configuration. Probably it could be useful to know for other users, which run into the same problem. But I found no suitable place to note it.

Maybe it could be build a 17.1.8-1 after this testing update is promoted to stable branch? It’s a little bit pity, because the install media is as a live media sometimes the first contact with Manjaro for new users.


#16

You might have accidentally grabbed it while Philip was still moving around packages for the testing update :wink:
On testing branch you will need version 396.18 for your kernel extramodules to be compatible.
Please use the “downgrade” command
sudo pacman -Syyuu
to have it sorted out!


#17

good update on xfce and awesome. Virtualbox update went well


#18

Well I was “forced” by some team members to create v17.1.8 ISOs. Normally I would had delayed it by some weeks. If we get higher error reports it makes sense to do another release of our install medias. Your PC seems to be common and most likely it is a Intel/Mesa issue. We will do some more testings and I’ll ping you when I’ve some new ISOs ready for general testing.


#19

I didn’t see glibc or pam included in the update…is this Arch news item worth considering when watching out for these packages when they get updated? I personally didn’t find any /etc/nsswitch.pacnew items, although my install is newish and I’m not quite sure what “removed modules” they’re referring to when browsing the /etc/pam.d directory. I have xscreensaver installed (because I like those screensavers), so that would probably be my concern.

A bit offtopic, I noticed my clock was off by nearly 30 seconds after 2 weeks…I didn’t notice ntpd was apparently inactive the whole time but checking “set time and date automatically” in the msm manager solved the issue. Is this setting always unchecked by default?


#20

Have not switched to unstable lately

Aha ^^ that solves a lot of questions on my side =) thx!

Done - no problems, thx