[Testing Update] 2018-04-12 - ALSA, Gnome v3.28.1, Deepin, Python


#1

Hi community,

welcome to another testing update of Manjaro. Our most effort went into ALSA, Gnome v3.28.1, Deepin and Python packages. We are now ready for a new stable update, based on our testings.

If you wanna test the latest features of the upcoming Manjaro release Illyria, you may checkout our Alpha releases:

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.103 [EOL]
  • linux41 4.1.51
  • linux44 4.4.127
  • linux49 4.9.93
  • linux414 4.14.33
  • linux415 4.15.16
  • linux416 4.16.1
  • linux417 4.17-rc0
  • linux-rt 4.14.29_rt25

Package Updates (Thu Apr 12 07:14:12 CEST 2018)

  • testing core x86_64: 7 new and 7 removed package(s)
  • testing extra x86_64: 23 new and 23 removed package(s)
  • testing community x86_64: 68 new and 66 removed package(s)


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-11           2017-04-12
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro     3.2.9.20180409-1             3.2.10-1
                                inxi             2.9.12-1             3.0.00-1
                           musescore              2.2-2.1            2.2.1-1.1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-11           2017-04-12
-------------------------------------------------------------------------------
                                 0ad                a22-5                a22-6
                             aws-cli             1.15.1-1             1.15.4-1
                         bitcoin-cli             0.16.0-1             0.16.0-2
                      bitcoin-daemon             0.16.0-1             0.16.0-2
                          bitcoin-qt             0.16.0-1             0.16.0-2
                          bitcoin-tx             0.16.0-1             0.16.0-2
                               botan              2.4.0-1              2.5.0-4
              deepin-desktop-schemas     3.2.9.20180409-1             3.2.10-1
                 deepin-image-viewer             1.2.18-1             1.2.19-1
                      dnscrypt-proxy              2.0.8-3              2.0.9-1
                      docker-compose             1.20.1-1             1.21.0-1
                 dolphin-emu 1:5.0.r6362.c08f6f0c53-1 1:5.0.r6362.c08f6f0c53-2
                                drbl            2.20.11-1            2.25.10-1
                             fig2dev              3.2.6-1            3.2.6.a-1
                    gimp-plugin-gmic              2.2.1-2              2.2.2-1
                                gmic              2.2.1-2              2.2.2-1
                                 i7z        0.27.2.git1-4        0.27.2.git1-5
                          ibus-anthy              1.5.9-1             1.5.10-1
     intellij-idea-community-edition           2:2018.1-1         2:2018.1.1-1
                               jedit              5.4.0-5              5.5.0-1
                             jenkins              2.115-1              2.116-1
                                 kea              1.3.0-5              1.3.0-6
                                knot              2.6.5-2              2.6.6-1
                   krita-plugin-gmic              2.2.1-2              2.2.2-1
                             libmgba              0.6.1-3              0.6.2-1
                      libmodsecurity           20170611-3            1:3.0.2-1
                    libqtshadowsocks              2.0.2-1              2.0.2-2
                              lolcat             90.8.8-2             99.9.9-1
                            mednafen             1.21.1-1             1.21.2-1
                           megaglest             3.13.0-4             3.13.0-5
                             mgba-qt              0.6.1-3              0.6.2-1
                            mgba-sdl              0.6.1-3              0.6.2-1
                           miniupnpc       2.0.20180222-1       2.0.20180406-1
                            mldonkey              3.1.6-1              3.1.6-2
                             ncmpcpp              0.8.1-4              0.8.2-1
                      nginx-mainline            1.13.11-1            1.13.12-1
                                 npm              5.8.0-1              5.8.0-2
                              nuitka           0.5.29.3-1           0.5.29.4-1
                            powerdns              4.1.1-1              4.1.1-2
                        python-boto3              1.7.1-1              1.7.4-1
                     python-botocore             1.10.1-1             1.10.4-1
                        python-munch              2.3.0-1              2.3.1-1
                          python-pbr              4.0.1-1              4.0.2-1
                  python-subunit2sql              1.8.0-1              1.9.0-1
                          python-tox              2.9.1-1              3.0.0-1
                       python2-boto3              1.7.1-1              1.7.4-1
                    python2-botocore             1.10.1-1             1.10.4-1
                       python2-munch              2.3.0-1              2.3.1-1
                         python2-pbr              4.0.1-1              4.0.2-1
                 python2-subunit2sql              1.8.0-1              1.9.0-1
                         python2-tox              2.9.1-1              3.0.0-1
                             radare2              2.4.0-1              2.5.0-1
                             remmina    1:1.2.0rcgit.27-2    1:1.2.0rcgit.29-1
                        riot-desktop             0.13.5-2             0.14.0-1
                            riot-web             0.13.5-2             0.14.0-1
                          ruby-async              1.4.1-1              1.5.0-1
                      ruby-async-dns              1.0.0-2              1.1.0-1
                       ruby-async-io              1.6.1-1              1.7.0-1
                          testssl.sh            2.9.5.3-1            2.9.5.4-1
                             trickle               1.07-9                    -
                           wxsqlite3              3.5.9-1              4.0.0-1
                                zart              2.2.1-2              2.2.2-1
                        zerotier-one              1.2.4-3              1.2.4-4
                          flawfinder                    -              2.0.6-1
                       ruby-manpages                    -              0.6.1-1
                              ssdeep                    -             2.14.1-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-11           2017-04-12
-------------------------------------------------------------------------------
                           procps-ng             3.3.13-0             3.3.14-0


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-11           2017-04-12
-------------------------------------------------------------------------------
                         btrfs-progs             4.15.1-1               4.16-1
                               glib2 2.56.0+16+gecabc6e21-1           2.56.1-1
                          glib2-docs 2.56.0+16+gecabc6e21-1           2.56.1-1
                       libutil-linux               2.32-2               2.32-3
                            syslinux               6.03-8              6.03-10
                          util-linux               2.32-2               2.32-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-11           2017-04-12
-------------------------------------------------------------------------------
                            alsa-lib              1.1.5-1              1.1.6-1
                            alsa-oss             1.0.28-1              1.1.6-1
                          alsa-utils              1.1.5-2              1.1.6-1
                              cantor            17.12.3-2            17.12.3-3
                      eclipse-common              4.7.3-1            4.7.3.a-1
                         eclipse-cpp              4.7.3-1            4.7.3.a-1
                        eclipse-java              4.7.3-1            4.7.3.a-1
                  eclipse-javascript              4.7.3-1            4.7.3.a-1
                         eclipse-jee              4.7.3-1            4.7.3.a-1
                         eclipse-php              4.7.3-1            4.7.3.a-1
                       gnome-desktop           1:3.28.0-1           1:3.28.1-1
                                htop              2.1.0-2              2.2.0-2
                           kuiserver             5.12.4-2             5.12.4-3
                        libqalculate              2.3.0-1              2.4.0-1
              plasma-wayland-session             5.12.4-2             5.12.4-3
                    plasma-workspace             5.12.4-2             5.12.4-3
                       qalculate-gtk              2.3.0-1              2.4.0-1
                             qca-qt4              2.1.3-9             2.1.3-10
                             qca-qt5              2.1.3-9             2.1.3-10
                                sdl2              2.0.8-7              2.0.8-8
                                 srt              1.2.3-1              1.3.0-1
                                step            17.12.3-2            17.12.3-3
                                xfig              3.2.6-2            3.2.6.a-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.


Nautilus - Middle click on any location in other-locations:/// closes tab


Noto Sans Mono has incorrect spacing or has vanished (under KDE)

This has been reported upstream but hasn’t yet been fixed. For the meantime please install noto-fonts-compat: sudo pacman -S noto-fonts-compat



#3

Gnome 3.28.1, kernel 4.17 and all the rest running fine here without issues!


#4

all went well but got the following messages. Is this normal?

Upgrading syslinux (6.03-8 -> 6.03-10)…

==> For setting up Syslinux BIOS using the syslinux-install_update script follow
https://wiki.archlinux.org/index.php/Syslinux#Automatic_Install

==> For setting up Syslinux EFI follow
https://wiki.archlinux.org/index.php/Syslinux#UEFI_Systems

==> The syslinux-install_update script does not currently support EFI install


#5

Kernel: x86_64 Linux 4.17.0-1-MANJARO
Last time i tried it the desktop did not display correctly, but its ok now.

DE: Xfce4
WM: Xfwm4
WM Theme: Vertex-Maia
GTK Theme: Vertex-Maia [GTK2]
Icon Theme: Vertex-Maia
Font: Cantarell 10


#6

Since testing update 2018-04-11 where Lollypop was upgraded from 0.9.403-3 to 0.9.500-1
it seems to be broken for me.

Issues:

  • The Radios entry on the left is gone
  • If I click through the other categories it crashes random

I couldn’t find any bug-reports for the latest version, so it would be helpful to know if someone could reproduce my issues.

 ➜  ~ lollypop                                                    
No module named 'pylast'
    - Scrobbler disabled
    - Auto cover download disabled
    - Artist information disabled
$ sudo pip3 install pylast
/usr/lib/python3.6/site-packages/gi/module.py:177: Warning: g_array_append_vals: assertion 'array' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:177: Warning: g_hash_table_lookup: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()
/usr/lib/python3.6/site-packages/gi/module.py:177: Warning: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed
  g_type = info.get_g_type()

Edit: A downgrade to lollypop-0.9.403-3 solves the problems.


#7

Have the same problems. Also right click on party mode button completly freezes my system and i have to do hard reset.


#8

You can customize the default entries and return recently added albums and radios by right clicking on the sidebar menu.


#9

No issues with the upgrade. Nvidia GTX650, Kernel 4.16 and Gnome 3.28.1 working without problems, extensions included. Gno-menu stopped working but I fixed it by installing gnome-menus package. Great work!


#10

On my main computer

A. New issues

Nothing new to report so far.

Once again, Pamac 6.2.7-1 detected and showed updates flawlessly.

Manjaro Cinnamon
Kernel 4.14 (using kernel-alive)
Did the update with Pamac

Intel i5-6400
Nvidia Geforce GTX 970


Upstream released 0.9.502 today.

Hope 0.9.502 will come to Manjaro very soon and will fix problems people are having with Lollypop right now.


#11

Is already in unstable and testing branch. :slight_smile:


#12

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.