[Testing Update] 2018-04-10 - Systemd, Gnome v3.28.1, Python, Perl, Haskell

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. Our most effort went into Systemd, Gnome v3.28.1, Python, Perl and Haskell packages.

If you wanna test the latest features of the upcoming Manjaro release Illyria, you may checkout our Alpha releases:

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.103 [EOL]
  • linux41 4.1.51
  • linux44 4.4.127
  • linux49 4.9.93
  • linux414 4.14.33
  • linux415 4.15.16
  • linux416 4.16.1
  • linux417 4.17-rc0
  • linux-rt 4.14.29_rt25

Package Updates (Tue Apr 10 08:17:34 CEST 2018)

  • testing community x86_64: 81 new and 79 removed package(s)
  • testing core x86_64: 6 new and 6 removed package(s)
  • testing extra x86_64: 35 new and 35 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro              3.2.9-1     3.2.9.20180409-1
          manjaro-gdm-18.0-theme-dev           20180407-1           20180409-1
                 manjaro-i3-settings           20180331-2           20180409-1
                                 yay              5.608-2              5.657-2


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                               bspwm              0.9.4-1              0.9.5-1
                           cbatticon              1.6.7-1              1.6.8-1
                             cryptol             2.5.0-46             2.5.0-47
              deepin-desktop-schemas              3.2.9-1     3.2.9.20180409-1
                               eclib           20171219-1           20171219-2
                    firefox-noscript           10.1.6.5-1           10.1.7.5-1
                               flint             2.5.2-20             2.5.2-21
                           git-annex        6.20180316-26        6.20180316-27
                         gnome-boxes             3.28.0-1             3.28.1-1
                               gsoap             2.8.65-1             2.8.66-1
                            gunicorn             19.7.1-1             19.7.1-2
                        haskell-dbus              1.0.1-2              1.0.1-3
                    haskell-dbus0.10            0.10.15-1            0.10.15-2
                       haskell-extra              1.6.4-1              1.6.5-1
                  haskell-fdo-notify             0.3.1-41             0.3.1-42
                 haskell-hledger-lib                1.9-2                1.9-3
                         haskell-sbv                7.6-8                7.6-9
             haskell-servant-swagger             1.1.4-63             1.1.4-64
                       haskell-shake            0.16.3-27            0.16.3-28
                    haskell-swagger2               2.2-40              2.2.1-1
       haskell-wai-middleware-static             0.8.1-39              0.8.2-1
                             hledger                1.9-2                1.9-3
                         hledger-api                1.9-4                1.9-6
                          hledger-ui                1.9-3                1.9-4
                         hledger-web                1.9-4                1.9-5
                               hlint              2.1.1-2              2.1.1-3
                              hoogle            5.0.16-55            5.0.16-56
                                hugo               0.38-1             0.38.2-1
                             jenkins              2.114-1              2.115-1
                          kdeconnect              1.2.1-1              1.3.0-1
                     latte-integrale              1.7.3-4              1.7.3-5
                             libbson              1.9.3-1              1.9.4-1
                             libgiac           1.4.9.59-1           1.4.9.59-2
                              linbox              1.5.2-3              1.5.2-4
                                lxdm              0.5.3-5              0.5.3-6
                           lxdm-gtk3              0.5.3-5              0.5.3-6
                                 ntl             10.5.0-1             11.0.0-1
                         offlineimap              7.1.5-1              7.2.0-1
                            paraview              5.4.1-2              5.5.0-1
                                 pcb            1:4.1.0-1            1:4.1.1-1
                perl-datetime-locale               1.17-1               1.18-1
                  perl-mediawiki-api               0.41-2               0.41-3
                          phpmyadmin              4.7.9-1              4.8.0-1
                           postgrest          0.4.4.0-110          0.4.4.0-112
                             pugixml                1.8-1                1.9-1
                             pychess             0.99.1-1             0.99.1-2
                               pynac             0.7.19-1             0.7.19-2
              python-cached-property              1.4.0-1              1.4.2-1
                      python-cheroot              6.1.2-1              6.2.0-1
                        python-munch              2.2.0-1              2.3.0-1
                     python-pygithub               1.38-1               1.39-1
                     python-tenacity              4.9.0-1             4.10.0-1
                        python-txaio              2.9.0-1             2.10.0-1
                      python-wsproto             0.11.0-1             0.11.0-2
             python2-cached-property              1.4.0-1              1.4.2-1
                     python2-cheroot              6.1.2-1              6.2.0-1
                    python2-gunicorn             19.7.1-1             19.7.1-2
                       python2-munch              2.2.0-1              2.3.0-1
                    python2-pygithub               1.38-1               1.39-1
                    python2-tenacity              4.9.0-1             4.10.0-1
                       python2-txaio              2.9.0-1             2.10.0-1
                     python2-wsproto             0.11.0-1             0.11.0-2
                             remmina    1:1.2.0rcgit.27-1    1:1.2.0rcgit.27-2
                            sagemath               8.1-11               8.1-12
                    sagemath-jupyter               8.1-11               8.1-12
                            singular           4.1.1.p1-1           4.1.1.p1-2
                               stack             1.6.5-67             1.6.5-68
                            startdde             3.1.26-1             3.1.27-1
                       supercollider              3.9.2-1              3.9.3-1
                    telegram-desktop             1.2.16-1             1.2.17-1
                          wanderlust           20180116-1           20180409-1
                                xcas           1.4.9.59-1           1.4.9.59-2
                              xmobar               0.26-2               0.26-3
                                xosd             2.2.14-8             2.2.14-9
                          youtube-dl         2018.04.03-1         2018.04.09-1
                      perl-data-perl                    -           0.002009-4
                perl-moox-handlesvia                    -           0.001008-5


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                          libsystemd           238.51-1.1             238.76-1
                           procps-ng           3.3.12-2.1             3.3.13-0
                             systemd           238.51-1.1             238.76-1
                  systemd-sysvcompat           238.51-1.1             238.76-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                           logrotate             3.13.0-1             3.14.0-1
                         openssl-1.0            1.0.2.n-1            1.0.2.o-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                            chromium      65.0.3325.181-6      65.0.3325.181-7
                                 eog             3.28.0-1             3.28.1-1
                           evolution 3.28.0+8+gf3e2c90d24-1           3.28.1-1
                evolution-bogofilter 3.28.0+8+gf3e2c90d24-1           3.28.1-1
               evolution-data-server 3.28.0+6+g501f51b1c-2            3.28.1-1
                       evolution-ews             3.28.0-1             3.28.1-1
              evolution-spamassassin3.28.0+8+gf3e2c90d24-1            3.28.1-1
                             freetds            1.00.85-1            1.00.86-1
                             fribidi   1.0.1+8+gdf7252b-1              1.0.2-1
                    gnome-calculator             3.28.0-1             3.28.1-1
                  gnome-disk-utility             3.28.0-1             3.28.1-1
          gnome-getting-started-docs             3.28.0-1             3.28.1-1
                          gnome-maps             3.28.0-1             3.28.1-1
                gnome-system-monitor             3.28.0-1             3.28.1-1
                      gnome-terminal             3.28.0-2             3.28.1-1
                     gnome-user-docs             3.28.0-1             3.28.1-1
       gtk-update-icon-cache 3.22.29+60+ge42d8598ca-1 3.22.29+86+gd92df4ff2c-1
                        gtk3 3.22.29+60+ge42d8598ca-1 3.22.29+86+gd92df4ff2c-1
                                gvfs             1.36.0-2             1.36.1-1
                            gvfs-afc             1.36.0-2             1.36.1-1
                            gvfs-goa             1.36.0-2             1.36.1-1
                         gvfs-google             1.36.0-2             1.36.1-1
                        gvfs-gphoto2             1.36.0-2             1.36.1-1
                            gvfs-mtp             1.36.0-2             1.36.1-1
                            gvfs-nfs             1.36.0-2             1.36.1-1
                            gvfs-smb             1.36.0-2             1.36.1-1
                          knetattach             5.12.4-1             5.12.4-2
                               krita              4.0.0-3              4.0.1-1
                             libsoup             2.62.0-1             2.62.1-1
                      plasma-desktop             5.12.4-1             5.12.4-2
                               solid             5.44.0-1             5.44.0-2
                          vte-common             0.52.0-1             0.52.1-1
                                vte3             0.52.0-1             0.52.1-1
                      vulkan-headers           1:1.1.70-3           1:1.1.72-1
                    vulkan-html-docs           1:1.1.70-3           1:1.1.72-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                       lib32-systemd             238.51-1             238.76-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-04-09           2017-04-10
-------------------------------------------------------------------------------
                       lib32-fribidi   1.0.1+8+gdf7252b-1              1.0.2-1


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Known issues and solutions

This is a wiki post; please edit as necessary.


Nautilus - Middle click on any location in other-locations:/// closes tab


Noto Sans Mono has incorrect spacing or has vanished (under KDE)

This has been reported upstream but hasn’t yet been fixed. For the meantime please install noto-fonts-compat: sudo pacman -S noto-fonts-compat



#3
plasma-desktop 5.12.4-2
solid 5.44.0-2

resolving issue with automounting disks in KDE. udiskie autostart is not needed anymore.


#4

No issues to report yet!


#5

Edit update: still happening here on EXT4 HDD

Krita no longer crashes on close. On the other hand, kernel 4.16 and 4.17 have the same thing regarding event16 when the Tabled or another USB device is connected after the system started up. Not a big deal for now since it can be disconnected and connected again, so it works after all.

Another thing i noticed (just now but it might be an old thing) regarding Krita, is reporting this when opened:

Invalid profile :  "/usr/share/color/icc/colord/Crayons.icc" "Crayon Colors"
Invalid profile :  "/usr/share/color/icc/colord/x11-colors.icc" "X11 Colors"

[Testing Update] 2018-05-13 - FFMPEG v4.0, ZFS v0.7.9, Gamemode, Usual Updates
#6

Before the next stable update the following package should be removed from community repos in testing and unstable branche… to avoid question. I guess it’s because the package were pushed in the wrong repository at 1st.

remove kinfocenter-5.12.4-2 from community as kinfocenter-5.12.4-2.1 is in extra (the normal repository for the package)

as octopi show that the installed version is newer than repos. even pacman don’t propose downgrades. (and it’s normal)


#7

Well neither 4.16.x nor 4.17.x allow my system to go to suspend to ram; It goes to sleap but not fully (so the power LED would start pulsing slow) and it can’t be woken up anymore.

Apr 10 12:07:58 hk-01 systemd[1]: Starting TLP suspend/resume...
Apr 10 12:07:58 hk-01 systemd[1]: Started TLP suspend/resume.
Apr 10 12:07:58 hk-01 systemd[1]: Reached target Sleep.
Apr 10 12:07:58 hk-01 systemd[1]: Starting Suspend...
Apr 10 12:07:58 hk-01 systemd-sleep[1808]: Suspending system...
Apr 10 12:07:58 hk-01 kernel: PM: suspend entry (deep)

Thats all I get from the journal from both kernel versions :frowning:


#8

Look at the gnome-logs. I think, this app gives more info.


#9

fyi

DO NOT SYNC REPO ZFS /SPL with version 0.77 ( Test & Unstable , Stable )
https://www.phoronix.com/scan.php?page=news_item&px=ZFS-On-Linux-0.7.8


#10

Installed Linux 4.17.r180408f8 All is fine Xfce 17.1.7.


#11

On my main computer

A. New issues

Nothing new to report so far.

Once again, Pamac 6.2.7-1 detected and showed updates flawlessly.

Manjaro Cinnamon
Kernel 4.14 (using kernel-alive)
Did the update with Pamac

Intel i5-6400
Nvidia Geforce GTX 970


#12

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.