[Testing Update] 2018-04-02 - Kernels, Gnome, Mesa, Pamac, Browsers, GStreamer, LibreOffice, PHP

update
testing

#14

I got a grub error during update:

( 6/32) Updating Grub-Bootmenu
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /usr/share/grub/themes/manjaro/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-4.15-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.15-x86_64.img
Found initrd fallback image: /boot/initramfs-4.15-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.14-x86_64
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
/dev/mapper/control: open failed: Kein passendes Gerät gefunden
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.146 (2017-12-18) and kernel driver (unknown version).
Command failed
Fehler: Befehl konnte nicht korrekt ausgeführt werden

An update-grub in a separte window gave the same error. I kept my fingers crossed during reboot. reboot worked and update-grub after reboot was successful as well. Phuuuh. :wink:


#15

Since kernel 4.16 just release i tried it and i experience flashes on desktop like for a second gamma is set to max and then back to normal. It happens moving the mouse. Playing games is not affected, i tried with dc enable and disable. I’m using kde and my graphics card is a radeon R9 380X.


#16

UaU (wow)
228 updates, download 971, 45 MiB
Pamac didn’t show any updates, using “sudo pacman -Syyu”


#17

Amen - and I create my franken-gnome; Replaced nautilus with nemo right now ^^
Probably should realy give xfce a shot soon though…


#18

Smooth update on my main rig. One thing i noticed regarding the 4.16.0 kernel … if i boot with my Cintiq OFF, when i turn it on, there is a connect-disconnect simultaneously, and i could only see something related to event16, but i don’t see it in journactl, just in the KSystemLog. I took a screenshot (i apologize for that), but as you can see i will not post it directly in the forum :slight_smile:

Same behavior if i attach an USB stick or external drive. Turing it off and on again seems to solve the Pen Display connection, but not always with the USB stick.


[Testing Update] 2018-10-07 - Linux419 LTS, Pamac-Dev, SPL/ZFS
#19
sudo modprobe dm-mod

Now - the question is why this needs to be done on some systems and not others.


#20

for me, the flashes disappeared with disabling amdgpu.dc - on RX480. You need to set the boot parameter to amdgpu.dc=0 to deactivate it! Removing the line from grub does not deactivate it, as it is activated by default on Arch-based distributions. 4.17 will activate amdgpu.dc on mainline.


#21

Only used if you use LVM or LVM2. See here and here.


#22

dm-mod is inserted on my current laptop (which is a relatively fresh install) but I haven’t used LVM at all… I’ll have to check my other machines.


#23

Good update on XFCE 4.15 and 4.14 with no issues as of right now


#24

Alright - now I found a problem with 4.16.0-1 Kernel; suspend to ram once again does not work; With 4.15 and 4.14 it does work though - so for now I will stay at 4.15 and see back next update.


#25

Good update Asus Z97 Mk 1 Intel I7 4790 Nvidia GTx 750ti 4.15.15-1 Plasma desktop.
Thanks to the devs and maintainers. Problem free-


#26

Update was smooth with only two problems:

  1. after update finish I left my notebook, when I came back was impossible to reopen the session, constantly says login error and keyboard didnt’t work as expected.

  2. after restart the notebook, night light is wonrking only in one screen and not in both. I also have redshift installed, will try to uninstall and try again.


#27

Installing kernel 4.16.0, there is no problem after reboot, all working smoothly.


#28
  1. works after uninstall redshift and try different options on Screen configuration in Gnome. I have two screen expanded, then I move to mirror mode and still night light only works in ne screen, and when I change again to expanded, begins to works right

#31

update went smooth except redshift doesnt work with 4.16 kernel

Any idea when we are likley to see 4.17 kernel release? Im still getting daily hangs on my ridgeraven 2400G and apparently it should be better under 4.17.

Good work guys!


#32

Thanks for the answer, i think it was deactivated by default. I hope it will be fixed on 4.17.


#33

I’ve been using thunar (custom actions, no read ahead, etc.) with gnome for quit some time now.
Works perfectly well.


#34

4.16 has just been released by the kernel developers.

I’ll let you do the calculation.


#35

No issues on my KDE laptop, also no issues in a Gnome VBox install.
Good job!