[Testing Update] 2018-03-21 - Kernels, Firefox, GCC, VIM, Python, Haskell

update
testing

#1

Hi community,

welcome to another testing update of Manjaro. This is a another set of pkgs from our last testing announcement. We worked again on our Kernels, added the latest Firefox, updated GCC and VIM plus added the latest Python and Haskell packages.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.100 [EOL]
  • linux41 4.1.50
  • linux44 4.4.122
  • linux49 4.9.88
  • linux414 4.14.28
  • linux415 4.15.11
  • linux416 4.16-rc6
  • linux-RT-LTS 4.14.28_rt23
  • linux-RT 4.14.28_rt23

Package Updates (Wed Mar 21 09:53:29 CET 2018)

  • testing community x86_64: 225 new and 221 removed package(s)
  • testing core x86_64: 18 new and 18 removed package(s)
  • testing extra x86_64: 143 new and 142 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro              3.2.8-1              3.2.9-1
                         linux414-rt       4.14.27_rt21-1       4.14.28_rt23-1
               linux414-rt-acpi_call              1.1.0-8              1.1.0-9
                linux414-rt-bbswitch                0.8-8                0.8-9
             linux414-rt-broadcom-wl       6.30.223.271-8       6.30.223.271-9
                 linux414-rt-headers       4.14.27_rt21-1       4.14.28_rt23-1
                  linux414-rt-nvidia           1:390.42-2           1:390.42-3
            linux414-rt-nvidia-304xx          1:304.137-8          1:304.137-9
            linux414-rt-nvidia-340xx            340.106-8            340.106-9
                linux414-rt-nvidiabl               0.88-8               0.88-9
                   linux414-rt-r8168           8.045.08-8           8.045.08-9
               linux414-rt-rt3562sta         2.4.1.1_r4-8         2.4.1.1_r4-9
                linux414-rt-tp_smapi               0.41-8               0.41-9
             linux414-rt-vhba-module           20161009-8           20161009-9
linux414-rt-virtualbox-guest-modules              5.2.8-3              5.2.8-4
 linux414-rt-virtualbox-host-modules              5.2.8-3              5.2.8-4


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                               abcde              2.8.1-3              2.9.1-1
                           auditbeat              6.2.2-1              6.2.3-1
                           bettercap                2.2-1                2.3-1
                       cabal-install           2.0.0.1-35           2.0.0.1-38
                               darcs   2.12.5.20170909-57   2.12.5.20170909-60
                       elasticsearch              6.2.2-1              6.2.3-1
                            filebeat              6.2.2-1              6.2.3-1
           firefox-developer-edition             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-ach             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-af             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-an             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ar             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-as             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-ast             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-az             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-be             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-bg             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-bn-bd             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-bn-in             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-br             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-bs             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ca             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-cak             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-cs             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-cy             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-da             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-de             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-dsb             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-el             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-en-gb             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-en-us             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-en-za             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-eo             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-es-ar             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-es-cl             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-es-es             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-es-mx             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-et             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-eu             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-fa             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ff             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-fi             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-fr             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-fy-nl             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-ga-ie             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-gd             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-gl             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-gn             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-gu-in             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-he             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-hi-in             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-hr             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-hsb             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-hu             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-hy-am             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ia             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-id             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-is             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-it             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ja             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ka             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-kab             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-kk             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-km             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-kn             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ko             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-lij             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-lt             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-lv             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-mai             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-mk             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ml             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-mr             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ms             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-my             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-nb-no             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-ne-np             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-nl             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-nn-no             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-or             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-pa-in             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-pl             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-pt-br             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-pt-pt             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-rm             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ro             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ru             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-si             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-sk             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-sl             60.0b4-1             60.0b5-1
  firefox-developer-edition-i18n-son             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-sq             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-sr             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-sv-se             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ta             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-te             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-th             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-tr             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-uk             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-ur             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-uz             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-vi             60.0b4-1             60.0b5-1
   firefox-developer-edition-i18n-xh             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-zh-cn             60.0b4-1             60.0b5-1
firefox-developer-edition-i18n-zh-tw             60.0b4-1             60.0b5-1
                           git-annex         6.20180316-2         6.20180316-6
                              glider              0.5.0-1              0.5.1-1
                haskell-authenticate             1.3.4-69             1.3.4-72
                         haskell-aws              0.19-39              0.19-42
                  haskell-cheapskate             0.1.1-58             0.1.1-59
         haskell-conduit-combinators             1.1.2-42             1.1.2-43
               haskell-conduit-extra           1.2.3.2-25           1.2.3.2-26
                   haskell-criterion            1.4.0.0-8           1.4.0.0-11
          haskell-cryptohash-conduit            0.1.1-150            0.1.1-151
          haskell-cryptonite-conduit             0.2.2-43             0.2.2-44
                         haskell-dav             1.3.2-30             1.3.2-31
                         haskell-dns              3.0.2-8              3.0.2-9
                   haskell-esqueleto             2.5.3-80             2.5.3-81
                        haskell-feed           1.0.0.0-39           1.0.0.0-40
                      haskell-hakyll          4.11.0.0-47          4.11.0.0-52
                 haskell-hjsonschema             1.7.2-49             1.7.2-52
                    haskell-hopenpgp            2.5.5-188            2.5.5-190
                   haskell-hspec-wai             0.9.0-43             0.9.0-44
              haskell-hspec-wai-json             0.9.0-48             0.9.0-49
                haskell-html-conduit           1.2.1.2-29           1.2.1.2-30
                        haskell-http          4000.3.10-2          4000.3.11-2
                haskell-http-conduit             2.2.4-67             2.2.4-70
                 haskell-ixset-typed            0.3.1.1-9           0.3.1.1-10
                   haskell-js-jquery             3.3.1-30             3.3.1-33
                haskell-monad-logger           0.3.28.2-2           0.3.28.2-3
                       haskell-nonce              1.0.7-2              1.0.7-3
                  haskell-persistent           2.7.3.1-33           2.7.3.1-34
           haskell-persistent-sqlite             2.6.4-59             2.6.4-60
         haskell-persistent-template           2.5.3.1-32           2.5.3.1-33
            haskell-project-template           0.2.0.1-20           0.2.0.1-21
                    haskell-safecopy              0.9.4-1            0.9.4.1-1
              haskell-servant-server              0.12-79              0.12-82
                       haskell-shake            0.16.3-16            0.16.3-19
             haskell-simple-sendfile            0.2.27-17            0.2.27-18
           haskell-tagstream-conduit          0.5.5.3-133          0.5.5.3-134
               haskell-typed-process            0.2.1.0-5            0.2.2.0-1
                    haskell-unliftio            0.2.5.0-1            0.2.6.0-1
                         haskell-wai           3.2.1.1-31            3.2.1.2-1
              haskell-wai-app-static          3.1.6.1-168            3.1.6.2-2
                 haskell-wai-conduit           3.0.0.3-19            3.0.0.4-2
                    haskell-wai-cors             0.2.6-21             0.2.6-22
                   haskell-wai-extra          3.0.22.0-31          3.0.22.0-32
          haskell-wai-handler-launch           3.0.2.3-41           3.0.2.3-43
                  haskell-wai-logger              2.3.2-6              2.3.2-8
       haskell-wai-middleware-static             0.8.1-34             0.8.1-35
              haskell-wai-websockets            3.0.1.2-1            3.0.1.2-2
                        haskell-warp           3.2.18.1-6           3.2.18.1-8
                    haskell-warp-tls           3.2.4.2-28           3.2.4.2-30
                 haskell-xml-conduit           1.7.1.2-20           1.7.1.2-21
                  haskell-xml-hamlet           0.4.1.1-45           0.4.1.1-46
                       haskell-yesod            1.4.5-226            1.4.5-228
                  haskell-yesod-auth           1.4.21-118           1.4.21-122
                  haskell-yesod-core          1.4.37.3-43          1.4.37.3-45
               haskell-yesod-default            1.2.0-280            1.2.0-282
                  haskell-yesod-form           1.4.16-121           1.4.16-123
            haskell-yesod-persistent             1.4.3-97             1.4.3-99
                haskell-yesod-static          1.5.3.1-114          1.5.3.1-117
                  haskell-yesod-test           1.5.9.1-82           1.5.9.1-84
                   heartbeat-elastic              6.2.2-1              6.2.3-1
                         hledger-api               1.5-99              1.5-102
                         hledger-web              1.5.1-7             1.5.1-11
                              hoogle            5.0.16-41            5.0.16-45
                      hopenpgp-tools           0.19.5-104           0.19.5-106
                               idris             1.2.0-51             1.2.0-52
                                 inn              2.6.1-6              2.6.2-1
                                inxi             2.3.56-1                    -
                                  jq                1.5-5                1.5-6
                             kbibtex                0.7-1    0.7.git20180320-1
                              kibana              6.2.2-1              6.2.3-1
                                lash         0.6.0~rc2-11         0.6.0~rc2-12
                             librime           1:1.2.10-1            1:1.3.0-1
                            librsync            1:1.0.0-1            1:2.0.2-1
                            logstash              6.2.2-1              6.2.3-1
                         mcollective             2.11.4-8             2.11.4-9
                          metricbeat              6.2.2-1              6.2.3-1
                      nginx-mainline             1.13.9-1            1.13.10-1
                           oniguruma              6.8.0-1              6.8.1-1
                          packetbeat              6.2.2-1              6.2.3-1
                              pandoc              2.1.3-2              2.1.3-5
                     pandoc-citeproc          0.13.0.1-43          0.13.0.1-46
                     pandoc-crossref            0.3.0.3-2            0.3.0.3-5
                                  pd             0.48.0-3             0.48.1-3
                           postgrest           0.4.4.0-92           0.4.4.0-96
                   python-hypothesis             3.50.1-1             3.50.2-1
                     python-oauthlib              2.0.6-1              2.0.7-1
                 python-phonenumbers              8.9.1-1              8.9.2-1
               python-setuptools-scm             1.16.1-1             1.17.0-1
                  python2-hypothesis             3.50.1-1             3.50.2-1
                    python2-oauthlib              2.0.6-1              2.0.7-1
                python2-phonenumbers              8.9.1-1              8.9.2-1
              python2-setuptools-scm             1.16.1-1             1.17.0-1
                       roundcubemail              1.3.4-1              1.3.5-1
                            shotwell           2:0.26.4-1           2:0.28.0-1
                            smplayer             18.2.2-1             18.3.0-1
                               stack             1.6.5-44             1.6.5-49
                            startdde             3.1.25-1             3.1.26-1
                      tamarin-prover             1.2.3-22             1.2.3-25
                        tt-rss 1:17.4.r180.g820873de-1 1:17.4.r441.ge35a4673-1
                              xmobar              0.25-14              0.25-17
                                zbar              0.10-12               0.20-1
                        python2-zbar                    -               0.20-1
                       ruby-net-ping                    -              2.0.3-2
                  ruby-sys-proctable                    -              1.2.0-1
                            zbar-gtk                    -               0.20-1
                             zbar-qt                    -               0.20-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                            linux414            4.14.27-1            4.14.28-1
                    linux414-headers            4.14.27-1            4.14.28-1
                            linux415            4.15.10-1            4.15.11-1
                    linux415-headers            4.15.10-1            4.15.11-1
                      linux416 4.16.r180316.gdf09348-1 4.16.r180321.g3215b9d-1
              linux416-headers 4.16.r180316.gdf09348-1 4.16.r180321.g3215b9d-1
                             linux44            4.4.121-1            4.4.122-1
                     linux44-headers            4.4.121-1            4.4.122-1
                             linux49             4.9.87-1             4.9.88-1
                     linux49-headers             4.9.87-1             4.9.88-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                                 gcc              7.3.0-1     7.3.1+20180312-1
                             gcc-ada              7.3.0-1     7.3.1+20180312-1
                         gcc-fortran              7.3.0-1     7.3.1+20180312-1
                              gcc-go              7.3.0-1     7.3.1+20180312-1
                            gcc-libs              7.3.0-1     7.3.1+20180312-1
                            gcc-objc              7.3.0-1     7.3.1+20180312-1
                      lib32-gcc-libs              7.3.0-1     7.3.1+20180312-1
                             libtool 2.4.6+40+g6ca5e224-4 2.4.6+40+g6ca5e224-5


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                  linux414-acpi_call             1.1.0-25             1.1.0-26
                   linux414-bbswitch               0.8-25               0.8-26
                linux414-broadcom-wl      6.30.223.271-25      6.30.223.271-26
                   linux414-catalyst     1:15.201.1151-25     1:15.201.1151-26
                linux414-ndiswrapper              1.61-25              1.61-26
                     linux414-nvidia           1:390.42-2           1:390.42-3
               linux414-nvidia-304xx         1:304.137-25         1:304.137-26
               linux414-nvidia-340xx           340.106-13           340.106-14
                   linux414-nvidiabl              0.88-25              0.88-26
                      linux414-r8168          8.045.08-13          8.045.08-14
                  linux414-rt3562sta        2.4.1.1_r4-25        2.4.1.1_r4-26
                        linux414-spl              0.7.6-3              0.7.6-4
                   linux414-tp_smapi              0.41-25              0.41-26
                linux414-vhba-module          20161009-25          20161009-26
   linux414-virtualbox-guest-modules              5.2.8-5              5.2.8-6
    linux414-virtualbox-host-modules              5.2.8-5              5.2.8-6
                        linux414-zfs              0.7.6-3              0.7.6-4
                  linux415-acpi_call             1.1.0-11             1.1.0-12
                   linux415-bbswitch               0.8-11               0.8-12
                linux415-broadcom-wl      6.30.223.271-11      6.30.223.271-12
                   linux415-catalyst     1:15.201.1151-11     1:15.201.1151-12
                linux415-ndiswrapper              1.61-11              1.61-12
                     linux415-nvidia           1:390.42-2           1:390.42-3
               linux415-nvidia-304xx         1:304.137-11         1:304.137-12
               linux415-nvidia-340xx           340.106-11           340.106-12
                   linux415-nvidiabl              0.88-11              0.88-12
                      linux415-r8168          8.045.08-11          8.045.08-12
                        linux415-spl              0.7.6-3              0.7.6-4
                   linux415-tp_smapi              0.41-11              0.41-12
                linux415-vhba-module          20161009-11          20161009-12
   linux415-virtualbox-guest-modules              5.2.8-4              5.2.8-5
    linux415-virtualbox-host-modules              5.2.8-4              5.2.8-5
                        linux415-zfs              0.7.6-3              0.7.6-4
                  linux416-acpi_call            1.1.0-0.7            1.1.0-0.8
                   linux416-bbswitch              0.8-0.7              0.8-0.8
                linux416-broadcom-wl     6.30.223.271-0.7     6.30.223.271-0.8
                   linux416-catalyst    1:15.201.1151-0.7    1:15.201.1151-0.8
                linux416-ndiswrapper             1.61-0.7             1.61-0.8
                     linux416-nvidia         1:390.42-0.7         1:390.42-0.8
               linux416-nvidia-304xx        1:304.137-0.7        1:304.137-0.8
               linux416-nvidia-340xx          340.106-0.7          340.106-0.8
                   linux416-nvidiabl             0.88-0.7             0.88-0.8
                      linux416-r8168         8.045.08-0.7         8.045.08-0.8
                        linux416-spl            0.7.6-0.7            0.7.6-0.8
                   linux416-tp_smapi             0.41-0.7             0.41-0.8
                linux416-vhba-module         20161009-0.7         20161009-0.8
   linux416-virtualbox-guest-modules            5.2.8-0.7            5.2.8-0.8
    linux416-virtualbox-host-modules            5.2.8-0.7            5.2.8-0.8
                        linux416-zfs            0.7.6-0.7            0.7.6-0.8
                   linux44-acpi_call             1.1.0-86             1.1.0-87
                    linux44-bbswitch               0.8-86               0.8-87
                 linux44-broadcom-wl      6.30.223.271-56      6.30.223.271-57
                    linux44-catalyst     1:15.201.1151-86     1:15.201.1151-87
                 linux44-ndiswrapper              1.61-54              1.61-55
                      linux44-nvidia           1:390.42-1           1:390.42-2
                linux44-nvidia-304xx         1:304.137-21         1:304.137-22
                linux44-nvidia-340xx            340.106-8            340.106-9
                    linux44-nvidiabl              0.88-86              0.88-87
       linux44-open-vm-tools-modules      2:2013.09.16-86      2:2013.09.16-87
                       linux44-r8168           8.045.08-8           8.045.08-9
                   linux44-rt3562sta        2.4.1.1_r4-54        2.4.1.1_r4-55
                         linux44-spl              0.7.6-1              0.7.6-2
                    linux44-tp_smapi              0.41-86              0.41-87
                 linux44-vhba-module          20161009-54          20161009-55
    linux44-virtualbox-guest-modules              5.2.8-1              5.2.8-2
     linux44-virtualbox-host-modules              5.2.8-1              5.2.8-2
                         linux44-zfs              0.7.6-1              0.7.6-2
                   linux49-acpi_call             1.1.0-68             1.1.0-69
                    linux49-bbswitch               0.8-68               0.8-69
                 linux49-broadcom-wl      6.30.223.271-68      6.30.223.271-69
                    linux49-catalyst     1:15.201.1151-68     1:15.201.1151-69
                 linux49-ndiswrapper              1.61-66              1.61-67
                      linux49-nvidia           1:390.42-1           1:390.42-2
                linux49-nvidia-304xx         1:304.137-27         1:304.137-28
                linux49-nvidia-340xx            340.106-8            340.106-9
                    linux49-nvidiabl              0.88-68              0.88-69
                       linux49-r8168           8.045.08-8           8.045.08-9
                   linux49-rt3562sta        2.4.1.1_r4-66        2.4.1.1_r4-67
                         linux49-spl              0.7.6-2              0.7.6-3
                    linux49-tp_smapi              0.41-68              0.41-69
                 linux49-vhba-module          20161009-66          20161009-67
    linux49-virtualbox-guest-modules              5.2.8-2              5.2.8-3
     linux49-virtualbox-host-modules              5.2.8-2              5.2.8-3
                         linux49-zfs              0.7.6-2              0.7.6-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                                asio             1.10.8-1             1.12.0-1
                            chromium      65.0.3325.162-1      65.0.3325.181-1
                        gnu-efi-libs              3.0.6-1              3.0.8-1
                             gparted             0.30.0-3             0.31.0-1
                                nmap               7.60-1               7.70-1
               publicsuffix-list 20180225.652.d311456-1 20180320.657.a39f111-1
                        python-numpy             1.14.1-1             1.14.2-1
                       python2-numpy             1.14.1-1             1.14.2-1
                        vim-spell-af           20150901-1           20180224-1
                        vim-spell-am           20150901-1           20180224-1
                        vim-spell-bg           20150901-1           20180224-1
                        vim-spell-br           20150901-1           20180224-1
                        vim-spell-ca           20150901-1           20180224-1
                        vim-spell-cs           20150901-1           20180224-1
                        vim-spell-cy           20150901-1           20180224-1
                        vim-spell-da           20150901-1           20180224-1
                        vim-spell-de           20150901-1           20180224-1
                        vim-spell-el           20150901-1           20180224-1
                        vim-spell-en           20150901-1           20180224-1
                        vim-spell-eo           20150901-1           20180224-1
                        vim-spell-es           20150901-1           20180224-1
                        vim-spell-fo           20150901-1           20180224-1
                        vim-spell-fr           20150901-1           20180224-1
                        vim-spell-ga           20150901-1           20180224-1
                        vim-spell-gd           20150901-1           20180224-1
                        vim-spell-gl           20150901-1           20180224-1
                        vim-spell-he           20150901-1           20180224-1
                        vim-spell-hr           20150901-1           20180224-1
                        vim-spell-hu           20150901-1           20180224-1
                        vim-spell-id           20150901-1           20180224-1
                        vim-spell-it           20150901-1           20180224-1
                        vim-spell-ku           20150901-1           20180224-1
                        vim-spell-la           20150901-1           20180224-1
                        vim-spell-lt           20150901-1           20180224-1
                        vim-spell-lv           20150901-1           20180224-1
                        vim-spell-mg           20150901-1           20180224-1
                        vim-spell-mi           20150901-1           20180224-1
                        vim-spell-ms           20150901-1           20180224-1
                        vim-spell-nb           20150901-1           20180224-1
                        vim-spell-nl           20150901-1           20180224-1
                        vim-spell-nn           20150901-1           20180224-1
                        vim-spell-ny           20150901-1           20180224-1
                        vim-spell-pl           20150901-1           20180224-1
                        vim-spell-pt           20150901-1           20180224-1
                        vim-spell-ro           20150901-1           20180224-1
                        vim-spell-ru           20150901-1           20180224-1
                        vim-spell-rw           20150901-1           20180224-1
                        vim-spell-sk           20150901-1           20180224-1
                        vim-spell-sl           20150901-1           20180224-1
                        vim-spell-sv           20150901-1           20180224-1
                        vim-spell-sw           20150901-1           20180224-1
                       vim-spell-tet           20150901-1           20180224-1
                        vim-spell-th           20150901-1           20180224-1
                        vim-spell-tl           20150901-1           20180224-1
                        vim-spell-tn           20150901-1           20180224-1
                        vim-spell-uk           20150901-1           20180224-1
                        vim-spell-yi           20150901-1           20180224-1
                        vim-spell-zu           20150901-1           20180224-1
                        vim-spell-sr                    -           20180224-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-03-20           2018-03-21
-------------------------------------------------------------------------------
                        lib32-libpsl             0.20.1-1             0.20.1-2

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


[Testing Update] 2018-03-22 - Kernels, Mesa, Pamac, MSM, Python, Haskell
#2

wiki post


#3

Smooth upgrade on KDE-edition with kernel 4.14


#4

All good, all works, xfce and lxde. :grinning: Thank’s


#5

good update no issues


#6

I released XFCE 17.1.7-rc6, so our community may test this update from within a new ISO.


#7

this edition uses XFCE-4.12?


#8

Was inxi dropped to aur in arch?


#9

Yes, it still uses XFCE-4.12. Only the ISO we created for Station-X and the Spitfire we used XFCE-4.14 so far.


#11

I was just trying to update my system yet it stops and gives me the error you can see on the screenshot here


I’ve tried running the update in the terminal and using the GUI Package Manager, yet I get the same error everytime. I am not qite sure what I should do since I don’t want to completely break my system. Anybody can help?


#12

Smooth update. KDE


#13

The issue is with python-pycparser package. Somehow files this package will install already exist on your harddrive. You may use pacman -Qo <path/to/one/existing/file> to see if that package is owned by another package or somehow left orphaned. You may use the terminal and copy the terminal output to delete the listed files or use sudo pacman -S --force python-pycparser as last resort.


#14

Have you ever run sudo pip install pycparser ?


#15

Not that I remember, no. It’s not only pycparser though. Scrolling further down the list, it also tells me that OpenSSL, cryptography, asn1crypto and cffi also exist already. As @philm suggested, I checked whether the packages are owned by another package and it seems to me that they aren’t. So am I correct in assuming that I can delete them without any issues?


#16

If the files aren’t owned by a package you can delete them or overwrite them with --force. Either will work.


#17

Should I install it from AUR?


#18

Read this thread first:


#19

So far, so good. Thumbs up!


#20

@philm i also upload a Gnome 17.1.7-rc1 to test in community.

Notable changes are:

  • papirus-maia-icon-theme as default icon theme to match with adapta-maia theme
  • added timeshift backup utility
  • added kernel-alive for maintain kernel-modules active after a kernel upgrade ( reboot active new kernel modules )

:wink:

Edit:forgot to say also kstatusnktifier extension is enabled instead of topicons plus…


#21

Good job on it! I really love it! One thing i couldn’t explain tho is that with the manjaro-gnome-maia-theme the settings to the wacom tablet (mapping buttons) opens a blank overlay. Once i remove that package and reinstall gnome-shell the mapping buttons works as it should, but of course the login screen reverts to the default one. Some people with tablets might get confused, and while they might want to use Gnome, they will think that there is no support for wacom in Manjaro :slight_smile:

Either way, for me, because i investigated a lot this tablet things, there was no real issue to get them work, and i left in that post my opinion and findings, but still i don’t understand completely what is behind the theme thing in Gnome.
Cheers!