[Testing Update] 2018-02-22 - MHWD, NVIDIA, Hybrid Graphic Setup

update
testing

#1

Hi community,

this is more or less a fix-up package since our last testing update we did on the 21th

  • We addressed the issue with nvidiafb and linux415+ series
  • We upgraded mhwd to v0.6.2 and simplified opensource driver installation for nouveau and amdgpu
  • We simplified installations on hybrid graphic card setups
  • We added regular upstream updates like Haskell and Python

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.54
  • linux318 3.18.95 [EOL]
  • linux41 4.1.49
  • linux44 4.4.116
  • linux49 4.9.82
  • linux414 4.14.20
  • linux415 4.15.4
  • linux416 4.16-rc1
  • linux-RT-LTS 4.14.18_rt15
  • linux-RT 4.14.18_rt15

Package Updates (Thu Feb 22 07:31:33 CET 2018)

  • testing community x86_64: 69 new and 67 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 6 new and 7 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-02-21           2018-02-22
-------------------------------------------------------------------------------
         manjaro-bspwm-mate-settings           20180221-2           20180221-3
                             volnoti                    -    0.1.r3.gc5a94af-2


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-02-21           2018-02-22
-------------------------------------------------------------------------------
                       cabal-install           2.0.0.1-12           2.0.0.1-14
                                ccid             1.4.28-1             1.4.29-1
                          containerd              1.0.1-1              1.0.2-1
                               darcs   2.12.5.20170909-30   2.12.5.20170909-31
                           git-annex        6.20180112-70        6.20180112-72
                haskell-authenticate             1.3.4-38             1.3.4-40
                         haskell-aws               0.19-5               0.19-7
                  haskell-cheapskate             0.1.1-38             0.1.1-40
                   haskell-criterion           1.3.0.0-17           1.3.0.0-19
                      haskell-hakyll           4.11.0.0-1           4.11.0.0-3
                 haskell-hjsonschema             1.7.2-22             1.7.2-24
                   haskell-hspec-wai             0.9.0-24             0.9.0-26
              haskell-hspec-wai-json             0.9.0-29             0.9.0-31
                        haskell-http          4000.3.9-11          4000.3.9-13
                haskell-http-conduit             2.2.4-36             2.2.4-38
                   haskell-js-jquery              3.3.1-8             3.3.1-10
                     haskell-servant            0.12.1-17            0.12.1-18
              haskell-servant-server              0.12-50              0.12-52
             haskell-servant-swagger             1.1.4-40             1.1.4-41
                       haskell-shake             0.16.2-1             0.16.2-3
                       haskell-vault            0.3.0.7-9            0.3.1.0-1
                         haskell-wai           3.2.1.1-26           3.2.1.1-27
              haskell-wai-app-static          3.1.6.1-142          3.1.6.1-144
                 haskell-wai-conduit           3.0.0.3-12           3.0.0.3-13
                    haskell-wai-cors             0.2.6-10             0.2.6-11
                   haskell-wai-extra          3.0.22.0-12          3.0.22.0-14
          haskell-wai-handler-launch           3.0.2.3-20           3.0.2.3-22
                  haskell-wai-logger              2.3.1-6              2.3.1-7
       haskell-wai-middleware-static             0.8.1-25             0.8.1-26
              haskell-wai-websockets           3.0.1.1-46           3.0.1.1-47
                        haskell-warp             3.2.16-3             3.2.16-5
                    haskell-warp-tls             3.2.4-52             3.2.4-54
                       haskell-yesod            1.4.5-191            1.4.5-193
                  haskell-yesod-auth            1.4.21-74            1.4.21-76
                  haskell-yesod-core          1.4.37.3-15          1.4.37.3-17
               haskell-yesod-default            1.2.0-252            1.2.0-254
                  haskell-yesod-form            1.4.16-86            1.4.16-88
            haskell-yesod-persistent             1.4.3-65             1.4.3-67
                haskell-yesod-static           1.5.3.1-85           1.5.3.1-87
                  haskell-yesod-test           1.5.9.1-47           1.5.9.1-49
                         hledger-api               1.5-61               1.5-63
                         hledger-web               1.5-61               1.5-63
                              hoogle             5.0.16-4             5.0.16-6
                               idris             1.2.0-28             1.2.0-30
                             keybase             1.0.41-2             1.0.42-1
                   libringclient 2:20180212.1.17fec46-1 2:20180216.1.63fd90f-1
                              marked             0.3.15-1             0.3.16-1
                             opendht         1:1.6.0rc1-1         1:1.6.0rc2-1
                              pandoc              2.1.1-1              2.1.1-3
                     pandoc-citeproc           0.13.0.1-1           0.13.0.1-3
                     pandoc-crossref           0.3.0.1-36           0.3.0.1-38
                                 pcb            1:4.0.2-1            1:4.1.0-1
                       perl-importer              0.024-3              0.025-1
                           postgrest           0.4.4.0-49           0.4.4.0-51
                       python-peewee             3.0.18-1             3.0.19-1
                      python2-peewee             3.0.18-1             3.0.19-1
                     ring-daemon 2:20180212.1.17fec46-1 2:20180216.1.63fd90f-1
                      ring-gnome 3:20180212.1.17fec46-1 3:20180216.1.63fd90f-1
                             ripgrep              0.8.0-1              0.8.1-1
                                smem                1.4-1                1.5-1
                               stack            1.6.3.1-1            1.6.3.1-3
                          stone-soup             0.21.0-1             0.21.1-1
                              stubby              0.2.1-1              0.2.2-1
                      tamarin-prover             1.2.2-87             1.2.2-89
                              xmobar            0.24.5-24            0.24.5-26
                       zita-ajbridge              0.7.0-3              0.7.0-4
                                 sox                    -             14.4.2-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-02-21           2018-02-22
-------------------------------------------------------------------------------
                                mhwd              0.6.1-2              0.6.2-1
                             mhwd-db              0.6.1-1              0.6.2-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-02-21           2018-02-22
-------------------------------------------------------------------------------
                  nvidia-304xx-utils          1:304.137-3          1:304.137-4
                  nvidia-340xx-utils            340.106-1            340.106-2
                        nvidia-utils           1:390.25-1           1:390.25-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-02-21           2018-02-22
-------------------------------------------------------------------------------
            archlinux-appstream-data           20180129-1           20180221-1
                               meson             0.44.0-2             0.44.1-1
                                 sox             14.4.2-2                    -
                      zita-resampler              1.3.0-5              1.6.0-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


[Testing Update] 2018-02-23 - Kernels, Systemd, Haskell, Python
[Stable Update] 2018-02-25 - Kernels, Plasma, Mesa, Systemd, QT5, Browsers
#2

Known issues and solutions

This is a wiki post; please edit as necessary.


My mouse is jittering like hell!

Seems the new libinput update created some issues with some touchpads. If our new kernel updates don’t solve the issue for you, you may think about downgrading libinput instead, until upstream found a proper solution for you:

sudo pacman -U https://archive.archlinux.org/packages/l/libinput/libinput-1.9.4-1-x86_64.pkg.tar.xz

xorgproto, libxfont, can’t remove… what?

Refresh your mirrors and try the update again. This package conflict should be resolved.

Otherwise, say Yes to replace all the “proto” packages with xorgproto. If it wants to remove any packages, STOP, and run

sudo pacman-mirrors -f 3
sudo pacman -Syyu

KDE Global Menu on all my windows

Check System Settings -> Application Style -> Window Decorations -> Buttons.

Make sure global menu widget is removed from the Titlebar, for some reason it was added in 5.12 when the global menu setting option was removed.


KDE remove green separator line between Titlebar and Window

System Settings>Application Style>Window Decorations>Breeze>Settings Icon
Turn off “Draw separator …”


On KDE my external drives don’t get automounted when I plugged them in

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that), after you had installed it. A re-login may be needed to get it active. As alternative start it manually for your current session.


My system won’t boot anymore after this update

Most likely you are using a freetype2 package from the AUR. Due the harfbuzz update, your system is broken. So either install the official supported freetype2 package from our repositories or downgrade to harfbuzz v1.7.4: sudo pacman -U https://archive.archlinux.org/packages/h/harfbuzz/harfbuzz-1.7.4-1-x86_64.pkg.tar.xz

You might try also try Freetype2-ultimate5 — fonts like in Infinality's ultimate5 which is a maintained package.


I get “error: command failed to execute correctly” during a GRUB update

Run sudo update-grub once more to ensure the command has worked correctly.


GNOME shell crashes

It’s probably an issue with an extension which needs to be updated. Disable them in turn until you find the one responsible.

If it’s when inserting USB drives, disable “Places Status Indicator”.


Font-Shadow issue within XFCE

Switch to another theme (e.g. Arc Maia), or execute the following cmd to fix the issue:

xfconf-query -c xfce4-desktop -p /desktop-icons/center-text -n -t bool -s false

This fixes the issue properly. (Can follow the links from Ask-Ubuntu #801478 to what exists for the xfce documentation.)

After the command is run the entry <property name="center-text" type="bool" value="false"/> is created under “desktop-icons” in /home/[user]/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml.


Firefox 58 won’t open

Please check this thread:


I don’t see any updates

That’s because your mirror is out of date. It can take several hours before a mirror get updated. If you want updates right now, run these commands :

sudo pacman-mirrors -f 3
sudo pacman -Syyu

You can always check the state of every mirrors here.


I get a black screen on boot or something doesn’t work

That’s probably because you have a partial set of updated packages. Switch to a text console using CTRL+ALT+F2, log in, then run the commands above.


An AUR package is stopping the update because of a conflict

Remove the AUR package, update, then reinstall the AUR package.


An AUR package says a key is invalid

You need to add the key to your keychain. Do a search of the forum, the answer has already been posted (several times :wink:).



#3

We addressed the issue with nvidiafb and linux415+ series

I don’t see any change for linux415 in the diff-listing.


#4

Is there a place I can read up on this part?


#5

I think it’s this one


#6

I thought that was the opensource drivers part, not the hybrid part…


#7

Maybe there is something more… i don’t know…
That’s simplify hybrid with opensource drivers.
If there is more I didn’t saw but I’d live to know too :smirk:


#8

It’s related to that:


The corresponding commit:


#9

Pull request [hybrid-intel-nvidia-bumblebee] nvidiafb changes


#10

Some explanation detail for these would be nice.


#11

On the opensource side:
Befor that change we have had drivers mhwd scripts to load setups for:

  • intel
  • Radeon
  • AMDGPU
  • nouveau
  • Intel+Radeon(PRIME)
  • intel+AMDGPU(PRIME)
  • intel+nouveau(PRIME)
  • Intel+Radeon(bumblebee)
  • intel+nouveau(bumblebee)

All of them where bound to a specific list of PCIIDs to load up correctly. If some ID was mission, the fallback always was vesa. While this sounds “good”, there was always this problem that while linux supports some Graphicschips, we never had the PCIID added for this chip XY. So it wasnt supported, only because some numbers are missing in a textfile.

Now all these mhwd scripts are merged together in one:

  • video-linux

It doesnt support PCIID’s, but vendor IDs. So ALL chips of AMD/NVIDIA/INTEL are supported by default. If it still does not work, its because there is no support for it in linux or mesa. Not because of mhwd. And no fallback to vesa anymore.


#12

Very nice.

Does it setup PRIME or is it still something that needs to be done manually?


#13

Noticed error starting in Stable considering nvidiafb, not when I started Testing. Hope it is corrected soon in stable.


#14

mesa dri_prime works like it did before, yep


#15

sorry,ingerman

Deutlich bessere Schriftendarstellung, endlich wieder gestochen scharf und deutlich besser zu lesen. :+1:
Scheint ein Update von Nvidia und/oder Mesa vor längerem kaputt gemacht zu haben.


#16

is it possible to consider separate system update(qt,gtk,libs) and app update.
i know, all is linked together .
i think it will give a better stable release and save time .

just a thought .:thinking::thinking::grinning:


#17

I got this regarding nvidiafb i see at boot for a sec, and when i shutdown or reboot … a bit over my understanding and maybe someone has some patience to explain :slight_smile:

$ dmesg | grep nvidia
[    7.310982] nvidiafb 0000:08:00.0: BAR 3: can't reserve [mem 0xce000000-0xcfffffff 64bit pref]
[    7.310984] nvidiafb: cannot request PCI regions
[    7.323086] nvidia: module license 'NVIDIA' taints kernel.
[    7.344860] nvidia-nvlink: Nvlink Core is being initialized, major device number 240
[    7.345127] nvidia 0000:08:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem
[    7.418043] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.25  Wed Jan 24 19:29:37 PST 2018
[    7.420175] [drm] [nvidia-drm] [GPU ID 0x00000800] Loading driver
[    7.420177] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:08:00.0 on minor 0
[    8.146145] caller _nv001170rm+0xe3/0x1d0 [nvidia] mapping multiple BARs
[    8.548032] nvidia-modeset: Allocated GPU:0 (GPU-a11a4176-83a7-6a4c-a3bf-5973ab483503) @ PCI:0000:08:00.0

#18

See Nvidiafb: unknown NV_ARCH 390.25 @ 4.15.4

tl:dr

Simply BLACKLIST nvidiafb module:

sudo bash -c "echo 'blacklist nvidiafb' > /etc/modprobe.d/nvidiafb_blacklist.conf"

Reboot.

See:


and


#19

I see that zita-resampler received an update, and also that Arch warns of a manual intervention due to an issue with symlinks:

https://www.archlinux.org/news/zita-resampler-160-1-2-update-requires-manual-intervention/

zita-resampler 1.6.0-1 -> 2 update requires manual intervention

2018-02-22 - Antonio Rojas

The zita-resampler 1.6.0-1 package was missing a library symlink that has been readded in 1.6.0-2. If you installed 1.6.0-1, ldconfig would have created this symlink at install time, and it will conflict with the one included in 1.6.0-2. In that case, remove /usr/lib/libzita-resampler.so.1 manually before updating.


#20

updated succesfull. But maybe update VLC too :relaxed: