[Testing Update] 2018-02-08 - Kernels, Browsers, Plasma, GCC, Nvidia, Systemd

update
testing

#24

Anyone having conflicts with nvidia utilities?

EDIT: I think I found the problem…I had the 4.13 kernel installed…


#25

I haven’t, but now Chrome with hardware accelerate and new nvidia driver (390.25) works with horrible freezes, on youtube particularly :slightly_frowning_face:


#26

Yesterday I had an issue that the wget backend for pacman got stuck during doenloads of community.db and also during downloads of some packages.

Terminating the wget process in htop made wget resume the download and it completed successfully.

I cannot reproduce it and there is nothing special in the journal. It happened on different machines three times.


#27

I think there will be some that will ask about these errors at shutdown

shutdown[1]: Failed to wait for process: Protocol error

seems related to systemd 237, but I did not found more detail now. just that someone also have it on arch.
https://bbs.archlinux.org/viewtopic.php?id=234329

I have them on my VM and latptop installation. (both on unstable)
doesn’t look armfull until now


Shutdown[1]: Failed to wait for process: Protocol error
#28

I also have this, and while i tried to look them up in journal another problem came up: they are not shown due to rate limit:

kernel: systemd-shutdow: 42 output lines suppressed due to ratelimiting

When i tried to remove rate limiting from /etc/systemd/journald.conf by setting RateLimitInterval=0
RateLimitBurst=0 the behavior does not change.


#29

I still have the server-error-internal-error issue I reported in 2018-02-03 Stable update. I kind of expected that since I saw no update directly related to printing at all, except cups-filters-driverless.

Switching to cups-filters-driverless 1.19.0-1 was a solution for my issue before. However, using cups-filters-driverless 1.20.0-1 leads to the same error as I had when I use cups-filters 1.20.0-1. Therefore, the only logical explanation I have is that upstream developpers introduced this problem themselves.

However, adding the printer with “Enter URI”, then manually selecting Gutenprint driver, still works. Adding the printer with “Find Network Printer” and the .local hostname of the printer, then manually selecting Gutenprint driver, works too.

Workaround with Find Network Printer





find-network-printer5

I am using a Canon Pixma MG4120 wireless printer.

Also, I got an esthetical regression with my Cinnamon menu with Adapta Maia theme. When I hover over categories, the icons get smaller than normal, either for a very small amount of time while I still hover over a category or until I hover over entries of the selected category. When the icons get smaller, the categories and the entries slightly moves to the left and when the icons gets to their normal size, the categories and the entries slightly moves to the right, back to their initial position.

Smaller :

Normal :

Normally, the icons should stay the same size everytime. Now, it just looks like the menu is shaking, which is very annoying and unpleasant.

Other Cinnamon Desktop themes installed by default (Cinnamon and Vertex-Maia) aren’t affected by this; I only have this problem with Adapta Maia theme.

Manjaro Cinnamon
Kernel 4.14


[Testing Update] 2018-02-14 - Kernels, Plasma, KDE Framework, Themes
[Testing Update] 2018-02-15 - Kernels, Firefox Dev, Bluez, Haskell, Python
[Testing Update] 2018-02-21 - Plasma, QT5, Kernel v4.16, Mesa, LibDRM, Haskell, Python
[Testing Update] 2018-02-28 - Kernels, Mesa, Browser, Haskell, Python
[Testing Update] 2018-02-09 - KDE Apps, LibreOffice, Fixed WLAN issues of v4.15
[Testing Update] 2018-02-13 - Kernels, LibreOffice, Systemd, Firefox Dev
#30

Smooth update (for me) :slight_smile:


#31

I cannot reproduce the menu issue (on unstable branch at least)
Anyone else with this problem? Maybe it could somehow have to do with screen resolution so it is not present on my setup?


#32

For some reason after this update, when i open more than one application the entire screen or part of it starts flashing big black zones.
Only thing that fix it is disabling compositor or switching from opengl to xrender.
Not sure what happened honestly but i wonder if it’s a video driver problem or what and if xrender is good or opengl would be better.
KDE - kernel 4.14
Edit: intel video driver.


#33

Only on Manjaro as we still use sync-first function. Please comment it for now. @oberon: didn’t we had a patch for this one?


#34

Erm, I don’t know anything about this… :thinking:


#35

I could reproduce my issue with these steps on a different computer (a laptop) :

  • Install Manjaro Cinnamon 17.1.4 on the computer.
  • Switch to testing with sudo pacman-mirrors -b testing
  • Update the entire system with sudo pacman -Syyu
  • Reboot the computer.

My main computer (the one which I first noticed this issue) has two screens, one with 1680x1050 resolution and one with 1920x1080 resolution. It also uses a Nvidia GeForce GTX 970 with non-free driver.

The laptop I used to reproduce the issue has a single screen with 1366x768 resolution. It uses an integrated AMD GPU with free driver.

However, I couldn’t reproduce this issue in VirtualBox though.


#36

I’m having these flashes as well. They did start after the update. Maybe the new Nvidia driver is not that good after all.


#37

Don’t know but i have intel driver so the problem maybe something else.


#38

One small issue with the wallpaper in plasma, background is originally set to a solid color but it shows as if it was the blurry option. I can set it back to the original color but it resets to blurry after rebooting.

Edit: Didn’t mean to reply to that post, sorry.


#39

No worries! :wink:


#40

Maybe needs to be reported upstream adapta @Ste74 ?


#41

I normally don’t run Discover since Manjaro KDE ships with Octopi. I installed Discover and I’m seeing the same thing as you, except I have a Flatpak area presumably because I have Flatpak installed and may not?

I also get an error that I haven’t been able to catch stating that it couldn’t communicate with something… Probably because it’s not seeing the repo!


#42

I tried the regular Adapta theme (the one provided with the adapta-gtk-theme, which is a package that directly comes from Arch Linux) and I get the exact same “shaky” effect I got with Adapta Maia theme (packaged by Manjaro Team).

Shaky effect with regular Adapta theme


Changing icons theme from Vibrancy to Adwaita didn’t solve my issue too.


#43

Silly, but…
Have you tried editing the menu to have text-only instead of icons and back again or any variant of such? Or maybe it would prefer you left them on the smaller setting?